A driver for Radeon X1650 newer than 10.2?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by jarckendar, Nov 1, 2013.

  1. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    I need a new catalyst driver for my old Sapphire Radeon x1650 GPU, but AMD has only the 10.2 catalyst which is very old. Is there a way to use a modded 13.9 catalyst driver from 2013, so that I can use it for my old GPU? :3
    If someone could make one for me? I need it for windows 7 sp1 - 32bit.

    Much appreciated. :)
     
    Last edited: Nov 1, 2013
  2. nhlkoho

    nhlkoho Ancient Guru

    Messages:
    7,720
    Likes Received:
    340
    GPU:
    RTX 2080ti FE
  3. Ruslu

    Ruslu Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Gigabyte GeForce GTX 760
  4. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    I tried what you guys suggested but nothing worked, I tried to mod the latest and other older catalyst drivers, but when installing them, they disable my aero theme of windows 7 and they give me errors. I also tried 12.11 modded driver and it refused to install the display driver. I guess there is no other way to make it work. :(
     

  5. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    Hi, could you post your DEV-ID, the tool" FLEM" is supposed to work on a Dx9 card like yours without any issues. The drivers disable the aero theme? That is the weirdest driver issue I've heard off. If you are having difficulties modding ask and we can help :)
     
  6. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    Well I got the hardware IDS of x1650 from device manager if that is what you are talking about here is a screenshot:

    [​IMG]


    No idea of what I'm doing wrong but if anyone could do it for me with the modding thing and upload it, would be great, thanks for trying to help though. :) Also here is the GPU Device ID: PCI\VEN_1002&DEV_71E6 In case you need it and the Inf section line: ati2mtag_RV530 they are taken from the diginal Flem.
     
    Last edited: Nov 2, 2013
  7. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    When installing the 12.11 Modded Legacy driver what steps did you follow to install the driver?
    Also which driver did you try to install?
     
  8. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    Sure, can make you a custom driver in a couple of days, Happy Halloween :)
     
  9. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    I only downloaded the "ATI Catalyst 12.11 B11 HotFix 10 P6 V11.10.6" and just install them as clean install. :)
     
  10. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    Thanks :) happy halloween to you too. Also try to make the custom driver from other than the catalyst 13.9 like the 13.4, cuz this version 13.9 for some reason doesn't start when I launch the setup exe, it just crashes when I try to launch it even after when I tried to modd it. :) Also I am on Windows vista ultimate sp2 32-bit, cuz windows 7 isn't good for my old PC.
     
    Last edited: Nov 2, 2013

  11. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Sorry for the delay in response. The V11.10.6? and not V11.10.6.3?
     
  12. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256

    I tried the ATI Catalyst 12.11 B11 HotFix 10 P6 V11.10.6.5 All Supported OS UPD
    and the ATI_Catalyst_12.11_B11_HotFix_10_P6_V11.10.6.6_All_Supported_OS

    They both just don't start when I try to launch them from the setup exe. They both crash and won't let me even install them.
     
  13. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Can you clarify a bit more? what do you mean by crash?
    Also would you like to have a Team Viewer Session?
     
    Last edited: Nov 2, 2013
  14. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    Well by crash I mean they give me error message when trying the launch from the setup exe the driver, this is the crash I get:

    [​IMG]
     
  15. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Hmm it seems you are not even making it to the installation. Would you like to have a Team Viewer Session with me as an attempt to resolve the issue?
     

  16. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    How does this team viewer session works?
     
  17. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Well, first download Team Viewer then run the setup and instead of choosing the install option you would select run, (For One Time use). After choosing run provide the given ID and Pass Via PM and I will use that to access your PC and take a look at the problem you are experiencing.
     
  18. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    I just sent you the details.
     
  19. jarckendar

    jarckendar Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI Radeon x1650 DDR3 256
    Well, it didn't work. I guess it has compatibility issues with my PC the setup exe of this driver package.
     
  20. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    I recommend doing a full Windows Upgrade as your computer seems to behind in Updates.
     

Share This Page