9.3's are up

Discussion in 'Videocards - AMD Radeon Drivers Section' started by m.3ck, Mar 18, 2009.

  1. vebero

    vebero Member Guru

    Messages:
    112
    Likes Received:
    0
    GPU:
    ASUS HD 5750 850/1075MHz
    Nice drivers. Though I was hoping for more performance improvements, at least stability is great and Crysis: Warhead performance got improved by 2 -3 fps.
     
  2. Gurid

    Gurid Member Guru

    Messages:
    152
    Likes Received:
    0
    GPU:
    2x Sapphire Radeon 4870
    Hi, I don't know why, but it seem that I don't see my OC any more on the ATI CCC
    Can any one help me please?
     
  3. Gurid

    Gurid Member Guru

    Messages:
    152
    Likes Received:
    0
    GPU:
    2x Sapphire Radeon 4870
    Ok fixed, just needed a restart (The MAGIC key for windows ;) )
     
  4. TDurden

    TDurden Ancient Guru

    Messages:
    1,981
    Likes Received:
    3
    GPU:
    Sapphire R9 390 Nitro
    Crysis Warhead DX10 still crashes on loading screen :(
     

  5. Funky Doodle

    Funky Doodle Master Guru

    Messages:
    792
    Likes Received:
    0
    GPU:
    Gigabyte ATI HD 5830 1GB
    i got better performance in 3dmark vantage, higher than previous once, since 8.12, especially gpu score +200p! Will try some games! And when da hell they're going to release video converter, huh?!
     
  6. Gurid

    Gurid Member Guru

    Messages:
    152
    Likes Received:
    0
    GPU:
    2x Sapphire Radeon 4870
    DEVIL MAY CRY 4 seem to have stable FPS
    I get better results than other drivers, GREAT !

    Looking for the DNA one ;)
     
  7. MrBozack

    MrBozack Master Guru

    Messages:
    670
    Likes Received:
    0
    GPU:
    Gigabyte 7850OC Windforce
    :cheers: Now that is fantastic, if truly fixed. brb installing.
     
  8. maikai

    maikai Maha Guru

    Messages:
    1,299
    Likes Received:
    36
    GPU:
    NVIDIA RTX 3060 Ti
    still no avivo support in vista x64. when i bought my card the box even said it supports these features to offload from my cpu. i can put in my old 8800gts and get better results. and about the comments telling guys to stop complaining and fix the problem themselfs. wtf is wrong with you? if i bought a car and it didnt have a gd steering wheel and i complained would u tell me to install it myself cause its an easy fix? and what happened to all those people who said nvidia only releases one official driver or two a year? seems theyve already surpassed that mark this year alone. ive used both nvidia and ati cards for a decade now, and this time around yes i am disappointed i decided to go ati and save some bucks. not to mention i have the visiontek 4850 with the stock design and the gd thing idles at 85c. its the very 1st card ive ever owned that actually overheated and turned my pc off.
    the whole point of these forums is to discuss views and opinions and share information. so when someone shares their 2 cents if you dont like it oh well, no need to get all bent out of shape. a lot of us are in the same boat and all the input can help others make better decisions and what product to purchase. or maybe even help them to realise its a common issue and its not just something theyve done wrong.
    overall general gaming performance has been fine on my card, the heat is retarded though. but im still waiting for the gd avivo support on vista x64. coming soon should be changed to say coming later.
     
  9. TDurden

    TDurden Ancient Guru

    Messages:
    1,981
    Likes Received:
    3
    GPU:
    Sapphire R9 390 Nitro
    Which part of AVIVO not working?
    Video decoding on GPU is working.
     
  10. pedropaulo

    pedropaulo Ancient Guru

    Messages:
    2,310
    Likes Received:
    94
    GPU:
    HD5850
    Also waiting for Avivo X64, and if it does not work in this set i´l pass it until Win 7 RC1 comes out.
     

  11. tommcd64

    tommcd64 Master Guru

    Messages:
    684
    Likes Received:
    0
    GPU:
    Quadfire 2 4870 X2's
    I haven't gotten to test them gaming yet but I can see that the powerplay bug is still present with my 4870 X2 cards.
     
  12. MrBozack

    MrBozack Master Guru

    Messages:
    670
    Likes Received:
    0
    GPU:
    Gigabyte 7850OC Windforce
    My Guild Wars is running around 10-20 frames faster now. I was using 9.2 Vista, so if it really is the same driver -I'm quite amazed. Dirt seemed smoother, Team Fortress was the same insane FPS ...but I can confirm the puddles are fixed in CoD:W@W

    I'm usually happy with ATi driver revisions, but this one seems veeeeery good. -GJ Terry Makedon!
     
  13. maikai

    maikai Maha Guru

    Messages:
    1,299
    Likes Received:
    36
    GPU:
    NVIDIA RTX 3060 Ti
    Known Issues Under the Windows Vista Operating System​
    This section provides information on known issues that may be experienced under the
    Windows Vista operating system with the latest version of Catalyst™. These include:​
    AVIVO converter may fail to convert h.264 avi video to another format

    “Unsupported file formats” error message dialog may occur when selecting H.264,
    mp4 and VC1 file formats

    “CCC Host application...” error message dialog may occur when cancelling a
    transcoding process

    Output media file size differs after transcoding multiple times to the same format

    The ATI AVIVO video transcoder does not currently use GPU acceleration under
    Windows Vista 64-bit edition

    "World of Warcraft" and "World of Warcraft: Wrath of the Lich King": Flickering
    may occur when Shadow is set to medium/high using CrossFire

    Google Sketchup may show blank screen

    Certain resolutions above 10 x 7 might not full screen for specific HDMI displays

    Both LCD and CRT may go blank when hotplugging the CRT to the system, and will

    not recover until it is switched to discrete GPU
     
  14. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    I am really disappointed with this driver, they dont fix the bug that mess up all your desktops icons after installation!!!. Besides that... better performance and easy installation (over old ones of course).

    wtf ATI fix your problems !!
     
  15. ForgedReality

    ForgedReality Master Guru

    Messages:
    216
    Likes Received:
    0
    GPU:
    HD4870x2OC + 9600GT PhysX
    What? I have NEVER seen that problem. Screenshot?
     

  16. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    Your issue, its fine here. Re-install the game....
     
  17. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    What, I think you are alone in that one!!
     
  18. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    Why would you have your PC on but not log in?
     
  19. Ghettorat

    Ghettorat Active Member

    Messages:
    82
    Likes Received:
    0
    GPU:
    EVGA GTX780 ClassifiedSLI
    Shadow bug is back in world of warcraft when set to medium/high. Was fine with 9.2.

    This is just rubbish ATI. Really poor.
     
  20. zer0_c0ol

    zer0_c0ol Ancient Guru

    Messages:
    2,976
    Likes Received:
    0
    GPU:
    FuryX cf
    how is the xp performance with these?
     

Share This Page