7970 stuttering help

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Fenric, Apr 21, 2015.

  1. Fenric

    Fenric Member

    Messages:
    43
    Likes Received:
    0
    GPU:
    MSI GTX 980ti
    Hi, thanks for taking the time to post. These are all wonderful suggestions and I have done every last one of them.

    I'm now of the opinion that there is something wrong with the engine and how it interacts with some hardware setups.

    As mentioned before, I had read on the game's forums that someone suggested there was an issue with a specific asteroid type.

    I've just got done traveling a bit to a new system and found a different type of asteroid field to bounty hunt at. The old one had asteroids with reddish patches that looked like iron ore. The whole field was very dusty and hazy.

    The new field I'm at has plain looking rocks and no dust or haze. I once in a while notice a tiny bit of stutter but it goes away right away. The longer stutters that were occasionally accompanied with part of the screen turning black doesn't happen at all anymore.

    I wish I had tried going somewhere else earlier.

    It's worth it though. I learned about the game, a lot about optimizing settings for games, got a newer bios flashed on my motherboard and video card, upgraded to Windows 8.1, discovered my bios had all my fans set at 100% all the time, and rebuilt my computer and cleaned it out.

    I feel a lot better now.
     
  2. Fenric

    Fenric Member

    Messages:
    43
    Likes Received:
    0
    GPU:
    MSI GTX 980ti
    Thanks everyone for your help, especially PrMinisterGR for taking the time to find a newer bios for my card and telling me how to use it.
     
  3. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    139
    GPU:
    Sapphire 7970 Quadrobake
    No problem man. If you manage to find a solution for the game (it looks like it is a game issue after all), PM it to me, I have friends who play who might care about the answer.
     
  4. Deathchild

    Deathchild Ancient Guru

    Messages:
    3,970
    Likes Received:
    2
    GPU:
    -
    Gj dude. :D
     

  5. TorrentG2

    TorrentG2 Banned

    Messages:
    35
    Likes Received:
    0
    GPU:
    ASUS 7790 2 GB OC
    Check on DPC latency. If found to be too high at all during tests, go in your bios and disable HPET (High Precision Event Timer.)

    Probably should just do it anyway and forget about latency testing for now.
     
  6. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    139
    GPU:
    Sapphire 7970 Quadrobake
    My system gets weird and glitchy when I disable HPET. It's not blanket advice, and it looks like Elite is the only game with that problem.
     
  7. Blackfyre

    Blackfyre Maha Guru

    Messages:
    1,021
    Likes Received:
    41
    GPU:
    MSI 1070 Gaming X
    I don't think I even have HPET in my BIOS to enable or disable it... I googled Gigabyte HPET BIOS, saw it in the power management section, I restarted my PC and I have no such option to enable or disable. I used the command prompt to disable it and it turned out it was disabled already... So now I have enabled it to test with it enabled (since apparently it was disabled by the OS by default).
     
  8. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    I've noticed that some games benefit from having HPET enabled from the Bios as well as within the OS. I personally found the games to be much more responsive, though it doesn't yield any performance gains to speak of. But for some people, leaving it as it is or turning HPET off from the Bios seemed to have helped their gaming experience. I guess it depends on your setup and hardware manufacturer.
     

Share This Page