7600 GS Help

Discussion in 'Videocards - NVIDIA GeForce' started by Nitro Noddy, Oct 18, 2007.

  1. Nitro Noddy

    Nitro Noddy New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    PNY Geforce 7600 GS
    Hi guys and gals, recently bought a PNY Geforce 7 7600 GS agp vid card from PC World (money constraints) and im having a problem which im hoping someone will kindly help me with.

    Since installing the card i have noticed in 90% of games i have played (Splinter cell - double agent ( which came with the vid card) and Race 07 and Neverwinters night 2) i am getting some of the text in the game/menus going all "bitty" and unreadable.

    I upgraded from a geforce 4 ti4200 and totally uninstalled /removed all traces of that video driver in safe mode before installing the lastest driver from Nvidia. This has not seemed to help. the games graphics seem ok its just the text thats goes all " matrix" on me.

    Thanks in advamce for all replies
     
  2. Fershlugg

    Fershlugg Master Guru

    Messages:
    546
    Likes Received:
    0
    GPU:
    PNY GTX 670
    hey bud, sucks you have this problem, but are you running the latest whql drivers? If you are, maybe try the newest betas which are available at www.guru3d.com/downloads , if not then maybe you DO need whqls....

    Sorry I can't be of more help, but I don't have the card you do....
     
  3. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,878
    Likes Received:
    479
    GPU:
    RX Vega
    As said try reinstalling drivers, This sort of thing does happen with incorrect/incorrectly installed drivers.
     

Share This Page