5850 questionable peformance - w/3dmark vantage scores

Discussion in 'Videocards - AMD Radeon' started by Spyder810, Jun 23, 2010.

  1. Spyder810

    Spyder810 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Sapphire 1GB 5850
    Think my performance isn't quite on par with what a 5850 should be putting out, as stated in another thread I have issues with low fps running gta 4 and fallout 3 maxxed out 1920x1080 running latest 10.6 drivers nothing currently overclocked.

    3DMARK VANTAGE score is as follows (ppu is disabled as per I have read to do):
    [​IMG]

    Current card link: http://www.newegg.com/Product/Product.aspx?Item=N82E16814102884

    I am thinking of rmaing this video card back to newegg and buying this (another HIS 5850 card) which I was planning on purchasing before I decided to go for this card.

    Comments please.
    I'm planning on contacting newegg about an rma by friday.

    Thanks :cool:
     
    Last edited: Jun 23, 2010
  2. Gripen90

    Gripen90 Master Guru

    Messages:
    869
    Likes Received:
    21
    GPU:
    2x RTX 2080Ti SLi
    Hmm GPU score doesn't look wrong to me. I don't really see anything wrong based on this result.
     
  3. Mr.Joe

    Mr.Joe Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    670DC2-1333/3915-EK~H20
    I'd blame your cpu...
     
  4. DES_MX

    DES_MX Master Guru

    Messages:
    770
    Likes Received:
    1
    GPU:
    GTX480 850/4400 1.075v
    nothing wrong with the scores if the card is on stock clocks
     

  5. Laykun

    Laykun Ancient Guru

    Messages:
    3,208
    Likes Received:
    0
    GPU:
    2 x EVGA GTX670 4GB
  6. chaotic1

    chaotic1 Ancient Guru

    Messages:
    2,853
    Likes Received:
    0
    GPU:
    PowercolorHD6970 2GB dead
    the cpu score looks a little low to me , i was getting that score with my old phenom II x3 720 BE @ stock speeds . getting just over 11000 cpu score with my 955 @ stock , not sure if your bios setup is the problem tbh
     
  7. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,556
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    Did you mod fallout 3 heavily?
     
  8. Spyder810

    Spyder810 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Sapphire 1GB 5850
    Didn't mod it at all, and it's not running any of the dlc.

    Also my 940 doesn't max out while playing gta 4 so I'm not sure that's the issue.
     
  9. Laykun

    Laykun Ancient Guru

    Messages:
    3,208
    Likes Received:
    0
    GPU:
    2 x EVGA GTX670 4GB
    GTA IV is a strange beat, I think it's somewhat limited when it comes to fully utilitising the CPU, even though I have an i7 965 it still uses the same percentage of CPU that my old Q6600 used to. If your 945 is anything like the performance of my old Q6600 then GTA IV is probably gonna run like crap for you.
     
  10. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,556
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    Show a GPU-Z shot please.
     

  11. Spyder810

    Spyder810 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Sapphire 1GB 5850
    I checked my bios and turned off cool and quiet (I do remember turning it off before). Also oc'd my 5850 to 775 in ccc and rebenched, scores are as follows:

    [​IMG]

    Will try running a few games again and report back.
     
  12. Spyder810

    Spyder810 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Sapphire 1GB 5850
    idle or after alt tabbing?
     
  13. chaotic1

    chaotic1 Ancient Guru

    Messages:
    2,853
    Likes Received:
    0
    GPU:
    PowercolorHD6970 2GB dead
  14. Sever

    Sever Ancient Guru

    Messages:
    4,826
    Likes Received:
    0
    GPU:
    Galaxy 3GB 660TI
    your gpu score looks about right. should be close to 14.5k-ish for a single 5850, but your cpu is slower than mine, so it might be held back a little.

    when i was running fallout3 at max detail on a single card, average fps was around 50-55fps in some places, so it should be stuttering a little.

    gta4 is just downright mean to any system.

    my 965be at 3.8ghz holds back my crossfire 5850s, so these cpus arent as punchy as they could be.

    oh and on a random note, dont bother grabbing a six core. they switch off three cores and boost the speed of the remaining three cores for games, so it wont really help you in gta4.
     
  15. Spyder810

    Spyder810 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Sapphire 1GB 5850
    Idle:
    [​IMG]

    Just after alt tab from gta 4:
    (the gpu core clock was at 775 right before the drop)
    [​IMG]


    Good to know.



    Also since I turned off cool and quiet, and rebenched, gta 4 hasn't gone lower the 24 fps as before I've seen it spike down to 14. Going to test Fallout 3 now.
     
    Last edited: Jun 23, 2010

  16. Ji1986

    Ji1986 Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    Gigabyte GTX670 OC SLI
    Shouldnt the GPU score be a little closer to the 15000 mark......

    I get that and its the same in the guru review...Im thinking CPU bottleneck
     
  17. Spyder810

    Spyder810 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Sapphire 1GB 5850
    After alt tab from gta 4 after a few minutes of playing(to show cpu activity):
    (large spike drop was an alt tab)
    [​IMG]
     
  18. RS-X

    RS-X Master Guru

    Messages:
    452
    Likes Received:
    0
    GPU:
    RTX 2060 super
    My Scores are below with CAT 10.5 every thing on stock no OC. I think cpu is bottle-necking. But if you play games @ 1920 X 1080 most of the problem will go away.
    [​IMG]
     
  19. naike

    naike Ancient Guru

    Messages:
    2,021
    Likes Received:
    0
    GPU:
    Asus EAH5870
    For me the 10.6 drivers failed, BC2 ran at 30-40 fps and everything looked weird and flashy, went back to 10.5 and everything runs fine now, 70-90fps.
     
  20. DES_MX

    DES_MX Master Guru

    Messages:
    770
    Likes Received:
    1
    GPU:
    GTX480 850/4400 1.075v
    lol interesting scores guys, with my profile config i score P26500 with vantage, game1 and game2 get 70 and 60 frames respectively and cpu score is around 48000... thats with ppu enabled of course and i7 920 @3.8ghz! Go intel + nvidia
     

Share This Page