4890 Lockups and more Lockups

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Prod, Dec 27, 2009.

  1. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    Ok so let me start off by saying my system is OCed but i know that isn't the problem. My ram has been tested with memtest for 12 or more hours with no errors. My CPU is running at 3.6ghz and is prime small FFTs sable for 24 hours. My video card (XFX 4890) has been tested with and without OC settings always having the same problem. I am pretty sure this is a Driver problem but want to make sure. This all started when i was using Win 7 64 Pro since well i got my 4890 when i started to use Win 7.. No matter what driver version i would use starting at 9.7 up to the 9.12 hotfix i get a lot of random PC lockups. It can happen during a video game or during web surfing or even watching a video file. This problem always happens if i am watching a video file from the HD. While watching a video file the PC will lock up with artifacts at the bottom of the screen or even with a sound loop, but it is still random meaning i can't do one thing and have it happen no matter what. sometimes it happens some times it doesn't. While playing video games the PC will just lockup with no artifacts but sometimes sound loops. What makes me think it is driver related is because the higher the driver number ie 9.9, 9.10, etc. the problem happens more often. Right now i am back at the 9.6 drivers testing them. I have also moved back to Win XP 64 but that doesn't seem to fix the problem. anything that you guys might think of trying would be great Thanks for reading this.

    Edit: I also wanted to add that I have tested the Video card with Crysis Warhammer Benchmark. Running the benchmark with OC settings and non OC settings in more then 20 to 30 loops. The Problem doesn't happen at all, but like i said it is purely random. I dont play Crysis enough to know if it would happen during game play.
     
    Last edited: Dec 27, 2009
  2. Camster

    Camster Member Guru

    Messages:
    131
    Likes Received:
    0
    GPU:
    Sapphire HD 4890 OC
    Hmmm I'm always concerned to see high overclocks & stability problems & wonder if everything would be stable at stock though you seem confident that is not an issue. Certainly heat is a concern with those high voltages on the CPU & GPU But..... the fact you mention looping sound etc. makes me wonder if the X-Fi drivers aren't to blame. Certainly sound card drivers can play hell with a system. Perhaps see if there are any updated ones for your sound card for Win 7 available.

    As for newer drivers seeming less stable sometimes newer drivers utilize the card better to get more performance from them which can stress the cards more & make them less stable when they are already running at the edge.
     
    Last edited: Dec 27, 2009
  3. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    Well heat isn't a problem since the CPU and GPU are both watercooled. The GPU and Vregs don't go over 50c and the CPU stays pretty much around 60c max load with all 4 cores maxed out. So i don't think that is the problem. I didn't think of the sound drivers. One thing i haven't tried yet is to disable the HDMI audio you get with the 4890. I am using my Prelude for main games but during video files i use the HDMI audio with my TV. Only thing that i hate here is that i had 2 8800 GTXs in SLI before i got my 4890. the 4890 gave me very little fps over my SLI cards. Sometimes i wish i wouldn't of moved. Every day i get more and more pissed off at ATI and there what seems to be more and more poor drivers. Not saying i didn't have problems with NV and drivers, but i didn't have lockups. Hopefully it is the sound card causing it. That would make me feel a lot better. Anyone think of any thing i can try. I checked and the sound drivers are up to date.
     
  4. rurik

    rurik New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Sapphire HD6970 stock
    I have the same problem and I do not know what to do.:biggun:
     

  5. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    Well so far with the 9.6 drivers I have been lock free all day today. I will test some videos tomorrow and post back. If i have to stick with the 9.6 drivers then all i will have to say is ATI needs to fix this crap.
     
  6. abrarhaq

    abrarhaq Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    2 x HD 5850 / 1024mb
    Honestly i had the same problem sort of... this is what i did

    I had an overclocked core i7 system on vista... everything works fine, i upgrade to 7 and i start getting lock ups, sound loops, bsods, the works... couldnt figure out why... (I dont know if my sig says it, but i have XFI as well)

    I went back to vista, and again it worked fine, exact same setup, same drivers same everything pretty much... went back to 7, same problem....

    What i figured out was 7 needs a slight increase in vcore as 7 uses the hardware in your computer to a fuller extent then vista...

    So try that, increase your vcore ever so slightly and see if that increases your reliability, (it added like 1 degree to each of my cores in idle, i only use air cooling
     
  7. rurik

    rurik New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Sapphire HD6970 stock
    my system is thoroughly tested for stability: Prime95-8 hours Blend test, Linx - 25 passes with full memory, 3DMarks ... and never had a single locks or BSOD.But in games ... one idea is driver.Now rolled back on 9.7, testing.
     
  8. korogui

    korogui Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    XFX Radeon 4770 x2
    Logs... Always try to look the logs to find out why the system crashed.

    For Windows 7, go to Control Panel, Administrative Tools, Event Viewer (Windows Logs -> System).

    If theres just critical errors pointing to ATI Kernel Module Agent you can blame the drivers.

    Anyway filter the logs and choose just the error and critical ones. And post here : X
     
  9. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    Well i think it was PowerPlay causing the lockups. I have disabled powerplay and so far no lockups or crashes in anything i was having problems with before. Only way i could get powerplay to disable fully was to edit the bios of the card. I guess time will tell but i am looking good so far for the last few days.

    Edit: Also wanted to add I have been using the 9.12 non hotfix for the last few days too.
     
  10. yelsewshane

    yelsewshane Banned

    Messages:
    1,591
    Likes Received:
    0
    GPU:
    Sapphire VaporX 290
    Your problem is your system is overclocked and not stable... like it or not that's the truth.
     

  11. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,815
    Likes Received:
    80
    GPU:
    GTX 980/290X
    Shhhhh, some people can't handle the truth.

    [​IMG]
     
  12. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    lol you think what you want to think but i have ran hours and hours of stress testing and once i turned off powerplay no lockups at all. CPU has been at these clocks for over a year now with no problems at all. Ram was tested with memtest for over 12 hours error free. Video card was ran on Crysis bench in a loop for about 8 hours lockups or restarts. Sry to tell ya but my system is stable. This is 100% a ATI problem and I know for a fact I will not be buying another ATI card when I go to upgrade again. It took alot of people to get me to buy the 4890, and I really wish i wouldn't of. That GTX 275 is looking pretty good right now. Should of been what I went to.
     
  13. Camster

    Camster Member Guru

    Messages:
    131
    Likes Received:
    0
    GPU:
    Sapphire HD 4890 OC
    Theres nothing really wrong with the 4890 or the drivers generally. It is likely a compatibility problem perhaps with your motherboard I'm guessing & turning off Powerplay seems to correct it. That doesn't make either one bad just they have issues together. I don't believe a GTX 275 would work much better either overall performance wise. It might be more compatible perhaps though.
     
  14. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    Well i am not saying that the 4890 is a bad card it isn't when it works it is great, but the 275 was what i was going to get if i didn't get a 4890. I have had nothing but driver problems with all the ATI cards I have had. Where with NV I never once had a problem with my 8800 GTX. I only went for the 4890 because it was cheaper then the 275.
     
  15. Camster

    Camster Member Guru

    Messages:
    131
    Likes Received:
    0
    GPU:
    Sapphire HD 4890 OC
    Now that you seem to have the issue resolved it'll be interesting to see what you think of it going forward. I asssume the Powerplay feature is what lowers the clocks in 2d modes?
     

  16. Acid Twin

    Acid Twin Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    Sapphire ATi 4870 X2 2GB
    Prod, I mentioned before i thought it was bios related.

    The only time I had this issue was when I first got the card, power play related again. Sapphire had quietly released a BIOS update that fixed issue.

    For me I think when I flashed with the new fan settings i messed up something and alas I'm stuck only with one working driver like you were at one point.

    Guess I'll have to locate the backup of the unmodified but fixed bios and give that a shot to solve my own problem :/

    Gr. :p
     
    Last edited: Jan 3, 2010
  17. NuMetal666

    NuMetal666 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire 4890 1GB
    Prod, I got the same problem as you and I've looked around trying to find a way to disabled powerplay but it dosen't seem to be working. :bang: Can you please tell me how you did it.

    Thanks in advance for you help.
     
  18. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    I just changed all the clocks to one set clock speed. I changed the bios doing that. This way the card will never change clock speed. There might be better way to do it without changing the bios but all of the ways i found to try didn't work.
     
  19. NuMetal666

    NuMetal666 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire 4890 1GB
    Have you done it in the overdrive tab in CCC or in rivatuner ???
     
  20. Prod

    Prod Master Guru

    Messages:
    303
    Likes Received:
    2
    GPU:
    Evga GTX 980
    I flashed the bios. i tried to make a Profile in CCC and it didn't work. I don't really use rivatuner much so I don't know how to really use it.
     

Share This Page