4870X2 = Latest Driver 10.7 + later beta versions wont enable 2nd gpu

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Plug2k, Jul 30, 2010.

  1. Ravynmagi

    Ravynmagi Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    XFX 4870 X2
    Two months is a pretty long time and I suspect it'll be more than 2 months before this gets fixed for 4870X2 owners.

    I'm playing Starcraft 2 and I'd personally love to have anti-aliasing support found in the 10.7a driver. But it seems that won't be happening.

    Not the end of the world. But just another kick in the pants in a long line of driver disappointments for my 4870X2.
     
  2. mceesay

    mceesay Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    Powercolor HD 4870 X2
    oh well same old story we love ati............lol
     
  3. TwL

    TwL Ancient Guru

    Messages:
    1,828
    Likes Received:
    0
    GPU:
    2x5850 2x6950 + 9800GTX
    It took several month for me to understand how quadfireX can be build functional and what exactly was the cause of the problems. Although, ATI did
    show the way very well with v10.7a now, but speaking of before that. Ideally I can make the quadfire 4###x2 working, but I am unsure would the same work
    for quadfirex where as single 48x0x2 cards will work. However, I will attempt to include full threaded support for 4 GPUs for new HD48x0x2 driver I am building
    at the moment with new CCC support.

    Ps. ATI didn't screw up they knew exactly what they were doing.

    -edit-

    If the possible I could pass an test build under private message to fellow with 2x48##x2 for testing, if he understands how basic device manager works.

    So, we would know before I add the HD4### build up to my thread. Would go forward really much faster more I have people testing.
     
    Last edited: Aug 14, 2010
  4. dox_aus

    dox_aus Master Guru

    Messages:
    301
    Likes Received:
    0
    GPU:
    MSi 290 Gaming CF
    Heh, so they intentionally broke cf for 4870 users in 10.6, 10.7 and 10.8 betas?
     

  5. TwL

    TwL Ancient Guru

    Messages:
    1,828
    Likes Received:
    0
    GPU:
    2x5850 2x6950 + 9800GTX
    Yes, I believe they did as driver team most of see the affect on first driver as it was WHQL. Of course, if someone can explain me. Why would they change same unfunctional code cross
    releases would be really curious to understand, but I cannot find any explain on the idea why would 5 completely different driver codes be all the suddently functioning through same DX10-11 processing.

    (not including 10.6 OR 10.7.. I would be referring 10.7a release and v8.761.0 releases in generally only as the driver in these releases originally
    worked flawless where now it is modified accordingly to 10.6 and 10.7 WHQL)

    Although, who am I to understand their work or even the whole idea.
     
    Last edited: Aug 14, 2010
  6. Quicks

    Quicks Master Guru

    Messages:
    554
    Likes Received:
    12
    GPU:
    Red Devil RX 470 / 4GB
    What the point of WHQL if they do not test the freaken drivers before they release it ?
     
  7. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    @TwL I am sure a few of us in this thread will be happy to test. Thanks for looking into our problem!

    @Quicks I think he meant that they did test it and they knew it was going to happen. And the only reason I can imagine this is intentional is so that we upgrade to 5970 or the new 6000 series because to be honest it is a capable card so there isn't much reason to upgrade (except 2560 res, but how many have that).

    So, ****up everyones (£300-350/$600) 4870x2 without too many noticing... Still working but 200mhz slower. Oh hey my card isn't so great with these new games...maybe i should get the filler cards (6000 series) or even 5970 (another £400) instead of holding out for a really worthwhile upgrade like...28nm northern island cards.. NAHHHHHH

    Of course it could just be a bug..but damn, 2 months now how hard can it be to get 3d detection working fully...not hard at all (nub guess, but come on). Problem is nVidia is just the same with its physx rubbish and cards that can't handle running at 100% for too long or they will melt..happened to my friends 8800 on the laptop and that 260 i think with sc2...my 4870x2 was hitting 2050 frames but it didn't melt...we need a 3rd choice! 'D:i

    btw since you are all here...for those of you on 10.5a and playing sc2, do you notice you load up quite slow?...feels like nearly everyone else loads faster...
     
    Last edited: Aug 14, 2010
  8. John

    John Ancient Guru

    Messages:
    16,762
    Likes Received:
    8
    GPU:
    GTX 970
    Works fine here, but then I overclock with Rivatuner and effectively disable 2d clocks altogether. Might be an option if you don't care about heat/power consumption.
     
  9. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,716
    Likes Received:
    1,008
    GPU:
    6800XT Nitro+ SE
    This is why I am moving on to greener pasture.

    I am buying a GTX480 this week, I dont care about power consumption, and heat will not be an issue as I will turn the fan up and have x1 200mm fan blowing from the side, and x1 120mm fan blowing in front of it.

    Should be a nice upgrade from my 4870x2, not much about 20% faster (correct me if I am wrong there).

    Nvidia may not release drivers very often but heck they work a lot better than ATI's. I just want away from dual cards, and a 5870 is not much of an upgrade from my card more like a side-grade.
     
  10. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    btw someone mentioned that u can have the card run at 3d clocks the whole time (if u arent bothered about power consumption) using rivatuner and so u dont need 3d detection...until ur 480 gets here :D

    lol i just woke up, the guy above u said it, u probably read it ahaha
     

  11. zodden

    zodden Guest

    Looks like we got a driver fix from Twl......1.0 experimental

    Can't believe ATI let this happen and yet he was able to fix so easily...
     
  12. Shataan

    Shataan Maha Guru

    Messages:
    1,144
    Likes Received:
    100
    GPU:
    EVGA 2080 RTX
    The 10.7a hotfix drivers disable the 2nd GPU on my 5970 as well. Back to the 10.4s, both work fine. I hope the driver dudes get their sh*t together. I paid alot of dough for this card.
     
  13. Stingray

    Stingray Master Guru

    Messages:
    334
    Likes Received:
    2
    GPU:
    Asus 2080 Super OC
    Don't feel bad, a good number of 5970 users can't seem to get past 10.5a either.
     
  14. PearlChoco

    PearlChoco Master Guru

    Messages:
    240
    Likes Received:
    5
    GPU:
    ASUS GTX 570 DirectCU II
    What's the easiest way to check if both GPU's are working?
     
  15. Mr_THC

    Mr_THC New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    4870x2@820/940 (Cat10.5a)
    Just run two instances of GPU-Z with selected different GPUs (on each app instance) and then launch some game ;)
     
    Last edited: Aug 28, 2010

  16. zodden

    zodden Guest

    Or run ATI Tray tools and turn on OSD....

    Then hit your OSD hotkey in game and it will tell you on screen what Mhz your card is running at.
     
  17. IM0001

    IM0001 Master Guru

    Messages:
    379
    Likes Received:
    0
    GPU:
    PNY 780 GTX
    Just overclock you GPU Core 10Mhz in rivatuner and be happy. You don't really save that much power from your 2D clocks anyway and its a small price to pay if 3D clocks is that big a difference for you.

    5970 Guys, when you say your 2nd core is broken, do you mean your also stuck in 2D clocks or do you notice an actual FPS difference from the 2nd core not in use? (like Vantage scores change drastically from a working to nonworking driver?). Even at 2D Clocks my 2nd core may only show 40% useage under GPU-Z but I do know I am getting a true FPS Increase from it then without it.

    Feels similar to the 9.8-10.2 days of the 4870X2 where the 2nd core would throw an ERROR 43 at us all day.

    These cards are not for the feint of heart, but when they work, (even if it takes a little effort on our part), they work fantastic.
     
  18. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    This is getting ridiculous, is it too much to ask that the other half of my purchase works? 3 Months now, mine and everybody elses' x2 is fux0rd. No sign of any change, maybe we just haven't been vocal enough on amd forums and catalyst makers twitter..
     
  19. blackfloyd

    blackfloyd Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    GTX 580
    I'm sick of this stupid bug and have to use 10.5. After all these years with many ATI graphic cards I'm going to buy a Nvidia card.
     
  20. TwL

    TwL Ancient Guru

    Messages:
    1,828
    Likes Received:
    0
    GPU:
    2x5850 2x6950 + 9800GTX
    How is the 10.8 hotfix which came after that 10.8 WHQL for HD4xxx cards ? (I don't really care, if it states AGP)

    Just running a bit here benchmarking for final HD3/4 card driver, which I build (before I started having system wide issues myself). Still needs a bit testing, but I think I am
    getting close to get newer drivers than 10.5a working soon enough.
     

Share This Page