4870 X2 10.2 and BSOD

Discussion in 'Videocards - AMD Radeon Drivers Section' started by shemek, Mar 10, 2010.

Tags:
  1. shemek

    shemek New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Sapphire 5770 1GB
    What happens right now is when I start my pc with installed drivers, screen goes black (after windows loading) and after 2-3 minutes I get BSOD with atikmdag.sys. (and sometimes atikmpag.sys)

    Safe mode works fine so there I can use driver sweeper to delete files so I can get back to "normal" windows and there uninstall rest.

    It started with 10.2 when I was playing games, screen went black occasionaly (not realy often) when I was quiting or alttabing so then I had to do hard reset. But on my last play I got some artifacts (little blue circles all over the screen) so I exit the game and *PUFF* black screen and windows didn't start to this day ;( And after this it happens with different drivers like 9.11 and 9.12.

    Spec:
    Vista 64bit SP2
    c2q q9550@3.2
    Sapphire 4870X2 with Arctic Cooling Accelero Xtreme
    Asus Rampage Formula
    2x 2GB DDR2 Kingston

    I kinda rulled out overheating because in idle it gets to 34'C and in stress to 48'C (and gpu was not o/c). Tried windows recovery from few days back, didnt help also read about one windows update that causes bsod but uninstalling didn't help :/ Installin just display drivers without ccc also no luck.

    any advice ?
     
  2. bokah

    bokah Ancient Guru

    Messages:
    2,316
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G
    uninstall and use ccleaner
     
  3. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    what are your vrms temps under load?
     
  4. Maulataur

    Maulataur Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    MSI 970 Gaming
    Same thing started happening to me on my XFX 4870x2 a week ago just a few days after installing 10.2. Went back to 9.12 and it continued to happen. Happened during POST as well. These issues didn't happen every time I started my computer or played a game. Then, yesterday, I found I could not boot my computer at all. Nothing came up on my screen. I reseated the card and nothing. The card had no dust clutter on it as I regularly clean my PC with cans of air. I put in an old 9500GS i had which allows me to now use my PC. Sucks going from a 4870x2 to a 9500GS. I got an RMA # and sent the card back today.
     

  5. tuco

    tuco Ancient Guru

    Messages:
    3,016
    Likes Received:
    0
    GPU:
    2 460's
    You RMA'd because of a bad driver installation? Are you saying installing 10.2 broke your gpu? lol :3eyes:
     
  6. shemek

    shemek New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Sapphire 5770 1GB
    can you tell where I can find it ? or what prog to check these temps but I can't run any game right now so dunno if I can read temps under stress

    doesn't work

    So should I assume that my card is ok because it runs without drivers, can play my hd movies or watch clips on youtube etc or something could have broke and does it work "differently" with drivers and should I say goodbay to it ? :|
     
  7. bokah

    bokah Ancient Guru

    Messages:
    2,316
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G
    did u try to install 9.11 or .12 after u cleaned drivers?
     
  8. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    Use the hardware monitoring option in Rivatuner and check for VRM temps under load
    [​IMG]

    I was having some black screens and found out that the temps VRM were really high (100+ degrees) because of that I was having those problems. Core temps were fine (watercooled) but VRM were insane. I fixed the position on the block and it is all good now.

    Btw when these black/blue screens happen are there lights on the videocard "on"?
     
  9. shemek

    shemek New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Sapphire 5770 1GB
    Sorry for late reply but suddenly net at dorm decided to stop workin for a day ;( ehh really got some bad luck lately
    Rivatuner is showing 71'C on vrms in idle (can't check it in stress, without drivers nothing wants to work ) so i guess its bit too high for just waving mouse in windows. I'll be trying to get some "equipment" and do something through weekend.
    Thanks
     
  10. nick0323

    nick0323 Maha Guru

    Messages:
    1,002
    Likes Received:
    55
    GPU:
    Asus DUAL RTX2060S
    Revert to Catalyst 9.11.

    Catalyst 9.12 and onwards doesn't seem to treat Radeon HD4XXX users very well.

    See all the user complaints about it from the Catalyst 10.2 thread on this forum.

    Also if you are using a partner board for example a HIS Radeon then you may wish to try using their drivers. HIS update drivers once every 3 months which is often enough.
     
    Last edited: Mar 12, 2010

  11. Maulataur

    Maulataur Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    MSI 970 Gaming
    Hehe, I RMA'd cause my GPU stopped working altogether. I'm not saying 10.2 broke my GPU. Just was a coincidence to happen shortly after installing them. :p
     
  12. lenne

    lenne Master Guru

    Messages:
    352
    Likes Received:
    0
    GPU:
    1080 GTX Gainward
    4870x2 here with 10.3, works like a charm, never heard about "drivers treating not well" seems like u got a differen problem, good shot at the vrm temps, check them...
     
  13. nick0323

    nick0323 Maha Guru

    Messages:
    1,002
    Likes Received:
    55
    GPU:
    Asus DUAL RTX2060S
    10.3 is still only in beta stages...

    I wasn't referring to beta drivers. I was referring to 9.12, 10.1 & 10.2 which don't treat the Radeon HD 4xxx series very well. We all know 10.3beta treats them better and if you want to test beta then that's up to you.

    Either way the latest certified driver is 10.2 and 9.11 is the best driver for most people on the HD4xxx series so far and when 10.3 comes out then hopefully it'll be the step up that most people are looking for in terms of stability and performance.
     
  14. KBDE

    KBDE Master Guru

    Messages:
    216
    Likes Received:
    25
    GPU:
    R290 4gb
    There is something serious wrong with 10.2. I've had overheating issues with these drivers to the point my room smelled burned. (this was after whole day idling @ windows desktop)

    Some kind of 2d/3d bug is in this release, althrough i could not confirm it.
    Anyway, i've installed rflairs drivers and problems are gone.

    PS: Didn't bring it up before since it's considered normal that ATI ****s this up.
     
    Last edited: Mar 16, 2010
  15. Maulataur

    Maulataur Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    MSI 970 Gaming
    Wow, I just got my replacement card back for my failed 4870x2 and it's a 5870. I hope it turns out to perform just as well as my 4870x2 did.
     

  16. jaggerwild

    jaggerwild Master Guru

    Messages:
    829
    Likes Received:
    298
    GPU:
    EVGA RTX 2070 SUP
    blank screen not a dead card! RMA is not a fix......
     
  17. 7DayTheory

    7DayTheory Active Member

    Messages:
    78
    Likes Received:
    0
    GPU:
    EVGA GTX 780 Ti SC
    My card did something similar.
    In 10.1 I saw some minor artifacting that I didn't really care about,in 10.2,games that use a lot of video memory started to artifact (Blue rectangles.) and my computer kept crashing randomly,it happened a lot when I was watching flash videos on Youtube,and I was using the GPU powered Flash beta.

    Uninstalled the drivers and did a total clean out with Driver Sweeper,installed 9.12,and also tried 10.1.
    No changes,kept doing the same. Used OCCT and it located 27999 errors within 36 minutes,I did an RMA but haven't got a replacement yet.
    Hopefully I get a 5870. (Bought a card meanwhile,had to order a bunch of other things anyway,and they said it would take 4-8 weeks to get a replacement.)
    Does anybody know how big the chance of getting a 5870 is?
    I mean,after all,the 4870x2 haven't been manufactured for quite some time.
    If anybody wonders my was a Club3D.

    This issue might've been a coincidence with the 2010 drivers or it was the cards time to go,funny though,my card had been running at around 80 degrees since I got it,reaching 95 when gaming. I couldn't do anything to fix that though since that would void the warranty.
     

Share This Page