4:3 on a Widescreen monitor with Nvidia drivers

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Insomniac34, Feb 24, 2008.

  1. Insomniac34

    Insomniac34 Ancient Guru

    Messages:
    1,903
    Likes Received:
    0
    GPU:
    GTX 460 768mb (800/1900)
    I was going to pick up an 1680x1050 widescreen monitor this afternoon, but there's only one thing holding me back. I have a couple games that I play quite often, "NBA Live 06" and MVP Baseball 2005", that don't have native support for widescreen monitors. There are fixes out there to allow for widescreen gaming, but all it does it stretch the image out. And that's something I just don't want.

    So my question is, using Nvidia drivers, how easy would it be to play these games at a 4:3 resolution on a widescreen monitor without any stretching? Is there a setting I can easily change? Is it as easy as setting a custom resolution? I was hoping to set the resolution to 1400x1050 (4:3) and be able to have black vertical bars on the sides of the screen. But I've never had a widescreen monitor, so I'm not sure how easy this is to set up. I'm also unsure if there's an option on the monitor itself to allow me to do this.

    I appreciate any help or info I can get.
     
  2. Paladinchan

    Paladinchan Ancient Guru

    Messages:
    1,998
    Likes Received:
    0
    GPU:
    EVGA RTX 2080 FTW3
    well.. what you are looking for is used with nvidia drivers and digital monitors where it puts those black bars around the outside ... It is called scaling but the bad news is that i believe XP drivers are broken when it comes to that..
     
  3. Insomniac34

    Insomniac34 Ancient Guru

    Messages:
    1,903
    Likes Received:
    0
    GPU:
    GTX 460 768mb (800/1900)
    Thanks for the quick reply. Shame that it doesn't work properly with XP, which is what I'm using. If anyone knows of any possible work-arounds, I'd greatly appreciate it :)
     
  4. Osamar

    Osamar Member

    Messages:
    38
    Likes Received:
    1
    GPU:
    Gforce 560 Ti 1Gb
    With DVI I never had any problem with scaling in WXP.

    In NVIDIA control panel:
    - Screen
    -- 3rd entry Flat screen scaling

    2nd scaling option
    "Use Nvidia aspect scaling"

    the options texts sure are not the same but I am free translating from spanish,but I think you get the meaning.
     

  5. neothe0ne

    neothe0ne Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    512mb XFX Radeon HD4870
    Correction to the above: You want NVIDIA scaling with fixed aspect ratio, not just NVIDIA scaling.

    If you can't get it to work after tinkering with options and different orders of applying/OK'ing, try a different driver set. Eventually you'll get scaling to stick, but NVIDIA is really annoying cuz they don't keep consistency (but better than ATI which doesn't have scaling at all?? correct me if I'm wrong)
     
  6. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    OK it will work.

    Firstly in "change flat panel scaling" set option to "do not scale".
    If you have an 8800 series card you may need to apply this patch then restart to get it to work
    http://nvidia.custhelp.com/cgi-bin/...std_adp.php?p_faqid=2064&p_created=1177972007

    This will give you the black bars around the edge hence no strecthing or scaling. (I used to play BF2 in 1400x1050 untill the true widesreen fix was released)

    However if you want to be extra certain it will work you could get a monitor which has either.....
    1) 1:1 Pixel mapping mode
    or
    2) 4:3 mode

    Then the monitor will actually centre the image for you aad put the black bars around the edge, so you don't have to worry about the idiots at nvidia with their rubbish drivers.

    I have a samsumg 215tw and it does 4:3 mode, so when set to this 1400x1050 has black bars down the sides.
     
  7. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    In Vista it works perfectely on my eVGA 8800GTX even without the compensation fix... while in XP it works sometimes yes and sometimes not (because of damn video playing that resets the setting and I have to reapply the compensation fix :(. It really sux).
     
  8. attila_gorilla

    attila_gorilla Master Guru

    Messages:
    608
    Likes Received:
    0
    GPU:
    ATI Mobility HD 5730
    I`ve got a widescreen monitor with 1680x1050 native and Win XP. I`ve had to make a custom resolution of 1400x1050 and it works every time, no resets and no patches required. You just need to create the custom resolution with the right settings.

    In the custom resolution advanced options, set scaling type to `centered` and Active horizontal pixels and active vertical lines the same as the desired res values (ie 1400x1050 in your case). And then set the flat panel scaling to `Do Not Scale`. No problems at all.
     
  9. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    LOL! The problem is "Do not scale"... if you watch a video it resets automatically itself to "Proportionate".
     
  10. attila_gorilla

    attila_gorilla Master Guru

    Messages:
    608
    Likes Received:
    0
    GPU:
    ATI Mobility HD 5730
    Hmmm I have 4 options:
    -Nvidia Scaling
    -Monitor buil-in scaling
    -Fixed aspect ratio
    - And Do Not Scale.

    Mine is set to Do not scale, and it never changes itself no matter how many videos I watch.
     

  11. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    Really? (Anyway I mean the first)

    Are you under Wind XP 32 or Vista?
     
  12. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Using Win XP 32Bit.With driver 174.12

    Watching avi files does reset my scaling choice from 'do not scale' to 'use display built in scaling'.

    However a restart sees it switch back to 'do not scale' (without me having to change it or reapply the fix)

    A can of worms me thinks
     
    Last edited: Mar 3, 2008
  13. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    I'll try 174.XX then!
     
  14. Corrupt^

    Corrupt^ Ancient Guru

    Messages:
    7,080
    Likes Received:
    373
    GPU:
    Geforce RTX 3090 FE
    Or u could buy a monitor which can force aspect scaling by itself. A clanmate of mine has this cheap ass monitor which can scale everything properly with bars when needed with the press of a button and the screen works fine aswell... makes me kinda mad spending 300 bucks on a freaking samsung.

    I'm gonna try slickric21's fix and see if it works for me, if it works, a free beer for you if I ever see u irl xD

    EDIT: lol I can now select scaling but it does not happen as it should... the drivers are acting as if my screen was a 4:3 monitor and not a 16:10 monitor and adds black bars @ the top instead of the side and thus making everything even more stretched xD
     
    Last edited: Mar 3, 2008
  15. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Thats always the best fail safe to have a monitor that does 1:1 pixel mapping - takes the Nvidia drivers out of the equation

    Did you select 'do not scale' option and which resoultions you trying ?
     

  16. attila_gorilla

    attila_gorilla Master Guru

    Messages:
    608
    Likes Received:
    0
    GPU:
    ATI Mobility HD 5730

    I`ve got XP32 with driver version 171.17. I don`t have the problem you`re talking about. Don`t know what could cause the issue for some people.
     
  17. Corrupt^

    Corrupt^ Ancient Guru

    Messages:
    7,080
    Likes Received:
    373
    GPU:
    Geforce RTX 3090 FE
    Yep, tried 1024x768
     
  18. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    I've just tried out the 1024x768 on my screen and it centered on my 16850x1050 display perfectly.

    Win Xp32, Driver 174.12, 'do not scale' ticked and applied.

    Seems this issue affects different setups in different ways. Sorry it didn't work for you.
     
  19. Kolt

    Kolt Ancient Guru

    Messages:
    1,652
    Likes Received:
    507
    GPU:
    RTX 2080 OC
    For me, all the options in the control panel are un-'tickable'. I would love to be able to "do not scale" if I could. Playing older games on my 16.10 monitor isn't the prettiest sight (stretch)

    Using 171.23XP32beta drivers
     
  20. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    apply this fix
    http://nvidia.custhelp.com/cgi-bin/...std_adp.php?p_faqid=2064&p_created=1177972007
    then restart. You should then be able to select them.

    http://forums.guru3d.com/showthread.php?t=254754
    http://forums.guru3d.com/showthread.php?t=239512
    = recent threads relating to this issue
     

Share This Page