2d/3d switch always needed?

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by blackrat, Apr 1, 2009.

Tags:
  1. blackrat

    blackrat Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Radeon HD5850
    When I set 3D overclocking, save, then go to 2D it has the overclocked values from 3D setting before.

    When I set 2D overclcking (meaning want to used default clock or lower), save, then go to 3D prformance oc it has the values form 2D.

    That means for this simple task that the graphics card throttles down in 2D, I have to make two profiles and a switch in hardware monitoreing? True. or only needed to add special things like fan speed or voltage changes.
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,999
    Likes Received:
    3,503
    Not all BIOSes allow 2D/3D clock separation, e.g. it is allowed on 6800Ultra, not allowed on 8800GTX, allowed on GTX 200 series etc. If your BIOS don't support 2D/3D clock separation, you can always emulate it with the task scheduler.
     
  3. blackrat

    blackrat Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Radeon HD5850
    Thanks, now I understand why it's not working.

    I have a 8800 GTS, problably the same reason as with GTX.
     
  4. blackrat

    blackrat Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Radeon HD5850
    I tried, but it is only possilbe to make a switch to go to a profile (hi clock) by means of framerate, but not to go again back to a low profile.

    Reasons: Hardware acceleration seems not to be changed from DirectX games
    When I exit 3D game, the framerate is not zero, it has no value at all, and so can't be used for a switch.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,999
    Likes Received:
    3,503
    > Reasons: Hardware acceleration seems not to be changed from DirectX games

    Not true, you should use exactly <Hardware acceleration> graph
     
  6. blackrat

    blackrat Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Radeon HD5850
    I checked it yesterday with Furmark, 3DMark, Fallout3:
    hardware accelaration in the hardware monitor is not triggered (RT 2.24, XP 182.0.8, 8800GTS)

    Beside solving this problem, could you simple make a change to RT, that it reports framerate 0 when no 3D runing, then I could use the framerate trigger easily.

    EDIT: I have to add, that I use driver emulation mode, because 182.0.8 not known by RT): I put in driver No. in power user panel
     
    Last edited: Apr 2, 2009
  7. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,999
    Likes Received:
    3,503
    Check it once again, you're doing something wrong (selected wrong provide for the graph?). It physically cannot be "not triggered" if framerate graph reads some values, because these graphs are just the binary conversions of the framerate graph.

    First, there is nothing to solve. Second, no I will not make that change because hardware acceleration graphs serve for that and framerate graph displays no data by design to allow seeing the differences betwenn no 3D application running and pseudo-3D application runtime.
     
  8. blackrat

    blackrat Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Radeon HD5850
    sampling period, freezing period

    Sorry for the last post,
    I made a little error in the values, and it's working now (with hardware acc.).

    In the scheduler I set sampling period to 1000,
    and freezing period to 2000
    Right, or are completely diff. values reccomended?
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,999
    Likes Received:
    3,503
    These parameters are intended for handling scheduled tasks based on rapidly changing hardware monitoring graphs, e.g. GPU usage or temperature. So you can safely set both to 0 for binary graph like Hardware acceleration.
     
  10. blackrat

    blackrat Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Radeon HD5850
    Thant you for alle the help, I think it's solved now.

    My error was, that I used "Hardware acceleration / OGL".
    Now I use simple "Hardware acceleration" and it works!!!

    I read an article on the internet, where they used the OGL setting, so never noticed that there are other settings around.
     

Share This Page