265.90 WoW issues

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mysteryboi, Jan 23, 2011.

  1. Mysteryboi

    Mysteryboi Member Guru

    Messages:
    129
    Likes Received:
    12
    GPU:
    EVGA GTX TITAN SC
    New to these forums im unsure if this is the correct section to post this but i will try my luck

    I recently upgraded from a evga gtx295 to a evga gtx580

    I installed the 265.90 drivers all games run smooth except world of warcraft


    My issue being if i load the game up it will run smooth after alt tabbing or minimizing the window occasionally when i bring the window up i will suffer a issue best describe as when moving in game it feels like im running at 10 - 15fps although when i display fps in game it shows a 150 - 250fps its as if the game is stuttering

    If i alt tab and tab back in the problem persists if i change from windowed mode (which is what i play in) to full screen the stuttering stops then switching back to windowed mode smooths the game again

    Is there a way or setting to prevent this happening nearly everytime i alt tab ?

    If you need anymore info just ask i will reply very fast thank you
     
  2. ThEcLiT

    ThEcLiT Master Guru

    Messages:
    519
    Likes Received:
    47
    GPU:
    Gigabyte 460 1gb OC
    Try closing "triple buffering" and untick "max background fps", these helped alot to me.
     
  3. Mysteryboi

    Mysteryboi Member Guru

    Messages:
    129
    Likes Received:
    12
    GPU:
    EVGA GTX TITAN SC
    Both already disabled
     
  4. OvR|<|LL

    OvR|<|LL Maha Guru

    Messages:
    1,168
    Likes Received:
    1
    GPU:
    Nvidia

  5. sykozis

    sykozis Ancient Guru

    Messages:
    21,934
    Likes Received:
    1,124
    GPU:
    MSI RX5700
    Blizzard recommends running the game in full screen for best performance....

    If you haven't already....you can try adding -d3d11 to the end of the target line in the shortcut properties to force DirectX 11 mode... the target line should look like this:

    "C:\Users\Public\Games\World of Warcraft\Launcher.exe" -d3d11
     
  6. Mysteryboi

    Mysteryboi Member Guru

    Messages:
    129
    Likes Received:
    12
    GPU:
    EVGA GTX TITAN SC
    I did try them the problem i speak about did not occur as much although it did happen a few times as for the dx 11 i am already using that

    Thanks for the suggestions

    Also when i installed the current drivers i used driver sweeper etc and did clean install in the nvidia install manager option
     
  7. Lightmgl

    Lightmgl Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    EVGA GTX 460 SC SLI
    I had very similar issues to this before I disabled HPET in my bios with my 460. Unfortunately WoW Windowed mode took a bit of a dip in performance and stability in Cataclysm too.
     
  8. Razunter

    Razunter Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    GTX 1080Ti
    Try switching back not by alt+tab, but with clicking on icon.
     
  9. bokah

    bokah Ancient Guru

    Messages:
    2,316
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G
    fps is capped at 200 by default now, u can try adjust this to 100-150 or maybe try 300 or 0
    hope it helps
     
  10. sykozis

    sykozis Ancient Guru

    Messages:
    21,934
    Likes Received:
    1,124
    GPU:
    MSI RX5700
    FPS in WoW is not capped at 200....I hit 400+ in some areas.
     

  11. bokah

    bokah Ancient Guru

    Messages:
    2,316
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G
    setting fps cap has changed a bit after cata, this used to be variable in cfg or wtf(added in 3.2 or something and it was set to 200 by default), but i cant find it there anymore

    instead u can change it from video options or /console

    http://www.arenajunkies.com/showthread.php?t=212221

    edit: i also tested this and it caps fps in both fullscreen and windowed modes
     
    Last edited: Jan 23, 2011
  12. sykozis

    sykozis Ancient Guru

    Messages:
    21,934
    Likes Received:
    1,124
    GPU:
    MSI RX5700
    You can either manually set an FPS cap...or disable the cap completely in the video properties. Personally, I'd recommend refering to the WoW forums as opposed to sites like arenajunkies....
     
  13. bokah

    bokah Ancient Guru

    Messages:
    2,316
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G
    nothing wrong with arenajunkies site opposed to site like wow forums, u can try google it, u most likely wont get to right post with it

    to op: disable all background programs and see if problem goes away: steam, browsers, pb, messenger, rivatuner and related, gpu-z etc
     
  14. Zer0K3wL

    Zer0K3wL Banned

    Messages:
    3,073
    Likes Received:
    0
    GPU:
    gtx 480 850/1700/2000 h2o
    set energy mode to full performance.

    wow is such crap game it does't even utelize gpu much at all.
    even that less that it feels like just going 2d clocks mostly.

    setting energy mode to full performance wil fix that.



    i would't google anything related to wow unless you want free malware :p
     
    Last edited: Jan 24, 2011
  15. sykozis

    sykozis Ancient Guru

    Messages:
    21,934
    Likes Received:
    1,124
    GPU:
    MSI RX5700
    I see, on average, 50-60% GPU usage in DX11 mode. Googling WoW doesn't give you free malware...lol.
     

  16. Mysteryboi

    Mysteryboi Member Guru

    Messages:
    129
    Likes Received:
    12
    GPU:
    EVGA GTX TITAN SC
    Just for future reference i didnt find a permanent fix for this problem


    If you change to Fullscreen then back to windowed mode the stuttering stops
     
  17. mitzi76

    mitzi76 Ancient Guru

    Messages:
    8,722
    Likes Received:
    19
    GPU:
    MSI 970 (Gaming)
    oh and crashes for me when u try and enable dx11. perf is better when i add the set line to the config.

    seems to work for a 5970 though..:)
     

Share This Page