2070 Super vs Netflix. Monitor flicker, TV goes no-signal

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by marcel0s, Oct 17, 2019.

  1. marcel0s

    marcel0s New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus Strix 2070S
    Hi,
    I've run into a very weird issue. I switched from GTX970 to 2070S recently.
    - Have latest drivers installed (436.48).
    - 1080p60Hz monitor and 4k60Hz TV connected with HDMI2 cables.

    As soon as I open Netflix in Firefox browser (or the store app), monitor starts to flicker and TV goes black screen. Eventually TV reports lost HDMI signal and the monitor continues to flicker until I unplug and reconnect TV hdmi cable. After that all goes back to normal (unless I keep netflix opened). Haven't noticed any other problems with the new graphics card itself. I plan to roll back to some older drivers to see if there will be any difference, but ran out of time today.

    Problem was non-existent when using GTX970.
    OS: Windows 10 1903
     
  2. Blackfyre

    Blackfyre Maha Guru

    Messages:
    1,017
    Likes Received:
    33
    GPU:
    MSI 1070 Gaming X
    1. Do a clean install of drivers. Use DDU (Display Driver Uninstaller) in Windows Safe Mode (give it permission from the programs options, run it as admin).

    2. Try a different HDMI cable for the TV. But first try the monitor by itself plugged into the GPU, then the TV by itself, see which one is causing the issue.

    Also note; If you want to watch Netflix 4K, use Edge Browser and go to the Windows Store first and download and install HEVC Video Extensions (restart PC after).

    If you upgraded from a GTX970 to a 2070s, I'm going to assume you do not have a CPU that supports 4K Netflix. So using the Edge Browser with that extension installed (I paid $2 for it, they might have made it free now) is your only option as the GPU will do the processing, since Pascal and higher nVidia GPU's support Netflix 4K with Microsoft Edge.

    To check if Netflix is running in 4K, press CTRL + ALT + SHIFT + D while watching something that you know is 4K supported on Netflix, give it a few seconds to a minute to switch to 4K while watching depending on your connection.
     
  3. Chastity

    Chastity Ancient Guru

    Messages:
    1,987
    Likes Received:
    500
    GPU:
    Nitro 390/GTX1070M
    I'd also make sure GSync is disabled for Firefox or any video playback app.
     
  4. marcel0s

    marcel0s New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus Strix 2070S
    Thanks for suggestions guys. Much appreciated.
    @Blackfyre
    - Wiping the drivers is on my to do list. Will update once tried.
    - I'd rule out HDMI cables. With 970 everything worked with the same setup. Same cables, same monitor and TV. Same resolutions and refresh rates.
    - I'd take CPU out of the picture as well. Currently have i7-9700K so it's way more than enough. Also there were no issues when I was using i5-4670k with GTX970 and same monitor and TV.

    @Chastity
    There's no GSync in the monitor. It's quite simple 1080p iiyama monitor.
     

  5. janos666

    janos666 Master Guru

    Messages:
    680
    Likes Received:
    50
    GPU:
    MSI GTX1070 SH EK X 8Gb
    Is that a real (local) game on the TV or a video (offline file or online stream) from a different video player?

    There is a free (hidden) version of that codec but everything (except 4k and HDR) should work fine without it (only limited to 2k and SDR).
    https://www.microsoft.com/en-us/p/hevc-video-extensions-from-device-manufacturer/9n4wgh0z6vhq?irgwc=1&OCID=AID2000142_aff_7593_159229&tduid=(ir__thmtlevkdgkfrmoqkk0sohz30n2xgxevo6jawi6100)(7593)(159229)()(UUwpUdUnU56397YYwYg)&irclickid=_thmtlevkdgkfrmoqkk0sohz30n2xgxevo6jawi6100&activetab=pivot:eek:verviewtab
    Another potential problem with 4k is that the effective HDCP version is cut to the lowest common denominator of any active displays. So, no 4k if you have an old 2k display connected and active (in extended or clone mode). But you still have 2k in that case (even with HDR).
    The display should never go blank in any case.

    Although I occasional do get blank screen problems while switching between SDR and HDR.
    And Netflix is capable of Dolby audio passthrough with some players (Store app only, I think, I would be surprised if it worked with FireFox) which requires exclusive access to the audio mixer and that can crash a video game or all other video players running (as soon as the exclusive app takes over everything else is cut off).
     
    Last edited: Oct 18, 2019
  6. marcel0s

    marcel0s New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus Strix 2070S
    I might have found something. TV has the "HDMI UHD Color" option which is currently disabled (I don't know if it was the same for 970). As soon as I enable it for the HDMI port connected with the GPU I lose signal on TV. As it turns out, when I open Netflix (regardless Firefox or store app) the "HDMI UHD Color" gets enabled automatically.
    I tried going down to 4k30Hz on TV but it still behaves the same.
     
  7. janos666

    janos666 Master Guru

    Messages:
    680
    Likes Received:
    50
    GPU:
    MSI GTX1070 SH EK X 8Gb
    May be do try another cable then (even if that other one is older and cheaper, just grab any you can find). Do any of your cables have a "Premium Speed" hologram sticker somewhere on the box? (Or at least sold as "HDMI 2.0 cable" - which is an incorrect labeling but still...)
    It's probably a compatibility issue with the TV's EDID though.
    Try to set the PC to 1080p60 8bit RGB and see if you can enable UHD Deep Color on the TV. Oh, and try to switch resolution (to literally anything random and then back to the desired) after you loose the image (sometimes it helps to "reinitialize").
     
    Last edited: Oct 18, 2019

Share This Page