185.85 WHQL available

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by gjaegy, May 7, 2009.

  1. E.J.Smith

    E.J.Smith Master Guru

    Messages:
    228
    Likes Received:
    0
    GPU:
    EVGA GeForce Titan
    Somewhat sophisticated computer user here and the CP also does not work on my system using XP SP3. I began with a clean install and then tried an install over the 182.50; neither method produced a complete driver installation. CP aside, performance with this driver is hit-or-miss. For example, Total War: Empires is very stuttery. I rolled back to 182.50.
     
  2. Year

    Year Ancient Guru

    Messages:
    11,594
    Likes Received:
    1
    GPU:
    EVGA GTX 690
    excellent drivers for me, just as good as the previous beta, never been a fan of 185.xx but the previous beta and this one are just perfect.

    at least they've fixed also the bug where NVCPLUI.exe would not unload (as seen in the Task Manager).

    no performance increase from the previous betas but now Fallout 3 bug has been fixed (i used to get a few flashing objects in the distance), it was the only issue i had and now its fixed, so far so good.
     
  3. Mr.Bigtime

    Mr.Bigtime Ancient Guru

    Messages:
    20,794
    Likes Received:
    8
    GPU:
    ASUS 1080TI

    agree. ATI scks in my PC..with its 4870.
     
  4. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,056
    Likes Received:
    572
    GPU:
    EVGA GTX 1080 Ti SC2
    I have to confess that despite claiming that I normally don't have any problems installing new drivers over old drivers, I did with these. Despite the fact that the control panel showed the correct 185.85 file versions, when I ran F.E.A.R. 2, it crashed upon entering the actual game itself. So did several other games too, although some worked oddly enough.

    So I ended up having to uninstall them, which only reinstated the earlier 182.08 ones for some reason, strange as I don't ever recall installing them! Anyway I ended up having to uninstall them from the Hardware Devices manager at which point I was asked to restart my PC. I used MSConfig to make sure it booted into Safe mode where I ran Driver Sweeper to remove all the old entries. I then reinstalled the 185.85 WHQL drivers and rebooted into Windows normally.

    All the games now work perfectly, including F.E.A.R. 2, although I did get an error about the NVCpl file when I first booted into Windows but it was gone on subsequent reboots.

    All my profile settings were, of course, lost as a result of doing a clean install but I was able to restore them using the very useful nHancer. Bearing in mind that the NVIDIA control panel has no way of backing up these profiles, it seems to me to be an oversight if people are expected to install drivers clean every time. Personally I think it's a right royal pain and much prefer the ATI Catalyst method of having the installer do all the uninstalling/deleting for you as I got to try them before I got this new computer when I briefly owned an ATI RADEON HD 3850 card before Christmas.
     

  5. Viper666

    Viper666 Active Member

    Messages:
    52
    Likes Received:
    2
    GPU:
    Sapphire RX 460 2GB
    looking good

    everything working ok with the following titles: Flatout 2 UC, UT3, Grid, GTA4, Runes of Magic, Stalker CS, Cryostasis, HAWX, L4D

    don't see any improvement in framerate but i like em cause they have WDDM 1.1 and working great on Windows 7 RC x64 :nerd:
     
  6. collinvue

    collinvue Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    ~ 169 GB/sec. currently
    +

    Ermm, I thought everyone knew this.
    Always: Power User Tab= RivaTuner/System//ForceDriverVersion xxxxx just to be safe.


    Like to see a poll of people who are having endless problems with nvidia drivers + using DriverSweeper. Maybe stop using it. :)
     
    Last edited: May 8, 2009
  7. michaelosm

    michaelosm New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA Titan Black
    also, as with previous 185.x versions, I cannot save the 'scaling' setting. If I change to nvidia scaling, it defaults to display scaling.

    59hz is also the default even though I specify 60hz

    annoying bugs drive or win7 bugs? who knows! :puke2:
     
  8. Zer0K3wL

    Zer0K3wL Banned

    Messages:
    3,073
    Likes Received:
    0
    GPU:
    gtx 480 850/1700/2000 h2o
    hmmmmm not sure but think temp readings are broken with this set asswell with rivatuner.
    with 9800gtx+
     
  9. hirmak

    hirmak Master Guru

    Messages:
    321
    Likes Received:
    0
    GPU:
    GTX285
    I don't have any problems with this driver and Riva Tuner:nerd:
     
  10. _OKAMI_

    _OKAMI_ Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    Asus DCU2 GTX660Ti SLI
    Anyone know how to fix context menu lag in Windows 7?
    Everything else seems to works fine except that and RivaTuner doesn't seems to want to overclock even with power user setting.

    EDIT: Oh it works just had to restart RivaTuner. Now only problem is context menu on desktop.
     
    Last edited: May 8, 2009

  11. Hard Boiled

    Hard Boiled New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    EVGA GTX 275 x 2
    These drivers are working good for me so far.
     
  12. Barton C++

    Barton C++ Master Guru

    Messages:
    603
    Likes Received:
    1
    GPU:
    MSI Hawk GTX460 1GB @ SLI
    annoying wait for nvcpl to show up, takes more than 10 seconds to get to read PhysX version, which also is...bugged. Had a rare "driver has stopped responding" during Vantage PhysX test. When I turned PC on today (went to watch TV) I was welcomed by msg "BSOD caused by nvidia gfx driver"...
     
  13. _OKAMI_

    _OKAMI_ Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    Asus DCU2 GTX660Ti SLI
    One question. Enable PhysX GPU acceleration will this decrease performance?
     
  14. elrazor

    elrazor Master Guru

    Messages:
    367
    Likes Received:
    5
    GPU:
    970GTX G1 1591/7452
    same!
     
  15. Roostitup

    Roostitup Active Member

    Messages:
    88
    Likes Received:
    0
    GPU:
    GTX 275 SLI 713/1584/1242
    These drivers are not that great. I got major texture corruption issues playing World in Conflict. Going back to 185.81 beta.
     

  16. BeeJAyP

    BeeJAyP Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    EVGA GTX 980Ti Hybrid
    I have the same problems, however with the scaling problem, even though after setting a selection the checkbox goes back onto the default setting, for me that setting is still set even though the control panel says that it hasn't been.

    Try changing it to no scaling for example, close the control panel, then launch a game running a low resolution, it should have no scaling set, I'm not sure if it works for the other settings as I only use no scaling.
     
  17. Tyler Dalton

    Tyler Dalton Master Guru

    Messages:
    478
    Likes Received:
    4
    GPU:
    EVGA GeForce GTX 980 SC
    I went back to 182.50, I noticed I lost 1-5fps in most games with the 185.85 vs the 182.50 with image quality pretty much the same. I now realize that ambient occlusion only works in Vista so I would have to say, if you have XP, stick with 182.50 for now. I've been using the 182.50's since they came out and I haven't found any bugs yet.
     
  18. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    6,070
    Likes Received:
    52
    GPU:
    XFX 5700 XT Thic II
    Try adding your montior Edid to the ini with a override function.I have to do something like this when I using a DVI to HDMI adaptor. But not with a HDMI to dvi cable o_O.

    For me its a montior thing and not a driver thing as my dad's Westinghouse 27inch LCD HDTV doesnt need this work around to show the colors right for the desktop. When usind a DVI to HDMI adaptor with a HDMI cable.
     
  19. YetYhunter

    YetYhunter Maha Guru

    Messages:
    1,231
    Likes Received:
    6
    GPU:
    Jetstream GTX1080
    I can't even run the vantage phisics test!!!It just crashes saying that the correct version is not installed
     
  20. mark007

    mark007 Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    XFX GTX 295
    Well this override has worked perfectly all the way upto the 182 series but as of 185 I cannot get it to work. Even custom monitor driver's doesn't stop it giving limited range.

    If you know of a way to get the edid override working on 185 series let me know ;) :banana:
     

Share This Page