185.85 WHQL available

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by gjaegy, May 7, 2009.

  1. blaugznis

    blaugznis Member Guru

    Messages:
    124
    Likes Received:
    0
    GPU:
    Gainward GTX 1060 6GB
    Had the same problems installing it on Win7 RC 64bit. What i did was removing PhysX_9.04.08_9.09.0408_SystemSoftware.exe from its install dir and then launching setup.exe manually. Worked like a charm :) Then after reboot just install PhysX drivers.
    Hope this works for You too!
     
  2. YetYhunter

    YetYhunter Maha Guru

    Messages:
    1,231
    Likes Received:
    6
    GPU:
    Jetstream GTX1080
    Drivers performance is good but I can't run physix test with PhysX 9.04.08_9.09.0408 installed.I have to install th 0203 version.
    I get P14327.
     
  3. meds

    meds Master Guru

    Messages:
    385
    Likes Received:
    2
    GPU:
    .
    great drivers so far... hopefully cryostasis works now
     
  4. Mukul

    Mukul Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    Wow...Just Installed 185.81 10 Hrs Ago...
    Nyhow great Awesome Drivers...
    brought Down Temps For My GTX 260 by Approx 9-10 Degrees on same Ambient Temps...Thats one hell of an achievement...

    Also Did nyone here was able to make riva tuner work with these drivers..only fan can be controlled now by rivatune now..lol

    Oder then that awesome drivers ..perfectly stable..no issues whatsoever...
     

  5. Antarius

    Antarius Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    MSI GTX 280 SLI x 2
    Lots of artefacts and flickering in Empire: Total War and Warhammer online. I had to go back to 182.50.
     
  6. max883

    max883 Banned

    Messages:
    190
    Likes Received:
    0
    GPU:
    Asus 780Ti SLi
    Great drivers. but i lost my full hd 1920 x 1080 60hz. now i only get 1920 x 1080 30hz.
    Can not play crysis with 1920 x 1080, can only play 1280 x 720 at higest.

    And my control panel is loading for ever!!!



    I got full hd 1920 x 1080 60hz with 185.65 beta drivers, my favorit.
     
    Last edited: May 10, 2009
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,000
    Likes Received:
    517
    GPU:
    EVGA GTX 1080 Ti SC2
    Personally I cannot stand screen tearing, it's one of the main reasons I've moved back from the consoles to gaming on the PC. I enable V-Sync and use D3DOverrider to enable triple buffering... it gives me silky smooth gameplay in every game I play without any stutter.

    And once the framerate tops 60 fps I cannot tell the difference anyway (except for the godawful screen tearing!) so it might as well be locked. The TFT monitor I'm playing the game on can only update the screen 60 times per second anyway so there's no point in having anything higher, all I end up with is more screen tearing since those 60 frames per second will have bits of the extra frames thrown in as the framebuffer becomes overloaded. Looks bloody ugly IMO.
     
  8. DEA

    DEA Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    eVGA 9800GTX 770/1940 SLI
    Hey, I am having issues with this driver currently. My right click on the desktop takes awhile to load and my control panel isn't working. It crashes everytime it loads. Any tips?
     
  9. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    ^

    maybe its that pos nvidia ntune feature - monitoring software 6.xx causing driver control panel to crash, since its the one with driver cp.
     
  10. DEA

    DEA Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    eVGA 9800GTX 770/1940 SLI
    So what do you suggest I do? Because I am not that great when it comes to drivers lol.
     

  11. pdawg17

    pdawg17 Member

    Messages:
    44
    Likes Received:
    0
    Is D3DOverrider necessary? Does the triple buffering setting in the Nvidia control panel not work?
     
  12. BeLGaRaTh_67

    BeLGaRaTh_67 Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    EVGA GT680 Classified 4GB
    Terrible drivers, at least for me. After installing and rebooting I get an explorer.exe has stopped working error whenever I right click the desktop, games complain about invalid resolutions (I generally play in 1440x900) and there seem to be a lot of resolutions missing, including 1440x900, when attempting to rectify this ingame or via the preferences (Fallout 3).

    have gone back to 182.50 for now.
     
  13. ElFishoIII

    ElFishoIII Guest

    I was wondering the same thing.
     
  14. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    if u do have nvidia monitoring software installed, try to uninstall it first and see if it still crashes..if not that its this nv software, but if its still here then try 182.50whql drivers..



    and as for d3d overrrider that in nv cp is only for opengl games, so yes you need RT d3d overrider for dx games..
     
  15. elrazor

    elrazor Master Guru

    Messages:
    366
    Likes Received:
    4
    GPU:
    970GTX G1 1591/7452
    hey my friend have anisotropic filtering broken too with this ones!!! In assassins creed with 285 GTX
     

  16. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    10,648
    Likes Received:
    1,630
    GPU:
    Gigabyte 1070 Ti
    This is getting old... but BioShock stutters on these drivers as well. And not just for me, for a lot of people.

    The newest driver I can find to play the game smoothly is the 178.24 set... but then I loose a lot of performance enhancements and fixes for other games. :(
     
  17. TeethDestroyer

    TeethDestroyer Member Guru

    Messages:
    104
    Likes Received:
    0
    GPU:
    Gigabyte GTX Titan
    Lost my 1080p at 60 Hz on my LCD Samsung 32 1080p. Games without menu selection of frecuency runs at 24p...:(. Crysis now at 24p. No matter what I´ve tried on creating manual resolution rating, the drivers doesn´t delete the rest of refresh rates: 24, 30, 50 and 60. Choosing by games 24 Hz as default.

    AF its BROKEN on games like AOE III, Assassins...

    Nvidia, bad way. Seems to be a different group of programers of 182 series.

    Back to 182.50.

    Nvidia should remember a lot of people uses LCD TV 1080p as monitor and want to create a manual refresh that delete the defaults read by drivers.

    AAArrrggg.
     
  18. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    6,156
    Likes Received:
    70
    GPU:
    XFX 5700 XT Thic II
    I agree with the vsync part, I also use D3D override and tbuffer combo as I cant stand tearing my self. As I notice it in any game with ease.

    other post- AF isnt broken for me tho I dont have those games. Max you can try to manaully add the refresh rate in the drivers ini along with the edid override for your montior.
     
  19. Indeed

    Indeed Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    GeForce 256 (NV10) 120Mhz
    The nVidia triple buffer is for OpenGL applications. The D3DOverrider forces the triple buffer in direct 3d games liek css and crysis. You simply must use the d3doverrider if you want a stable 60 fps ingames. If you just enable the nvidia one, you'll be only using v-sync so intimes your fps will fall under 60.

    Same here man! The control panel takes it's sweet time to load. Lazy bastard! :banana:
     
    Last edited: May 11, 2009
  20. lmimmfn

    lmimmfn Ancient Guru

    Messages:
    10,419
    Likes Received:
    89
    GPU:
    AorusXtreme 1080Ti
    these sound ****, for the first time in 10 years ive experienced WHQL drivers that are **** from nvidia, the 182.50's, menu options missing, cant change things( one of the optimisation settings cant be turned on ) etc.

    So nope,seems their drivers are getting worse, will need a lot of convincing to install these
     

Share This Page