185.85 and L4D

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by uffa, May 14, 2009.

  1. uffa

    uffa Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    EVGA GTX 680
    Just installed 185.85 today. When I play L4D it the game freezes every while and then and it's ruining my game experience. Any one had the same problem? any driver that you recomend?

    I had this problem in the past. some drivers seem to have it and some worked like a charm. Back then after trial and error I sticked to one driver that didn't have this problem (which of course I don't remember now!)

    Any ideas?
     
  2. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
  3. Helpful

    Helpful Master Guru

    Messages:
    635
    Likes Received:
    0
    GPU:
    GTX 980 Ti
  4. LedHed

    LedHed Banned

    Messages:
    6,827
    Likes Received:
    1
    GPU:
    BenQ FP241W
    185.85 crashes on my GTX 295 and my GTS 512 during L4D play (even at stock speeds all around (CPU/GPU/RAM)), I'm almost positive there is a problem with the DLC and the 185 series drivers. I would definitely try playing on 182.50 as this is most certainly the best driver for L4D (I've tried the last 10 drivers and that is the best (including betas))

    show me any proof of CUDA versions having anything to do with L4D, L4D does not use CUDA in anyway. The only way that could be possible is if CUDA auto launches at start up and L4D has a conflict with a certain version.
     

  5. uffa

    uffa Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    EVGA GTX 680
    Thanks a lot guys! Downloading 182.50 right now.
     
  6. Helpful

    Helpful Master Guru

    Messages:
    635
    Likes Received:
    0
    GPU:
    GTX 980 Ti
    185.85 does look for CUDA:

    [SourceDisksFiles]
    NvCplSetupEng.exe = 1
    dpinst.exe = 1
    nvBridge.kmd = 1
    nvapi.dll = 1
    nvcod.dll = 1
    nvcuda.dll = 1
    nvcuvenc.dll = 1
    nvcuvid.dll = 1
    nvd3dum.dll = 1
    nvdisp.nvu = 1
    nvlddmkm.sys = 1
    nvoglv32.dll = 1
    nvudisp.exe = 1
    nvwgf2um.dll = 1

    And, while X3 Terran Conflict is not coded to use CUDA , the 185.85 is giving my
    game ~ 10 FPS boost @ 5120x 1200 res.
    Burnout Paradise too seems to look better though game limited to 60 FPS.
    I don't know...but trying cannot hurt, can it?
     
  7. LedHed

    LedHed Banned

    Messages:
    6,827
    Likes Received:
    1
    GPU:
    BenQ FP241W
    Just because 185.85 driver gives you a boost doesn't have anything to do with CUDA, it has to do with new optimizations in the driver. I still don't believe CUDA has anything to do with it and I'm running the newest version which still had crashes on both a GTS 512 and GTX 295.
     
  8. mammaryman

    mammaryman Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    XFX GTX 275
    You're not alone, I have the same issue with all the 18x.xx drivers, my problem is that I can't go back to the 178 series as I'm using a GTX 275.

    I've tried ALL the known fixes, they all seem to revolve around the multi core support. Tried OFF, ON at both game and driver level, also tried using the task manager core affinity with no effect.

    Starting to get really p1ssed off with it as it seems my nice new Nvidia card is hampered by shoddy driver support. On the brightside GTA 4 runs like a dream!!
     
  9. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    Mate, have you tried 182.50? The problem IS NOT present with those drivers.
     
  10. mammaryman

    mammaryman Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    XFX GTX 275
    Yeah I did and the problem was still there, will try again just to double check though.
     

  11. XcroN

    XcroN Master Guru

    Messages:
    332
    Likes Received:
    0
    GPU:
    GTX 1080Ti Aorus xtreme
    the new drivers have some problems i had this too and rolled back to 182.50 now everything working fine
     
  12. mammaryman

    mammaryman Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    XFX GTX 275
    So is it wise to disable multicore support for L4D even when using 182.50?
     
  13. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    Nope, it is not of course. 182.50 for me and many (all?) of us don't present any problems, so it is useless to disable multithreaded rendering (that implies performance loss).

    If you are using 185.81/185.85, then yes you should disable it to not have freezings problem.
     
  14. BaDmOfO

    BaDmOfO Maha Guru

    Messages:
    1,401
    Likes Received:
    1
    GPU:
    2 x Evga sc GTX 780
    I had the same problem with the 182.50s. I'm not sure what fixed it but, I installed the 185.85 drivers, then I verified the L4D cache, and defragged the cache using the built in tools in steam, and that fixed it, without having to castrate my cpu with disabling multicore support.
     
  15. mammaryman

    mammaryman Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    XFX GTX 275
    Sorry to rain on the 185 parade but there are a shedload of people having this problem with the 182 and 185 driver set. It seems almost entirely random, I came here from both the steam and nvidia forum hoping somebody had found a 'fix all' solution but it appears not.

    Disabling multicore support for the 185 drivers appears to only work in some cases but definitely not all. The only surefire way seems to be to rollback to 178 but that is a wee bit of an issue for the GTX 275 as its not supported. I'll just carry on waiting for 186 and hope they've pulled their collective fingers out of their arses and fixed it :bang:
     

  16. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    Yeah, it is true.

    It seems there are actually two different problems:
    - one lighter: random freezes often in the beginning of a game for few secs that has as a solution: install 182.50 or disable multithreaded rendering
    - one harder: random freezes lasting longer and all over a game that seems to have as the solution just to install 178.24.


    I suffer the lighter and I have absolutely no freezes with 182.50 with multithreaded rendering on.
     
  17. mammaryman

    mammaryman Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    XFX GTX 275
    Agreed, unfortunately I have the 'harder' issue, will wait for the next driver release and if that doesn't fix it I'm going to sell the card and go and get the HD 4890.
     
  18. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    Have you tried disabling multithreaded rendering + setting paged pool memory to LOW? It is the solution that Valve itself has in its support pages.

    https://support.steampowered.com/kb_article.php?ref=5034-EIPV-6426

    Another advice is to force NVIDIA Driver multi-core threading optimization DISABLED on panel.
     
    Last edited: May 15, 2009
  19. mitzi76

    mitzi76 Ancient Guru

    Messages:
    8,722
    Likes Received:
    19
    GPU:
    MSI 970 (Gaming)
    i tried the 275 and would get crashes with any drivers over 182.50 and lfd. def watch your overclock as well..that can cause crashes with diff drivers when previously it was ok.

    played most games with the 182.50's and the 275 was great...

    u guys using driver sweeper in safe mode to clean out your old drivers?
     
  20. Punisher!|ITA

    Punisher!|ITA Master Guru

    Messages:
    468
    Likes Received:
    4
    GPU:
    EVGA 8800GTX
    I always do. I hope the rest too.
     

Share This Page