16.3.2 hardlocking BF4

Discussion in 'Videocards - AMD Radeon Drivers Section' started by flash22, Apr 4, 2016.

  1. flash22

    flash22 Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    Gigabyte GTX1070 G1 GMG
    Hi team -

    I've got 2x Gigabyte Windforce R9 290's in xfire and since updating to the new crimson drivers I get hardlocks about 1 hour into gameplay on BF4. I'll hear the windows notification beep that states a driver failure but then everything locks and I cant do anything but hard reset.

    Havent had the time to test other games but just wanted to know your thoughts or if others having similar issues.
     
  2. freeman94

    freeman94 Master Guru

    Messages:
    306
    Likes Received:
    5
    GPU:
    MSI GTX 1070 ARMOR
    Do you overclock?
    If so then revert to stock then test it out.
    If that won't help then use DDU and reinstall drivers, check integrity of bf4 game files, turn off ULPS.
     
  3. flash22

    flash22 Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    Gigabyte GTX1070 G1 GMG
    I don't overclock - completely stock clocks. Always use DDU with any update and ULPS has been disabled.

    Is it possible that one of my cards is dying?
     
  4. Agonist

    Agonist Ancient Guru

    Messages:
    3,113
    Likes Received:
    383
    GPU:
    XFX 5700XT Raw II
    Only if it does it with any driver in more then BF4.
    Run Valley Extreme preset and report issues and temps.
     

  5. primetime^

    primetime^ Master Guru

    Messages:
    906
    Likes Received:
    16
    GPU:
    Sapphire RX Vega 64
    Yes it possible for sure. Its also possible it something else entirely. If the one of the cards was having issues -Try lowering the boost clocks 50-100 mhz and try again. If that helps we at least have an idea whats going on.
     
  6. vase

    vase Ancient Guru

    Messages:
    1,653
    Likes Received:
    2
    GPU:
    -
    problem is somewhere with wddm 2.0, maybe the vram management with xfire
    i had the exact same problem with bf4 and gta v
    i went back do w7 and everything's fine.
    one thing i did first in w10 which reduced the occurence of the issue (but did not get completely rid of it) was to disable vsr, because i play it in 1440p
    but vsr is working on w7 as well of course... so np.

    if you check eventvwr after hardresetting for application/system errors it will say something like atikmdag has stopped working and has been successfully restarted... or similiar.

    and yes in w10 i dont get the problem with xfire disabled...
     
  7. flash22

    flash22 Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    Gigabyte GTX1070 G1 GMG
    Its weird cause I never had that issue with previous driver builds until now. I did miss a few updates so might even revert back if it keeps persisting. I really hope its not the cards as they are absolutely brilliant for my set up (1440p @ 144hz gaming). BUT - with the temps they sometimes run in xfire at the peak of a new zealand summer it has been a concern for me....
     
  8. vase

    vase Ancient Guru

    Messages:
    1,653
    Likes Received:
    2
    GPU:
    -
    what i am saying is, its windows 10
     
  9. OnnA

    OnnA Ancient Guru

    Messages:
    12,823
    Likes Received:
    3,202
    GPU:
    Vega XTX LiQuiD
    Try to swich Mantle driver (you''ll have all drivers up there in PrMinisterGR thread)
     
  10. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,643
    Likes Received:
    98
    GPU:
    XFX RX 480 RS 4 GB
    Try the latest 16.4.1 driver and see if that helps.
     

  11. SwissCh33z3

    SwissCh33z3 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD/Sapphire R9/290 Ref
    Getting the same issues as flash22.. lotta random freezes and crashes.. all since the crimson drivers came out.. but i do love the crimson drivers.. the custom resolution settings let me oc my monitor to 70 hz and that is a nice little bump in fps for bf4 .. been getting alot of "get device removed" errors and also freezes when the multimedia class scheduler starts and stops.. sooo annoying..

    cheeze out
     
  12. flash22

    flash22 Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    Gigabyte GTX1070 G1 GMG
    yea updated to the latest drivers and it was still doing random freezes etc. Only on BF4 strangely. Ran Unigen all night maxed out no issues.

    Changed it to Mantle and haven't had any problems. Recommend using Mantle if ur getting the same issues.
     
  13. haz_mat

    haz_mat Master Guru

    Messages:
    243
    Likes Received:
    1
    GPU:
    1070 FE
    No problems for me in BF4 (dx11) on 16.4.1 - seems like one of the better performing drivers in my experience. I ran DDU recently though (around the time I installed 16.3.1), I think that might have helped clean up some of the crud. I'm running win10 on the rig in my profile.

    The only time I've got "driver not responding" problems is either a bugged game that needs a patch or I'm pushing the overclock a bit much.

    On a side note, there are a couple tweaks for BF4 that have served me well. The first is to disable the "video background" in Battlelog - that one is in the general battlelog settings (on your name dropdown menu in the browser). In my experience, this animated background continues to steal cpu/gpu resources while I'm in-game.

    The other one helps resolve issues with Mantle, by deleting the cache and forcing BF4 to rebuild it. Just delete the files in:
    Code:
    C:\Users\<your pc>\Documents\Battlefield 4\cache
     
    Last edited: Apr 11, 2016

Share This Page