1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

16.101.X [Pre-GCN driver pack]

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by user1, Jul 28, 2016.

  1. Orof83

    Orof83 New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    2x Twintech 9600GT XT OC
    i have the same setup (7670m + 8650g) and i wanted to try the firepro driver. i had the same problem as you did:
    but once I deleted the files, my PC WOULDNT WAKE UP. it took me 2 hours to move the files back from a backup i created using CMD to the original folder, just the get the windows to boot. now i also have the firepro drivers installed, but i don't really see any difference from the crimson 16.2.1 beta. what was the point of this? should i see some improvments?

    and to anyone else - proceed with caution!
     
  2. oldfart

    oldfart New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    6770
    I can't install the recommended driver >>16.101.X With Catalyst 15.11.1["new"]<<< on Windows 7 64

    Its a Sapphire HD 6770 VEN1002 DEV_68BA SUBSYS_E144174B REV_00

    I can install the last WHQL driver (15.7.1) from AMD but oclhashcat reports errors (driver is not officially supported) and the crimson beta (16.2.1) but this comes without OpenCL. So I tried this driver pack with f8 start -> disable driver signature check.

    If I run the installer from the first post it seems to install everything but the gfx driver and manually installing an updated driver (selecting the directory of the decompressed 7zip pkg) only results in the 'best driver already installed' message.

    I tried adding the ids to the inf and msi files (even though I think it should work out of the box) but that didn't work either.

    Anything I missed or can try? Manually copying stuff around in safe mode is probably even more error prone...
     
  3. user1

    user1 Maha Guru

    Messages:
    1,167
    Likes Received:
    310
    GPU:
    hd 6870
    sounds like you have a borked windows installation, i recommend using the DDU utility to clear any exsisting driver packages before attempting to install/

    when you install you should get a message warning you about the unsigned inf file(and install anyway), if you dont there is something wrong.
     
  4. oldfart

    oldfart New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    6770
    thx for the reply

    borked install is unlikely as it is pretty much a fresh install just to get this card running (just platform drivers, intel cpu cl driver, 7zip and truecrypt)

    What is odd that currently opencl seems to be working (should be from 15.7.1) - just the self test of the required mode fails
    Maybe someone with the above driver installed can test if

    hashcat64 -b -m 6241

    works or if the integrated self test fails for them too.

    What is strange is that version 4 and up all fail the self test and do not work with the sample hashes from the website while older versions appear to solve the sample but have no integrated self test (which makes the results a bit suspicious)

    Guess I should move this to the hashcat forum but maybe I can make sure the driver/card can handle the hash mode or if I waste my and anyones time...
     

  5. user1

    user1 Maha Guru

    Messages:
    1,167
    Likes Received:
    310
    GPU:
    hd 6870
    thing is the opencl libraries from 15.7.1 arent tremendously different from 15.11.1beta / firepro drivers(last driver versions with opencl), the opencl implementation is buggy on pre gcn cards. i'd really recommend finding something like an hd 7770 for cheap over a 6770, it will have much better opencl support and can probably be found for <50$


    edit: it is not strange older versions work, the newer versions are probably written with gcn cards in mind, where as the older versions probably have tuning for pre-gcn. very common problem, many programs have the same issue.

    also make sure you have fully updated windows 7, the amd drivers need sp1 and a few later patches on win7
     
    Last edited: Nov 30, 2018
  6. oldfart

    oldfart New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    6770
    Are the 15.11.1 better than the 15.7.1? I don't care about game performance/bugs - would only like to use the compute part.

    If I can't get the card to work I probably just ditch the GPU accel - I rather have only 40% of the speed and confidence in the result than second guessing any negative outcome. (I think) I remember enough of the password that the required time will be reasonable.

    Edit: oops misread aren't different for are different ....
     
  7. user1

    user1 Maha Guru

    Messages:
    1,167
    Likes Received:
    310
    GPU:
    hd 6870
    this is the last normal driver for desktop pregcn cards https://www.guru3d.com/files-details/amd-catalyst-15-11-1-beta-driver-download.html that supports opencl.
    this one should install correctly.


    The last proper driver for pre-gcn cards is this fire pro driver https://www.amd.com/en/support/professional-graphics/legacy-products/firepro-v-series/firepro-v9800 it has the lastest opencl libs that i used for the driver pack.
    you can try an inf edit if you want,

    it is possible that one these might have a bugfix that would help you, but i doubt it.

    best of luck
     
  8. oldfart

    oldfart New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    6770
    I'm now the proud owner of a "ATI FirePro V5800 (FireGL V)" - or at least windows thinks that ;)

    Duplicated the DEV_68A9 entry in the driver (as it was the only Juniper based) and installed it through the "have disk" dialog where it appeared as compatible device (just using "browse for driver" with "include subfolders" ticked strangely wasn't enough)

    CL runtime seems to have updated too but the issues with the truecrypt mode self test persist as you had expected. Guess the CPU has to do for now as I feel slightly insulted by the GPU prices right now - they can't shift the cards anymore (see Q3 news at the front page) but lowering the prices at least to the launch level of x years ago doesn't seem to have crossed the manufacturers/retailers minds...

    Thanks again for the assistance user1 - I'm off generating word lists and doing some crunching.
     
    Last edited: Nov 30, 2018
    user1 likes this.
  9. systemcrasher

    systemcrasher New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    7670 amd
    hey user1

    thanks for the constant work on this driver ... i really appreciate your work
    but i have encountered a problem you see .....
    i have win 8.1 with 7670m and used this driver (16.101.X_Repack_radeonset_17.1.1_Jan30_dxva-nocl_[WIP]) for awhile now ...
    but when i tried and uninstalled my driver with and installed this (16.101.X_Repack_Catalyst-Win7_64_18.X_Aug_12), the device comes up as a "Microsoft Basic Display Driver Adapter"...
    should i use the Win10 one??(i don't want to update to win10 )
     
  10. user1

    user1 Maha Guru

    Messages:
    1,167
    Likes Received:
    310
    GPU:
    hd 6870
    A simple edit is required for windows 8.1 to work , find the C7305846.inf file and use a text editor to change this line [ATI.Mfg.NTamd64.6.1] to [ATI.Mfg.NTamd64.6.3] and remove the existing [ATI.Mfg.NTamd64.6.3] located at the bottom of the file, once this is done it should work.
     
    systemcrasher likes this.

  11. systemcrasher

    systemcrasher New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    7670 amd
    Thx man ....
    will try that way:)
     
  12. xenobi354

    xenobi354 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Amd Radeon 5750
    Can not install these drivers on my windows 7. Disabling signing drivers are installing correctly and after restarting windows, the driver can not load the driver because it is not signed. How to solve this problem?
     
  13. inkkubuss

    inkkubuss New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    HD6520G+6600/6700M
    My windows does not see the driver. Did as you advised. The driver is not detected.
    Windows 8.1 х64 Embedded Pro
    Sorry for bad English
     
  14. user1

    user1 Maha Guru

    Messages:
    1,167
    Likes Received:
    310
    GPU:
    hd 6870
    not sure what would be causing the problem, worked the last time i installed it on win7 , the driver files are actually signed, just not the
    inf. .
    can't help you with that, i have no experience with windows 8.1 embedded, just use the normal drivers.
     
  15. inkkubuss

    inkkubuss New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    HD6520G+6600/6700M
    thanks for the answer user1
     

  16. xenobi354

    xenobi354 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Amd Radeon 5750
    https://imgur.com/tD6UDzq
    Maybe there is a problem with installing these drivers on my computer? Can I install this certificate would help this?
     
  17. user1

    user1 Maha Guru

    Messages:
    1,167
    Likes Received:
    310
    GPU:
    hd 6870
    dont think so, the driver files apart from the inf are signed by microsoft, i think there is probably something wrong with your windows install.
     
  18. xenobi354

    xenobi354 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Amd Radeon 5750
    Maybe I know how to solve the problem but I can not do it. In the driver directory 16.2.1 is a cat file with digital signatures. In the directory of this driver is not. So the question would be to create a cat file for this driver?
     

Share This Page