16.101.X [Pre-GCN driver pack]

Discussion in 'Videocards - AMD Radeon Drivers Section' started by user1, Jul 28, 2016.

  1. ms178

    ms178 Member Guru

    Messages:
    126
    Likes Received:
    43
    GPU:
    Vega 56
    Thanks for sharing this trick!
     
  2. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    OGL driver is newer than official beta. But its slower, i tested. However, after running OGL extension viever, my 5xxx grade non-gc card shows all 4.5 extensions available, only 4.5 shader language missing. I believe 4.5 extensions brings more performance (when used) than general lowered ogl speed.
     
  3. OnnA

    OnnA Ancient Guru

    Messages:
    14,997
    Likes Received:
    4,317
    GPU:
    3080Ti VISION OC
  4. FunkyMike

    FunkyMike Master Guru

    Messages:
    539
    Likes Received:
    0
    GPU:
    ATI 6850m /Intel HD3000

    That is interesting Dan. Are they much slower? You still got any results from the benches?
     

  5. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    I tested API test https://github.com/nvMcJohn/apitest benchmark (comapred to older tests) and gpu caps viewer demos looks slower. I dont know if its just like OpenGl extension viewer started to work correctly with this driver and showing extensions. Anyway i see improvement in cemu emulator (small fps speed) which rely on 4.5 extensions. I can upload dlls.

    Edit: please test, because i didnt do it extensively, so i may be wrong
    https://www.sendspace.com/file/zxx75x
     
    Last edited: Aug 19, 2016
  6. OnnA

    OnnA Ancient Guru

    Messages:
    14,997
    Likes Received:
    4,317
    GPU:
    3080Ti VISION OC
    THX Bratan' :nerd:
     
    Last edited: Aug 19, 2016
  7. windrunnerxj

    windrunnerxj Master Guru

    Messages:
    440
    Likes Received:
    97
    GPU:
    MSI Gaming 1060 6G
    Does RadeonSettings crash for anyone else every time you try to manipulate a new game profile (add/remove/reset)? After the crash and re-launch of RadeonSettings you can configure that profile without crashing. Also, can I upgrade RadeonSettings from the latest official GCN branch or RS in this release is modded to support nonGCN cards as well?
     
    Last edited: Aug 19, 2016
  8. jereur

    jereur New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    6990
    at me radeonsetting is killing process when I am starting pc it won't be possible to start
     
  9. user1

    user1 Ancient Guru

    Messages:
    2,065
    Likes Received:
    808
    GPU:
    hd 6870
    the newer radeon settings will probably crash if you do not use the newer adl libraries, known as atiadlxx.dll and atiadlxy.dll , thankfully these libraries have not been signifigiantly changed since 16.2.1 so they work fine on non gcn parts, though i imagine eventually they will not function properly.it is only a matter of time.
     
  10. windrunnerxj

    windrunnerxj Master Guru

    Messages:
    440
    Likes Received:
    97
    GPU:
    MSI Gaming 1060 6G
    What drivers do you use with your card? This one or official releases?
    Just curious :)
     
    Last edited: Aug 23, 2016

  11. FunkyMike

    FunkyMike Master Guru

    Messages:
    539
    Likes Received:
    0
    GPU:
    ATI 6850m /Intel HD3000
    thank you dude!

    Am not sure if this is because of the old openCL libs or not. Will have to check in the future.
     
  12. user1

    user1 Ancient Guru

    Messages:
    2,065
    Likes Received:
    808
    GPU:
    hd 6870
    I use a modified variant of this one, its 16.101.2901.1001+ opencl libraries from 15.201.2601.1005 and use the last catalyst, due to issues with Radeon settings(overriding msi afterburner weirdness).
     
  13. vinyl

    vinyl Active Member

    Messages:
    71
    Likes Received:
    1
    GPU:
    6870(OC) @ 975mhz
    Last edited: Sep 29, 2016
    skipper2342 likes this.
  14. windrunnerxj

    windrunnerxj Master Guru

    Messages:
    440
    Likes Received:
    97
    GPU:
    MSI Gaming 1060 6G
    AMD drivers give me a headache with all the DXVA issues in Chrome.
    Like 15.11.1 work fine for the most part but some 1080p60fps youtube and twitch videos lag and freeze like hell with HWA enabled - unwatchable.
    16.2.1 all highfps videos work fine but on some highfps videos/webms I have a green/purple tint with HWA enabled - unwatchable.
    These modded drivers and 16.2.1 with dxva dll swap work fine but some videos/gifs/webms won't play and give an error "Playback is stopped because content is unsupported" or something like that.
    Why can't everything work fine for once without having to sacrifice one feature so the other one would work properly.

    These didn't work for me on Sapphire 6850 (PCI\VEN_1002&DEV_6739&SUBSYS_174B174B).
    Drvsig disabled and when I try to install the drivers via devmgr it says that my drivers are already up to date (tried on a clean install Microsoft basic adapter and on top of a 15.11.1). If I try to force install it via "have disk" it says "'the folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with windows for x64-based systems".

    upd. there was a [manufacturer] line missing in the inf file. Added it and driver installed without any issues, however OpenCL is missing. Do I need to use dlls from the Catalyst drivers or driver didn't install correctly?

    P. S. never really noticed it but are these constant core/vram clock and voltage spikes normal when I watch a twitch stream?
    http://i.imgur.com/m07V6T0.gif
    Might be mistaken but I think on Catalyst drivers it was like a constant 300core/1000mem whenever I watched a DXVA accelerated video in a browser. If I watch something in PotPlayer I also get 300/1000 on non-catalyst drivers.
     
    Last edited: Aug 24, 2016
  15. vinyl

    vinyl Active Member

    Messages:
    71
    Likes Received:
    1
    GPU:
    6870(OC) @ 975mhz

    I know that feeling, as a FF user it's even worse..

    EDIT:
    Not sure if you use a weak CPU. I have to manually get FF to use h/w accell and even then it's :bang:


    Sorry to hear that, I took user1's manufacturer section from 16.101 in this one as I thought he added even more support (wrestler/sumo/etc).

    I guess I can just c/p the one's from 16.2.1 but i'll hold off for now untill I add support for all OS and do further tests. I did notice OpenCL is missing too.

    I have a 6850->6870 (mod) card but have yet to try it on my laptop which is a 6520G. I do know user1's inf worked on there so i'm assuming this will too.

    My driver resets have calmed down lately, but I will look into the spiking as soon as I can and confirm this in firefox.
     
    Last edited: Aug 25, 2016

  16. user1

    user1 Ancient Guru

    Messages:
    2,065
    Likes Received:
    808
    GPU:
    hd 6870
    unfortunately hardware acceleration (h.264/dxva) in the web browser is mostly broken on both chrome and firefox, infact i'm pretty sure firefox blacklists both 15.300/16.101 and 15.201 for h.264 acceleration (you can check by going the to about:support page), not much you can do about that other than just disabling video accel in the about:config/about:flags page.

    If you want opencl support i recommend a modded version of either 15.201.2401 http://support.amd.com/en-us/download/workstation/previous/detail?os=Windows+10+-+64&rev=15.201.2401 or 15.201.2601.1005 http://download.windowsupdate.com/d/msdownload/update/driver/drvs/2016/04/20863851_550c64ee16a5a2dbd558c0ac6dfb610c6588b842.cab (or just the libs) since these are probably the last true drivers to support non gcn cards 100%.
     
  17. vinyl

    vinyl Active Member

    Messages:
    71
    Likes Received:
    1
    GPU:
    6870(OC) @ 975mhz
    I'm only seeing one jump from 300 to 775 (max is 900) at the start of a vid, no voltage spikes on twitch & youtube, 60fps. However the 300 didn't jump to 775 on youtube so it likely was something else.
     
    Last edited: Aug 26, 2016
  18. windrunnerxj

    windrunnerxj Master Guru

    Messages:
    440
    Likes Received:
    97
    GPU:
    MSI Gaming 1060 6G
    So basically all legacy drivers (including modded) for Windows 10 have broken HWA? And yeah, h264 HW decode in FFX is unavailable, at least on these modded drivers.
    I also know that Chrome blacklisted all 15.201.xx drivers from using DX11 in browser, forcing DX9Ex.

    I already use OpenCL dlls from the 15.201.2601.1005 with this (16.101.2901.1001) modded driver. Everything works more or less fine besides the HWA issues and those random clock spikes if I use Flash on twitch, which almost non-existent if I disable Flash on twitch: http://gpuz.techpowerup.com/16/08/25/scd.png

    I wonder how old NVIDIA cards are doing right now in this regard.
     
    Last edited: Aug 25, 2016
  19. vinyl

    vinyl Active Member

    Messages:
    71
    Likes Received:
    1
    GPU:
    6870(OC) @ 975mhz
    OpenCL working for me, version v2.0.4.0 and it's all there in the inf, also the description reads the following:

    Package Includes:
    Display Driver
    OpenCL Runtime
    DisplayPort and HDMI audio driver
     
    Last edited: Aug 26, 2016
  20. windrunnerxj

    windrunnerxj Master Guru

    Messages:
    440
    Likes Received:
    97
    GPU:
    MSI Gaming 1060 6G
    I assume by overriding MSIAB you mean custom fan profiles?
    I use OC in a couple of game profiles (fan settings are on Auto) in RS but I also want to use MSIAB for hardware monitoring and RivaTuner overlay. Should I uninstall RS and use CCC or RS and MSIAB should work fine provided I don't use overclock and fan profiles in MSIAB?
     

Share This Page