15.200.1012.2 WDDM2.0 driver for win 10 64bit

Discussion in 'Videocards - AMD Radeon Drivers Section' started by primetime^, Mar 21, 2015.

  1. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,636
    Likes Received:
    266
    GPU:
    RX 580 8GB
    Here's me thinking Windows 10 is in development and it's not intended for end-users to play games on it. It's for testing and improving. Because AMD haven't added VSR yet doesn't mean they won't.
    And you think people trying to help is a bad thing? You're in the wrong place then mate.
     
  2. Mooby29

    Mooby29 Member Guru

    Messages:
    134
    Likes Received:
    0
    GPU:
    R9 290X@1150/1500mhz
    VSR is available for Windows 10 in the drivers available in the other thread (http://forums.guru3d.com/showthread.php?t=398274).
    R9 290X can go up to 4K now (3840x2160).
    Still it's not fully implemented (only 60hz available for me in the higher resolutions, Assetto Corsa wouldn't let me choose one higher than 1080p etc...) and Windows Update will keep trying to "downgrade" to the official driver.
    Anyway, they're obviously working on it and it should be there in the next "big" release.
     
  3. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I did exactly what you said and it didn't work.

    I added 3840x2160 as a new res in CRU 1.2 under "detailed resolutions".

    I closed CRU and run "restart64" after some flickering it comes back to desktop but the new resolution is not avalaible in "screen resolution".


    [​IMG]

    A reboot didn't add it.

    Maybe a DisplayDriver is needed for this, a modded EDID or even a patched pixel clock.

    I don't know.

    I have a DisplayPort to HDMI adapter and i could try it to bypass the 165 MHz limit:

    http://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU


    ?¿?¿
     
    Last edited: Apr 12, 2015
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    You may need to untick the "Use EDID or driver defaults" box in Catalyst Control Centre.
     

  5. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I remember this setting but i can't find it now.

    I must be blind! :nerd:

    Can you show me where is?
     
  6. cirios83

    cirios83 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    AMD R9 280x
    You can try to change in CRU "Default extension block" to "No extension block".
     
  7. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I tried and it doesn't work, i must try with my DP to HDMI adapter to see if it can use higher pixel clock.

    As you can see in the pic 545.08 MHz at 3840x2160 seems to high for HDMI.

    ?¿?¿
     
  8. munirshah77

    munirshah77 New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    r9 290 vapor X 4GB
    Has anyone got it to work with windows 10 and r9 290 vapor x 4Gb to get actual 4k? If yes Can you please mention the procedure that helped you get it working. The link to the driver is broken. Can anyone provide a working link to the modded driver? Will appreciate your help
     

Share This Page