14.11.1 doesnt support APU's ? why?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by samusprime89, Nov 11, 2014.

  1. samusprime89

    samusprime89 Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    Gigabyte GTX 970
    just saw that the new 14.11.1 beta drivers from AMD do not support any class of APU's whatsoever. this sucks because as it stands COD: Advanced Warfare is unplayable on my pc. but im not using dual graphics mode at all. i have a dedicated 7870 with my a8-6600k. the reason i have an apu is because when i first built my rig on a mere budget of 500 dollars i didnt have alot of choices, the 7870 was added later after upgrading from a radeon 7750
     
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,504
    Likes Received:
    1,551
    GPU:
    ROG Strix 1080 OC
    Because they are desktop GPU drivers, you need the APU drivers
     
  3. ArtemB1988

    ArtemB1988 Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    Radeon R7 Series
    Use Catalyst 14.9.2
     
  4. jsdecker100

    jsdecker100 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    MSI R7 250 2GB DDR3
    Wellll, I have the AMD A10-7700K APU and a MSI R7-250 2gb DDR3 GPU. I tried installing the 14.1.1 drivers after using the latest version of DDU...same process that I always follow...uninstall using DDU in safe mode, etc. After installing the drivers and rebooting, of course, my R7-250 showed that it was using the new 14.11.1 drivers, but the A10-7700K was still using the standard VGA graphics drivers still. bummer..!! Soooo...after asder00 released his modded version of the 14.11.1 drivers earlier, in the list of supported devices, both of mine are displayed in the list...deviceID: 1313(A10-7700K APU) is on there..AND deviceID: 6610(R7-250) is on there. I haven't tried installing the modded ones yet, but since it says they are BOTH supported, do you think they would work for BOTH my APU and discrete GPU?

    Thanks!
     
    Last edited: Nov 13, 2014

  5. jsdecker100

    jsdecker100 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    MSI R7 250 2GB DDR3
    Well, I went ahead and took the plunge on asder00's modded 14.11.1 beta drivers and they WORKED SUCCESSFULLY on my Dual-Graphics system! Everything installed properly and both display adapters are enabled with NO problems out of either of the two! Also, I've read of several separate instances on these forums, and elsewhere, of people having their gpu's being falsely recognized and renamed to some other "equivalent" GPU, but NOT what they're used to it being displayed as. For ME and asder00's modded 14.11.1 drivers, BOTH my A10-7700K APU and my MSI R7-250 2gb DDR3 gpu are properly named in the Windows 7(x64) device manager. Everything seems to be a real success so far! In addition to what I just mentioned, I've always had everything properly configured in my Gigabyte BIOS to have Dual-Graphics enabled, and with this driver update, I was kinda leery of dual-graphics possibly not functioning properly or maybe not being recognized by the drivers/system. Guess what? ....NOPE! As soon as I installed the drivers, restarted the system, and logged into my Admin account, the "AMD Dual-Graphics" popup window that asks you if you would like to enable "AMD Dual-Graphics" appeared without any hesitation.

    :rock:

    -- Soooo, if anyone is wondering if these are compatible with APU's, the answer is YES, as long as your specific APU is listed under the list of supported devices in his modded 14.11.1 drivers thread. I'm typing this message right now, as we speak, from my pc with said drivers just installed and working properly just a few minutes ago. As long as your device is listed, I don't see why you shouldn't go ahead and give it a shot...it might just work!

    Thanks asder00!!

    Keep em comin!! =)
     
    Last edited: Nov 13, 2014
  6. samusprime89

    samusprime89 Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    Gigabyte GTX 970
    Im not using dual graphics btw, but i was told by AMD personally that the drivers dont support APU's, so maybe thats why my performance is so bad
     
  7. atoneapone

    atoneapone Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    Radeon 6650M +6520g/ 1GB
    Not officially supported but it might work with asder00's HD5000&HD6000 modded 14.11.1b drivers. Give it a try if your card is listed in INF file.
    Download and open Win8.1 INF file with notepad:

    http://www44.zippyshare.com/v/34101142/file.html

    Check for your APU in this Win8.1 INF file (file is taken from the mod HD5000 & HD6000). Scroll down to bottom of file for a list of APUs & GFX cards that are supported to see if your APU is listed. If yours is listed then you should be able to install it.(Go to asder00's HD5000&HD6000 modded 14.11.1 thread for full driver).
    If performance is still bad, then go back to using 14.9.2b or older.


    note: Many APUs are listed eg.:7400G, 7520G, 7620G, 7660G, 8510G, 8310G, 6520G, 6620G, 6480G, etc....(just naming a few--check full list in file.)
     
    Last edited: Nov 13, 2014

Share This Page