13.1 Reloaded driver for legacy users...

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kevsamiga1974, Jan 28, 2013.

  1. SylvaeDragon

    SylvaeDragon New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI HD3470 256MB
    Nope, Win7 x64 here.. (;
    But it might have happened because I have version 7.12.0.7712 already installed?!?
     
  2. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Shouldn't really matter enough to cause a BSOD just installing the HDMI audio.

    How strange, .7712 on Win7 is running here fine...

    Looks like i'm gonna have to change the HDMI audio components to play it safe for some ppl.

    I'll update the main link soon with the changes.

    Updated main driver link with non problematic HDMI audio drivers, even for Windows 8 and 7/Vista as well.
     
    Last edited: Jan 28, 2013
  3. labodj

    labodj Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD Mobility HD4670 1GB
    Thank you very much for all your hard work
     
  4. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    Everythings going fine................your a genius!!!
    Thanks for all your work!!
     

  5. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Nice to know it's working for Windows 8 x64 as well as Win 7 without issue now...

    With the clock bug kicked into the abyss for those with crossfire/multigpu.

    Not bad for a 1st attempt if I do say so myself.

    -------------------------------------------------------------------------

    You'll notice with something like AIDA64 that the cfx and dx10 components as well as the OpenGL are all higher than official 13.1 legacy drivers and yet still work/function correctly without any instability/issue.

    * Beware of using other OpenGL files posted up on other threads with the same .11774 version number apart from the ones included in these drivers. (there are file size differences despite the exact same version number)

    The other bandwagon ones posted up don't work reliably in some cases although they appear at first sight to work ok, and *will* crash your apps/games whereas the ones included don't and have been extensively tested not to crash/fail... :)
     
    Last edited: Jan 30, 2013
  6. mkflawless

    mkflawless Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Crossfire ATI 4870
    I've just installed your 11.12 v7 final, everything ok so far.

    Should i plan getting this one, now that you're working on it?
     
  7. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Only if your interested in something for Windows 8 x64 that's less buggier than the default ones/has higher components etc.

    I don't plan to work on it much more. It works fine already as it stands, unless with the next legacy driver there are any significant changes.

    Now people...in these recent days i've currently been researching into ways to reap back the crossfire improvements YES! you read that correctly, of later drivers for modern games that currently run awful due to lack of modern drivers (BF3 coming off 35% gpu utilisation springs to mind) rolled back into legacy cards without having to touch the core DX9/10 components which have indeed have had the code hoovered away.

    It apparently seems the non legacy driver crossfire stuff is doing a check somewhere requesting DX11/DX10 to work correctly @ a minimum. Why do I say this ???. Well the crossfire components of later drivers actually *do* infact work amazingly enough on legacy cards as long as you are jamming the cfx .dll's into DX10 games and not DX9 ones. (JC2 DX10 & BFBC2 DX10 mode set works with a 12.8 non legacy .dll injection on legacy cards)

    But games such as farcry 3 DX9 or DX11 mode only as such on legacy are out of luck atm with this workaround.

    If I can find a way in the cfx components to hunt down the part of the code doing the check for a minimum of DX11 to work which works with DX10 games amazingly still but not DX9 games without the atiumdag.dll_unloaded DX9 errors using later components, and flip the switch back to a different check @ minimum instead of a DX11 check at minimum to work instead of just exiting out we might just be in luck... another part of this that makes me think it's doable and will work for re-enabling legacy DX9 crossfire of later drivers is that the x-fire components did not significantly change in size between the end of legacy support and new drivers xfire components that don't now work on legacy cards.

    And infact i'm guessing but might be onto something all the same that crossfire has just been all artificially restricted to running on DX11 cards using crossfire instead of DX10 inclusive of DX9 legacy for the x-fire stuff now instead of being actually fully disabled by removal since these files only ever increase (as more game support is added) not decrease (with removal of code).

    But....this is proving extremely tough though just for one man alone to find even with the initial groundwork and theory laid out, because my knowledge of x86 ASM is limited...maybe someone else might have a stab at getting this little investigative detective theory to work, or indeed testing it...

    And if this little trick can infact be pulled off, you're maybe in for a complete shocker at how well BF3 now runs in crossfire on your so called legacy cards before the support was cut off and/or artificially restricted by not being able to use later drivers. :)

    So with some probing around and a bit of luck and experimentation we should *all* be able to reap the benefits of later crossfire improvements for games this way, and not just for those that are in the position of owning a series higher up and above compared to what we're left saddled with for legacy multi gpu's, and the dissapointing stagnation of crossfire support in the drivers for legacy crossfire.

    I haven't found much if any difference by benchmarks in just changing the driver files for DX9,DX10. Of course there are bugfixes to later DX9,DX10 components, but the code hasn't it seems been really changed for years since the introduction of cayman and the end of the 10.x series enough to make a whole lot of difference really.

    What has made a difference though in almost every case is changing out the crossfire components each time. These are what make or break the fps in a game on multigpu/x-fire setups and not the actual DX9/DX10 files themselves as I find it. So not having newer updated DX9,DX10 components alongside forced to work later x-fire components is really no big loss if this task can be achieved.
     
    Last edited: Feb 1, 2013
  8. SylvaeDragon

    SylvaeDragon New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI HD3470 256MB
    Downloaded and installed it again and this time it worked like a charm (no BSOD and such).

    I noticed, the HDMI sound driver is a bit older than the one I had installed (this one's 7.12.0.7706, I had 7.12.0.7712) - did you do it on purpose, to avoid crashes and bugs?

    Anyway, thank you very much for your hard and great work! (;
     
  9. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Short answer yes.
     
  10. Danny Nissan

    Danny Nissan Active Member

    Messages:
    88
    Likes Received:
    0
    GPU:
    Radeon HD 4890 1GB
    Just a MINOR correction. BF3 does NOT support DX9 at all. It is only DX11 or DX10 (for HD4000 series for example).

    Thank you for your hard work kev!
     

  11. mkflawless

    mkflawless Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Crossfire ATI 4870
    BF3 doesn't support dx9 indeed (nor does it support windows xp).

    Kev is just a genius, that's why we love him :banana:
     
  12. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    A got a a problem in photoshop CS6 64bit: when I open a photo after half second it completly disappears in the center but it stills there in the little Navigation box (in right above for to see the % of zoom).

    This happens if I leave selected use grafhic processor in graphics processor settings.

    I tried to no select: use openCL then anti alias in advance settins, but nothing, photo dosen't compair.

    Only if I don’t use graphic processore at all, the photo dosen’t go away.

    This thing never happened on 2.6 reloaded V5r2 that I had for passed 3/4 mounths.
    It happened 3 times on 2.6Reloaded V7 (but I tried it only for 2 days so I didin't sospect that it was the driver) and now with 13.1reloaded.

    So I tested again..... 2.6 V7 and even her I don't have to use graphic processore to visualate the photo, then again 13.1reloaded.....same.

    Now I rolled back to 2.6 reloaded V5r2 with no problems in PS and I never had problems like green in flash/DXVA with this in last 4 mounths.
    Trying to get 2.6V6 or V6r2 but they are not more downloadable.

    What’s going wrong??

    Can I test Hybrid?? wich will I test??
     
    Last edited: Jan 31, 2013
  13. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Not to worry. It just seems like it's the new .11774 OpenGL to blame...pity because it works ok with everything else including all the ogl games that are tricky.

    I'll have a look back up the 12.6R threads.

    Obviously .11774 has problems in PS, but not in anything else I tested.

    .11762 in 12.6R's indeed works in PS, but breaks games instead. That's why it got changed out. Catch 22. :bang:

    Although I do have a .11764 to try that works with all the games and just *might* might work with PS aswell since it's close enough to PS working .11762 version.

    Does the "official" one from 12.6 and 13.1 work with what you are trying to perform with PS ? Those OpenGL versions are .11653 and 11672.

    I have compiled a little list of all versions of OpenGL higher than legacy that still work and those that don't work correctly (well they do appear to work but bomb in a few difficult well known problematic games) so we will start backing down from .11774 till all games still work and photoshop works properly aswell again like it did in the early 12.6R's .11762 but crashed games instead.

    But don't worry, even though the 12.6R's aren't available anymore, I still have access to all the relevant OpenGL files to put this little problem right so *everything* works. It's just that they like to break things in drivers from one version to the next and you have to experiment and test extensively to find the right combinations that covers everything working...

    So we shalll try backing up one step at a time starting with version .11764 which works with the problem games, but just need confirmation of PS working fine. And I will swap the link @ the OP, give me overnight.

    Then you may download driver again and report back whether the 11764 aswell as .11762 instead of 11774 works correctly with PS as .11764 does work correctly with games.

    We should get there to a version that works with everything in the end solving together the game problems and the PS problems, but still higher than the last official legacy version of .11672.

    It's not just us. Other people have broken PS depending what driver they're using even with non legacy cards. AMD drivers are a bitch to get right. But if it was working before for you, then it can likely be fixed up as long as i'm careful not to break anything else like the games.

    It's just impossible alone for me to test every single app and things like PS problems creep back in that were fixed b4, but together we can solve these remaining issues, all the well known problem games do work in every driver posted though.

    The DXVA/flash green screens afflict 5K series post 11.12 and mobility legacy 3K series & < topend 4K like mobility 4200 etc. That's why you never saw it, but was fixed anyhow for these poor sods just in case.

    * Driver top link changed. Please report back to the thread if this changed version OpenGL .11764 clears the outstanding PS issues now Joe 69, thanks.

    If not the next stepdown test is .11753 (works with all games) .11762 (PS works, long time problematic GL games crash)
     
    Last edited: Feb 1, 2013
  14. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC

    Gah got confused with BFBC2 it was like 2am. Then in that case, since BF3 is DX10 tell me what happens if you say d/l and unpack Catalyst 12.8 non legacy.

    Take out these two files :

    aticfx32.dl_
    aticfx64.dl_

    Unpack them from a CMD prompt with

    Expand aticfx32.dl_ aticfx32.dll
    Expand aticfx64.dl_ aticfx64.dll

    Copy these expanded files into your root/bin folder of BF3 where the main .exe resides and start the game and see what FPS you get on 4K now (if it works just as a little experiment.) :)

    You can remove the files from the folder after the test. But if the FPS is higher you may leave them where they are. Your BF3 should be utilising higher non legacy cfx files to play. :)

    * note, this won't work @ all for anything DX9 so don't even bother trying. But JC2 and BFBC2 works using this method. (DX10)
     
    Last edited: Feb 1, 2013
  15. mkflawless

    mkflawless Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Crossfire ATI 4870
    Ok gonna try this now, downloading driver 12.8.

    Edit : Allright, i did the whole thing, result is negative, 32-35% on both cards, and choppy most of the time mate!
     
    Last edited: Feb 1, 2013

  16. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Hmmm. Thing was using the 12.8's dll's fixed the poor cfx performance for me here for BFBC2 that started with 12.4 and got left like that with 12.6. Worth a try.

    You might try doing the same with higher drivers like 12.10 or so and see what comes from that, but i think it might be the same results. It will probably never be fixed for BF3 now on these cards, but this trick seems to work for other DX10 games that are not supported properly in the drivers...
     
    Last edited: Feb 1, 2013
  17. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    Sorry for let you wait.....I closed the computer last night.....so I downloaded the driver with new .11764 this mornig and test.......but same problem in PS.
    I rolled back to 12.6 V5r2 with .11653


    I don't know how PS goes with 12.6 official driver becaus I have PS from 3 months (october) and I tried once 12.6 official for a week in Agost then rolled back to 11.12 b and then I build on your 12.6 reloaded V5r2 (the best for me still now) in september. But if you say above that 12.6 has .11653 like my 12.6 reloadedV5r2.....well i think it has to work)

    Do you think I have to trie 13.1 official( above you said they have .11672)?? Strange......I know that 13.1 is the same thing of 12.6 thats why everyone calls thema the AMD's joke.

    Where can I get :.11753 (works with all games)/ .11762 (PS works, long time problematic GL games crash) and trie them??
     
    Last edited: Feb 1, 2013
  18. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    One of the 12.6R's had higher .11762 where photoshop did work, but later I found out it crashed obscure OpenGL games so it was changed for .11774 which didn't crash any of my test games but photoshop then did not work.

    The official 13.1 has a higher opengl than official 12.6 at .11672 vs .11653. and a newer CCC which 13.1 Reloaded already contains.

    But I'm interested to see for everyone with using the modded driver to get photoshop to work without bugs, but also need a little testing help what is the highest OGL driver we can all use for legacy before photoshop working becomes broken, even if all the problem games do work good despite non working PS. And we already know PS was working in higher versions already because .11762 worked. :)

    I will update the main link again today with .11753 version for PS test (the next all games working OGL driver step down). I don't have photoshop to test this missing image problem, but I can test every changed driver against all the well known problematic on legacy cards OpenGL games like the polynomial, atom zombie smasher, cities in motion, quake 1-3, rage etc to make sure they work all correctly with different versions of OGL...

    I'm just curious about the where, when, and what version the PS working got broken by AMD to diagnose this PS problem and eliminate the bad versions that do not work with PS so others may benefit to have a fully working updated legacy driver with highest version components for all games working and for PS working aswell.

    Shortly we should have the answer to this question...and a fixed driver :) (we can skip past .11740 because the games fail)

    .11774 ... Your version of PS broken, games working. Higher version than this does not work on legacy cards.
    .11764 ... Your version of PS broken, games working.
    .11762 ... Your version of PS working, games broken.
    .11753 ... Your version of PS broken, games working,
    .11740 ... games broken.
    .11733 ... games working
    .11672 ... Catalyst 13.1 legacy, games working. Your version of PS working.
    .11662 ... games working.
    .11653 ... Catalyst 12.6 legacy, PS working, games working
     
    Last edited: Feb 1, 2013
  19. labodj

    labodj Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD Mobility HD4670 1GB
    With 11774 OGL my PS CS6 X64 works good.
    No problems.
    OpenGL+OpenCL hardware accelerated.


    In my opinion I think it's better to remove the previous driver with Atiman unistaller 7.0.2, and then reinstall.

    I had problems not unistalling driver with atiman before update them.
     
    Last edited: Feb 1, 2013
  20. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    This is the big problem I have on my hands with these modded drivers....conflicting reports that PS works for some and not for others. They might well be telling the truth in their case. I don't know.

    So then I change out versions in an attempt to fix things, and then blam ! It wasn't actually broken according to others.

    I just really have no way to really know the truth whether these components are working or not in PS for ppl from a clean install across all cards. I guess I need way more than 2 reports.

    But thanks for fb...
     
    Last edited: Feb 1, 2013

Share This Page