12.6 legacy driver reloaded.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kevsamiga1974, Aug 20, 2012.

  1. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    I haven't included any others modded files or anyone elses work this time...

    I'm still procrastinating and pondering/testing over it... :)

    For the moment it's important for me to get this green DXVA/flash bug kicked out for those that are experiencing it...
     
    Last edited: Jan 19, 2013
  2. mkflawless

    mkflawless Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Crossfire ATI 4870
    Okay mate, thanks for your dedication! I can't wait to see the fruit of your work :banana:
     
  3. Sasquatch_04

    Sasquatch_04 Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    R9 Fury Nitro
    12.6 reloaded v6 cured my green screen issues. i know it's not an installation issue because i have reinstalled it three times to verify.
    One install of 12.6 V5 or 11.12 Hybrid R2 and the green screen is back.

    You would think that if a 4870 desktop is not affected then a 4670 mobility shouldn't as well. But that's not the case.

    Thanks for effort you are putting to get this issue sorted out.
    If you ever decide to implement akinferno's patch i'll give it a run on my system.
     
  4. labodj

    labodj Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD Mobility HD4670 1GB
    latest 12.6 r7 works, no green screen
    BUT
    in photoshop CS6 x64 I can't use opencl... :bang:
     
    Last edited: Jan 19, 2013

  5. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    ok, i'll now freeze the video components since the green screens are gone and back down the OGL one step at a time till PS CS6 works again, has to be new OGL causing CS6 non functioning, since OCL hasn't changed since the last version one byte !

    So I don't know how opencl has now become magically "broken" with PS.

    ::Edit::

    On second thoughts, Infact i'm just gonna bite the bullet and d/l the free trial of PS CS6 and make sure it's working tested on different ogl's before uploading a fix.

    Will save time me testing instead of uploading gigs of drivers that might be still broke with PS...give me a day or 2.

    New 11.12 Hybrids coming soon as well with these improvements/fixes.

    Well, surprisingly on the contrary Photoshop CS6 extended 64-bit is working mighty fine here with the latest 12.6R V7 .774 OpenGL/OpenCL release, therefore I see absolutely no need revert the OpenGL
    subsystem anywhere between .774 and .662 levels potentially re-introducing other bugs.

    If PS CS6 wasn't working those options would be greyed out would they not ??? because PS CS5/6 sniffs out your gpu opengl/ocl driver compatibility @ each startup...and blanks the options if it doesn't pass the tests.

    I've now spent over half a day faffing around installing/testing/changing/rebooting/uninstalling/unpacking/wiping/modifying/ investigating workable opengl version changes searching and testing looking for a reported bug that doesn't actually exist...grrrr :(

    [​IMG]
     
    Last edited: Jan 20, 2013
  6. labodj

    labodj Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD Mobility HD4670 1GB
    thanks for your effort.
    How can I help you?

    12.6 v6 r4 screen HERE Installed without amd cleanup util

    12.6 v7 screen HERE The same result with or without amd cleanup util

    There must be something very strange...
    I ran amd_cleanup_util_1.2.1.0 (never done before)
    reinstalled 12.6 v6 r4 and in photoshop opencl was greyed out.
    Then i rerun cleanup util, reinstalled 12.6 v6 r4 and in photoshop opencl wasn't greyed out.
    :bang: :bang: :bang:

    Then rerun cleanup util, Grayed out with 12.6 v7

    EDIT: I used the ankinferno performance patch over 12.6 v7
    opencl in photoshop works.
    no green screen on flash videos, no dxdiag problem.

    12.6 v7 + ankinferno patch screen HERE

    anyway I'm trying Saints Row The Third in dx 10/11 mode with 12.6 v7 + ankinferno patch, there is a problem with the textures, they are red and blue pointed... (I cannot make a screen)

    Everything's fine with dx9 mode.

    EDIT2: i returned to 12.6 v6r4 and the game ran smooth in dx10/11, also CS6 is working, no green screen.

    EDIT3: Now i'm really going crazy! :3eyes:
    I cleaned v6r4 with the amd tool, then installed v7, opencl in photoshop works, Saints row in dx 10/11 works, no green screen on flash videos..
    WTF :bang: :bang: :bang:

    Continue testing
     
    Last edited: Jan 20, 2013
  7. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    If your installation is old. I think these 12.6 r V7 should really work by default from a fresh clean install, and when I say fresh I mean...

    Use ATIMan+driver sweeper or re-install Windows, and load 12.6 R7 from a clean install.

    In the ankinferno files, some files are actually *older* than what these drivers standalone contain which may explain the texture issues, everything is tested with the combination of given package only.

    Using files patching on top is undefined and anything can happen.
     
    Last edited: Jan 20, 2013
  8. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M

    Boy its not the problem of the Driver or any other files ITS because of the AMD Cleanup utility... I had to reinstall the OS when I tried the utility today on my HD 7900.. A total crap utility... Dont use it..

    EDIT : hmm odd,, I tried the same patch with 13.2BETA modded for my HD 4650 in DX 10 No issues..!!! :3eyes:

    As I'have said.. Its really Difficult to punch the Driver package because Every Driver performs Differently in different GPU
     
    Last edited: Jan 20, 2013
  9. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    It's difficult, because it's a handful of people trying to make legacy better & solve issues instead of the whole of AMD. :)

    People scream bug to me, and then when I waste the whole damn day trying, I don't see it on a gpu of theirs I don't own.

    I've learned this from AMD drivers, that if you are on a driver that works, and from a result of that you see no issues, then STAY ON IT and don't ever ever change, not even if it promises amazing performance or to cook you dinner and put the cat out for the night, because as sure as the sun rises they will cock things up for you down the line in something that was working previously.

    eg. 13.1 and now it seems they messed up StarCraft 2, why can't they just leave things the hell alone if they work. No regression testing, that's why.

    AMD's drivers have been plop, are plop, and always will be plop. I just try and find the solid clumps out of all the plop to stick together in a way that works. :funny:

    And anyone who thinks otherwise or is quick to defend their mess, hasn't delved deep enough or tested extensively. Crossfire = complications, Antialiasing on games = complications, the list goes on.

    I can't even use the touted R700 12x or 24x shader Edge AA from Catalyst 9.12hf to Catalyst 11.3 in games or I get flashing black square glitches how's about that.

    Their OpenGL driver doesn't even pass the piglit tests and there is nothing you or I can do about it...
     
    Last edited: Jan 20, 2013
  10. labodj

    labodj Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD Mobility HD4670 1GB
    So...
    I ran Atiman unistaller then DriverSweeper...

    Installed 12.6 v7

    everything seems working fine.
     

  11. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Ya see...works it was the PEBKAC problem ! :)
     
    Last edited: Jan 20, 2013
  12. vlc_marcos

    vlc_marcos Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    asus 8800gt/ hd M 4650
    can i ask something. because i have a problem with a game, Black ops 2, every time that iam starting the game, on the first moment when the guy is trying to save the other from the fire, my screen frizzes and some lines appear on the screen. at the moment is only happening on this game, crysis 2 and war fighter i dont have any problems.
    it is only me or there is anyone else with the same problem?

    Core 2 p7450 + 4650 ddr2
     
  13. labodj

    labodj Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD Mobility HD4670 1GB
    The only little problem is:

    Saints Row The Third in DX 10/11 mode

    When I switch on post fx the textures fails.
     
  14. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    To both posts above, I am in the process of obtaining some of these games, which will better help me diagnose and understand these issues on legacy cards.

    Starting with rage and moving on to others, but this process is going to be comparatively slow due to connection speed...

    So I can't do anything about it for the moment...

    On a different note something that's been bothering me recently for quite a while, but I kept quiet about it...

    As for all the other modded legacy drivers out there like icemod mobility 12.10 legacy drivers or those claiming to be using versions higher than 12.6 (and yes i've checked them all), here is what you should know before you screw around with any of them on your system, but you are free to do whatever you wish, or worse...even wish to believe they are really higher than 12.6, or use the official drivers if you want and forget all about using mine, I don't really care either way. I'm just offering up this knowledge for joe public so they don't screw up their systems :

    They are using much older .dll's from the Catalyst 10.xx range res edited/res hacker/resource hacked to look like they are versions of a much higher catalyst release, namely those above 12.6 legacy (12.5 April 18th beta). This is where the performance claims come from, but infact, this is where any performance ends and the bugs start because in virtually all cases these "faked" micky mouse .dll's in most instances are over 2 years old.

    I only ever use official and unmodified/unedited AMD .dll's in these drivers which are the highest official versions that you can utilise that still work on legacy without resorting to 5 minute editing tricks. They took the time to edit all the version numbers carefully to fake it to look better or newer than 12.6, but in their infinite wisdom forgot to edit out a signature in a all AMD driver .dll's which identifies the development branch, and finding this and unpacking the originals to compare, you will come to the conclusion that the file size is more or less virtually identical to the ancient older version with nothing more than a version number change with a resource hacker.

    There are no existing .dll's above 12.6 in any official released driver, beta or otherwise from any of these claimed newer driver ranges that works without crashes on legacy cards in DX9/DX10 save for OpenGL, because the code simply isn't there, it simply doesn't exist and i've tested them almost all. So, I'm calling your cards in for those that didn't do their homework properly in the 5 minute editing department. So there...you've now been found out... :moon:

    Those attesting otherwise that they are newer for legacy than 12.6 by being the fake fairies, or claiming otherwise are simply delusional fantasists....


    I just thought people should know the truth, before they risk their systems with this edited and faked, falsely claimed newer drivers for legacy nonsense.
     
    Last edited: Jan 21, 2013
  15. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M

    Can you be precise and name those modders.. :mad:
     

  16. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Dellon & the icemod legacy mobility ones ( don't know the creator )

    atiumdag is 10.11...simply version rename to look like latest versions of files.

    I won't give out the method of how to derive the signatures, or next time they'll just cover their tracks. :)
     
    Last edited: Jan 21, 2013
  17. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    Hmm i see,
    I know the method ;) ..
     

Share This Page