12.6 legacy driver reloaded.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kevsamiga1974, Aug 20, 2012.

  1. playdvij

    playdvij New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    4850@ 700/1200
    X32 driver works good, but can you make a final vercion like x64 drivet?:puke2:
     
  2. Zeratullo

    Zeratullo Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Mobility hd4670 1gb gdr3
    Thank you very much :)! I'll report as soon as possible since with the old ones i got artefacts (probably related to ati tray tools)
     
  3. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Do you mean artifacts in the sense of missing see through triangles on the polygons in games ?

    EDIT: It's time I asked for a favour....Can anyone pack and upload the Windows 8 x64 8.971.0.6 default legacy drivers stored in the file repository here on Win8 ? :

    system32\DriverStore\FileRepository\C8xxxxx

    So I can have a tinker around with them without having to lose everything just to install Winblows 8, have a look at things etc. I noticed they are a different version. I wanna see what's still broken or fixed etc.
     
    Last edited: Aug 31, 2012
  4. masterchan777

    masterchan777 Master Guru

    Messages:
    261
    Likes Received:
    0
    GPU:
    GTX 1070 OC
    Hello, the default Win8 display drivers are not stored under C8xxxxx folder, there are two sets of default display drivers and I guess they are pretty much identical with two different names, they are saved under atiilhag.inf_amd64 folder, and here are the two sets for you, I hope this helps and let me know if there is anything else you need from Win8

    http://www.mediafire.com/?hq1lanhiibc2b39

    cheers
     

  5. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    Wow awesome job on those drivers mate.That performance increase is desirable to us all legacy users.
     
  6. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Thanks very much for these, was curious to see what had changed from 8.97 to 8.971.0.6...

    Well....I had a look thru them, one set isn't signed, don't know why that is or if they ever would have been installed by default on Windows 8 since there isn't any x64 signing, and 8.971.0.6 has very slightly file size differences on the important files, but it looks like the MultiGPU clock bug is still there on Windows 8 as I forced installed them on Windows 7 to test using the delta.cat and the clock on the second adapter was back in 3D after boot.

    They are missing the opengl components as well as a few other important files. Pretty much bare standard Windows 8 install of the Win7 8.97's, with the same bugs included and more files of the standard 8.97's cut out and of course no control panel or additions.

    Pity....nothing much I can use here to make things in the legacy driver any better or recent, oh well it was worth a try...I was just curious since the version numbers on the Windows 8 ones were higher...

    What else I need from Windows 8? Hmmm....how about metro and the silly login gestures removed lol. :)
     
    Last edited: Sep 1, 2012
  7. Zeratullo

    Zeratullo Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Mobility hd4670 1gb gdr3
    Well i had a severe flickering in Darksiders 2 (resolved by forcing vsync in ati tray) and in League of Legends the fog of war was very strange, i don't know how to explain... It moved all along the map like there was wind :3eyes:...

    Btw i still can't install your driver :bang:, only hydravision, hdmi audio and some other things (not the ccc as I can see) are installed, but I can force it trough the control panel.
    I have a mobility 4670 with VEN_1002&DEV_9488 id...
     
  8. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    How strange, it's clearly exists in .inf

    "%AMD9480.2%" = ati2mtag_M9x, PCI\VEN_1002&DEV_9480
    "%AMD9488.1%" = ati2mtag_M9x, PCI\VEN_1002&DEV_9488
    "%AMD94A0.1%" = ati2mtag_M9x7, PCI\VEN_1002&DEV_94A0

    and later in...

    AMD9480.2 = "ATI Mobility Radeon HD 4650"
    AMD9488.1 = "ATI Mobility Radeon HD 4670"
    AMD94A0.1 = "ATI Mobility Radeon HD 4830"

    I was just afraid it was the missing polygon bug in textures created since 12.3...

    Can't do anything about the other problems, 12.6 as it stands is WYSIWG, can't upgrade only downgrade.
     
    Last edited: Sep 1, 2012
  9. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    i tested bc2 last night, for that earlier package, you should have used 12.2 not 11.11/10, since 12.2 fixed the rare black flicker (otherwise you would workaround it by turning off bloom)
     
  10. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    It was 11.12 aticfx I used not 11.10/11 and it also fixes the flicker without having to turn off bloom. It was 12.1 that broke it again. 12.2 doesn't fix it nor 12.3 despite what the release notes say, however the 12.2 preview aticfx does strangely...

    I don't know why they have to keep breaking it all the time.

    The reason I went with 11.12 aticfx to fix the BC2 flicker instead of 12.2 preview ones was because it also solved crossfire IE/Firefox rendering as already explained much earlier in the thread, 12.2 doesn't do that without making a user profile for IE9/Firefox, so it got rid of 2 bugs in one swoop. The IE/Firefox GPU accelerated rendering is broken in 12.1-12.4/a/b in crossfire, 12.6 fixes the browser flaw but then you get ****ty BC2 fps, so can't use that one either. :)

    Did you notice the 4870x2 BC2 fps drop after the 12.3's packages too ?

    The WEI scores also dropped after 12.3. A 4870x2 on my Windows 7 setup normally scores 7.5 for me, has done all along with any driver going back the last few years, anything after driver 12.3 and the scores are 7.3.

    Since your on Vista where the maximum WEI score for anything is 5.9 you maybe not notice this slowdown after 12.3, since a 4870x2 on vista is always going to score <=5.9.

    I since found out this lower WEI score can be solved by replacing atidxx DX10 component back from 12.3 into 12.4/12.6, the 12.6 atiumdag DX9 part is fine and doesn't change the WEI scores only changing atidxx does, so it would also tally with the drop off in FPS i'm seeing in BC2 after 12.3 since it only affects DX10 mode. BC2 in DX9 there is no fps loss.

    I have a gut feeling that the wheels fell off for legacy cards beginning with the 12.x series somewhere along the line. The build quality just doesn't seem to be on the same kind of level as the 11.x series, not that they weren't without their faults, but at least as far as legacy cards go they don't seem as "polished" anymore compared, with more issues/annoyances/slowdowns etc.
     
    Last edited: Sep 1, 2012

  11. vejn

    vejn Maha Guru

    Messages:
    1,002
    Likes Received:
    0
    GPU:
    MSI 7870 TF3
    @kevsamiga1974
    Please, modify next legacy,12.9, if they will have problems.
    Could you do it for Win xp 32 bit?
     
  12. Zeratullo

    Zeratullo Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Mobility hd4670 1gb gdr3
    I don't know what to say, official 12.6 works fine and I never had this problem even with asder modded drivers
     
  13. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    @Zeratullo

    Unless I know what to look for, I won't know how to fix it. The .inf is now practically the same as the original 12.6 one, and all the files referenced by the .inf are intact.

    So for all intents and purposes it should be working the same as the original 12.6 .inf save for just installing different file versions that's all...If you open the .inf you can clearly see the mobility 4670 is support the same as the original 12.6 .inf has.

    They install and work fine on discrete cards. I had positive feedback on all the builds overall apart from V2 which I removed.
    I've been extra careful not to touch anything in there that might break something. I didn't add or remove anything from it.
    If the CCC doesn't install for you aswell, and you are seeing artifacts etc then something is clearly very wrong with mobility side of things.

    Unfortunately I don't have access to mobility or every legacy card to examine every possible scenario of an install, they tested out and install 100% fine on discrete cards. They install and work fine on a 4870x2 and a 4870. I know that doesn't help much.

    Can you post a screenshot of where it's going wrong and failing to install/identify your mobility 4670, maybe this will help me grasp the issue exactly where it's falling apart because the mobility definitions in the .inf are already in there, and the CCC version is nothing special that hasn't been released already so it should be being picked up by the installer.
     
    Last edited: Sep 1, 2012
  14. Keepcool

    Keepcool Banned

    Messages:
    21
    Likes Received:
    0
    GPU:
    4870 512mb CFx
    I only have "atiilhag.inf_amd64_ae6e6f4a21b45b05" rep. on system32\DriverStore\FileRepository\

    Windows 8 build 9200 90 days trial fresh install without updates..
    I Installed "8.951.1-120305" driver without problems but I have the FF (16 beta) acceleration CF bug.
    I would like to try "kevsamiga1974" driver but anybody know how to install it in windows 8..?? some drivers install fine in compatibility mode this isn't.

    I tried "kevsamiga1974" widows 8 drivers intent without avail.

    kevsamiga1974 what is my best option for me now..?? I play mostly BF3 and ME3.
    Thanks.
     
    Last edited: Sep 2, 2012
  15. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Someone else had some success on a different thread installing 11.10's on Windows 8 and said they were the only ones that they could get to work, you could try those since they were the "BF3" drivers...

    I've heard other reports of 11.12 working aswell, but try 11.10 first...

    And no firefox CF bug of the 12.x series...
     
    Last edited: Sep 1, 2012

  16. DIiSIER

    DIiSIER Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI HD4870
    I there. I'am using the latest 12.6 release for my HD 4870 1GB card.
    Should i use the V5r2 Final Vista/Win7 x64 instead? Are there significant changes to it??
     
  17. Zeratullo

    Zeratullo Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Mobility hd4670 1gb gdr3
    Ok here are some screenshoots:

    This is 12.6 official:

    [​IMG]

    this is the modded one:

    [​IMG]

    And you can see that ccc and the video drivers are missing, if i continue the process the second one is much shorter than the first one but doesn't give any errors.

    I'll try to uninstall everything and do a passage of ccleaner and drivesweeper and report back again
     
  18. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Last edited: Sep 2, 2012
  19. Zeratullo

    Zeratullo Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Mobility hd4670 1gb gdr3
    Reporting back:

    The good news is that now the driver installs fine :D, the bad one is that the ccc is still missing:

    [​IMG]
     
  20. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Ok, unpack drivers and delete CCC2 folder. Copy CCC2 folder from 12.6 legacy originals into apps folder and everything should install ok now.
     
    Last edited: Sep 2, 2012

Share This Page