Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA GeForce
Videocards - NVIDIA GeForce This forum is all about NVIDIA graphics cards and related technology. Do you have a question regarding an older GeForce videocard? Likely we have the answer.



Reply
 
Thread Tools Display Modes
how to stop NVEnc downclocking my VRAM :( // Tool for Perf.Level 2 Change?
Old
  (#1)
De-M-oN
Member Guru
 
De-M-oN's Avatar
 
Videocard: Nvidia Geforce GTX 1080
Processor: Intel i7 3770k @ 4,1 ghz
Mainboard: Asus P8Z77-V Deluxe
Memory: Corsair 16 GB(CL7-1600mhz
Soundcard: Asus Xonar HDAV1.3 Deluxe
PSU: Seasonic M12-600
Default how to stop NVEnc downclocking my VRAM :( // Tool for Perf.Level 2 Change? - 05-18-2017, 23:49 | posts: 56 | Location: Germany

The NVEnc downclocks my VRAM by about 500mhz because of going to Performance Level 2 - and that despite option at nvidia control panel set to maximum performance :x
If I use Shadowplay - obviously the card stays at Perf. State. 0. *how surprising* But Shadowplay has too bad quality for me.

I tried to edit the P2 State with NVInspector but I cant apply it at all
As soon as I click on apply it resets back to the low VRAM clock.

I thought - maybe it conflicts with MSI Afterburner's OC, so I closed it.
Still not changable..

I have a GTX 1080 Extreme Gaming by Gigabyte on a Windows 7 Ultimate, I use the driver version 381.89 at the moment.

Is there any way to change the P2 state to same of P0 (I mean the max performance one) so that this damn P2 switch is at least workarounded by this??

Last edited by De-M-oN; 05-18-2017 at 23:52.
   
Reply With Quote
 
Old
  (#2)
Mda400
Master Guru
 
Mda400's Avatar
 
Videocard: EVGA GTX 980 1519/7906mhz
Processor: i7-4790k @ 4.7ghz 1.29v
Mainboard: Asus z97-E LGA 1150
Memory: 16GB Corsair DDR3 2400mhz
Soundcard: LG LHB326 Receiver (HDMI)
PSU: Ultra X4 1050w (76A 12v)
Default 05-19-2017, 17:11 | posts: 553 | Location: Minnesota

Should only run one overclocking utility to start, also depends on if the graphics card detects a 3D application or not. The card will still downclock to idle, even if max performance is set because the setting only affects 3D applications.


I'd use afterburner and make an overclock profile for 3D applications with its options. What are you trying to capture using NVENC?
   
Reply With Quote
Old
  (#3)
De-M-oN
Member Guru
 
De-M-oN's Avatar
 
Videocard: Nvidia Geforce GTX 1080
Processor: Intel i7 3770k @ 4,1 ghz
Mainboard: Asus P8Z77-V Deluxe
Memory: Corsair 16 GB(CL7-1600mhz
Soundcard: Asus Xonar HDAV1.3 Deluxe
PSU: Seasonic M12-600
Default 05-19-2017, 20:59 | posts: 56 | Location: Germany

Performance mode 2 has still the full gpu clock, but the VRAM clock is reduced by about 500 mhz.
It happens with every software which isnt shadowplay if you use the NVEnc Encoder.

Afterburner seems only to change performance mode 3. I didnt found a possibility there to change specific performance levels. Or is it somehow possible with it?

This case has nothing to do if 3D application or not.
I dont talk about the boost clock. I talk about VRAM Clock being reduced because of going down to performance level 2. Due to my setting in nvidia control panel (prefer maximum performance) the card stays at performance level 3 also on desktop (except the boost clock of course)
But as soon as NVEnc is in use by 3rd party software - it goes down to performance level 2 with the reduced VRAM clock. Very very annoying.
I want to use OBS Studio to capture my Datapath VisionSC-DP2 Capture Card and do the encoding via NVEnc so that there is no engine hook and also no encoding going on. This results in 0 fps loss in game capture. But this vram issue is very disappointing. It has to go away at all costs. I'm very thankful for every tip by you which could lead to a solution..

Last edited by De-M-oN; 05-19-2017 at 21:01.
   
Reply With Quote
Old
  (#4)
Agent-A01
Ancient Guru
 
Agent-A01's Avatar
 
Videocard: 980Ti SLI H20
Processor: i7 5930K 4.7GHz H20
Mainboard: ASUS X99-AU31
Memory: G.Skill 32GB 3200C12
Soundcard: ASUS Phoebus
PSU: EVGA P2-1200W
Default 05-19-2017, 23:25 | posts: 9,298 | Location: USA

You can use MSI AB to lock the card to 3d mode clocks(no downclocking)

I think you press L inside AB to lock it.
   
Reply With Quote
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.