Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
AMD Catalyst 14.7 RC1 (14.200.1004.0 July 9)
Old
  (#1)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Talking AMD Catalyst 14.7 RC1 (14.200.1004.0 July 9) - 07-10-2014, 19:46 | posts: 1,005 | Location: iTALY

Enjoy

> Download <


Build Info:
DriverVer=07/09/2014, 14.200.1004.0000
Catalyst: 14.7
CCC: 2014.0709.1135.19003
D3D: 9.14.10.01044
OGL: 6.14.10.12967
OCL: 10.0.1526.3
Mantle: 9.1.10.0020

Supported Cards:
 Click to show spoiler



Twitter!
@asder00 | @guru_3d

Last edited by asder00; 07-10-2014 at 19:51.
   
Reply With Quote
 
Old
  (#2)
lycanwrath
Member Guru
 
lycanwrath's Avatar
 
Videocard: CrossFire 2X HD 6950 2GB
Processor: Intel I5 2500K
Mainboard: Asus P8Z68V-LX
Memory: DDR3 4* 4GB 1600 Gskill
Soundcard: Realtek ALC887 w DolbyDHT
PSU: Aerocool 680W
Default 07-10-2014, 19:47 | posts: 67 | Location: Mauritius

Thanks Asder!
Downloading right now
   
Reply With Quote
Old
  (#3)
MerolaC
Maha Guru
 
MerolaC's Avatar
 
Videocard: Sapphire HD 7970 OC 3Gb
Processor: i5 3570k@H60
Mainboard: ASUS Maximus V Gene
Memory: G.Skill Sniper 1866 8GB
Soundcard: C-SB-Titanium HD PCI-E
PSU: OCZ Fatal1ty G.G. - 750w
Default 07-10-2014, 19:55 | posts: 2,226 | Location: Argentina

Thanks!!!
   
Reply With Quote
Old
  (#4)
k4sh
Member Guru
 
Videocard: r9 290 @ 1150/1500
Processor: I5 2500K @ 4.6 Ghz H2O
Mainboard: Gigabyte Z68XP UD3
Memory: 16Go DDR3 1866
Soundcard: Auzentech X-FI Forte
PSU: C.Master S. Pro gold 800W
Default 07-10-2014, 19:57 | posts: 85 | Location: Naoned

Seems to be very close to 14.6 RC2. Not sure it's worth the download.
Thank you anyway Asder.
   
Reply With Quote
 
Old
  (#5)
lexuger
Newbie
 
Videocard: Gigabyte 7870 OC 2GB
Processor: AMD FX-8320@4200Mhz
Mainboard: Asrock 970 Extreme3 R2.0
Memory: Corsair Vengeance 8GB
Soundcard: Asus Xonar DX 7.1
PSU: Corsair TX850W
Default 07-10-2014, 20:01 | posts: 8 | Location: Barcelona

Thanks! i'm gonna try out right now.
   
Reply With Quote
Old
  (#6)
WittyScreenName
Newbie
 
Videocard: Sapphire r7 260x 2gb
Processor: Athlon II x4 635 3ghz
Mainboard: Foxxcon 2ab1
Memory: 8gb Gskill Ripjaw 1333
Soundcard:
PSU: Coolermaster 500w
Default 07-10-2014, 20:15 | posts: 28

Not updating drivers untill they make major performance enhancements or fix the heat "thing" that was introduced in 14.6.

Still no word as to WHY every single card runs 5-10c hotter with 14.6 compared to drivers earlier than 14.4
   
Reply With Quote
Old
  (#7)
SlackerITGuy
Master Guru
 
SlackerITGuy's Avatar
 
Videocard: AMD Radeon HD 7970 GHz
Processor: Intel Core i5-2500K
Mainboard: ASRock Z77 Extreme4
Memory: 8GB Corsair DDR3 RAM
Soundcard: ASUS Xonar DS
PSU: Corsair TX950W
Default 07-10-2014, 20:37 | posts: 241

Same version for everything, come on AMD, damn...

EDIT: Btw thanks asder00!
   
Reply With Quote
Old
  (#8)
The Mac
Maha Guru
 
Videocard: Sapphire R9-290 Vapor-X
Processor: i7-4970K
Mainboard: Asus Z97-A
Memory: Corsair Vengeance Pro
Soundcard:
PSU: Corasir AX750
Default 07-10-2014, 20:38 | posts: 2,190 | Location: USA

CCC is newer, thats all
   
Reply With Quote
Old
  (#9)
freeman94
Member Guru
 
Videocard: GIGABYTE HD7870 OC 2GB
Processor: i5 3570
Mainboard: ASUS P8H77-M PRO
Memory: DDR3 (2x4GB) 1600MHz
Soundcard: Realtek + Sony STR-KSL500
PSU: OCZ 600W
Default 07-10-2014, 20:45 | posts: 143 | Location: Poland

Quote:
Originally Posted by The Mac View Post
CCC is newer, thats all
Yeah, They don't even change number...It's still says its 14.6 RC in CCC for me.
   
Reply With Quote
Old
  (#10)
windrunnerxj
Member Guru
 
Videocard: Sapphire 6850HD Vapor-X
Processor: AMD Phenom II
Mainboard:
Memory:
Soundcard:
PSU: 750W
Default 07-10-2014, 20:53 | posts: 51

Did they fix BSODs with this version? Those were from HW acceleration, I think or whenever I tried to play BF3 or CIV5 with my browser open. Launch the game and get a BSOD -> reboot and launch the game again -> game starts fine.

Started from 14.6, I've seen some similar posts about this issue so I had to roll back to 14.4

Last edited by windrunnerxj; 07-10-2014 at 21:13.
   
Reply With Quote
 
Old
  (#11)
Agonist
Maha Guru
 
Agonist's Avatar
 
Videocard: HD7950 3GB Eyefinity
Processor: i7 950 @ 4.1 HT H100
Mainboard: MSI X58A-GD45
Memory: Corsair XMS3 12GB 1600
Soundcard: Onboard 5.1+ X-540
PSU: OCZ Fata1ty 1000w
Default 07-10-2014, 20:53 | posts: 917 | Location: Tennessee

Quote:
Originally Posted by WittyScreenName View Post
Not updating drivers untill they make major performance enhancements or fix the heat "thing" that was introduced in 14.6.

Still no word as to WHY every single card runs 5-10c hotter with 14.6 compared to drivers earlier than 14.4
I dont have this issue with my crossfire 7850s. Even with high oc of 1150/1400. Thought they have AIO H50s on them and memory heatsinks. Always under 50c load.

Thanks asder00. Gonna download. Each one since 14.6 beta has made my new eyefinity setup with mixed monitors work better.
   
Reply With Quote
Old
  (#12)
derpyQ
Newbie
 
Videocard: HD 7950 3GB
Processor: Intel Core i5
Mainboard:
Memory:
Soundcard:
PSU: 750w
Default 07-10-2014, 20:59 | posts: 29

AMD still has a lot of issues to fix....
High temps, OpenGL performance issues, Mantle optimizations in BF4 for 7xxx cards, and more. The first two were only introduced in 14.4 and newer drivers. Hard to imagine they might've been fixed without even updating the component numbers :@.

Edit: Official release notes indicate that this driver includes an updated crossfire profile for PvZ Garden Warfare, and a fix to reduce flickering in one specific monitor. COOOOOOOOOOOOOOOOOOOOOOOOL.

Last edited by derpyQ; 07-10-2014 at 21:02.
   
Reply With Quote
Old
  (#13)
|ALE|
Master Guru
 
Videocard: Asus R290X DCII
Processor: Intel Core-i7 980x@4.2Ghz
Mainboard: Gigabyte X58A-OC
Memory: 3x4GB DDR3 2ghz
Soundcard:
PSU: Thermaltake 875W
Default 07-10-2014, 21:07 | posts: 234

thanks asder.

@AMD, waiting 1 month for...? 14.6 rc with an other name? i can't see differences in release note.
   
Reply With Quote
Old
  (#14)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 07-10-2014, 21:13 | posts: 8,689 | Location: UK

Quote:
Originally Posted by derpyQ View Post
AMD still has a lot of issues to fix....
High temps, OpenGL performance issues, Mantle optimizations in BF4 for 7xxx cards, and more. The first two were only introduced in 14.4 and newer drivers. Hard to imagine they might've been fixed without even updating the component numbers :@.

Edit: Official release notes indicate that this driver includes an updated crossfire profile for PvZ Garden Warfare, and a fix to reduce flickering in one specific monitor. COOOOOOOOOOOOOOOOOOOOOOOOL.
Looks like they've just added a couple of extra fixes to the 14.6s, but seen as were now in July, they've had to call em 14.7, as Julys the 7th month
   
Reply With Quote
Old
  (#15)
cristian.a
Newbie
 
cristian.a's Avatar
 
Videocard: Sapphire HD6850 GDDR5 1GB
Processor: AMD A8-3870K
Mainboard: Gigabyte A55M-DS2
Memory: 2x4GB DDR3 1333 Mhz
Soundcard: 2.1 Edifier
PSU: Saikano Kanzen Mass 500W
Default 07-10-2014, 21:15 | posts: 35 | Location: NET

Quote:
Originally Posted by freeman94 View Post
Yeah, They don't even change number...It's still says its 14.6 RC in CCC for me.

For me too.. Say 14.6 RC in CCC and GPU-Z.

Thank you asder00
   
Reply With Quote
Old
  (#16)
PieEyedPiper
Master Guru
 
Videocard: MSi HD7950 Twin Frozr/3GB
Processor: Xeon X3360 @ 3.6GHz
Mainboard: Asus P5K Deluxe
Memory: 4GB DDR2 G.Skill @1100MHz
Soundcard: SB Z / Logitech 5.1 550w
PSU: Kingwin LazerP 550w
Default 07-10-2014, 21:21 | posts: 245

Quote:
Originally Posted by WittyScreenName View Post
Not updating drivers untill they make major performance enhancements or fix the heat "thing" that was introduced in 14.6.

Still no word as to WHY every single card runs 5-10c hotter with 14.6 compared to drivers earlier than 14.4
I'm not convinced the "heat" thing was ever proved, certainly not across the board. I've definitely not seen any before/after comparisons, either.

Personally, I've not noticed any difference in temps at all between these and the last 6+ sets but that doesn't mean that newer generations 260/290 don't see such behavior. I'd be curious to know if you were willing to do some proper testing on the matter.

That being said, I don't exactly feel compelled to swap these in for the rc2's, either.

Last edited by PieEyedPiper; 07-10-2014 at 21:26.
   
Reply With Quote
Old
  (#17)
windrunnerxj
Member Guru
 
Videocard: Sapphire 6850HD Vapor-X
Processor: AMD Phenom II
Mainboard:
Memory:
Soundcard:
PSU: 750W
Default 07-10-2014, 21:25 | posts: 51

Quote:
Originally Posted by PieEyedPiper View Post
Personally, I've not noticed any difference in temps at all between these and the last 6+ sets but that doesn't mean that newer generations 260/290 don't see such behavior.
I didn't measure the temps but my fan was noticeably louder on 14.6RC1 than on 14.4 or older versions. I doubt they screwed up automatic fan control (that's what I use) and I've seen posts about temp being 5-10c higher than usual.
   
Reply With Quote
Old
  (#18)
Gizmo
Member Guru
 
Videocard: 7970 PC v3
Processor: i5 3570k @ 4.5Ghz
Mainboard: Asrock z77 Extreme4
Memory: DDR3 2x4GB
Soundcard: Creative SB X-Fi / CA
PSU: 800watt
Default 07-10-2014, 21:25 | posts: 98 | Location: Terra Nova

Thanks for the effort Asder,but Wow.....AMD neck and neck with Creative on useful driver updates and not fixing glaring problems....what a f*n joke
   
Reply With Quote
Old
  (#19)
PieEyedPiper
Master Guru
 
Videocard: MSi HD7950 Twin Frozr/3GB
Processor: Xeon X3360 @ 3.6GHz
Mainboard: Asus P5K Deluxe
Memory: 4GB DDR2 G.Skill @1100MHz
Soundcard: SB Z / Logitech 5.1 550w
PSU: Kingwin LazerP 550w
Default 07-10-2014, 21:29 | posts: 245

Quote:
Originally Posted by windrunnerxj View Post
I didn't measure the temps but my fan was noticeably louder on 14.6RC1 than on 14.4 or older versions. I doubt they screwed up automatic fan control (that's what I use) and I've seen posts about temp being 5-10c higher than usual.
I was just thinking about that, if the issue was a matter of fan profiles.

If the issue is widespread and people are, in fact, getting temps of 5-10*C hotter (idle AND load) using 14.6+ I would have expected further study.

For a moment, I was all swept up, myself, into the notion that my card was running hotter when those reports started appearing. Fortunately, it was just a good 'ol case of placebo.

knocks on wood

Quote:
Originally Posted by Gizmo View Post
Thanks for the effort Asder,but Wow.....AMD neck and neck with Creative on useful driver updates and not fixing glaring problems....what a f*n joke
Now that's some funny ish!

Last edited by PieEyedPiper; 07-10-2014 at 21:35.
   
Reply With Quote
Old
  (#20)
Cave Waverider
Master Guru
 
Videocard: 2x GeForce GTX680 4GB SLi
Processor: Core i7 3930K @ 4.5GHz
Mainboard: Gigabyte G1.Assassin2
Memory: 32GB Corsair DDR3 1600
Soundcard: SB X-Fi CA20k2 (onboard)
PSU: Corsair Gold AX1200 1200W
Default 07-10-2014, 21:36 | posts: 230 | Location: Deep in the Caribbean...

Could the temperature issue be related to higher ambient temperatures? Personally, I haven't seen any noticeable increases on my system with AMD video cards.
   
Reply With Quote
Old
  (#21)
DrunkenDonkey
Member Guru
 
Videocard: Powercolor 290
Processor: Core I7-920@3.8
Mainboard: EVGA X58 Classified 3SLI
Memory:
Soundcard: DIY DAC
PSU: Seasonic 900W
Default 07-10-2014, 21:46 | posts: 91

I have not seen an increase either, or at least not noticeable to make me an impression. Usually driver with temps increase is a good one, meaning card gets used more = more fps and/or smoother play in the games. If you have played a specific game and now you see it runs hotter then congrats - they might have optimized the drivers for it
   
Reply With Quote
Old
  (#22)
RzrTrek
Member Guru
 
RzrTrek's Avatar
 
Videocard: HD6970, 2GB
Processor: i7-2600K
Mainboard: P8P67 DELUXE B3
Memory: DDR3-1866, 8GB
Soundcard: ALC889 (7.1)
PSU: HX850
Default 07-10-2014, 21:46 | posts: 46 | Location: Stockholm, Sweden

I'm afraid I might leave the AMD-bandwagon (donkey) for Nvidia in a few months, had enough of lousy drivers, zero optimizations, stutter, lack of drivers and Mantle support for older +32nm cards.

Last edited by RzrTrek; 07-10-2014 at 21:58.
   
Reply With Quote
Old
  (#23)
sapo_joe
Master Guru
 
Videocard: MSi Radeon R9 290 4GB
Processor: AMD PhenomII X6 1090T
Mainboard: Asus M4A78 Pro
Memory: 8GB DDRII 667Mhz Dual
Soundcard: SB X-Fi Titanium
PSU: 620W Antec Gamer
Default 07-10-2014, 21:57 | posts: 374 | Location: Brazil

Downloading.... Let's test these!

Thanks for sharing!
   
Reply With Quote
Old
  (#24)
sapo_joe
Master Guru
 
Videocard: MSi Radeon R9 290 4GB
Processor: AMD PhenomII X6 1090T
Mainboard: Asus M4A78 Pro
Memory: 8GB DDRII 667Mhz Dual
Soundcard: SB X-Fi Titanium
PSU: 620W Antec Gamer
Default 07-10-2014, 22:05 | posts: 374 | Location: Brazil

Quote:
Originally Posted by RzrTrek View Post
I'm afraid I might leave the AMD-bandwagon (donkey) for Nvidia in a few months, had enough of lousy drivers, zero optimizations, stutter, lack of drivers and Mantle support for older +32nm cards.
I left nVidia a few months ago for the same reason dude... Couldn't enable HW acceleration on browsers or I had system crashes, etc...

What now? LOL
   
Reply With Quote
Old
  (#25)
RzrTrek
Member Guru
 
RzrTrek's Avatar
 
Videocard: HD6970, 2GB
Processor: i7-2600K
Mainboard: P8P67 DELUXE B3
Memory: DDR3-1866, 8GB
Soundcard: ALC889 (7.1)
PSU: HX850
Default 07-10-2014, 22:08 | posts: 46 | Location: Stockholm, Sweden

Quote:
Originally Posted by sapo_joe View Post
I left nVidia a few months ago for the same reason dude... Couldn't enable HW acceleration on browsers or I had system crashes, etc...

What now? LOL
Intel Graphics?
   
Reply With Quote
Reply

Tags
@asder00

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.