Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
AMD Catalyst 14.6 RC2 (14.200.1004.0 June 20)
Old
  (#1)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Talking AMD Catalyst 14.6 RC2 (14.200.1004.0 June 20) - 06-24-2014, 17:49 | posts: 1,007 | Location: iTALY

Enjoy

> Download <


Build Info:
DriverVer=06/20/2014, 14.200.1004.0000
Catalyst 14.6 RC2
CCC: 2014.0620.2260.39449
D3D: 9.14.10.01044
OGL: 6.14.10.12967
OCL: 10.0.1526.3
Mantle: 9.1.10.0020

Supported Cards:
 Click to show spoiler



Twitter!
@asder00 | @guru_3d

Last edited by asder00; 06-24-2014 at 17:59.
   
Reply With Quote
 
Old
  (#2)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Thumbs up 06-24-2014, 17:56 | posts: 8,824 | Location: UK

YAY! Thanks asder

303mb

Last edited by Rich_Guy; 06-24-2014 at 17:58.
   
Reply With Quote
Old
  (#3)
Undying
Ancient Guru
 
Undying's Avatar
 
Videocard: R9 280X Vapor-X
Processor: Intel i5 2500k @ 4.6Ghz
Mainboard: Gigabyte GA-Z68AP-D3
Memory: 8GB Patriot Signature
Soundcard: Asus Xonar DG
PSU: Tt Toughpower XT 775W
Default 06-24-2014, 17:58 | posts: 4,118 | Location: Serbia, NS

I think i'm gonna wait for release notes. Thanks asder.
   
Reply With Quote
Old
  (#4)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Default 06-24-2014, 17:59 | posts: 1,007 | Location: iTALY

Quote:
Originally Posted by Undying View Post
I think i'm gonna wait for release notes. Thanks asder.
Rls notes added in the dl page now.


Twitter!
@asder00 | @guru_3d
   
Reply With Quote
 
Old
  (#5)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 06-24-2014, 18:00 | posts: 8,824 | Location: UK

Release notes are up aint they, as when you go to download em, it takes you to AMDs download page, and it tells you on there what they bring.

Gah beaten

   
Reply With Quote
Old
  (#6)
Undying
Ancient Guru
 
Undying's Avatar
 
Videocard: R9 280X Vapor-X
Processor: Intel i5 2500k @ 4.6Ghz
Mainboard: Gigabyte GA-Z68AP-D3
Memory: 8GB Patriot Signature
Soundcard: Asus Xonar DG
PSU: Tt Toughpower XT 775W
Default 06-24-2014, 18:01 | posts: 4,118 | Location: Serbia, NS

Quote:
Originally Posted by asder00 View Post
Rls notes added in the dl page now.
lol, that was fast.
   
Reply With Quote
Old
  (#7)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 06-24-2014, 18:18 | posts: 3,285 | Location: UK

Thanks for the heads up Asder00.
   
Reply With Quote
Old
  (#8)
freeman94
Member Guru
 
Videocard: GIGABYTE HD7870 OC 2GB
Processor: i5 3570
Mainboard: ASUS P8H77-M PRO
Memory: DDR3 (2x4GB) 1600MHz
Soundcard: Realtek + Sony STR-KSL500
PSU: OCZ 600W
Default 06-24-2014, 18:26 | posts: 143 | Location: Poland

Thank you
   
Reply With Quote
Old
  (#9)
Agonist
Maha Guru
 
Agonist's Avatar
 
Videocard: HD7950 3GB Eyefinity
Processor: i7 950 @ 4.1 HT H100
Mainboard: MSI X58A-GD45
Memory: Corsair XMS3 12GB 1600
Soundcard: XFI Extreme Audio + X-540
PSU: OCZ Fata1ty 1000w
Default 06-24-2014, 18:28 | posts: 979 | Location: Tennessee

Hopefully this fixes my few odd issues. Weird screen flickers in Chrome when eyefinity enabled, stuck uvd clocks in game. Used this driver on my 80gb raptor and had no issues, did a new win 8.1 install and it has ran like pure **** sadly.
   
Reply With Quote
Old
  (#10)
fragba1t
Member Guru
 
fragba1t's Avatar
 
Videocard: Vapor-x R9 270x
Processor: FX 8320
Mainboard: ASUS Cheap'n'Nasty
Memory: DDR3/8GB
Soundcard: X-Fi Extreme Music
PSU: OCZ 700w
Default 06-24-2014, 18:35 | posts: 139 | Location: Edinburgh

Thanks, hope this fixes the State of Decay gfx issues!
   
Reply With Quote
 
Old
  (#11)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 06-24-2014, 18:42 | posts: 8,824 | Location: UK

Not a good start, opened AB, selected profile, BSOD restart, after the restart, profile selected, fine
   
Reply With Quote
Old
  (#12)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 06-24-2014, 18:55 | posts: 3,285 | Location: UK

Performance improvements for WildStar, finally.
   
Reply With Quote
Old
  (#13)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 06-24-2014, 18:57 | posts: 6,074 | Location: 127.0.0.1

Quote:
Originally Posted by Rich_Guy View Post
Not a good start, opened AB, selected profile, BSOD restart, after the restart, profile selected, fine
Im not updating my drivers for another good few builds yet after the ridiculous number of bugs in the last 14.6 drivers, 90% bugs 10% new features that didn't work properly lol

14.4 WHQL for the foreseeable future
   
Reply With Quote
Old
  (#14)
fasor
Member Guru
 
Videocard: Gigabyte HD7870 2Gb
Processor: AMD Phenom II 1055T
Mainboard: Gigabyte GA-MA770-UD3
Memory: DDR2 8GB
Soundcard: Realtek ALC888
PSU: Chieftec 700W
Default 06-24-2014, 19:06 | posts: 46 | Location: Russia

DX9 games still have bugs like it was with first 14.6 RC
rolling back to 14.4 again =)
   
Reply With Quote
Old
  (#15)
fragba1t
Member Guru
 
fragba1t's Avatar
 
Videocard: Vapor-x R9 270x
Processor: FX 8320
Mainboard: ASUS Cheap'n'Nasty
Memory: DDR3/8GB
Soundcard: X-Fi Extreme Music
PSU: OCZ 700w
Default 06-24-2014, 19:07 | posts: 139 | Location: Edinburgh

Quote:
Originally Posted by fragba1t View Post
Thanks, hope this fixes the State of Decay gfx issues!
It didn't Think I might also go back to 14.4
   
Reply With Quote
Old
  (#16)
Rivers23
Newbie
 
Videocard: amd 7670m
Processor: Intel i3 2350m
Mainboard:
Memory:
Soundcard:
PSU: regular
Default 06-24-2014, 19:11 | posts: 17

Basically useless for non r9 single cards, nothing was updated except the CCC version.
   
Reply With Quote
Old
  (#17)
Olvik
Master Guru
 
Olvik's Avatar
 
Videocard: ASUS GTX Titan Black
Processor: Intel i7 3960x @4.80MHz
Mainboard: ASUS Rampage IV BE
Memory: G.Skill 2133MHz.
Soundcard: Creative X-Fi Fatal1ty
PSU: OCZ ZX Series 1250w
Default 06-24-2014, 19:11 | posts: 164 | Location: Spain

Thank you
   
Reply With Quote
Old
  (#18)
Espionage724
Maha Guru
 
Espionage724's Avatar
 
Videocard: MSI R7850 PE 2GD5/OC
Processor: TBA
Mainboard: TBA
Memory: DDR3 1333 (PC3 10666) 8GB
Soundcard: TBA
PSU: hec HP585D 585W ATX12V
Default 06-24-2014, 20:02 | posts: 1,251 | Location: Charleroi, PA

Guess I chose a good time to reinstall Windows on my laptop. The first RC of 14.6 was fine, so I don't really expect anything different with these...

Edit: There is no AMD SATA driver included. The first RC came with an outdated SATA driver iirc. Still comes with the usual HDMI, HDMI Filter, and other stuff (PCI Bus filter, USB 3.0, RAID), but I'm unsure how their versions match up to previous releases.

Last edited by Espionage724; 06-24-2014 at 20:05.
   
Reply With Quote
Old
  (#19)
montafede
Newbie
 
montafede's Avatar
 
Videocard: ati 7970 dual-x
Processor: i5 2500k
Mainboard: asrock z68
Memory: 4x4 ddr3 corsair vegance
Soundcard:
PSU: 750w
Default 06-24-2014, 20:05 | posts: 8 | Location: rome

Hello to every one...this drivers are good for hd 7970 dual x
please answer to me
   
Reply With Quote
Old
  (#20)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 06-24-2014, 20:09 | posts: 8,824 | Location: UK

Few benchies.

14.6 Beta v1

Tomb Raider - Min 62 - Max 112 - Avg 84

Sniper V2 - Avg 79.43 - Min 42.75

3D Mark 11 - 11,849

Metro LL - Avg 71.67 - Max 128.50 - Min 20.53

Metro 2033 - Avg 77.33 - Max 203.29 - Min 10.99

Grid 2 - Avg 88.95 - Min 66.59 - Max 131.72

14.6 RC2s

Tomb Raider - Min 62 - Max 104 - Avg 82.1

Sniper V2 - Avg 79.31 - Min 15.69

3D Mark 11 - 11,870

Metro LL - Avg 71.67 - Max 141.12 - Min 7.36

Metro 2033 - Avg 78 - Max 196.58 - Min 10.12

Grid 2 - Avg 92.12 - Min 69.27 - Max 137.39

Going back to the Beta 1s, as some of the minimums on these are dire, especially on Sniper V2.
   
Reply With Quote
Old
  (#21)
DiceAir
Master Guru
 
Videocard: 2x Club3D R9-280x RK
Processor: i7-4790k Stock
Mainboard: MSI z97 Gaming 5
Memory: 16GB corsair 1600MHz
Soundcard: Sound Blaster Z
PSU: Corsair ax850w
Default 06-24-2014, 20:21 | posts: 480 | Location: South Africa

Will try these when i get my crossfire running. Just waiting for 4790K to become available here
   
Reply With Quote
Old
  (#22)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 06-24-2014, 20:40 | posts: 8,824 | Location: UK

Quote:
Originally Posted by Extraordinary View Post
Im not updating my drivers for another good few builds yet after the ridiculous number of bugs in the last 14.6 drivers, 90% bugs 10% new features that didn't work properly lol

14.4 WHQL for the foreseeable future
The 14.6 Beta 1s have been fine for me, got a couple of frames increase, and had no issues.

Just re-ran Sniper V2 again back on the Beta 1s, minimums gone back up to normal, 40 odd.

Thought they were a bit low on the minimums, as i also noticed while running the LL bench, on some parts i was dropping as low as 45/50, where as on the Beta 1s, was only going around 70/72, same parts.

Last edited by Rich_Guy; 06-24-2014 at 20:44.
   
Reply With Quote
Old
  (#23)
Gizmo
Member Guru
 
Videocard: 7970 PC v3
Processor: i5 3570k @ 4.5Ghz
Mainboard: Asrock z77 Extreme4
Memory: DDR3 2x4GB
Soundcard: Creative SB X-Fi / CA
PSU: 800watt
Default 06-24-2014, 20:45 | posts: 109 | Location: Terra Nova

Thanks for the feedback guys...looks like yet another lame 14.x set think i'll be sticking with 13.12 till Nv release there 8x0 cards and i can move back to the green team
   
Reply With Quote
Old
  (#24)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 06-24-2014, 20:48 | posts: 6,074 | Location: 127.0.0.1

Quote:
Originally Posted by Rich_Guy View Post
The 14.6 Beta 1s have been fine for me, got a couple of frames increase, and had no issues.

Just re-ran Sniper V2 again back on the Beta 1s, minimums gone back up to normal, 40 odd.

Thought they were a bit low on the minimums, as i also noticed while running the LL bench, on some parts i was dropping as low as 45/50, where as on the Beta 1s, was only going around 70/72, same parts.
It's the Eyefinity changes that broke everything for me, I run Eyefinity 24/7 now and it's unusable with 14.6, they broke everything about it, mainly Win key & P to swap between single and multi screen doesn't work any more

Along with a list as long as my arm of other problems, and 0 performance improvements for WDs, actually -20% in watchdogs, I get way better fps with 14.4

I hated my machine while I was using 14.6, it's great again with 14.4
   
Reply With Quote
Old
  (#25)
BrainDedd
Master Guru
 
Videocard: ASUS Radeon HD5870
Processor: Intel Core i7-3770k
Mainboard: ASUS Maximus V Formula
Memory: Corsair Dominator 16GB
Soundcard: Onboard
PSU: Corsair AX860i
Default 06-24-2014, 20:51 | posts: 151 | Location: Johannesburg, South Africa

Knock on wood ... but these do seem to have fixed the black screen video options dialog.
   
Reply With Quote
Reply

Tags
@asder00

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.