Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA Drivers Section
Videocards - NVIDIA Drivers Section In this section you can discuss everything ForceWare driver related. ForceWare (Detonator) drivers are for NVIDIA TNT, Quadro and all GeForce based videocards.


Reply
 
Thread Tools Display Modes
Vsync Microstuttering frustrations
Old
  (#1)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default Vsync Microstuttering frustrations - 06-19-2014, 05:22 | posts: 1,469 | Location: Oregon

This is something that really confuses and pisses me off.

Basically


60Hz Vsync + 30FPS cap = Constant microstuttering , decent Input lag.
60Hz 1/2 Refresh Vsync + 30FPS cap = No microstuttering, large increase in input lag.


It's ridiculously frustrating.

I've got plenty of overhead to achieve perfect 30FPS if I can't maintain a perfect 60FPS in any given game. But every few seconds or when the camera is moved, it drops a frame or there is a spike in the time it takes to get a frame out and it creates judder/microstutter.


I don't understand how this is happening. Double buffered Vsync = can't maintain 60, drops to 30. So why is this happening when a 30FPS cap is being used?


Using Triple buffering doesn't seem to help this issue.


I've noticed this in a few games and it's a big problem in the game i'm playing now, Mafia II.

And maybe this explains *somehow* the constant microstuttering I get in Dead island with a 30FPS cap and Vsync on. I don't recall trying it with 1/2 Refresh to check microstuttering but I do remember trying 1/2 Refresh to check input lag and it was a bit worse

*Video Link* https://www.copy.com/s/asp9Aw1Er9oP/...%20showing.avi


Anyone else ever notice this?

Last edited by MrBonk; 06-19-2014 at 05:27.
   
Reply With Quote
 
Old
  (#2)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 06-19-2014, 16:06 | posts: 753

what graphics card are you using?
   
Reply With Quote
Old
  (#3)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-19-2014, 19:57 | posts: 1,469 | Location: Oregon

Gtx 570
   
Reply With Quote
Old
  (#4)
Smooth Operator
Member Guru
 
Videocard: MSI GTX690
Processor: Intel i7 3930k
Mainboard: Asus X79 Pro
Memory: 32GB Kingston Hyper X
Soundcard: Quad L 5.1 Speaker System
PSU: XFX Pro 1000W
Default 06-19-2014, 20:34 | posts: 61 | Location: UK

Use adaptive vsync in Mafia 2 anything else seems to have framepacing issues whether you use vsync in-game or the control panel.

In quite a few games vsync doesn't work properly so you just have to try different combinations between in-game vsync, control panel vsync or adaptive vsync, triple buffering on and off, or D3DOverider with triple buffering as one method doesn't always fix it.
   
Reply With Quote
 
Old
  (#5)
Terepin
Master Guru
 
Terepin's Avatar
 
Videocard: MSI GTX 970 Gaming 4G
Processor: Core i7-4790K
Mainboard: ASUS MAXIMUS VII HERO
Memory: Corsair DDR3 2x4 GB @2133
Soundcard: Realtet ALC1150
PSU: Seasonic SS-860XP
Default 06-19-2014, 21:26 | posts: 379 | Location: Košice, Slovakia

Quote:
Originally Posted by MrBonk View Post
This is something that really confuses and pisses me off.

Basically


60Hz Vsync + 30FPS cap = Constant microstuttering , decent Input lag.
60Hz 1/2 Refresh Vsync + 30FPS cap = No microstuttering, large increase in input lag.


It's ridiculously frustrating.

I've got plenty of overhead to achieve perfect 30FPS if I can't maintain a perfect 60FPS in any given game. But every few seconds or when the camera is moved, it drops a frame or there is a spike in the time it takes to get a frame out and it creates judder/microstutter.


I don't understand how this is happening. Double buffered Vsync = can't maintain 60, drops to 30. So why is this happening when a 30FPS cap is being used?


Using Triple buffering doesn't seem to help this issue.


I've noticed this in a few games and it's a big problem in the game i'm playing now, Mafia II.

And maybe this explains *somehow* the constant microstuttering I get in Dead island with a 30FPS cap and Vsync on. I don't recall trying it with 1/2 Refresh to check microstuttering but I do remember trying 1/2 Refresh to check input lag and it was a bit worse

*Video Link* https://www.copy.com/s/asp9Aw1Er9oP/...%20showing.avi


Anyone else ever notice this?
Who in the right mind would be using double buffered VSync?
   
Reply With Quote
Old
  (#6)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-20-2014, 09:01 | posts: 1,469 | Location: Oregon

Triple buffering in some cases actually increases input lag. So don't be ignorant alright?
   
Reply With Quote
Old
  (#7)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-20-2014, 09:03 | posts: 1,469 | Location: Oregon

Quote:
Originally Posted by Smooth Operator View Post
Use adaptive vsync in Mafia 2 anything else seems to have framepacing issues whether you use vsync in-game or the control panel.

In quite a few games vsync doesn't work properly so you just have to try different combinations between in-game vsync, control panel vsync or adaptive vsync, triple buffering on and off, or D3DOverider with triple buffering as one method doesn't always fix it.
Maybe that's it. Triple buffering was causing some issues and increasing IL a bit for this game.

Adaptive Vsync isn't an option for me. I can't stand tearing when it comes to SP games.

Right now 1/2 refresh is doing the job. But it's not an ideal solution
   
Reply With Quote
Old
  (#8)
Terepin
Master Guru
 
Terepin's Avatar
 
Videocard: MSI GTX 970 Gaming 4G
Processor: Core i7-4790K
Mainboard: ASUS MAXIMUS VII HERO
Memory: Corsair DDR3 2x4 GB @2133
Soundcard: Realtet ALC1150
PSU: Seasonic SS-860XP
Default 06-20-2014, 09:03 | posts: 379 | Location: Košice, Slovakia

Quote:
Originally Posted by MrBonk View Post
Triple buffering in some cases actually increases input lag. So don't be ignorant alright?
I would like to see those cases. Never encountered them in 12 years.
   
Reply With Quote
Old
  (#9)
kurtextrem
Member Guru
 
kurtextrem's Avatar
 
Videocard: NVIDIA GeForce GTX 765M
Processor: Intel i5-4200H
Mainboard:
Memory: 8GB
Soundcard:
PSU: ?
Default 06-20-2014, 11:25 | posts: 71 | Location: Munich

Short random vsync question: My NVIDIA panel does only show "on", "off" and something with "3d settings". Where can I enable, let's say, adaptive?
And last time I've read about triple buffering I heard "only enable it with vsync", is that still true? Or can it improve performance w/o vsync?
   
Reply With Quote
Old
  (#10)
tsunami231
Ancient Guru
 
tsunami231's Avatar
 
Videocard: EVGA 660gtx sig2
Processor: i7 920 CNPS10X Quiet
Mainboard: Evga x58 SLI LE
Memory: 3x2gb Dominator@1600 6Gb
Soundcard: Realtek HD Audio
PSU: Antec Truepower 750
Default 06-20-2014, 21:04 | posts: 3,609 | Location: USA

Quote:
Originally Posted by kurtextrem View Post
Short random vsync question: My NVIDIA panel does only show "on", "off" and something with "3d settings". Where can I enable, let's say, adaptive?
And last time I've read about triple buffering I heard "only enable it with vsync", is that still true? Or can it improve performance w/o vsync?
TB only works with vsync..
   
Reply With Quote
 
Old
  (#11)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-20-2014, 21:19 | posts: 1,469 | Location: Oregon

Quote:
Originally Posted by Terepin View Post
I would like to see those cases. Never encountered them in 12 years.
I just showed you one. And it's not the only reported case.


Not every game has increased input lag. But many do, Mafia II, L4D2,WoW on OSX, and others too.


Some games have decreased input lag, such as Pinball FX2 and others.

But it's not universal.

Triple buffering also breaks Steam Big Picture and causes it to crash.
   
Reply With Quote
Old
  (#12)
-Tj-
Ancient Guru
 
-Tj-'s Avatar
 
Videocard: ZOTAC GTX780 OC AmpFan
Processor: i7 4770K OC 4.7GHz @1.28v
Mainboard: ASUS Z87 Deluxe
Memory: Crucial BLE 16GB 2400MHz
Soundcard: Creative X-Fi Titanium HD
PSU: Chieftec NTRO88+ 650W
Default 06-20-2014, 22:49 | posts: 8,323 | Location: Urban`Jungle

in L4D2 cap to 60fps +Triplebuffer vsync, driver 1 frame to render ahead and no input lag at all, well very very minimal.
   
Reply With Quote
Old
  (#13)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-21-2014, 08:22 | posts: 1,469 | Location: Oregon

I get a ton of Input lag with Vsync/+TripleBuffering in L4D2. (And I do have the game capped to 60> so i'll have to try that)
   
Reply With Quote
Old
  (#14)
GanjaStar
Master Guru
 
Videocard: POV gtx 660
Processor: Intel i5 4670K
Mainboard: GA-Z87-D3HP
Memory: 8gb Corsair Vengeance pro
Soundcard: x-fi extreme gamer
PSU: corsair tx 650w
Default 06-21-2014, 13:37 | posts: 593 | Location: Zagreb,Croatia

Quote:
Originally Posted by Terepin View Post
I would like to see those cases. Never encountered them in 12 years.
Well read up on triple buffering then.

By its very design it creates input lag in every single game.

Someone not noticing it, well, that's a different story.
   
Reply With Quote
Old
  (#15)
Terepin
Master Guru
 
Terepin's Avatar
 
Videocard: MSI GTX 970 Gaming 4G
Processor: Core i7-4790K
Mainboard: ASUS MAXIMUS VII HERO
Memory: Corsair DDR3 2x4 GB @2133
Soundcard: Realtet ALC1150
PSU: Seasonic SS-860XP
Default 06-21-2014, 19:26 | posts: 379 | Location: Košice, Slovakia

I'm playing L4D2 with triple buffered Vsync and the only input lag, which I don't even notice anymore, is from Vsync itself.

MrBonk, you can always try forcing triple buffering with RP. Oh yeah, and in 99% you NEED to cap FPS as well, otherwise you will see stuttering. Especially in L4D2. Use RTSS to cap it globally. But not to 30 FPS, but to 60 FPS. If you can maintain solid 60, you'll be fine.

Last edited by Terepin; 06-21-2014 at 19:29.
   
Reply With Quote
Old
  (#16)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-21-2014, 19:57 | posts: 1,469 | Location: Oregon

I do use RTSS to cap the framerate almost all the time in every case.
   
Reply With Quote
Old
  (#17)
octiceps
Banned
 
Videocard: GeForce GT 650M SLI
Processor: Intel Core i7-3630QM
Mainboard:
Memory: 8GB DDR3-1600
Soundcard:
PSU: 170W
Default 06-21-2014, 20:49 | posts: 124

Any form of V-Sync always introduces some input lag, but the extent of it depends on the game engine in question. For example, mouse responsiveness is really impacted in Source and UE3 games, but it's a lot more subtle in BF3/BF4 (Frostbite 2/3) and Halo PC (Blam!).

Of course, personal preferences differ so YMMV.

Fluid controller response is key for me, so no V-Sync in any game here. I just cap FPS at 58 or 62 which leaves only a bit of minor screen tearing that doesn't really bother me.

Last edited by octiceps; 06-21-2014 at 20:58.
   
Reply With Quote
Old
  (#18)
bishi
Master Guru
 
Videocard: GTX780 3GB SLI
Processor: 5960X @ 4.4ghz
Mainboard:
Memory:
Soundcard: G930
PSU: 850W XFX
Default 06-22-2014, 02:30 | posts: 328 | Location: London

With vsync enabled there is usually no reason to cap with rtss. Capping framerate outside of the application can cause microstutter. Which will be more noticeable the lower your framerate. Also try temporarily disabling hyperthreading as it can be a cause, usually with SLI but it can't hurt to try.
If nothing else works try capping framerate to 1-4 FPS BELOW your synced framerate. Start at 1 and work down

Last edited by bishi; 06-22-2014 at 02:35.
   
Reply With Quote
Old
  (#19)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-22-2014, 08:23 | posts: 1,469 | Location: Oregon

I get a lot of judder/if capped at 59/58 and it feels really off.

If I don't cap at 60, it seems the framerate fluctuates a lot more between 58,59/60 (As the actual display refresh rate is actually 59.94 or 59.97 on some of my monitors) and frame times are more erratic. Usually capping at 60 keeps a consistent 16.67ms

But the problem here is using standard 60HZ vsync, but with a 30FPS cap. Which should be fine.

Maybe it's just the game i'm playing that's the problem. Because as I mentioned, 1/2 refresh works fine. But increases the input lag probably about 50ms just based on how it feels.
   
Reply With Quote
Old
  (#20)
RealNC
Master Guru
 
Videocard: Palit GTX 780 Jetstream
Processor: Intel Core i5 2500K
Mainboard: MSI P67A-C43
Memory: DDR3 16GB
Soundcard: Asus Xonar D1, JBL Spot
PSU: Corsair HX650
Default 06-22-2014, 08:43 | posts: 161

I went for a different solution with a game that can't maintain 60FPS. In this case, that's Assassin's Creed IV. It would drop down to ~52FPS at worst.

So to solved that, I created a 48Hz mode for my monitor (with CRU) and use V-Sync. The game then ran at 48FPS at all times, and was still smooth. 48Hz is the lowest my monitor will go. 48Hz is also awesome for 24P (24FPS) movies, btw.

Frankly, with this game, I can't tell much difference between 48Hz and 60Hz since I play with an XBOX gamepad. Other than having absolutely zero stutters in 48Hz, of course. If using a mouse though, then 48FPS doesn't feel as smooth as 60 of course, but still much much better than if I had used 30FPS at 60Hz.

Note that for this to actually be smooth, your monitor must actually really output 48Hz. If the monitor is frame skipping at that frequency, then you'll get stutters. After you switch to a 48Hz mode, you can test for frame skipping. If you see gaps in the photo you take there, than you're out of luck; your monitor can't display 48Hz smoothly.

Last edited by RealNC; 06-22-2014 at 08:49.
   
Reply With Quote
Old
  (#21)
octiceps
Banned
 
Videocard: GeForce GT 650M SLI
Processor: Intel Core i7-3630QM
Mainboard:
Memory: 8GB DDR3-1600
Soundcard:
PSU: 170W
Default 06-22-2014, 09:14 | posts: 124

Quote:
Originally Posted by MrBonk View Post
I get a lot of judder/if capped at 59/58 and it feels really off.

If I don't cap at 60, it seems the framerate fluctuates a lot more between 58,59/60 (As the actual display refresh rate is actually 59.94 or 59.97 on some of my monitors) and frame times are more erratic. Usually capping at 60 keeps a consistent 16.67ms

But the problem here is using standard 60HZ vsync, but with a 30FPS cap. Which should be fine.

Maybe it's just the game i'm playing that's the problem. Because as I mentioned, 1/2 refresh works fine. But increases the input lag probably about 50ms just based on how it feels.
I don't use 60 FPS cap because it increases tearing always in the same part of the screen, which is why I offset it by a few frames, for example 58 or 62. No V-Sync, of course.

Last edited by octiceps; 06-22-2014 at 09:19.
   
Reply With Quote
Old
  (#22)
tsunami231
Ancient Guru
 
tsunami231's Avatar
 
Videocard: EVGA 660gtx sig2
Processor: i7 920 CNPS10X Quiet
Mainboard: Evga x58 SLI LE
Memory: 3x2gb Dominator@1600 6Gb
Soundcard: Realtek HD Audio
PSU: Antec Truepower 750
Default 06-22-2014, 19:05 | posts: 3,609 | Location: USA

Quote:
Originally Posted by octiceps View Post
I don't use 60 FPS cap because it increases tearing always in the same part of the screen, which is why I offset it by a few frames, for example 58 or 62. No V-Sync, of course.
you gona tear regardless with vsync off, only thing that is gona stop tearing it vsync being on....

Quote:
Originally Posted by MrBonk View Post
This is something that really confuses and pisses me off.

Basically


60Hz Vsync + 30FPS cap = Constant microstuttering , decent Input lag.
60Hz 1/2 Refresh Vsync + 30FPS cap = No microstuttering, large increase in input lag.


It's ridiculously frustrating.

I've got plenty of overhead to achieve perfect 30FPS if I can't maintain a perfect 60FPS in any given game. But every few seconds or when the camera is moved, it drops a frame or there is a spike in the time it takes to get a frame out and it creates judder/microstutter.


I don't understand how this is happening. Double buffered Vsync = can't maintain 60, drops to 30. So why is this happening when a 30FPS cap is being used?


Using Triple buffering doesn't seem to help this issue.


I've noticed this in a few games and it's a big problem in the game i'm playing now, Mafia II.

And maybe this explains *somehow* the constant microstuttering I get in Dead island with a 30FPS cap and Vsync on. I don't recall trying it with 1/2 Refresh to check microstuttering but I do remember trying 1/2 Refresh to check input lag and it was a bit worse

*Video Link* https://www.copy.com/s/asp9Aw1Er9oP/...%20showing.avi


Anyone else ever notice this?

Win 7? could trying disable desktop composition see if it helps with studdering win 8 has similar feature its just not simple to disable it cause there is no disable desktop composition feature last i checked.

Last edited by tsunami231; 06-22-2014 at 19:08.
   
Reply With Quote
Old
  (#23)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 06-22-2014, 22:20 | posts: 1,469 | Location: Oregon

Quote:
Originally Posted by tsunami231 View Post
you gona tear regardless with vsync off, only thing that is gona stop tearing it vsync being on....




Win 7? could trying disable desktop composition see if it helps with studdering win 8 has similar feature its just not simple to disable it cause there is no disable desktop composition feature last i checked.
Desktop composition/Aero is disabled. I only use it when windowed programs need Vsync.

Quote:
Originally Posted by RealNC View Post
I went for a different solution with a game that can't maintain 60FPS. In this case, that's Assassin's Creed IV. It would drop down to ~52FPS at worst.

So to solved that, I created a 48Hz mode for my monitor (with CRU) and use V-Sync. The game then ran at 48FPS at all times, and was still smooth. 48Hz is the lowest my monitor will go. 48Hz is also awesome for 24P (24FPS) movies, btw.

Frankly, with this game, I can't tell much difference between 48Hz and 60Hz since I play with an XBOX gamepad. Other than having absolutely zero stutters in 48Hz, of course. If using a mouse though, then 48FPS doesn't feel as smooth as 60 of course, but still much much better than if I had used 30FPS at 60Hz.

Note that for this to actually be smooth, your monitor must actually really output 48Hz. If the monitor is frame skipping at that frequency, then you'll get stutters. After you switch to a 48Hz mode, you can test for frame skipping. If you see gaps in the photo you take there, than you're out of luck; your monitor can't display 48Hz smoothly.
Yeah i've used that test before. Best I could do was 50Hz


Appreciate the responses everyone
   
Reply With Quote
Old
  (#24)
octiceps
Banned
 
Videocard: GeForce GT 650M SLI
Processor: Intel Core i7-3630QM
Mainboard:
Memory: 8GB DDR3-1600
Soundcard:
PSU: 170W
Default 06-23-2014, 02:17 | posts: 124

Quote:
Originally Posted by tsunami231 View Post
you gona tear regardless with vsync off, only thing that is gona stop tearing it vsync being on....
Never said it didn't tear, just that capping FPS at exactly 60 causes a really slow tear in one part of the screen which is really distracting.
   
Reply With Quote
Old
  (#25)
Noisiv
Ancient Guru
 
Videocard: GTX 460 HAWK Talon Attack
Processor: Q6600@3.5GHz
Mainboard: Gigabyte EP-43-DS3L
Memory: 4GB OCZ 5-4-4-4-12
Soundcard: Onboard Realtek ALC888
PSU: Silent Pro M700
Default 06-23-2014, 02:32 | posts: 3,084

Quote:
Originally Posted by Terepin View Post
I would like to see those cases. Never encountered them in 12 years.
Then you've never played Half-Life 2, Left 4 Dead, Team Fortress or any other game on Source engine
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.