Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI
Videocards - AMD - ATI AMD Radeon graphics cards. Do you have one or want to buy one? Use this forum to discuss anything concerning products using Radeon graphics cards, CrossFireX, from Radeon 9800 to HD 6900


Reply
 
Thread Tools Display Modes
issues on Crossfire R9-290X
Old
  (#1)
felix46
Newbie
 
Videocard: R9 290x crossfire
Processor: i7 3930K
Mainboard:
Memory:
Soundcard:
PSU: stridder gold 1200w
Default issues on Crossfire R9-290X - 11-07-2013, 15:55 | posts: 5

hey there i have some issue with my R9-290X crossfire,firstly let's talk about the beginning of problem


This is my rig spec
-i7 3930K 4.5GHz
-16GB ram dominator platinum 2133MHz
-Crossfire power color OC BF 4 edition R9-290X with AMD Catalyst Beta 13.11
-1200W stridder gold
-1080p res monitor

my crossfire 290X is super great when running on benchmark 3DMark11
here's the benchmark result http://www.3dmark.com/3dm11/7443421

and this is benchmark from my previous GTX 780 SLI
http://www.3dmark.com/3dm11/7411536

what a huge different right ?

i thought Crossfire R9-290X is great Cards untill i played Battlefield 4,and crysis 3.

because my crossfire R9-290X just get 50-70 fps on ultra setting (with so much laggy) while my previous GTX 780 SLI can get over 100 Fps with very steady.

with that huge different benchmark score i think at least R9-290X can perform battlefield 4 110-120fps steady
*my crossfire R9-290X temp was 90-94 celcius degree and still can perform 1030MHz engine clock and 100% GPU usage

based on this review at least i can get 110fps
http://www.guru3d.com/articles_pages...review,17.html

what i really want to ask is,why my crossfire R9-290X run very bad with battlefield 4 ? this is just very bad AMD Driver or what ? really dissapointed with this card


thanks for any response




here some screen shot from crossfire R9-290X
*i have not screen shot of my previous SLI GTX 780
[img][/img]
crossfire R9 290X amd catalyst beta 13.11

[img][/img]
Battlefield 4 fps 53

Last edited by felix46; 11-07-2013 at 17:19.
   
Reply With Quote
 
Old
  (#2)
Ecurb
Newbie
 
Videocard: Radeon 290X 4GB @ XFire
Processor: i7 4930k @ 4.6 Ghz
Mainboard: Asus Rampage IV Extreme
Memory: 32 GB Ripjaws-X @ 2400
Soundcard: Asus Xonar Essence One
PSU: Lepa G1600-MA 1600W
Default 11-08-2013, 03:53 | posts: 37 | Location: Australia

Hey Felix,

I have just put in 2 x 290x (stock cooling atm and no overclocks etc) going from 4 x GTX 680's.

I am running BF4 @ 1600p Ultra 4xmsaa @ FPS limited 61fps and it nevers budges on the 2 x 290xs. I'm also not even really oc-ing my CPU (4770k @ 3.9ghz)

You might want to check vsync is OFF as then i turn it on, it locks to around 40 fps and runs absolutely TERRIBLY on the 290x which i assume is a driver bug.

Re Crysis 3- i get around 45-55 FPS with Very High, FXAA (1600P) i think this will get much better when i properly OC my CPU again to 4.5.
Also saw the same problem with Vsync ON- lower FPS and stuterring like crazy.

For now i'd disable Vsync and see how you go. Crysis still felt bad (not smooth) to me even with Vsync off but like i said i think this is my CPU needing more OC.

BF4 with Vsync off was butter smooth and at 61fps cap no exceptions
   
Reply With Quote
Old
  (#3)
felix46
Newbie
 
Videocard: R9 290x crossfire
Processor: i7 3930K
Mainboard:
Memory:
Soundcard:
PSU: stridder gold 1200w
Default 11-08-2013, 04:50 | posts: 5

Quote:
Originally Posted by Ecurb View Post
Hey Felix,

I have just put in 2 x 290x (stock cooling atm and no overclocks etc) going from 4 x GTX 680's.

I am running BF4 @ 1600p Ultra 4xmsaa @ FPS limited 61fps and it nevers budges on the 2 x 290xs. I'm also not even really oc-ing my CPU (4770k @ 3.9ghz)

You might want to check vsync is OFF as then i turn it on, it locks to around 40 fps and runs absolutely TERRIBLY on the 290x which i assume is a driver bug.

Re Crysis 3- i get around 45-55 FPS with Very High, FXAA (1600P) i think this will get much better when i properly OC my CPU again to 4.5.
Also saw the same problem with Vsync ON- lower FPS and stuterring like crazy.

For now i'd disable Vsync and see how you go. Crysis still felt bad (not smooth) to me even with Vsync off but like i said i think this is my CPU needing more OC.

BF4 with Vsync off was butter smooth and at 61fps cap no exceptions
i have make sure that my battlefield 4 have Off Vsync and still same with my crossfire R9 290X. so laggy and very bad fps (around 45-60fps)

crysis 3 is very hardware killer game and i think it's ok if i can get more than 60 fps with every setting on and ultra but the truth is i only get 45-55 fps

i think so,maybe u need to OC your CPU to 4.5GHz at least




i found a new case, if i disable Crossfire in other words just use 1 Card for play battlefield 4 i get better fps it's around 70-80 stable with less laggy than crossfire

here's the screenshot using single R9 290X
[IMG][/IMG]
   
Reply With Quote
Old
  (#4)
felix46
Newbie
 
Videocard: R9 290x crossfire
Processor: i7 3930K
Mainboard:
Memory:
Soundcard:
PSU: stridder gold 1200w
Default 11-08-2013, 04:56 | posts: 5

Quote:
Originally Posted by Ecurb View Post
Hey Felix,

I have just put in 2 x 290x (stock cooling atm and no overclocks etc) going from 4 x GTX 680's.

I am running BF4 @ 1600p Ultra 4xmsaa @ FPS limited 61fps and it nevers budges on the 2 x 290xs. I'm also not even really oc-ing my CPU (4770k @ 3.9ghz)

You might want to check vsync is OFF as then i turn it on, it locks to around 40 fps and runs absolutely TERRIBLY on the 290x which i assume is a driver bug.

Re Crysis 3- i get around 45-55 FPS with Very High, FXAA (1600P) i think this will get much better when i properly OC my CPU again to 4.5.
Also saw the same problem with Vsync ON- lower FPS and stuterring like crazy.

For now i'd disable Vsync and see how you go. Crysis still felt bad (not smooth) to me even with Vsync off but like i said i think this is my CPU needing more OC.

BF4 with Vsync off was butter smooth and at 61fps cap no exceptions
i have make sure that my battlefield 4 setup is with vsync off

i think so,u need to OC your CPU for optimal perfomance

i think it's okay if i can get 55-65 fps when playing crysis 3 with all set ultra but the truth is i can only get 45-55



i found a new case, if i disable Crossfire in other words just use 1 Card for play battlefield 4 i get better fps it's around 70-80 stable with less laggy than crossfire

here's the screenshot using single card R9 290X
   
Reply With Quote
 
Old
  (#5)
anxious_f0x
Master Guru
 
Videocard: EVGA 780Ti SC ACX in SLi
Processor: Intel Core i7 980X 4.4Ghz
Mainboard: EVGA X58 SLi
Memory: 12GB Corsair Vengence
Soundcard: Asus Xonar Essence ST
PSU: Silverstone 1000 watt
Default 11-08-2013, 16:08 | posts: 214 | Location: UK

I was also having lower than expected fps in BF4, disabling Frame Pacing in CCC solved this for me, might be worth giving it a go.
   
Reply With Quote
Old
  (#6)
yasamoka
Ancient Guru
 
Videocard: 7970CF @ Qnix 1440p 110Hz
Processor: i7 930
Mainboard: ASUS P6X58D Premium
Memory: 6GB Corsair Dominators
Soundcard: Audio-GD NFB-11.32 +DT880
PSU: CM Silent Pro Hybrid 1300
Default 11-08-2013, 16:41 | posts: 3,107 | Location: Lebanon

Disable ULPS.
   
Reply With Quote
Old
  (#7)
The Postman
Maha Guru
 
The Postman's Avatar
 
Videocard: 290x CF EK H2O
Processor: I7 4770k 4.6ghz
Mainboard: Z87X-UD5H
Memory: Corsair 16GB DDR3
Soundcard: Soundblaster Z
PSU: Antec HCP 1200w
Default 11-08-2013, 23:08 | posts: 1,683 | Location: Boston

Not sure..but does your board support pci gen3? I had some spikes like those before until switch to gen 3. It went back to normal.
Do you have CFX with reference coolers? When I tried, it was horrible.

Yeah disable ULPS like Yasamoka said.
   
Reply With Quote
Old
  (#8)
yasamoka
Ancient Guru
 
Videocard: 7970CF @ Qnix 1440p 110Hz
Processor: i7 930
Mainboard: ASUS P6X58D Premium
Memory: 6GB Corsair Dominators
Soundcard: Audio-GD NFB-11.32 +DT880
PSU: CM Silent Pro Hybrid 1300
Default 11-08-2013, 23:45 | posts: 3,107 | Location: Lebanon

Quote:
Originally Posted by The Postman View Post
Not sure..but does your board support pci gen3? I had some spikes like those before until switch to gen 3. It went back to normal.
Do you have CFX with reference coolers? When I tried, it was horrible.

Yeah disable ULPS like Yasamoka said.
Sounds like the 99% GPU usage bug on the 2nd GPU throwing CF results off and messing with the frametimes.
   
Reply With Quote
Old
  (#9)
The Postman
Maha Guru
 
The Postman's Avatar
 
Videocard: 290x CF EK H2O
Processor: I7 4770k 4.6ghz
Mainboard: Z87X-UD5H
Memory: Corsair 16GB DDR3
Soundcard: Soundblaster Z
PSU: Antec HCP 1200w
Default 11-08-2013, 23:56 | posts: 1,683 | Location: Boston

It could be that.

When I tried CFX, the temps were horrible with those coolers.
   
Reply With Quote
Old
  (#10)
DropHD
Newbie
 
Videocard: ASUS R9 290 XFX
Processor: Intel i7-4930k
Mainboard: EVGA X79 Dark
Memory: 16GB G.Skill Sniper 2400
Soundcard:
PSU: EVGA SuperNOVA P2 1000W
Default 11-09-2013, 02:51 | posts: 7 | Location: Elmira, NY

Hey guys I just made an account to add that I am having the same exact problems with the R9 290's in crossfire. I have tested both cards individually and both work 100% fine. Also Benchmarks look normal. But when I jump into a BF4 server my GPU usage bounces from 0% to 100% like when one card goes up the other goes down.

I have tried reformatting and fresh install of windows, I have disabled ULPS, I have tried different drivers, I also just now tried disabling Frame Pacing as suggested earlier in this thread to no avail, the problem persists.

My thread: http://www.overclock.net/t/1440600/r...ith-crossfire/

Last edited by DropHD; 11-09-2013 at 02:58.
   
Reply With Quote
 
Old
  (#11)
felix46
Newbie
 
Videocard: R9 290x crossfire
Processor: i7 3930K
Mainboard:
Memory:
Soundcard:
PSU: stridder gold 1200w
Default 11-09-2013, 03:03 | posts: 5

Quote:
Originally Posted by anxious_f0x View Post
I was also having lower than expected fps in BF4, disabling Frame Pacing in CCC solved this for me, might be worth giving it a go.
disable frame pacing maybe just cover the problem not solve the problem

Quote:
Originally Posted by yasamoka View Post
Disable ULPS.
what ULPS and where i can disable that ?

Quote:
Originally Posted by The Postman View Post
Not sure..but does your board support pci gen3? I had some spikes like those before until switch to gen 3. It went back to normal.
Do you have CFX with reference coolers? When I tried, it was horrible.

Yeah disable ULPS like Yasamoka said.
i used motherboard Asus Rampage IV extreme

yes i used refference cooler it's horrible but not bad at all in fact GPU Boost/Engine clock

still can running at 950-1030MHz even in hot temp still running optimal

what ULPS for ?

Quote:
Originally Posted by yasamoka View Post
Sounds like the 99% GPU usage bug on the 2nd GPU throwing CF results off and messing with the frametimes.
yeah i hope just driver bug so the problem will solve when AMD launch their Graphic

driver, what i am afraid is i have bad hardware(graphic card)

Quote:
Originally Posted by DropHD View Post
Hey guys I just made an account to add that I am having the same exact problems with the R9 290's in crossfire. I have tested both cards individually and both work 100% fine. Also Benchmarks look normal. But when I jump into a BF4 server my GPU usage bounces from 0% to 100% like when one card goes up the other goes down.

I have tried reformatting and fresh install of windows, I have disabled ULPS, I have tried different drivers, I also just now tried disabling Frame Pacing as suggested earlier in this thread to no avail, the problem persists.

My thread: http://www.overclock.net/t/1440600/r...ith-crossfire/
just like what happen to me

i have visit your threat u have a similar problem with me

when u have find solution for this problem just info me

Last edited by felix46; 11-09-2013 at 03:07.
   
Reply With Quote
Old
  (#12)
DropHD
Newbie
 
Videocard: ASUS R9 290 XFX
Processor: Intel i7-4930k
Mainboard: EVGA X79 Dark
Memory: 16GB G.Skill Sniper 2400
Soundcard:
PSU: EVGA SuperNOVA P2 1000W
Default 11-09-2013, 03:08 | posts: 7 | Location: Elmira, NY

its not your hardware, I've heard of some other people having this issue as well. ULPS is a setting that disables one of your cards when the other is working or something for some unknown reason. But I had the same problem you had and I tried disabling it and it didn't fix the problem.
   
Reply With Quote
Old
  (#13)
anxious_f0x
Master Guru
 
Videocard: EVGA 780Ti SC ACX in SLi
Processor: Intel Core i7 980X 4.4Ghz
Mainboard: EVGA X58 SLi
Memory: 12GB Corsair Vengence
Soundcard: Asus Xonar Essence ST
PSU: Silverstone 1000 watt
Default 11-09-2013, 03:30 | posts: 214 | Location: UK

Quote:
Originally Posted by felix46 View Post
disable frame pacing maybe just cover the problem not solve the problem
It covers it for now, but hopefully with some driver fixes Frame Pacing will work properly with BF4.

It pretty much cured all my fps problems, with Frame Pacing and V-Sync enabled I was getting heavy drops down to 35fps and massive stuttering which made the game unplayable. With Frame Pacing disabled I get between 70 and 120 fps and a much smoother experience.

Of course I do have completely different cards to you guys, so what works for me, may not solve your problem but it was worth a shot

Also when disabling ULPS make sure you're doing a restart for it to take effect.

Last edited by anxious_f0x; 11-09-2013 at 03:34.
   
Reply With Quote
Old
  (#14)
Agent-A01
Ancient Guru
 
Agent-A01's Avatar
 
Videocard: GTX Titan H20 1472/7600
Processor: i7 3770K@5Ghz HT H20
Mainboard: Asus P8Z77-WS
Memory: G.Skill 8GBx2 2400
Soundcard: Xonar Phoebus-PC360/HD598
PSU: SeaSonic Platinum-1000
Default 11-09-2013, 04:14 | posts: 6,206 | Location: USA

And this is another reason im avoiding amd drivers.. I knew frame pacing would be half assed. Hopefully you get a fix in newer drivers.
   
Reply With Quote
Old
  (#15)
anxious_f0x
Master Guru
 
Videocard: EVGA 780Ti SC ACX in SLi
Processor: Intel Core i7 980X 4.4Ghz
Mainboard: EVGA X58 SLi
Memory: 12GB Corsair Vengence
Soundcard: Asus Xonar Essence ST
PSU: Silverstone 1000 watt
Default 11-09-2013, 04:26 | posts: 214 | Location: UK

Quote:
Originally Posted by Agent-A01 View Post
And this is another reason im avoiding amd drivers.. I knew frame pacing would be half assed. Hopefully you get a fix in newer drivers.
To be fair to AMD, Frame Pacing has been pretty reliable with every other game, just doesn't play nice with BF4, hopefully a patch and some fresh drivers will cure it.
   
Reply With Quote
Old
  (#16)
Agent-A01
Ancient Guru
 
Agent-A01's Avatar
 
Videocard: GTX Titan H20 1472/7600
Processor: i7 3770K@5Ghz HT H20
Mainboard: Asus P8Z77-WS
Memory: G.Skill 8GBx2 2400
Soundcard: Xonar Phoebus-PC360/HD598
PSU: SeaSonic Platinum-1000
Default 11-09-2013, 07:11 | posts: 6,206 | Location: USA

Quote:
Originally Posted by anxious_f0x View Post
To be fair to AMD, Frame Pacing has been pretty reliable with every other game, just doesn't play nice with BF4, hopefully a patch and some fresh drivers will cure it.
Also the fact that they dont plan to add DX9/DX10 games to frame pacing.. Probably will be a long time for that to change
   
Reply With Quote
Old
  (#17)
felix46
Newbie
 
Videocard: R9 290x crossfire
Processor: i7 3930K
Mainboard:
Memory:
Soundcard:
PSU: stridder gold 1200w
Default 11-09-2013, 07:24 | posts: 5

i have new report for now

i just clean install using DDU in safe mode then install AMD Catalyst 13.11Beta.v9

and this new driver make my pc worse

http://www.3dmark.com/3dm11/7455954

http://www.3dmark.com/3dm11/7455992

i don't know what happen just 2 benchmark in a row.
   
Reply With Quote
Old
  (#18)
anxious_f0x
Master Guru
 
Videocard: EVGA 780Ti SC ACX in SLi
Processor: Intel Core i7 980X 4.4Ghz
Mainboard: EVGA X58 SLi
Memory: 12GB Corsair Vengence
Soundcard: Asus Xonar Essence ST
PSU: Silverstone 1000 watt
Default 11-09-2013, 14:50 | posts: 214 | Location: UK

Looks like it's only detecting 1 stick of RAM in your new benchmarks, in your previous runs all 4 sticks are shown.
   
Reply With Quote
Old
  (#19)
DropHD
Newbie
 
Videocard: ASUS R9 290 XFX
Processor: Intel i7-4930k
Mainboard: EVGA X79 Dark
Memory: 16GB G.Skill Sniper 2400
Soundcard:
PSU: EVGA SuperNOVA P2 1000W
Default 11-09-2013, 15:48 | posts: 7 | Location: Elmira, NY

Yup, I bet its something with the ram because your physics score was cut in half.
   
Reply With Quote
Old
  (#20)
DropHD
Newbie
 
Videocard: ASUS R9 290 XFX
Processor: Intel i7-4930k
Mainboard: EVGA X79 Dark
Memory: 16GB G.Skill Sniper 2400
Soundcard:
PSU: EVGA SuperNOVA P2 1000W
Default 11-10-2013, 18:02 | posts: 7 | Location: Elmira, NY

Crysis 3 8x MSAA
one R9 290: 36.7 fps
two R9 290 xfx: 72.4 fps
197.3%

Batman Arkham Origins 8x MSAA
one R9 290: 82.7 fps
two R9 290 xfx: 134.4 fps
162.5%

Borderlands 2 FXAA
one R9 290: 137.1 fps
two R9 290: 220 fps
160.5%

BF4 4xMSAA
one r9 290 (frame pacing off): 72.9 fps
two r9 290 (frame pacing off): 88.6 fps
two r9 290 (frame pacing on): 87.2 fps
121.5% (frame pacing off)

BF4 4x MSAA @ 4K (Felt VERY jittery with two cards, but smooth with one)
one r9 290: 28.7
two r9 290: 45.5
158.5%

Last edited by DropHD; 11-10-2013 at 19:25.
   
Reply With Quote
Old
  (#21)
The Postman
Maha Guru
 
The Postman's Avatar
 
Videocard: 290x CF EK H2O
Processor: I7 4770k 4.6ghz
Mainboard: Z87X-UD5H
Memory: Corsair 16GB DDR3
Soundcard: Soundblaster Z
PSU: Antec HCP 1200w
Default 11-10-2013, 21:46 | posts: 1,683 | Location: Boston

I dont disable frame pacing and it is smooth. Am I missing something? why turn it off?
   
Reply With Quote
Old
  (#22)
anxious_f0x
Master Guru
 
Videocard: EVGA 780Ti SC ACX in SLi
Processor: Intel Core i7 980X 4.4Ghz
Mainboard: EVGA X58 SLi
Memory: 12GB Corsair Vengence
Soundcard: Asus Xonar Essence ST
PSU: Silverstone 1000 watt
Default 11-10-2013, 23:40 | posts: 214 | Location: UK

Quote:
Originally Posted by The Postman View Post
I dont disable frame pacing and it is smooth. Am I missing something? why turn it off?
Are you using vsync? Frame Pacing plus vsync gives me massive fps drops, could always be that they use a different method of frame pacing on the R9 290X compared to the 7970's.
   
Reply With Quote
Old
  (#23)
negachampa
Member Guru
 
Videocard: EVGA 780 Ti SLI
Processor: Intel 3930K @4.6
Mainboard: Asus P9 x79 Pro
Memory: 32 GB
Soundcard: X-fi Forte 7.1
PSU: OCZ 1250W
Default 11-11-2013, 02:07 | posts: 54

I just upgraded to 3 x R9 290 in Trifire from GTX 680 SLI yesterday after being a long time Nvidia user ( 7 years ).

Took me a bit to test and get familiar with the AMD drives but I found that more often then not framepacing works much better when you enable V-Sync from the CCC instead of in game.

The performance jump from GTX 680 SLI to 290's in trifire are crazy. Battlefield 4 I am getting 60 - 70 fps all ultra w/4xAA and the resolution slider at 130% at 2560x1600 !!! It is a sight to behold !

I must admit I was worried about micro-stutter, affects some games more then others but battlefield 4 runs super smooth.

now if only these cards only could run a bit cooler they would be perfect, with 3 of them so tightly together I need a very aggressive fan profile to keep my overclock of 1050Mhz all the time with our throttling.
   
Reply With Quote
Old
  (#24)
The Postman
Maha Guru
 
The Postman's Avatar
 
Videocard: 290x CF EK H2O
Processor: I7 4770k 4.6ghz
Mainboard: Z87X-UD5H
Memory: Corsair 16GB DDR3
Soundcard: Soundblaster Z
PSU: Antec HCP 1200w
Default 11-11-2013, 02:41 | posts: 1,683 | Location: Boston

Quote:
Originally Posted by negachampa View Post
I just upgraded to 3 x R9 290 in Trifire from GTX 680 SLI yesterday after being a long time Nvidia user ( 7 years ).

Took me a bit to test and get familiar with the AMD drives but I found that more often then not framepacing works much better when you enable V-Sync from the CCC instead of in game.

The performance jump from GTX 680 SLI to 290's in trifire are crazy. Battlefield 4 I am getting 60 - 70 fps all ultra w/4xAA and the resolution slider at 130% at 2560x1600 !!! It is a sight to behold !

I must admit I was worried about micro-stutter, affects some games more then others but battlefield 4 runs super smooth.

now if only these cards only could run a bit cooler they would be perfect, with 3 of them so tightly together I need a very aggressive fan profile to keep my overclock of 1050Mhz all the time with our throttling.
If you are running reference coolers, your cards must running like at 400mhz. I had two running with those coolers and it was horrible.
   
Reply With Quote
Old
  (#25)
The Postman
Maha Guru
 
The Postman's Avatar
 
Videocard: 290x CF EK H2O
Processor: I7 4770k 4.6ghz
Mainboard: Z87X-UD5H
Memory: Corsair 16GB DDR3
Soundcard: Soundblaster Z
PSU: Antec HCP 1200w
Default 11-11-2013, 02:42 | posts: 1,683 | Location: Boston

Quote:
Originally Posted by anxious_f0x View Post
Are you using vsync? Frame Pacing plus vsync gives me massive fps drops, could always be that they use a different method of frame pacing on the R9 290X compared to the 7970's.
I have both setups. Same frame pacing but I dont enable vsync.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.