Guru3D.com Forums

Go Back   Guru3D.com Forums > Hardware > Soundcards, Speakers HiFI & File formats
Soundcards, Speakers HiFI & File formats A cracking SoundBlaster ? Got new Speakers ? Be heard in here !


Reply
 
Thread Tools Display Modes
Sound Blaster Z slow Control Panel
Old
  (#1)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default Sound Blaster Z slow Control Panel - 08-10-2013, 18:52 | posts: 604 | Location: Portugal

Just got this little piece of hardware to replace my old Audigy 1. It's not that I needed it, but was fed up with having small issues with swapping between speakers and headphones.
Basically, I have an old Creative Labs FPS 1600 (4 speakers and 1 subwoofer) that I use with Window$ 7 x64. As most of you know, Creative Labs hasn't made any good driver for this OS and the Audigy. I had to use some known driver pack to kinda fix it. It didn't fix all. Mic was all weird (used the onboard instead) and I had to mess with CMSS-3D and speaker configuration to make it sound as I wanted.

Times have changed and I got fed up, I decided to go for the SB Z. I put it on a PCI-e x8 (one of the GPU that my x58 has), since the 1x was being blocked by the GFX card, and it installed fine.

The problem: SBX control panel takes ages to show up or to change tabs. It's a pain as I have to swap from speakers to headphones and I want it to be quick. Does anyone know a fix for this issue? I only found this problem in Creative Labs forum but nobody gave a solution yet.

About the card... well, installation is a lot simpler, sound is crisper (or it looks like it is) but the surround isn't quite the same. Maybe I need to get used to it or something. Also, you may know it too, the mic is to quiet and the headphone is way too loud... Oh well.

Thanks if anyone can help me out on this CPL thingy.
   
Reply With Quote
 
Old
  (#2)
Corvus.Corax
Newbie
 
Videocard: Asus 7970 DirectCU 2
Processor: i5 2500K
Mainboard: Asus P8P67
Memory: ddr3 8 gb
Soundcard: Asus STX
PSU: Corsair 850w
Default 08-14-2013, 16:47 | posts: 14 | Location: Finland

I encountered the same problem, when I upgraded to a AMD videocard. Just as a shot in the dark I disabled the AMD High Definition Audio Device from the device manager and that solved the problem in my case. Might be worth a try.
   
Reply With Quote
Old
  (#3)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 08-14-2013, 23:09 | posts: 604 | Location: Portugal

Thanks Corvus.Corax. I had already tried that after searching for similar problem online. Unfortunently it doesn't change anything. Now, once in a while, it crashes too.
I only need to access the control panel to toggle surround OFF and ON again. Yeah... sigh... need to do that or I won't hear stereo in the 4 speakers (at least not after reboot).
Thanks anyway.
   
Reply With Quote
Old
  (#4)
Svarog
Ancient Guru
 
Svarog's Avatar
 
Videocard: Zotac GTX 680 4GB
Processor: Intel Core 4770K
Mainboard: Gigabyte Z87X-UD5H
Memory: 8GB G.Skill ARES 2133 MHz
Soundcard: SoundBlaster ZxR
PSU: Seasonic Platinum 760
Default 08-15-2013, 09:39 | posts: 3,682 | Location: Nederland

Sounds like there is more wrong than with just the CP.

It's the first thing that starts up for me.
   
Reply With Quote
 
Old
  (#5)
MaxBlade
Master Guru
 
MaxBlade's Avatar
 
Videocard: GT770/ATIHD7970/+ more
Processor: I7, I5 @4.8
Mainboard: Z78 Gigabyte/msi/Asus
Memory: 16g
Soundcard: To many :)
PSU: 1000
Default 08-15-2013, 17:26 | posts: 684

Mine does the same thing at times. If I reboot its fast but sometimes you click it and nothing then 1-5min later it pops up.
   
Reply With Quote
Old
  (#6)
ArgonV
Master Guru
 
Videocard: AMD XFX 7970 Ghz Edition
Processor: Intel i7 920 @ 3.5 Ghz
Mainboard: Gigabyte GA-EX58-UD3R
Memory: 12GB DDR3 1600
Soundcard: Sound Blaster ZxR, 5.1
PSU: Thermaltake 700W
Default 08-15-2013, 19:18 | posts: 311 | Location: Texas, USA

If you have an AMD video card with built-in audio, disable ULPS in the registry. Also, in the AMD CCC Panel, disable the audio cards there for Displayport and/or HDMI. This is really a problem with how AMD cards init audio devices. It's even more of an issue if you run CrossfireX, because the second card will go into ULPS and it takes a while to reinit the audio devices on that card when you go into an audio control panel (Either Window's or Creative's).
   
Reply With Quote
Old
  (#7)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 08-15-2013, 23:22 | posts: 604 | Location: Portugal

Quote:
Originally Posted by ArgonV View Post
If you have an AMD video card with built-in audio, disable ULPS in the registry. Also, in the AMD CCC Panel, disable the audio cards there for Displayport and/or HDMI. This is really a problem with how AMD cards init audio devices. It's even more of an issue if you run CrossfireX, because the second card will go into ULPS and it takes a while to reinit the audio devices on that card when you go into an audio control panel (Either Window's or Creative's).
I tried your suggestion about the ULPS, rebooted but same thing. I didn't find anything related to Displayport and/or HDMI in CCC. Maybe because I'm using a DVI to VGA adapter (monitor only has VGA, altough it's a LCD).

Without going into any love/hate discussion about it... I bet it's the usual Creative Labs driver behaviour...
I'll wait for a new driver version, if any, and see if it goes away.
   
Reply With Quote
Old
  (#8)
velocityx
Master Guru
 
velocityx's Avatar
 
Videocard: CF R9 290
Processor: i7 4790K
Mainboard: Maximus 7 Hero
Memory: Corsair Vengeance 16gb
Soundcard: Xonar Phoebus+AKG K550
PSU: XFX 850 Gold+
Default 08-17-2013, 07:26 | posts: 194 | Location: Szczecin

Quote:
Originally Posted by Corvus.Corax View Post
I encountered the same problem, when I upgraded to a AMD videocard. Just as a shot in the dark I disabled the AMD High Definition Audio Device from the device manager and that solved the problem in my case. Might be worth a try.
thx so much for a hint. CP was so slow, I'd click the icon in the bar, wait 5 secs, it shows up,

disabled two amd hdmi, (ulps was disabled already ) and it works from the bat no reboot needed. I click it and it pops up like it should in the beginning.
   
Reply With Quote
Old
  (#9)
Abilio_KID
Master Guru
 
Abilio_KID's Avatar
 
Videocard: Asus GTX 780 OC DCII 3GB
Processor: Intel Core i7 920 @ 4 Ghz
Mainboard: Asus P6T SE iX58
Memory: DDR3 / 3x2GB + 3x4GB
Soundcard: SoundBlaster Z
PSU: Corsair HX750 Modular
Default 08-17-2013, 19:09 | posts: 604 | Location: Portugal

Just to keep you up to date, and it may also help somebody else, I seem to have fixed the issue (for now).
I removed everything related to Creative Labs, including some old installation info from my Audigy, ran Driver Sweeper, CCleaner, even manually removed stuff from Windows Registry (with proper reboot in the middle). After all this, I installed the SoundBlaster Z without the EXTRAS and it's not slow anymore.
For the record, I can enable AMD HDMI audio (not that I need it anyway) and I don't get any problem.

As always with Creative Labs, I hope things don't get messed again... For now it's all working as should.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.