Guru3D.com Forums

Go Back   Guru3D.com Forums > General Chat > Frontpage news
Frontpage news Perhaps you have some news to report or want to check out the latest Guru3D headlines and comment ? Check it in here.


Reply
 
Thread Tools Display Modes
Server vulnerability 14 July 2013 - Database restored and passwords reset
Old
  (#1)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Exclamation Server vulnerability 14 July 2013 - Database restored and passwords reset - 07-14-2013, 12:40 | posts: 20,811 | Location: Guru3D testlab

Hey everybody.

As some of you know yesterday we had a vulnerability exploit as one of the moderator accounts got hacked. The hacker got access that way towards the ModCP panel and injected a malicious code. The exploit lasted merely an hour but throughout the night more and more became clear about the significance of all this.

Initially I wanted to leave the database as is, but moments ago I decided to re-install a backup of 4 weeks ago. That way I can be sure that nobody messed with the MySQL tables. It sucks as a couple of weeks content will be lost, but I want to be sure that in the future an exploit wasn't hidden in the Vbulletin templates and MySQL tables.

Better safe then sorry is my motto here. You again will be prompted to change your password. And if you registered within the last 4 weeks, you'll have to do so again.

Sorry about this all !


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
 
Old
  (#2)
dsbig
Maha Guru
 
Videocard: evga 780 classified
Processor: Intel i7 3770k @ 4.3ghz
Mainboard: GA-Z77X-UD3H
Memory: 16gb 1920mhz
Soundcard: Soundblaster ZxR
PSU: Kingwin 850 watts
Default 07-14-2013, 12:45 | posts: 2,587 | Location: in your closet

khaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaan!!!!!! !!!!!!!!!!!!!!!
   
Reply With Quote
Old
  (#3)
Tat3
Ancient Guru
 
Tat3's Avatar
 
Videocard: Gigabyte GTX480 w/ 244T
Processor: i7 920 @ 4,4GHz | Water
Mainboard: DFI UT X58 T3eH8
Memory: 3*2Gb 8-8-8-20 @ 1680MHz
Soundcard: UA-55 -> 2*Genelec 8030B
PSU: Defo not modular (TX950W)
Default 07-14-2013, 12:56 | posts: 11,282 | Location: Finland

Better safe than sorry.
   
Reply With Quote
Old
  (#4)
dsbig
Maha Guru
 
Videocard: evga 780 classified
Processor: Intel i7 3770k @ 4.3ghz
Mainboard: GA-Z77X-UD3H
Memory: 16gb 1920mhz
Soundcard: Soundblaster ZxR
PSU: Kingwin 850 watts
Default 07-14-2013, 12:59 | posts: 2,587 | Location: in your closet

I been changing my password to everything and then I cant remember what the passwords where. lucky I use roboform to remember them for me.
   
Reply With Quote
 
Old
  (#5)
cowie
Ancient Guru
 
cowie's Avatar
 
Videocard: GTX
Processor: 2600k
Mainboard: gigabyte p67 UD7
Memory: 2x4g 1600 ddr3
Soundcard:
PSU: pcp&c 1200 watt
Default 07-14-2013, 13:02 | posts: 11,901 | Location: new jersey

Glad you are on top of it boss
   
Reply With Quote
Old
  (#6)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 07-14-2013, 13:05 | posts: 3,290 | Location: UK

I had a problem a minute or two ago, and I though my password had been changed, but it looks like it was when you were changing the databases over. All ok now.
   
Reply With Quote
Old
  (#7)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 07-14-2013, 13:07 | posts: 20,811 | Location: Guru3D testlab

Quote:
Originally Posted by Ghosty View Post
I had a problem a minute or two ago, and I though my password had been changed, but it looks like it was when you were changing the databases over. All ok now.
I noticed your email
Please make sure you use new passwords guys, like I stated. Better save than sorry okay ?


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#8)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 07-14-2013, 13:11 | posts: 3,290 | Location: UK

Quote:
Originally Posted by Hilbert Hagedoorn View Post
I noticed your email
Please make sure you use new passwords guys, like I stated. Better save than sorry okay ?
Yep, changed my password and email address. Thanks.
   
Reply With Quote
Old
  (#9)
Wagnard
Maha Guru
 
Wagnard's Avatar
 
Videocard: EVGA Signature GTX 690
Processor: I7 3770K
Mainboard: Asus Maximus Gene V
Memory: 16GB corsair DDR 3
Soundcard: Realtek
PSU: Corsair 1k Watt
Default 07-14-2013, 13:28 | posts: 1,497 | Location: Laval (Qc) , Canada

Not sure if your restore went well, there seem to be a lot of missing OLD thread.
For example there was quite a huge and old one in NVIDIA Driver forums talking about HPET. It seems gone now.
Maybe I misunderstood something?
   
Reply With Quote
Old
  (#10)
k1net1cs
Ancient Guru
 
Videocard: Radeon HD 5650m (550/800)
Processor: Intel Core i5-520M 2.4GHz
Mainboard: Sony VAIO VPCEA16FG
Memory: 2x4GB CMSO4GX3M1A1333C9
Soundcard: ASUS Xonar U3
PSU: n/a
Default 07-14-2013, 13:30 | posts: 3,714

Quote:
Originally Posted by Wagnard View Post
Not sure if your restore went well, there seem to be a lot of missing OLD thread.
For example there was quite a huge and old one in NVIDIA Driver forums talking about HPET. It seems gone now.
Maybe I misunderstood something?
Quote:
Originally Posted by Hilbert Hagedoorn View Post
Initially I wanted to leave the database as is, but moments ago I decided to re-install a backup of 4 weeks ago. That way I can be sure that nobody messed with the MySQL tables. It sucks as a couple of weeks content will be lost, but I want to be sure that in the future an exploit wasn't hidden in the Vbulletin templates and MySQL tables.
That.
Emphasis is mine.

Those old threads were probably only recently being active again in less than a month ago.
Reverting to a backup that's older than the post that 'revived' the old thread will always make the thread buried again, but not completely lost.




Interested in folding with fellow gurus? Click here to get you started!

Last edited by k1net1cs; 07-14-2013 at 13:46.
   
Reply With Quote
 
Old
  (#11)
dsbig
Maha Guru
 
Videocard: evga 780 classified
Processor: Intel i7 3770k @ 4.3ghz
Mainboard: GA-Z77X-UD3H
Memory: 16gb 1920mhz
Soundcard: Soundblaster ZxR
PSU: Kingwin 850 watts
Default 07-14-2013, 13:36 | posts: 2,587 | Location: in your closet

yeah... but that thread was over 4 weeks old.


stuff was lost...........
   
Reply With Quote
Old
  (#12)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 07-14-2013, 13:38 | posts: 20,811 | Location: Guru3D testlab

Use search a little please:

http://forums.guru3d.com/showthread.php?t=368604


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#13)
dsbig
Maha Guru
 
Videocard: evga 780 classified
Processor: Intel i7 3770k @ 4.3ghz
Mainboard: GA-Z77X-UD3H
Memory: 16gb 1920mhz
Soundcard: Soundblaster ZxR
PSU: Kingwin 850 watts
Default 07-14-2013, 13:40 | posts: 2,587 | Location: in your closet

Quote:
Originally Posted by Hilbert Hagedoorn View Post
well then....


I sorry
   
Reply With Quote
Old
  (#14)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 07-14-2013, 13:42 | posts: 20,811 | Location: Guru3D testlab

Just post some replies and the thread will be bumped up again.


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#15)
k1net1cs
Ancient Guru
 
Videocard: Radeon HD 5650m (550/800)
Processor: Intel Core i5-520M 2.4GHz
Mainboard: Sony VAIO VPCEA16FG
Memory: 2x4GB CMSO4GX3M1A1333C9
Soundcard: ASUS Xonar U3
PSU: n/a
Default 07-14-2013, 13:43 | posts: 3,714

Quote:
Originally Posted by dsbig View Post
yeah... but that thread was over 4 weeks old.


stuff was lost...........
Well, damned if Hilbert did, damned if Hilbert didn't.
If he decided to keep the database untouched and then something like this happened again because of it, you'd probably be the first (again) to complain about having to change your password.




Interested in folding with fellow gurus? Click here to get you started!
   
Reply With Quote
Old
  (#16)
dsbig
Maha Guru
 
Videocard: evga 780 classified
Processor: Intel i7 3770k @ 4.3ghz
Mainboard: GA-Z77X-UD3H
Memory: 16gb 1920mhz
Soundcard: Soundblaster ZxR
PSU: Kingwin 850 watts
Default 07-14-2013, 13:45 | posts: 2,587 | Location: in your closet

argg
   
Reply With Quote
Old
  (#17)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 07-14-2013, 13:48 | posts: 20,811 | Location: Guru3D testlab

Please make a new one, we'll have to start over with some threads I'm afraid. I know this all sucks my friends, but once the threads are created again this will start rolling fast enough.


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#18)
Wagnard
Maha Guru
 
Wagnard's Avatar
 
Videocard: EVGA Signature GTX 690
Processor: I7 3770K
Mainboard: Asus Maximus Gene V
Memory: 16GB corsair DDR 3
Soundcard: Realtek
PSU: Corsair 1k Watt
Default 07-14-2013, 13:50 | posts: 1,497 | Location: Laval (Qc) , Canada

Ok things are fixed correctly now. It seem I was only able to see Max 9 threads. Now things seems ok here.
Thanks Hilbert
   
Reply With Quote
Old
  (#19)
StewieTech
Chuck Norris
 
StewieTech's Avatar
 
Videocard: MSI 270x [1200/6000]
Processor: i5 4670k [4.4]
Mainboard: AsRock z87 Extreme3
Memory: Kingston 8GB [1600]
Soundcard: Asus Xonar DG
PSU: OCZ ZT 550W
Default 07-14-2013, 14:01 | posts: 1,299 | Location: Portugal

I understand, better to be safe. I just hope the little **** who did this get some kind of punishment through whatever means avaible!

edit: it seams the forum has lost pretty much all its content, sections with only one page of threads, is this normal, is it this bad?

Last edited by StewieTech; 07-14-2013 at 14:04.
   
Reply With Quote
Old
  (#20)
Anarion
Ancient Guru
 
Anarion's Avatar
 
Videocard: ASUS GeForce GTX 780 DC2
Processor: Intel Core i7 3770K
Mainboard: ASUS P8Z77-V
Memory: G.SKILL RipjawsX 16 GB
Soundcard: Sound Blaster Zx + HD 595
PSU: SF Golden Green Pro 600W
Default 07-14-2013, 14:16 | posts: 10,817 | Location: Finland

Shame, I was wondering why content was suddenly Lost.
   
Reply With Quote
Old
  (#21)
eclap
Ancient Guru
 
eclap's Avatar
 
Videocard: HD7950 CFX + Qnix QX2710
Processor: i5 2500k @4.5 1.2v
Mainboard: Asus P8Z77-V Pro
Memory: 8GB G-Skill RipjawsX 1600
Soundcard: SB Z/Aune T1/AD700/DT880
PSU: XFX Black 750W 80+ Gold
Default 07-14-2013, 14:18 | posts: 26,090 | Location: Hampshire UK

Quote:
Originally Posted by StewieTech View Post
I understand, better to be safe. I just hope the little **** who did this get some kind of punishment through whatever means avaible!

edit: it seams the forum has lost pretty much all its content, sections with only one page of threads, is this normal, is it this bad?
Seeing as the forum only shows threads from the last 1 month by default and the forum was taken 4 weeks back, that's understandable
   
Reply With Quote
Old
  (#22)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 07-14-2013, 14:23 | posts: 20,811 | Location: Guru3D testlab

Quote:
Originally Posted by StewieTech View Post
I understand, better to be safe. I just hope the little **** who did this get some kind of punishment through whatever means avaible!

edit: it seams the forum has lost pretty much all its content, sections with only one page of threads, is this normal, is it this bad?
The view limit is set at 1 month, I expanded most section to two months now.


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#23)
Loobyluggs
Maha Guru
 
Loobyluggs's Avatar
 
Videocard: EVGA 670 FTW
Processor: Intel 3770k
Mainboard: Asus P8z77-v pro
Memory: DDR3 16GB Corsair
Soundcard: Creative Labs Recon 3D
PSU: Corsair
Default 07-14-2013, 14:29 | posts: 1,185 | Location: UK

goddammit.

I wrote a 3,000 word review of Man of Steel that's lost forever...

/goes to pick a fight with someone.
   
Reply With Quote
Old
  (#24)
iancook221188
Maha Guru
 
Videocard: GTX 670 SLI / GTX 460 SLI
Processor: 2600k4.5 / i7 970 4.4 WC
Mainboard: X68 UD4 / X58A UD5
Memory: 16GB / 24GB
Soundcard:
PSU: TX850 / AX850
Default 07-14-2013, 14:32 | posts: 1,451 | Location: uk

OOO f**k... but sh*T happens deal with with it and move on
   
Reply With Quote
Old
  (#25)
The Laughing Ma
Maha Guru
 
The Laughing Ma's Avatar
 
Videocard: Gigabyte 670GTX
Processor: I5 750 @ 3.2Ghz
Mainboard: Asus Maximus Formula III
Memory: 8Gb Corsair Dominator
Soundcard: Creative Xi-fi
PSU: Corsair 650W
Default 07-14-2013, 14:42 | posts: 2,190

Quote:
I wrote a 3,000 word review of Man of Steel that's lost forever...
3,000 words to say 'sh*t happens' that be an awful lot of words.

Ok time to own up, was anyone silly enough to actually put their credentials in to that pop up?
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.