Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA Drivers Section
Videocards - NVIDIA Drivers Section In this section you can discuss everything ForceWare driver related. ForceWare (Detonator) drivers are for NVIDIA TNT, Quadro and all GeForce based videocards.


Reply
 
Thread Tools Display Modes
Anyone else get microstuttering with Vsync if you don't Cap it to 60FPS externally?
Old
  (#1)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default Anyone else get microstuttering with Vsync if you don't Cap it to 60FPS externally? - 05-01-2013, 05:15 | posts: 1,408 | Location: Oregon

I've started to notice strange things whenever I use Vsync now days.


Msi Afterburner will report that when Vsync is on the FPS is constantly fluctuating from 59 to 60FPS and the frametime will rapidly change.

And what seems to happen is if you try to move the game camera in a circle it will hitch up at random points and microstutter even though I can maintain 60FPS easily.


Now, if I turn off Vsync and cap it to 60 using Afterburner, frame time is constantly 16.66ms and it is always 60 with no hitching at all.


Same thing if I cap it to 60 (Or 30 if using 1/2 refresh rate vsync) with Vsync enabled. Microstuttering gone! Poof. Constant 60FPS, always 16.66ms frametime.



GPU and drivers: GTX 460 V1 (256-bit 1GB original) and 314.14(has happened prior to this driver. And 320.00 was unstable for my system. Caused my PC to crash with L4D2 and act erratic. The next WHQL driver will probably be fine)
   
Reply With Quote
 
Old
  (#2)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 05-01-2013, 05:20 | posts: 9,769 | Location: UK

No problems like that here.

See what happens with a fresh install of windows on a spare drive.
   
Reply With Quote
Old
  (#3)
tsunami231
Ancient Guru
 
tsunami231's Avatar
 
Videocard: EVGA 660gtx sig2
Processor: i7 920 CNPS10X Quiet
Mainboard: Evga x58 SLI LE
Memory: 3x2gb Dominator@1600 6Gb
Soundcard: Realtek HD Audio
PSU: Antec Truepower 750
Default 05-01-2013, 06:03 | posts: 3,532 | Location: USA

Quote:
Originally Posted by MrBonk View Post
I've started to notice strange things whenever I use Vsync now days.


Msi Afterburner will report that when Vsync is on the FPS is constantly fluctuating from 59 to 60FPS and the frametime will rapidly change.

And what seems to happen is if you try to move the game camera in a circle it will hitch up at random points and microstutter even though I can maintain 60FPS easily.


Now, if I turn off Vsync and cap it to 60 using Afterburner, frame time is constantly 16.66ms and it is always 60 with no hitching at all.


Same thing if I cap it to 60 (Or 30 if using 1/2 refresh rate vsync) with Vsync enabled. Microstuttering gone! Poof. Constant 60FPS, always 16.66ms frametime.



GPU and drivers: GTX 460 V1 (256-bit 1GB original) and 314.14(has happened prior to this driver. And 320.00 was unstable for my system. Caused my PC to crash with L4D2 and act erratic. The next WHQL driver will probably be fine)

Games I play that actual keep 60fps seem to sow 16.66ms with vsync on games that cant keep 60 fps is another story
   
Reply With Quote
Old
  (#4)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 05-01-2013, 06:20 | posts: 1,408 | Location: Oregon

Quote:
Originally Posted by Mufflore View Post
No problems like that here.

See what happens with a fresh install of windows on a spare drive.
Ugh I don't have a separate drive, would probably need to make another partition.


This doesn't happen with all games. Just some. (The Microstuttering at least.)

Most games don't seem to keep a completely constant frametime (though the fluctuations are usually very small. A few ms)if the framerate isn't capped manually with vsync on.
   
Reply With Quote
 
Old
  (#5)
yosef019
Maha Guru
 
yosef019's Avatar
 
Videocard: GTX770 4gb @1250mhz
Processor: i5 3570k 4.6 1.2v NH-D14
Mainboard: P8Z68-V
Memory: 8GB 2133 ARES CL9 2T
Soundcard: SB Recon3D Pro Fatality
PSU: Crosair 860i
Default 05-01-2013, 07:02 | posts: 1,749 | Location: Israel - Haifa

Quote:
Originally Posted by MrBonk View Post
Ugh I don't have a separate drive, would probably need to make another partition.


This doesn't happen with all games. Just some. (The Microstuttering at least.)

Most games don't seem to keep a completely constant frametime (though the fluctuations are usually very small. A few ms)if the framerate isn't capped manually with vsync on.
happens in dead island riptide only if i enable vsync or cap to 60
   
Reply With Quote
Old
  (#6)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 05-01-2013, 09:49 | posts: 1,408 | Location: Oregon

So you get microstuttering regardless of whether you cap or use Vsync?

What about using them together? Try that
   
Reply With Quote
Old
  (#7)
angmar
Maha Guru
 
angmar's Avatar
 
Videocard: Sapphire R9 290X Tri-X
Processor: i7 3770k@ 4.7ghz h20
Mainboard: ASRock Z77 Extreme4
Memory: Mushkin DDR3 1600 16GB
Soundcard: Onboard
PSU: OCZ 600 Watt 80 Plus
Default 05-01-2013, 10:22 | posts: 1,136 | Location: Monmouth County, NJ

nada no problems here...could be some sort of problem on your end possibly.
   
Reply With Quote
Old
  (#8)
Loophole35
Ancient Guru
 
Loophole35's Avatar
 
Videocard: 670 FTW Sli H2O/780 TFIV
Processor: 2600k@4.8 H2O/2500k@4.5
Mainboard: P8Z68-V PRO/P8Z77-V
Memory: corsair ddr3 8GB@1866
Soundcard: ASUS Phoebus/onboard
PSU: Corsair HX850w/TX850w
Default 05-01-2013, 13:01 | posts: 5,430 | Location: FLA,USA

Is it microstutter or are you running out of VRAM?
   
Reply With Quote
Old
  (#9)
K.S.
Master Guru
 
K.S.'s Avatar
 
Videocard: EVGA GTX Titan SC. SLI
Processor: Core i7 4930K @ 4.2GHz
Mainboard: ASUS P9X79-E WS
Memory: Ripjaws X DDR3-2133 16GB
Soundcard: Realtek ALC1150, NV HDMI
PSU: CM Silent Pro Gold 1200W
Default 05-01-2013, 13:26 | posts: 760 | Location: Honolulu, Hawaii

Odd, nothing like that here. I did used to get some micro stuttering on my old setup. Had two 470s with that one but can't say I'm having anything like what you're describing. It's a bummer 320.00 gave you problems, so far it's been the best one for me, then again I have keplers so I'm not sure I could give the best comparison.

Was it something that only started happening in recent driver releases?

Quote:
Originally Posted by Mufflore View Post
No problems like that here.

See what happens with a fresh install of windows on a spare drive.
I know it can be a little time-consuming, but tbh I'd try what this user suggested ^ if all else fails. Never hurts to keep on the look out for firmware updates for your components either...

Last edited by K.S.; 05-01-2013 at 13:30.
   
Reply With Quote
Old
  (#10)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 05-01-2013, 13:46 | posts: 452

The 680 is the first card where I got it outside of games that feature microstutter as part of the experience (Skyrim/Fallout etc.). Never experienced any sort of microstuttering with a range of cards from TNT2/6800GT/4850/570. Now I have to cap 60 with Precision on nearly every game.

Last edited by NeoandGeo; 05-01-2013 at 13:59.
   
Reply With Quote
 
Old
  (#11)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 05-01-2013, 13:57 | posts: 1,408 | Location: Oregon

Quote:
Originally Posted by Loophole35 View Post
Is it microstutter or are you running out of VRAM?
No. Have plenty of VRAM. Don't ever really approach the 1GB mark.



It doesn't happen in all games and it doesn't always happen in the same situations.


Like in L4D2, Capped to 60 externally or Vsync causes microstuttering on the intro camera pan to any campaign but not during gameplay. (Been having this issue for a while.)


In Serious Sam TSE HD with Vsync on and no cap for a while earlier I was getting microstuttering when rotating the camera.

But doesn't seem to happen now when I tried again a little bit ago.


Maybe it's just me.


Afterburner does report while in-game though that if uncapped the framerate rapidly changes between 59.x and 60. And the Frametime varies a few ms above 16.66ms.

If I minimize out and look at Afterburner's graphs, it will show the Framerate as a steady 60 (rather than what shows in-game via overlay)

But the frametime graph shows pretty much what I saw in-game.

just a drawing for example.
https://i.minus.com/ip4n7jQuAcvVP.png
(The no cap picture is just an approximation. It can vary depending. And is usually just within 2-5ms of 16.66.)


I think maybe I haven't tested enough games.

Or i'm just seeing things.
   
Reply With Quote
Old
  (#12)
bishi
Master Guru
 
Videocard: GTX780 3GB SLI
Processor: 5960X @ 4.4ghz
Mainboard:
Memory:
Soundcard: G930
PSU: 850W XFX
Default 05-01-2013, 13:57 | posts: 325 | Location: London

I have best results in terms of minimum stutter and best response times when I cap the FPS at refresh rate - 2, so 118fps or 142fps
   
Reply With Quote
Old
  (#13)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 05-01-2013, 13:58 | posts: 1,408 | Location: Oregon

I tried capping at 59/58 in the past. But it caused an uneven cadence and created hitching/stuttering of it's own. (With Vsync On in most cases)
   
Reply With Quote
Old
  (#14)
yosef019
Maha Guru
 
yosef019's Avatar
 
Videocard: GTX770 4gb @1250mhz
Processor: i5 3570k 4.6 1.2v NH-D14
Mainboard: P8Z68-V
Memory: 8GB 2133 ARES CL9 2T
Soundcard: SB Recon3D Pro Fatality
PSU: Crosair 860i
Default 05-01-2013, 17:39 | posts: 1,749 | Location: Israel - Haifa

Quote:
Originally Posted by bishi View Post
I have best results in terms of minimum stutter and best response times when I cap the FPS at refresh rate - 2, so 118fps or 142fps
you good to go when you have 120hz screen .. i have 60hz
   
Reply With Quote
Old
  (#15)
-Tj-
Ancient Guru
 
-Tj-'s Avatar
 
Videocard: ZOTAC GTX780 OC AmpFan
Processor: i7 4770K OC 4.7GHz @1.28v
Mainboard: ASUS Z87 Deluxe
Memory: Crucial BLE 16GB 2400MHz
Soundcard: Creative X-Fi Titanium HD
PSU: Chieftec NTRO88+ 650W
Default 05-01-2013, 18:18 | posts: 8,094 | Location: Urban`Jungle

Yeah i experienced that in source games, for example L4D2 or TF2.

As soon as i enable 60fps cap with MSI afterburner + ingame vsync, camera and mouse movements became ultra smooth.
   
Reply With Quote
Old
  (#16)
Jakshi
Master Guru
 
Videocard: PoV GTX680@1300/3700
Processor: Intel i5-3570k@4.5 Ghz
Mainboard: Asrock Z77 Extreme4
Memory: Corsair Vengeance 1600Mhz
Soundcard: Onboard 7.1 Sound
PSU: Corsair 750 Watt
Default 05-01-2013, 18:38 | posts: 184

Seems to be engine related. Same happened when I still had my AMD cards. L4D2 is a very good example but also Sleeping Dogs or Metro 2033.

Odd thing to notice though: all these games with engine stutter work perfectly fine with SLI and Crossfire configurations, as these seem to have driverbased framecorrections with added inputlagg as downside.
   
Reply With Quote
Old
  (#17)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 05-01-2013, 18:47 | posts: 753

certain games do it. another trick to reduce stutter is lowering prerendered frames to 1 in nvidia control panel
   
Reply With Quote
Old
  (#18)
kens30
Maha Guru
 
kens30's Avatar
 
Videocard: Asus DC2-OC 2gb GTX770
Processor: 2700K 4.7 HT / H100
Mainboard: Asus P8Z77-V Deluxe
Memory: Corsair 1866 16gb
Soundcard: Optical out+Sony amp 5.1
PSU: Corsair AX860 Platinum
Default 05-01-2013, 19:30 | posts: 907 | Location: Greece/Australia

Never had such a problem unless it's game related and i always use vsync to avoid screen tearing without any micro stutter in games that can maintain 60fps constantly, and in Msi Afterburner when running with frame rate onscreen display FPS is constantly fluctuating from 59 to 60FPS but as i said with no stutter,and games that i can't max out with constant 60fps i use in game vsync along with Afterburner's frame limiter which i set at 45fps and still get a smooth game experience except if it's a game or engine related stutter that can,t be fixed.
   
Reply With Quote
Old
  (#19)
MrBonk
Maha Guru
 
MrBonk's Avatar
 
Videocard: EVGA GTX 570 1.2GB
Processor: Intel Core i7 950 @4Ghz
Mainboard: ASUS Rampage II GENE
Memory: G-SKILL 12GB @1600Mhz
Soundcard: Creative Sound Blaster Z
PSU: Corsair 750TX V1
Default 05-02-2013, 07:07 | posts: 1,408 | Location: Oregon

It's gotta be game related.

Just for more conclusive evidence for frametime.

I ran the same recorded Demo in SS TSE HD and screencapped afterburner's frame time monitor.

Spike at the end is when the Demo ended and it went back to the menu (Which runs at 34FPS for whatever reason)

https://i.minus.com/iTsxKdKxburAb.png
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.