Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Sapphire 7870 Ghz OC Bios fix for black screen
Old
  (#1)
Rillipiru
Master Guru
 
Videocard: Sapphire 7870 Ghz OC
Processor: Xeon 1230v2
Mainboard: AssRock B75 2.0 GL
Memory: 8GB DDR3
Soundcard: MMX2
PSU: Strider Essential 500W
Default Sapphire 7870 Ghz OC Bios fix for black screen - 04-11-2013, 12:54 | posts: 308 | Location: Finland




http://www.sapphiretech.com/presenta...pid=1487&leg=0

Orginal BIOS is this, with black screen issue and some (not my card, just some random GPU-Z shot)



Sapphire tech support "new" bios (my card):



After a week or so, i finally can say that this BIOS from sapphire tech support is at least working for me. Not a single black screen or bsod (13.3 Beta) since bios flash. My 7870 is new patch, so this is NOT a hardware problem, but still occasional black screens and sound loops?? Since this "new" bios, not a single problem, not one. Played BF3 like 40h, no problems what so ever! This bios default voltage is 1.231.

Use winflash and dont forget to put this .rom in to the winflash folder.

http://********net/40676082

Winflash:

http://www.techpowerup.com/downloads...h%202.3.0.html

Last edited by Rillipiru; 04-11-2013 at 13:07.
   
Reply With Quote
 
Old
  (#2)
Fox2232
Maha Guru
 
Videocard: Accelero7970 1125/1500MHz
Processor: i5-2500k@4.5GHz NH-D14
Mainboard: MSI Z68A-GD80[g3]
Memory: 4x4GB 1600MHz 9,9,9,24
Soundcard: Essence ST / AKG K-701
PSU: FSP Gold series 750W
Default 04-11-2013, 16:23 | posts: 1,382 | Location: EU, CZ, Brno

You should provide revision/ batch number of your PCB, so people know that you have same board as they do before they try to flash.

Tho, no big risk on dual bios cards, just everyone should do backup.
   
Reply With Quote
Old
  (#3)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 04-11-2013, 16:39 | posts: 6,467 | Location: 127.0.0.1

Quote:
Originally Posted by Fox2232 View Post
You should provide revision/ batch number of your PCB, so people know that you have same board as they do before they try to flash.

Tho, no big risk on dual bios cards, just everyone should do backup.
The 7870 doesn't have a dual bios afaik, mine doesn't


----
@OP My 7870 has the BIOS you show in your first screenshot, and I do not suffer from any problems at all


Last edited by Extraordinary; 04-11-2013 at 16:42.
   
Reply With Quote
Old
  (#4)
Faruk
Member Guru
 
Videocard: Sapphire 290 Vapor-X
Processor: 4790K @ 4.7GHz
Mainboard: Sabertooth Z97 Mark 1
Memory: Gskill RipjawsX 1866 8 GB
Soundcard: Realtek ALC1150
PSU: Xigmatek 700W
Default 04-11-2013, 18:17 | posts: 81 | Location: Turkey

@Extraordinary same here;

   
Reply With Quote
 
Old
  (#5)
Jeggu
Newbie
 
Videocard: Gigabyte GTX 680 SOC
Processor: i5-3570K
Mainboard: ASUS P8Z77-LX
Memory: 8gb DDR3
Soundcard:
PSU: xfx 650W
Default 04-11-2013, 20:19 | posts: 13 | Location: Finland

Can this BIOS be flashed to the non-OC version of the card?

   
Reply With Quote
Old
  (#6)
Rillipiru
Master Guru
 
Videocard: Sapphire 7870 Ghz OC
Processor: Xeon 1230v2
Mainboard: AssRock B75 2.0 GL
Memory: 8GB DDR3
Soundcard: MMX2
PSU: Strider Essential 500W
Default 04-12-2013, 07:35 | posts: 308 | Location: Finland

I belive so, but take a backup copy of your orginal bios if something goes wrong. You have a HD 4000 igpu, so you can flash the orginal bios back in case it wont work for your card.
   
Reply With Quote
Old
  (#7)
Jeggu
Newbie
 
Videocard: Gigabyte GTX 680 SOC
Processor: i5-3570K
Mainboard: ASUS P8Z77-LX
Memory: 8gb DDR3
Soundcard:
PSU: xfx 650W
Default 04-12-2013, 19:46 | posts: 13 | Location: Finland

The flash went well and gave some unexpected but very nice results. The bios raised my powerlimit in CCC overdrive from 20% to 50%. I'll have to test and see if it raised my OC capabilities as well.

AFAIK the hardware in 7870 non-OC and OC is identical albeit the OC models have been a bit more tested to ensure a stable factory OC. It's also nice that the bios raised the voltage a bit so I won't have to use AB to OC my 7870. (Ja pirulle kiitokset ohjeistuksesta)

Last edited by Jeggu; 04-12-2013 at 19:53.
   
Reply With Quote
Old
  (#8)
Faruk
Member Guru
 
Videocard: Sapphire 290 Vapor-X
Processor: 4790K @ 4.7GHz
Mainboard: Sabertooth Z97 Mark 1
Memory: Gskill RipjawsX 1866 8 GB
Soundcard: Realtek ALC1150
PSU: Xigmatek 700W
Default 04-12-2013, 21:00 | posts: 81 | Location: Turkey

Is there any benefit to flashing this new bios besides black screen issue?
   
Reply With Quote
Old
  (#9)
iain martin
Member Guru
 
iain martin's Avatar
 
Videocard: 580 @ 990/1980/4300 1.2v
Processor: 2600K @ 5GHz (1.50v)
Mainboard: P8P67 Deluxe
Memory: 8GB RipJawsX 2133MHz
Soundcard: X-Fi Fatal1ty
PSU: Corsair AX 850W
Default 04-12-2013, 21:19 | posts: 45 | Location: Southend-on-Sea

Hi guys, sorry for being off topic, but have any of you noticed the fan speed of the sapphire cards don't go above 1150rpm, even with manual settings at 100%?? mine doesn't & my card often reaches 80 degrees while gaming & reboots my PC! so annoying!
   
Reply With Quote
Old
  (#10)
chaotic1
Ancient Guru
 
Videocard: PowercolorHD6970 2GB dead
Processor: PHENOM II 1100T X6 @4Ghz
Mainboard: CrosshairIV Formula 890FX
Memory: RipJawX PC3-12800C9 2x4gb
Soundcard: OnBoard
PSU: CM Silent Pro M1000W
Default 04-12-2013, 21:48 | posts: 2,853

80c is not that hot for a gfx card
   
Reply With Quote
 
Old
  (#11)
ToBbErT
Member Guru
 
Videocard: 2x sapphire 7870
Processor: i5 3570k
Mainboard: p8z77-v le plus
Memory: 16gb 2400mhz Kingston
Soundcard: xonar dgx
PSU: xfx 850w be silver
Default 04-13-2013, 06:45 | posts: 148

80c is actually pretty high. Ive owned the same card and also noticed the low rpm on high temps. I didnt expierence low rpm on 100% fan speed though, atleast afaik. Mine would reach 75c at full load. I recently replaced that card with the newer sapphire 7870 GHZ edition. The smaller version with the green stripe and noticed sapphire has made the fan control way more agressive. This is a smaller card and smaller heatsink and temps never go beyond 60c. It might be worth updating the bios and see if it improves the fan control.
   
Reply With Quote
Old
  (#12)
brutlern
Master Guru
 
Videocard: Asus GTX760 DirectCUII
Processor: Intel i5-2500K @ 4 Ghz
Mainboard: Asrock Z68 Ex3 Gen3
Memory: 2 x 4 GB DDR3 1600Mhz
Soundcard: onboard Realtek HD audio
PSU: Corsair VX550
Default 04-13-2013, 13:59 | posts: 167 | Location: Romania

Here is mine. As you can see it's a much older revision, it might actually be one of the bugged versions, I've had issues with it using the pre 12.11 drivers but since then, it's been smooth sailing mostly. I've only had 3 crashes since then, oddly enough on 3 separate games, World of Tanks, Dead Space 3 and the most recent Bioshock Infinite.

   
Reply With Quote
Old
  (#13)
GPhalanx
Newbie
 
GPhalanx's Avatar
 
Videocard: SapphireHD7870 GHz 2GB OC
Processor: Intel Core i7 3770k 3.5G
Mainboard: Asrock Z77 Extreme 4
Memory: GSkill 8G 2x4GB Dual 1600
Soundcard: Altec Lancing 2.1 40XX
PSU: Seasonic x-650 series
Default 04-16-2013, 13:59 | posts: 10 | Location: Philippines



So far after 3x Replacements of card, 2weeks now no BSOD... Hoping
   
Reply With Quote
Old
  (#14)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 04-16-2013, 14:08 | posts: 6,467 | Location: 127.0.0.1

Quote:
Originally Posted by iain martin View Post
Hi guys, sorry for being off topic, but have any of you noticed the fan speed of the sapphire cards don't go above 1150rpm, even with manual settings at 100%?? mine doesn't & my card often reaches 80 degrees while gaming & reboots my PC! so annoying!
Mine does, but never needs to go that high even under full load, and Im yet to see the temp go above 70c even stress testing

   
Reply With Quote
Old
  (#15)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 04-16-2013, 14:11 | posts: 6,467 | Location: 127.0.0.1

Quote:
Originally Posted by GPhalanx View Post


So far after 3x Replacements of card, 2weeks now no BSOD... Hoping

CCC 13.3 b3 is available you know, much better drivers than 13.1 you have installed
   
Reply With Quote
Old
  (#16)
w0mbat
Newbie
 
Videocard: Sapphire HD7870
Processor: AMD Phenom II X6 1055T
Mainboard: ASRock 970 Extreme4
Memory: 8GB DDR3-1333
Soundcard: OnBoard
PSU: BeQuiet! E9-CM 480W
Default 04-18-2013, 11:11 | posts: 15 | Location: Germany

Could anyone upload it into the TPU database via GU-Z?
   
Reply With Quote
Old
  (#17)
w0mbat
Newbie
 
Videocard: Sapphire HD7870
Processor: AMD Phenom II X6 1055T
Mainboard: ASRock 970 Extreme4
Memory: 8GB DDR3-1333
Soundcard: OnBoard
PSU: BeQuiet! E9-CM 480W
Default 04-28-2013, 12:32 | posts: 15 | Location: Germany

Anyone? Or more infos on how this BIOS works?
   
Reply With Quote
Old
  (#18)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 04-28-2013, 12:55 | posts: 6,467 | Location: 127.0.0.1

Quote:
Originally Posted by w0mbat View Post
Anyone? Or more infos on how this BIOS works?
Its in the OP
   
Reply With Quote
Old
  (#19)
Mamel
Newbie
 
Videocard: SapphireRadeon HD7870 2GB
Processor: Intel CORE I5 2500K 3.3G
Mainboard:
Memory:
Soundcard:
PSU: Corsair CX500 V2, ATX
Default 05-02-2013, 17:52 | posts: 2

I have used it for my Sapphire Radeon HD7870 2GB. Nothing changes... still bsod in games :| Cant play a **** on this and sapphire dont want to rma it
   
Reply With Quote
Old
  (#20)
2easy4me
Newbie
 
Videocard: sapphire hd 7870 oc
Processor: intel i7 2600k
Mainboard:
Memory:
Soundcard:
PSU: thermaltake 800
Default 11-08-2013, 19:42 | posts: 1

I need to know if updating the bios fix the black screen problem I have the first vercion of the bios. 015,017,000,000 BIOS version. and need lasted bios drivers
   
Reply With Quote
Old
  (#21)
eddie6630
Newbie
 
Videocard: Sapphire 7870 Dual-X GHz
Processor: Phenom II 965BE
Mainboard:
Memory:
Soundcard:
PSU: Cooler Master GX700
Default 05-22-2014, 19:57 | posts: 1

Oh, hello there...it's a long time this post don't have visits. Anyway, i have a 7870 ghz dualx with black screen issues and maybe this will help...

Can somebody please share the bios file? The OP link is dead
Thanks!!!!
   
Reply With Quote
Old
  (#22)
alan_yo_99
Newbie
 
Videocard: saphire 7870 2gb
Processor: amd fx 8350
Mainboard:
Memory:
Soundcard:
PSU: modular
Default 07-02-2014, 02:13 | posts: 1

hello can you pass me the bios patch , i have the same problem and card, i ll tanks
   
Reply With Quote
Old
  (#23)
Shakur92
Newbie
 
Videocard: R9 280X Vapor-X
Processor: Intel Core i5 3570k @4.5
Mainboard: Asus Maximus V Gene
Memory: 8 GB Geil 2133 mhz cas10
Soundcard: Creative X-Fi
PSU: OCZ 600w
Default 07-02-2014, 11:36 | posts: 4 | Location: Italy

here it is

https:// dl.dropboxusercontent.com/u/59222482/217x040a_634846843081952828.zip
   
Reply With Quote
Old
  (#24)
Angela8605
Newbie
 
Videocard: Sapphire HD7870 2GB DDR5
Processor: Intel Q6600 2.4ghz
Mainboard:
Memory:
Soundcard:
PSU: Chieftec 550W
Default 08-13-2014, 21:53 | posts: 3

Quote:
Originally Posted by Shakur92 View Post
here it is

https:// dl.dropboxusercontent.com/u/59222482/217x040a_634846843081952828.zip
i need this bios for my HD7870 pls pls pls
   
Reply With Quote
Old
  (#25)
Extraordinary
Ancient Guru
 
Extraordinary's Avatar
 
Videocard: MSI R9 290 GAMING TF 4GB
Processor: FX-8350 @ 4.9GHz / H100i
Mainboard: ASUS Crosshair V Formula
Memory: 12GB 2133 G.Skill
Soundcard: 5.1 Surround
PSU: Corsair TX950
Default 08-13-2014, 22:01 | posts: 6,467 | Location: 127.0.0.1

Quote:
Originally Posted by Angela8605 View Post
i need this bios for my HD7870 pls pls pls
Dropbox link still works
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.