Guru3D.com Forums

Go Back   Guru3D.com Forums > General Chat > The HTPC, HDTV & High Definition section
The HTPC, HDTV & High Definition section Home Theater PC Enthusiasts or want to talk in High-Definition ? This is Guru3Ds Premier Community of HD and HTPC.


Reply
 
Thread Tools Display Modes
Question about film/DVD audio and volume
Old
  (#1)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Question Question about film/DVD audio and volume - 03-20-2013, 08:49 | posts: 3,650 | Location: UK

Not sure if this is in the right section.

I have noticed that when my kids are watching Lion king the voices are quiet and the music and 'action moments' are really loud. I use a PC to play these films/DVD's. I can't believe they are made like this. I use XBMC to play them.

Is their anything I can do?
   
Reply With Quote
 
Old
  (#2)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 03-20-2013, 09:20 | posts: 9,769 | Location: UK

Its playing back with full dynamic range.
You can compress the dynamic range with many players, look through the options.
See section 2
http://wiki.xbmc.org/index.php?title=Video_playback
   
Reply With Quote
Old
  (#3)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 03-20-2013, 09:33 | posts: 3,650 | Location: UK

Ok. Will have a look at that now. Someone told me that I should go into the Windows options for audio and put my stereo speakers as 'full dynamic range' too. Is that wrong?
   
Reply With Quote
Old
  (#4)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 03-20-2013, 09:44 | posts: 3,650 | Location: UK

Ok I checked out section 2. I have noticed sometimes also that film audio crackles with loud parts. I turned up the Volume amplification to 12 as in the picture but it still did it. So I turned also turned down the volume in that section to what it has in the picture and it seems to have stopped crackling.

Why does it crackle?

I have the sound coming from the back of the sound card straight to the stereo.

Last edited by HonoredShadow; 03-20-2013 at 09:48.
   
Reply With Quote
 
Old
  (#5)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 03-20-2013, 10:24 | posts: 9,769 | Location: UK

It crackles if you exceed the maximum output of any part of the audio chain, this saturates the sine waves so that they become flat lines at their peaks, that sound bad.
Reducing the volume level at the right place will remedy it.
ie there are a few volume controls, you may need to experiment to find the right volume control that is too loud.

The idea with compressing the dynamic range is that you turn up the compression which increases the level of quiet sounds.
You then need to reduce the volume level in the same place, otherwise the compression can introduce its own crackles/distortion.
You can reduce the volume elsewhere, but the odd crackle may occur, so its better to change it where you increased the compression.


There is no right and wrong with dynamic range, its down to your circumstance or preference how you configure it.
For example:

a) If you want the full dynamic experience, leave everything on full range.
This will makes quiet things quiet and loud things loud.
To hear the quiet sounds, the main volume control will need turning up, making loud things very loud.
This is how it was intended to be heard.

b) If this is too loud, employ some range compression in one place to make loud and quiet sounds nearer the same level, then reduce the volume level.
There is no need to turn full dynamic range off everywhere, just do it in one place.
Otherwise you end up with a ton of compression and if you want to adjust it enough, you may need to find everywhere that its enabled.
   
Reply With Quote
Old
  (#6)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Talking 03-20-2013, 19:35 | posts: 3,650 | Location: UK

Thanks! That makes alot of sense. Will have a gander.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.