Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Help card not detected.
Old
  (#1)
usoldier
Newbie
 
usoldier's Avatar
 
Videocard: ATI 5870 1GB Watercooled
Processor: I7 920@ 4200 Watercooled
Mainboard: Asus P6T Deluxe V2
Memory: 6GB
Soundcard: Creative
PSU: 850W ArkAngel
Default Help card not detected. - 01-31-2013, 01:57 | posts: 32 | Location: Portugal

Can some one help iam trying to install on a fresh windows 7 64bit and the driver doesnt detect my 7970 also tried the official 13.1 and does the same thing, on my windows devices it gets detected has a Generic VGA ?
   
Reply With Quote
 
Old
  (#2)
xacid0
Master Guru
 
Videocard: Sapphire HD7950 Vapor-X
Processor: Xeon E3-1230v2
Mainboard: MSI B75-G43A
Memory: G.Skill RipjawX 8GB 1600
Soundcard: BeatUpAudio
PSU: Enermax 650W 82+ Bronze
Default 01-31-2013, 02:41 | posts: 288

What is the HardwareIDs of that Generic VGA?
   
Reply With Quote
Old
  (#3)
usoldier
Newbie
 
usoldier's Avatar
 
Videocard: ATI 5870 1GB Watercooled
Processor: I7 920@ 4200 Watercooled
Mainboard: Asus P6T Deluxe V2
Memory: 6GB
Soundcard: Creative
PSU: 850W ArkAngel
Default 01-31-2013, 03:21 | posts: 32 | Location: Portugal

Quote:
Originally Posted by xacid0 View Post
What is the HardwareIDs of that Generic VGA?
PCI\VEN_1002&DEV_6798&SUBSYS_04181043&REV_00
PCI\VEN_1002&DEV_6798&SUBSYS_04181043
PCI\VEN_1002&DEV_6798&CC_030000
PCI\VEN_1002&DEV_6798&CC_0300

Please help iam getting desperate
   
Reply With Quote
Old
  (#4)
xacid0
Master Guru
 
Videocard: Sapphire HD7950 Vapor-X
Processor: Xeon E3-1230v2
Mainboard: MSI B75-G43A
Memory: G.Skill RipjawX 8GB 1600
Soundcard: BeatUpAudio
PSU: Enermax 650W 82+ Bronze
Default 01-31-2013, 11:12 | posts: 288

Seems legit. Maybe you can try force install through Device Manager.
   
Reply With Quote
 
Old
  (#5)
yasamoka
Ancient Guru
 
Videocard: 7970CF @ Qnix 1440p 110Hz
Processor: i7 930
Mainboard: ASUS P6X58D Premium
Memory: 6GB Corsair Dominators
Soundcard: Audio-GD NFB-11.32 +DT880
PSU: CM Silent Pro Hybrid 1300
Default 01-31-2013, 11:35 | posts: 3,104 | Location: Lebanon

Did you uninstall the card from Driver Manager when it installed as a Generic VGA? Then after that, did the resolution mess up?

If it did, then now you have no GFX drivers. Try to install Catalyst 13.1, and if it doesn't install, then reboot the PC and reinstall them before Windows installs Generic VGA drivers.
   
Reply With Quote
Old
  (#6)
usoldier
Newbie
 
usoldier's Avatar
 
Videocard: ATI 5870 1GB Watercooled
Processor: I7 920@ 4200 Watercooled
Mainboard: Asus P6T Deluxe V2
Memory: 6GB
Soundcard: Creative
PSU: 850W ArkAngel
Default 02-01-2013, 00:47 | posts: 32 | Location: Portugal

Yay that fixed it thanks for the help guys.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.