Guru3D.com Forums

Go Back   Guru3D.com Forums > General Chat > Frontpage news
Frontpage news Perhaps you have some news to report or want to check out the latest Guru3D headlines and comment ? Check it in here.


Reply
 
Thread Tools Display Modes
Download GeForce 313.96 Beta driver
Old
  (#1)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 5960K
Mainboard: X99
Memory: 16GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default Download GeForce 313.96 Beta driver - 01-30-2013, 10:57 | posts: 21,698 | Location: Guru3D testlab

NVIDIA made a small iteration to the 313.95 WHQL driver and updated it towards 313.96 WHQL. GeForce 313.96 drivers fix an installation issue reported with GeForce 313.95 drivers with international ...

Download GeForce 313.96 Betadriver
   
Reply With Quote
 
Old
  (#2)
Greyleroux
Member Guru
 
Greyleroux's Avatar
 
Videocard: Gtx660 Sli_U2713
Processor: 3570K@4.4_H80i
Mainboard: Asrock Z77 Extreme4
Memory: 16G DDR3 @1600
Soundcard: SB ZxR_ATH-AD-500X
PSU: 850W
Default 01-31-2013, 02:11 | posts: 76 | Location: Japan

Installed it ,My sli don't work in crysis 3 beta ....,i get 30~45fps tough !can't wait for the full support .
   
Reply With Quote
Old
  (#3)
Steve
Newbie
 
Videocard: EVGA 680 Classified SLI
Processor: Intel 4770K@4.7Ghz
Mainboard: Gigabyte G1 Sniper M5
Memory: G.Skill XMP 2133 Cas 9
Soundcard: Creative X-FI & Recon3D
PSU: Corsair AX860 80+Platinum
Default 01-31-2013, 02:28 | posts: 13

Quote:
Originally Posted by Greyleroux View Post
Installed it ,My sli don't work in crysis 3 beta ....,i get 30~45fps tough !can't wait for the full support .
Hey Grey, Take a look here http://secure.mycrysis.com/forums/vi...56456&p=579964 for the Crysis 3 Beta SLI fix.
   
Reply With Quote
Old
  (#4)
Greyleroux
Member Guru
 
Greyleroux's Avatar
 
Videocard: Gtx660 Sli_U2713
Processor: 3570K@4.4_H80i
Mainboard: Asrock Z77 Extreme4
Memory: 16G DDR3 @1600
Soundcard: SB ZxR_ATH-AD-500X
PSU: 850W
Default 01-31-2013, 03:00 | posts: 76 | Location: Japan

Thanks mate will do
   
Reply With Quote
 
Old
  (#5)
telc
Newbie
 
Videocard: 2 X EVGA 780Ti
Processor: Intel 3930K
Mainboard: Asus Rampage IV Formula
Memory:
Soundcard:
PSU: Corsair 1200i
Default 01-31-2013, 06:14 | posts: 11 | Location: Australia

SLI didnt work for me for either on Crysis 3 Beta until I used Nvidia Inspector to activate the SLI profile. Works like a charm now...
   
Reply With Quote
Old
  (#6)
War child
Master Guru
 
Videocard: EVGA 780 SLI
Processor: Intel 3570k @ 4.5ghz
Mainboard: Sabertooth Z77
Memory: GSkill Ripjaw 8Gb 2133mhz
Soundcard: Asus Xonar Essence STX
PSU: Seasonic 850W
Default 01-31-2013, 08:45 | posts: 263 | Location: Oslo

Can anyone else confirm if they had the same issue as me.

My temps with 680 SLI have gone up by avg 15C while playing games such as Crysis 2 or Far Cry 3 using the new beta drivers. I reverted back to the previous released driver and temps went down again.

I'm using 2 MSI branded reference cards. Stock fans. I didn't see any new functionalities that would resort to such an increase in GPU temps in 313.95 (will check when I am home from work if case continues with 313.96)

Last edited by War child; 01-31-2013 at 08:48.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.