Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Dead Island Stuttering.
Old
  (#1)
Mr Terry Turnip
Master Guru
 
Videocard: Intel iGPU
Processor: Intel 4670K @4.3Ghz
Mainboard: Asus Z87 Pro
Memory: 8GB Corsair
Soundcard: ATI HD Audio
PSU: Corsair RM850W
Exclamation Dead Island Stuttering. - 01-04-2013, 18:07 | posts: 254 | Location: UK

Hi,

Any tips on making this game run without hideous stuttering ?

1080p
VSYNC ON
60hz

have tried using afterburner ot limit frame rate to 60, which solves stuttering a large portion of games.

Have also tried disabling internet as I read on one forum

Saw a youtube video which claimed stuttering and was shocked it was not stuttering it was epic pauses for seconds (thats not stuttering, thats like pausing the game, scratching ur ass, and unpausing it) I hate that everybodys idea of stuttering is so different.


To clarify, my PC is fine, I play BF3 and just cause 2 perfectly, no stutters.
   
Reply With Quote
 
Old
  (#2)
Groovy-Music
Newbie
 
Videocard: 2x 7970 WForce3@1150/1745
Processor: AMD 1100T
Mainboard: GA-890GPA-UD3H
Memory: 8Gb 1866 Mhz
Soundcard: x-Fi Fatal1ty Platinum
PSU: Antec 1000W
Default 01-04-2013, 18:52 | posts: 27 | Location: Montréal, Canada

Hello there

I own Dead Island since the first day and at first, I had no stuttering at all with the game until they patched it the day after launch. The first build was supposedly the "developer" build and just by pressing 'J' we were enabling NoClip and FlyMode...aaa well... Since the patches, they introduced the stuttering and they never fixed it!: Way to go !

From what I know, if you have the same stuttering as me and my friends, this is caused by the keyboard repeating key strokes.

---> Try playing with a Xbox controller which should fix any stuttering associated with the characters' movements.

---> Or to alleviate the problem still using the keyboard and mouse, download the "Dead Island Helper tool" found in this thread:
http://forums.steampowered.com/forum....php?t=2114535

It's just an .exe
Run this tool before playing Dead Island

This tool's icon will be in the task bar--> RightClick on it --> go to "Keyboard and Mouse" menu --> check "Fix micro-stuttering (prevent keystroke repetition)"
This alleviate A LOT the stutters, but not completely. It still stutters when you press many buttons at the same time: Ex: Forward + Right at the same time... but in dead island, you can run just by pressing Sprint one time and just holding forward alone. So try that, try not to press all the keys together or play with the controller, which produce perfectly fluid movements.
   
Reply With Quote
Old
  (#3)
Mr Terry Turnip
Master Guru
 
Videocard: Intel iGPU
Processor: Intel 4670K @4.3Ghz
Mainboard: Asus Z87 Pro
Memory: 8GB Corsair
Soundcard: ATI HD Audio
PSU: Corsair RM850W
Default 01-04-2013, 19:27 | posts: 254 | Location: UK

Thanks very much for this I appreciate it allot, very kind of you to take the time to help out in such detail.

I do only play with the controller, that's the first thing, I also have the DA helper tool, tried that as well, I also tried limiting the FPS to 60, still with no luck, disabling internet for LAN ONLY, or single player mode.

Borderlands, BF3, Just Cause 2, all run with perfect fluidity.

Dead Island is a foul mess, ill look into it some more tomorrow.
   
Reply With Quote
Old
  (#4)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-04-2013, 19:54 | posts: 9,236 | Location: UK

Was gona get this in the Steam sale, think ill give it a miss
   
Reply With Quote
 
Old
  (#5)
Mr Terry Turnip
Master Guru
 
Videocard: Intel iGPU
Processor: Intel 4670K @4.3Ghz
Mainboard: Asus Z87 Pro
Memory: 8GB Corsair
Soundcard: ATI HD Audio
PSU: Corsair RM850W
Default 01-04-2013, 20:22 | posts: 254 | Location: UK

Yes steam sale is what made me think....

problem was, because of these exact issues, I NEVER buy a game without d/l first to test it, never do anymore,ever, however, 20 mins left on sale there was last night at about £6 so I thought well, it's a risk, but so cheap so, ill take that risk, boy, regret is a bitch, don't do it.

Just money down the drain, and allot of time reading and looking into the issue, it's cost allot more than £6 on time alone, with no result.
   
Reply With Quote
Old
  (#6)
Fox2232
Maha Guru
 
Videocard: Acc7970 XL2420T @120Hz
Processor: i5-2500k@4.5GHz NH-D14
Mainboard: MSI Z68A-GD80[g3]
Memory: 4x4GB 1600MHz 9,9,9,24
Soundcard: Essence ST / AKG K-701
PSU: FSP Gold series 750W
Default 01-04-2013, 21:16 | posts: 1,554 | Location: EU, CZ, Brno

Hello, I run game at 120Hz LCD with quick response. Not at 120Hz since engine allows me to set only 100Hz.

I decided to check how it plays at 60Hz with default maximum setting (reset of cfg. and set to max in game).
Well, feeling was really bad, felt like 30fps even while motion blur helps a bit.

I run over dozens of different settings in RadeonPro to find out if it can be improved:
Advanced - Flip Queue Size manually to - 3
Tweaks - VSync control - Always On
Tweaks - Tripple Buffering - On
Tweaks - Display refresh rate 60Hz (I had to use it to be sure to simulate 60Hz environment)
Tweaks - Dynamic Frame Control - On
Tweaks - Keep Up To - 60 fps
Tweaks - Misc. - CPU Affinity - only 2 cores (since game does not need more)

I believe issue is caused by bad v-sync, because game w/o vsync can render at max settings on HD7970 between 150 and 220fps.
And with all settings above when I changed DFC from 60 to 120 to test it Stuttering was back.
Basically settings above are to properly limit fps and to optimize frame queue.

Try all settings above together and write if it helped you.

Edit: And game is really good for that price, so I hope you will be able to solve it.
   
Reply With Quote
Old
  (#7)
Mr Terry Turnip
Master Guru
 
Videocard: Intel iGPU
Processor: Intel 4670K @4.3Ghz
Mainboard: Asus Z87 Pro
Memory: 8GB Corsair
Soundcard: ATI HD Audio
PSU: Corsair RM850W
Default 01-05-2013, 08:18 | posts: 254 | Location: UK

Thanks allot fox, what is radeon pro? lol I will google it.
   
Reply With Quote
Old
  (#8)
Mr Terry Turnip
Master Guru
 
Videocard: Intel iGPU
Processor: Intel 4670K @4.3Ghz
Mainboard: Asus Z87 Pro
Memory: 8GB Corsair
Soundcard: ATI HD Audio
PSU: Corsair RM850W
Default 01-05-2013, 22:21 | posts: 254 | Location: UK

Thanks very much again, I tried the settings you suggested and others also, the fact is, the game is a hideous mess, and I won't be playing it, and the lesson of ALWAYS d/l a game before PAYING for it (on PC) has been hammered home, YET AGAIN.
   
Reply With Quote
Old
  (#9)
shankly1985
Master Guru
 
Videocard: MSI R9 290 GE Crossfire
Processor: i7 2600k @4.5
Mainboard: Asus P8z77 WS
Memory: Kingston HyperX 16GB
Soundcard: Asus Xonar D2X - Roccat
PSU: SuperFlower 1000w Platium
Default 01-06-2013, 00:10 | posts: 372 | Location: England

Its a bug in the game when using a K&M better using a game pad removes the stuttering completely.
   
Reply With Quote
Old
  (#10)
Portman87
Member Guru
 
Portman87's Avatar
 
Videocard: XFX 6870 DD 920/1130 1GB
Processor: PII 955 C3 4GHz NB 2.6GHz
Mainboard: ASRock 970 Extreme3
Memory: 2x2DDR3 1600 Kingston BLU
Soundcard: ALC892 SPA2602/10
PSU: FSP Group AURUM GOLD 700W
Default 01-06-2013, 12:49 | posts: 96 | Location: Bulgaria

Same problem for me on my old system and the new.On a GTX 460 1GB and AM2+ MB same problem on my current system.Running the game from Dead Island Helper resolve the problem.
   
Reply With Quote
 
Old
  (#11)
hulawafu77
Master Guru
 
Videocard: 7970M
Processor: 3610QM
Mainboard:
Memory:
Soundcard:
PSU: Clevo
Default 01-06-2013, 20:20 | posts: 191

Quote:
Originally Posted by Rich_Guy View Post
Was gona get this in the Steam sale, think ill give it a miss
Why? It's a great game. Unlike the OP I have no stuttering issue and neither does my co-op buddy nor anyone else I know who also use AMD GPUs.
   
Reply With Quote
Old
  (#12)
BababooeyHTJ
Member Guru
 
Videocard: 7950 crossfire
Processor: i5 3570k
Mainboard: Gigabyte Z77x-UD5H
Memory:
Soundcard: Xonar STX
PSU: Corsari AX850
Default 01-06-2013, 21:28 | posts: 138

I thought that the game was awful. Just plain awful.
   
Reply With Quote
Old
  (#13)
Mr Terry Turnip
Master Guru
 
Videocard: Intel iGPU
Processor: Intel 4670K @4.3Ghz
Mainboard: Asus Z87 Pro
Memory: 8GB Corsair
Soundcard: ATI HD Audio
PSU: Corsair RM850W
Default 01-06-2013, 21:35 | posts: 254 | Location: UK

Quote:
Originally Posted by Rich_Guy View Post
Was gona get this in the Steam sale, think ill give it a miss
Just be very careful listening to this hulawafu guy, he's very strange, he popped up in my other thread as well, spouting some very obscure scheisse, I would stick to your decision if I was you (I honestly regret wasting the time and money) or wait for it to become VERY cheap. Judging from the guys attitude, I would think he is just one of a large portion of people not perceptive enough to detect the shocking stuttering (which is actually a fairly well known issue in dead island so I am told) he probably also thinks 30fps is 'smooth'

I honestly do NOT KNOW WHY he is targeting me and my threads, it's totally out of the blue, I wish he would go mind his OWN business, and let the kind people of guru3d help me in peace with problems I am having, as i have had some superb help so far, and learned allot about how ot make th emost of my ATI card, which I am very much enjoying - pretty sure the problem is the games, for the most part, and me not knowing enough about ATI 3d party apps.

Quote:
Originally Posted by hulawafu77 View Post
Why? It's a great game. Unlike the OP I have no stuttering issue and neither does my co-op buddy nor anyone else I know who also use AMD GPUs.

Last edited by Mr Terry Turnip; 01-06-2013 at 21:43.
   
Reply With Quote
Old
  (#14)
GenClaymore
Ancient Guru
 
GenClaymore's Avatar
 
Videocard: Evga 780 Dual 1202/3305
Processor: I5 3570k @4.5Ghz SA SB-E
Mainboard: Gigabyte Z77X-UD3H
Memory: 30nm 2x 4GB DDR3-1600
Soundcard: X1>Frost Uber>LDMKII>T90
PSU: Cosair 850watt RM850
Default 01-06-2013, 21:36 | posts: 5,433 | Location: Michigan,usa

Quote:
Originally Posted by hulawafu77 View Post
Why? It's a great game. Unlike the OP I have no stuttering issue and neither does my co-op buddy nor anyone else I know who also use AMD GPUs.
Yea same for me, I didn't even know there was a stuttering issue with DI, til I Saw this thread, And I use KB&M. The only issue I had with Dead island was performance, but that Dead island helper fixed that for me.
   
Reply With Quote
Old
  (#15)
crkwhr
Master Guru
 
Videocard: 290x
Processor: i7 3770
Mainboard: MSI p67a g45
Memory: 8gig ddr3
Soundcard: onboard baby! harman sou
PSU: corsair gs600
Default 01-07-2013, 01:33 | posts: 155 | Location: arizona

Quote:
Originally Posted by Mr Terry Turnip View Post
Just be very careful listening to this hulawafu guy, he's very strange, he popped up in my other thread as well, spouting some very obscure scheisse, I would stick to your decision if I was you (I honestly regret wasting the time and money) or wait for it to become VERY cheap. Judging from the guys attitude, I would think he is just one of a large portion of people not perceptive enough to detect the shocking stuttering (which is actually a fairly well known issue in dead island so I am told) he probably also thinks 30fps is 'smooth'

I honestly do NOT KNOW WHY he is targeting me and my threads, it's totally out of the blue, I wish he would go mind his OWN business, and let the kind people of guru3d help me in peace with problems I am having, as i have had some superb help so far, and learned allot about how ot make th emost of my ATI card, which I am very much enjoying - pretty sure the problem is the games, for the most part, and me not knowing enough about ATI 3d party apps.



It probably has something to do with you complaining about games in 3 separate games in 3 threads and your benchmarking in a 4th. And to boot 2 of the games you have issues with are buggy in the first place with everything DI and Skyrim. And the 3rd is a game I dont know anyone has a problem with amd or nvidia. That is probably why he is annoyed at you.
   
Reply With Quote
Old
  (#16)
trocio2
Master Guru
 
trocio2's Avatar
 
Videocard: HD 4670 512mb DDR3 pci-e
Processor: Core 2 Quad
Mainboard: Intel DQ35JO
Memory: ddr2 800 mhz, 3x2gb= 6gb
Soundcard: Realtek
PSU: Cooler Master
Default 01-07-2013, 02:39 | posts: 383

Something bad is going to happen...
   
Reply With Quote
Old
  (#17)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 980 SC
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe v2103
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX PRO Black Ed. 850W
Default 03-09-2013, 21:56 | posts: 12,135 | Location: England

I've just loaded this game up on my PC after about a year and I'm seeing abysmal performance which I'm sure I never had before as it ran at 60 fps with v-sync on. I'm using the Xbox 360 controller too but the game feels laggy/stuttery/juddery when moving, like it is 20 fps not 40 fps, and the framerate fluctuates between 32 and 60 fps on the title screen and hovers around 32-45 fps in-game even though the GPU usage across both cards is around 10% and the temps never go above 48 C as a result. It's like something is limiting the performance as even if I look straight up at the sky or down at the floor the framerate can still stay at 32 fps and never goes above 45 fps. I am forcing 8xCSAA using the 0x10C1 flag but even with it disable and no forced AA the game doesn't run any faster at all. Forcing AA should cause a heavier load on the GPUs, right? Here it doesn't. The GPU doesn't boost either, staying at 1,006 MHz, which it nevers does in any game I've played. I'm using the v314.14 beta drivers and wonder if it is the drivers that are the issue.

What is causing this if it isn't the drivers? I'm pretty sure this game was running at over 100 fps without v-sync when I last benchmarked it but now, even with v-sync off, it doesn't go above 45 fps.
   
Reply With Quote
Old
  (#18)
-Tj-
Ancient Guru
 
-Tj-'s Avatar
 
Videocard: ZOTAC GTX780 OC AmpFan
Processor: i7 4770K OC 4.7GHz @1.28v
Mainboard: ASUS Z87 Deluxe
Memory: Crucial BLE 16GB 2400MHz
Soundcard: Creative X-Fi Titanium HD
PSU: Chieftec NTRO88+ 650W
Default 03-09-2013, 22:58 | posts: 8,047 | Location: Urban`Jungle

Like others said its like a issue with vsync + that keyboard keystroke bug..

disable vsync and maybe limit it to ~ 120fps, this did the trick for me when i use to play it (i didnt use any tool). If there is to much tearing try 70fps cap..


@ Darren
I think that AA flag is bugged, try SSAA brute force flag..


edit: yep try this, but do go to high its still stressful
0x0000F0C1

Last edited by -Tj-; 03-09-2013 at 23:05.
   
Reply With Quote
Old
  (#19)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 06-25-2014, 13:11 | posts: 9,236 | Location: UK

Well picked it up in the Steam Summer Sale along with Riptide (got the franchise pack), and did have the stuttering via keyboard problem, this Dead Island Helper tool sorted it out though.
   
Reply With Quote
Old
  (#20)
CPC_RedDawn
Ancient Guru
 
CPC_RedDawn's Avatar
 
Videocard: 3GB HD7970OC/2GB HD7770
Processor: 4770K@4.5GHz/Q6600@3.6GHz
Mainboard: Z87-GD65 / P5K PREMIUM
Memory: 16GB@1866MHz/4GB@1066MHz
Soundcard: Creative SoundBlaster Z
PSU: 1200W/900W
Default 06-25-2014, 13:21 | posts: 5,958 | Location: Wolverhampton/United Kingdom

Easy to fix, it is a well known issue with the techland engine even since call of juarez used it.

Everything maxed in game at 1080p and it runs ridiculously well at over 200fps literally all the time.

The stutter happens infrequently, and seems to be random. Simply disable VSYNC in game (for some this option is broken and even enabling it does nothing but cause stutter).

Now cap your fps to something a little less over the the top. I normally cap to 60fps for most games but some engines are worse than others when doing this and capping at 60fps with vsync off can lead a whole world of tearing issues (just look at Titanfall for this!). For Dead Island I cap my fps to either 75 or 125fps.

I then also force the game via a profile in Radeonpro to use 8xMSAA, 16xAF, and also set CPU priority to high.

The game is very CPU bound, and you need to fix that by forcing it to use more GPU power. The game barely breaks the 512MB barrier of VRAM at stock maxed settings. With 8xMSAA, 16xAF, and all texture qualities set to maxium it uses near or just over 1GB VRAM and all stutter is gone.
   
Reply With Quote
Old
  (#21)
CrunchyBiscuit
Member Guru
 
Videocard: AMD Radeon HD6950 2GB
Processor: AMD Phenom II x4 970@3800
Mainboard: Asus M4A88T-M
Memory: Kingston HyperX 4GB DDR3
Soundcard: VIA HD Audio
PSU: Corsair TX650 V2
Default 06-26-2014, 22:32 | posts: 87

This game used to run well before, after applying the keyboard stroke fix.

However, ever since the Dead Island 'Riptide - preperation update' (there was an update for the original Dead Island when Riptide was released), the game just graphically stutters for me, my brother (who has almost the same system as I do) and a good friend (with an Intel i5, nVidia 560 something). Nothing we can do on our ends helps with the problem, but we used to play together before that update just fine at 60fps/60Hz without v-sync (v-sync never worked properly for us with this game). Now it's stutter, stutter, stutter.

V-sync, fps-caps, keyboard fixes, they all won't help.

Have you guys played it lately, or are you speaking from past experience? 'Cause the three of us can't seem to fix it, the game is essentially broken at the moment. We paid full price and haven't even finished it yet

Oh well. Let me know if you guys can get it to run well, not from memory but from recent and actual tests.

I wanted to buy Riptide, but I don't think I will - it probably has the same issues.

Played Gunslinger though, same engine (Chrome from Techland), but those developers fixed the keyboard stroke issue right away and Gunslinger also doesn't have those stutter problems. The developers of Dead Island still have not fixed the keyboard issue.
   
Reply With Quote
Old
  (#22)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1300
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 06-27-2014, 20:21 | posts: 9,236 | Location: UK

I only bought them in this summer sale, so only had the games a few days, and fixed the stutter via the helpers, so both are fine now.
   
Reply With Quote
Old
  (#23)
CrunchyBiscuit
Member Guru
 
Videocard: AMD Radeon HD6950 2GB
Processor: AMD Phenom II x4 970@3800
Mainboard: Asus M4A88T-M
Memory: Kingston HyperX 4GB DDR3
Soundcard: VIA HD Audio
PSU: Corsair TX650 V2
Default 06-28-2014, 02:48 | posts: 87

Thanks for verifying, I will try it out again next week.

Really hoping the helper tool works No other zombie game offered such satisfying melee combat.
   
Reply With Quote
Old
  (#24)
CrunchyBiscuit
Member Guru
 
Videocard: AMD Radeon HD6950 2GB
Processor: AMD Phenom II x4 970@3800
Mainboard: Asus M4A88T-M
Memory: Kingston HyperX 4GB DDR3
Soundcard: VIA HD Audio
PSU: Corsair TX650 V2
Default 07-12-2014, 04:28 | posts: 87

Tried it again, spent more than a day trying out various things, used every setting in the helper, RadeonPro, tried running it on less cores, triple buffering on/off, with/without v-sync, tried using Dxtory fps cap instead of the RP one, played around with various internal timers, set it to borderless fullscreen instead of regular, tried playing it on 50 Hz, 59Hz, 60Hz, 64Hz & 75Hz, tried out Catalysts 8.97beta, 13.4, 13,8beta2, 13.12, 14.4 and 14.6beta, tried increasing/decreasing mouse polling rate, tried the old FPS_Limiter tool, tried running it in compatibility modes and via DisplayChanger, tried some custom *.dll files people suggested, tried running without Steam using a crack, enabling/disabling my second monitor, I dunno what else.

Flawless, silky smooth 60fps/60Hz with v-sync enabled isn't gonna happen, not for me at least.

Despite super high frame rates and no load pauses, the graphics just stutter, both while walking and when moving the mouse, but not in sync (mouse stutter is different from the walk stutter). I can tell the keyboard stroke thing works though, because it's even worse without the fix.

Used to be able to play fine before. I give up.

Last edited by CrunchyBiscuit; 07-12-2014 at 04:32.
   
Reply With Quote
Old
  (#25)
crz
Member Guru
 
Videocard: 2 x R9 290 Gigabyte WF3
Processor: Intel i7 4770
Mainboard: ASRock Z87 Extreme6
Memory: 2 x 8 GB DDR3 1600 GEIL
Soundcard: Xonar DX
PSU: Corsair TX750 V2
Default 07-12-2014, 09:48 | posts: 84 | Location: Bucharest

Played both games on my previous card (7970), like others have said, I also remember that it was a mess with v-sync on despite running at over 100 FPS with v-sync off. With it on the game stuttered like hell.

I also recommend the Dead Island Helper tools (there is one for each game), those in combination with v-sync off made the gameplay much smoother. Had no more issues after this and I finished both games.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.