Guru3D.com Forums

Go Back   Guru3D.com Forums > General > Operating Systems
Operating Systems Is Windows 2000, XP or Vista giving you a hard time ? Wanna try out Linux ?


Reply
 
Thread Tools Display Modes
creative drivers delayed for windows 8
Old
  (#1)
yosef019
Maha Guru
 
yosef019's Avatar
 
Videocard: GTX770 4gb @1250mhz
Processor: i5 3570k 4.6 1.2v NH-D14
Mainboard: P8Z68-V
Memory: 8GB 2133 ARES CL9 2T
Soundcard: SB Recon3D Pro Fatality
PSU: Crosair 860i
Default creative drivers delayed for windows 8 - 11-30-2012, 13:21 | posts: 1,745 | Location: Israel - Haifa

creative drivers delayed for windows 8
recon3d: mid December / January
x-fi titanium fatality: early February

OMG

http://support.creative.com/kb/showa...aspx?sid=61105
   
Reply With Quote
 
Old
  (#2)
Amigafan35
Master Guru
 
Videocard: EVGA GTX780 ACX
Processor: AMD FX 8350
Mainboard: Sabertooth 990FX Bios1604
Memory: 4x4 Gig Corsair XMS3
Soundcard: X-Fi Titanium pci-e
PSU: SS Strider Plus 1000w
Default 11-30-2012, 14:17 | posts: 153

Nothing surprising there, it's Creative after all, alot are still waiting for decent drivers for Windoes 7! lol
   
Reply With Quote
Old
  (#3)
-Tj-
Ancient Guru
 
-Tj-'s Avatar
 
Videocard: ZOTAC GTX780 OC AmpFan
Processor: i7 4770K OC 4.7GHz @1.28v
Mainboard: ASUS Z87 Deluxe
Memory: Crucial BLE 16GB 2400MHz
Soundcard: Creative X-Fi Titanium HD
PSU: Chieftec NTRO88+ 650W
Default 11-30-2012, 14:37 | posts: 7,971 | Location: Urban`Jungle

Well i used Daniel_K 1.8 UAA pack with disabled driver signing and i dont mind this delay one bit. ;D
   
Reply With Quote
Old
  (#4)
yosef019
Maha Guru
 
yosef019's Avatar
 
Videocard: GTX770 4gb @1250mhz
Processor: i5 3570k 4.6 1.2v NH-D14
Mainboard: P8Z68-V
Memory: 8GB 2133 ARES CL9 2T
Soundcard: SB Recon3D Pro Fatality
PSU: Crosair 860i
Default 11-30-2012, 16:54 | posts: 1,745 | Location: Israel - Haifa

Quote:
Originally Posted by -Tj- View Post
Well i used Daniel_K 1.8 UAA pack with disabled driver signing and i dont mind this delay one bit. ;D
where for my card????
   
Reply With Quote
 
Old
  (#5)
Mannerheim
Ancient Guru
 
Mannerheim's Avatar
 
Videocard: VTX3D R9 280x
Processor: AMD FX8150
Mainboard: Asus M5A99X Evo
Memory: Kingston 2x4GB DDR3 1600
Soundcard: X-fi Xtreme Gamer 5.1
PSU: Chieftec 700W
Default 11-30-2012, 17:54 | posts: 4,571 | Location: Finland / Helsinki

My X-fi works just fine with beta drivers... no problems.


   
Reply With Quote
Old
  (#6)
yosef019
Maha Guru
 
yosef019's Avatar
 
Videocard: GTX770 4gb @1250mhz
Processor: i5 3570k 4.6 1.2v NH-D14
Mainboard: P8Z68-V
Memory: 8GB 2133 ARES CL9 2T
Soundcard: SB Recon3D Pro Fatality
PSU: Crosair 860i
Default 11-30-2012, 19:16 | posts: 1,745 | Location: Israel - Haifa

Quote:
Originally Posted by Mannerheim View Post
My X-fi works just fine with beta drivers... no problems.
mine noti hear sound like 20.000 khz
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.