Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI
Videocards - AMD - ATI AMD Radeon graphics cards. Do you have one or want to buy one? Use this forum to discuss anything concerning products using Radeon graphics cards, CrossFireX, from Radeon 9800 to HD 6900


Reply
 
Thread Tools Display Modes
Dead card?
Old
  (#1)
Kaltern
Newbie
 
Videocard: XFX AMD 7970 Black 3Gb
Processor: AMD FX 8320 Black Edition
Mainboard: Gigabyte GA-78LMT-S2P
Memory: 5.5Gb DDR2 @ 900mhz
Soundcard: X-Fi XtremeGamer
PSU: 650W InWin
Default Dead card? - 11-27-2012, 06:50 | posts: 27 | Location: Lockerbie, UK

So I just rebooted my PC, and I hear a series of POST beeps. The fans on my ASUS 6950 don't spin up, and the PC carries on booting as normal. I have no display.

I'm assuming the card just died on me. Could it be anything more, or am I going to be PC-less for a while
   
Reply With Quote
 
Old
  (#2)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: X-Fi Fatal1ty
PSU: AcBel M8 750
Default 11-27-2012, 07:46 | posts: 24,263 | Location: NZ

Quote:
Originally Posted by Kaltern View Post
So I just rebooted my PC, and I hear a series of POST beeps. The fans on my ASUS 6950 don't spin up, and the PC carries on booting as normal. I have no display.

I'm assuming the card just died on me. Could it be anything more, or am I going to be PC-less for a while
How many beeps? Long or short?...need that info.
   
Reply With Quote
Old
  (#3)
3dPlayer
Banned
 
Videocard: Have
Processor: a
Mainboard: good
Memory: day
Soundcard: or
PSU: not
Default 11-27-2012, 16:56 | posts: 1,822

PC less?lol

Just buy a cheap one on Ebay.
   
Reply With Quote
Old
  (#4)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 11-27-2012, 17:26 | posts: 9,769 | Location: UK

As Pill said.

Try resetting the CMOS.
Failing that, unplug the power connectors, make sure there is no dust, then replace them
Failing that, strip the PC down and clean it.
   
Reply With Quote
 
Old
  (#5)
Kaltern
Newbie
 
Videocard: XFX AMD 7970 Black 3Gb
Processor: AMD FX 8320 Black Edition
Mainboard: Gigabyte GA-78LMT-S2P
Memory: 5.5Gb DDR2 @ 900mhz
Soundcard: X-Fi XtremeGamer
PSU: 650W InWin
Default 11-27-2012, 17:26 | posts: 27 | Location: Lockerbie, UK

Um, it's Xmas.. any spare cash goes to kids and food...

It is the card, I found an old X600 and that works fine.

Really displeased, especially as it was fine just that morning.
   
Reply With Quote
Old
  (#6)
DrDoU
Member Guru
 
Videocard: wii
Processor: i3
Mainboard: wii
Memory:
Soundcard:
PSU: Toshiba
Default 11-28-2012, 02:30 | posts: 140 | Location: Texas! What country you from

Can you rma?
   
Reply With Quote
Old
  (#7)
kn00tcn
Maha Guru
 
kn00tcn's Avatar
 
Videocard: Sapphire 4870x2
Processor: Intel Q9550 3.6ghz
Mainboard: Asus P5Q-E
Memory: OCZ 2x2gb 5-4-4-15 840mhz
Soundcard:
PSU: Corsair 750TX
Default 11-28-2012, 05:55 | posts: 1,589 | Location: Toronto

boots as normal... without a display.. shouldnt it stop itself since it sees something in the pcie slot?

i want to see some attempted revival investigating action on that card
   
Reply With Quote
Old
  (#8)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: X-Fi Fatal1ty
PSU: AcBel M8 750
Default 11-28-2012, 05:57 | posts: 24,263 | Location: NZ

Need Beep codes.
   
Reply With Quote
Old
  (#9)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 11-28-2012, 06:01 | posts: 9,769 | Location: UK

Beep
   
Reply With Quote
Old
  (#10)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: X-Fi Fatal1ty
PSU: AcBel M8 750
Default 11-28-2012, 06:05 | posts: 24,263 | Location: NZ

Beep Beep.
   
Reply With Quote
 
Old
  (#11)
alig23
Newbie
 
Videocard: 7950
Processor: 965be
Mainboard:
Memory:
Soundcard:
PSU: 750 cosair
Default 11-28-2012, 08:25 | posts: 10

Oven time.
   
Reply With Quote
Old
  (#12)
Kaltern
Newbie
 
Videocard: XFX AMD 7970 Black 3Gb
Processor: AMD FX 8320 Black Edition
Mainboard: Gigabyte GA-78LMT-S2P
Memory: 5.5Gb DDR2 @ 900mhz
Soundcard: X-Fi XtremeGamer
PSU: 650W InWin
Default 11-28-2012, 11:01 | posts: 27 | Location: Lockerbie, UK

Closer investigation of the card has revealed 2 missing resistors from the memory chips, they appear to have been blown clean off

Beep code was this:

1 long, 8 short - Display test failure; The video adapter is either missing or defective.

Which would be about right.

I don't think there's a soldering iron in the world small enough for me to fix it

SO um, secret santa this year?

Last edited by Kaltern; 11-28-2012 at 11:20.
   
Reply With Quote
Old
  (#13)
Kaltern
Newbie
 
Videocard: XFX AMD 7970 Black 3Gb
Processor: AMD FX 8320 Black Edition
Mainboard: Gigabyte GA-78LMT-S2P
Memory: 5.5Gb DDR2 @ 900mhz
Soundcard: X-Fi XtremeGamer
PSU: 650W InWin
Default 11-30-2012, 11:46 | posts: 27 | Location: Lockerbie, UK

Ok, so I have about 150 to spend on a nice new card. Any suggestions from you wise folk?

I'm kinda leaning towards a 2gb 7870... Any reason I should avoid that one?

Last edited by Kaltern; 11-30-2012 at 11:55.
   
Reply With Quote
Old
  (#14)
PNeV
Maha Guru
 
PNeV's Avatar
 
Videocard: MSI 7950 @ 1150/1650
Processor: 3570K @ 4.4GHZ
Mainboard: ASRock Extreme4 Z77
Memory: 8GB Corsair Vengeance
Soundcard: Onboard
PSU: Antec HCG M 620W
Default 11-30-2012, 13:29 | posts: 1,758 | Location: Northampton, United Kingdom

150 is a 2GB 7850 price bracket. Good cards yes but if your looking to go for a 7870 then you may need to up the budget to around 170/180 for a good one such as the TF3 by MSI.
   
Reply With Quote
Old
  (#15)
Kaltern
Newbie
 
Videocard: XFX AMD 7970 Black 3Gb
Processor: AMD FX 8320 Black Edition
Mainboard: Gigabyte GA-78LMT-S2P
Memory: 5.5Gb DDR2 @ 900mhz
Soundcard: X-Fi XtremeGamer
PSU: 650W InWin
Default 11-30-2012, 14:14 | posts: 27 | Location: Lockerbie, UK

Hmm does the 7850 perform as well as the 6950? Few google results seem to be fairly inconclusive.

Oh, and I'm still not sure why my old 6950 isn't being recognised by the motherboard - those beeps seem to indicate it doesn't exist...
   
Reply With Quote
Old
  (#16)
Kaltern
Newbie
 
Videocard: XFX AMD 7970 Black 3Gb
Processor: AMD FX 8320 Black Edition
Mainboard: Gigabyte GA-78LMT-S2P
Memory: 5.5Gb DDR2 @ 900mhz
Soundcard: X-Fi XtremeGamer
PSU: 650W InWin
Default 11-30-2012, 14:18 | posts: 27 | Location: Lockerbie, UK

Ok I just had a worrying thought... is it possible for the 2x PCI-e power connectors to stop working, yet the rest of the PSU to work as normal?
   
Reply With Quote
Old
  (#17)
thatguy91
Ancient Guru
 
Videocard: HIS R9-280x Iceq X2 Turbo
Processor: i5-3570K
Mainboard: Asrock Z77 Extreme6
Memory: DDR3-2400 2x8GB
Soundcard: ALC898 + Microlab FC-730
PSU: Enermax Platimax 750W
Default 11-30-2012, 21:36 | posts: 4,071 | Location: Australia

Quote:
Originally Posted by Kaltern View Post
Ok I just had a worrying thought... is it possible for the 2x PCI-e power connectors to stop working, yet the rest of the PSU to work as normal?
Yes.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.