Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA Drivers Section
Videocards - NVIDIA Drivers Section In this section you can discuss everything ForceWare driver related. ForceWare (Detonator) drivers are for NVIDIA TNT, Quadro and all GeForce based videocards.


Reply
 
Thread Tools Display Modes
[fixed] figured out why borderless window fixes framerate stuttering in many games
Old
  (#1)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default [fixed] figured out why borderless window fixes framerate stuttering in many games - 11-16-2012, 23:52 | posts: 753

Has anyone figured out exactly why borderless window fixes framerate stuttering/drops in so many games?

The problem I'm describing looks like low fps even though a framerate indicator shows 60fps -- for instance in darksiders 2, when i stand still and move the camera around, the scenery that is in motion sort of moves in a slightly jumpy/stuttery way, rather than perfectly smooth, as if frames are being skipped , resulting in a low fps look to the motion.

It seems like there must be something wrong with the way windows 7 handles fullscreen games , because so many games framerate drops and stuttering are fixed by using windowed mode and d3doverrider to force vsync?

Two examples are : 1) skyrim, the camera panning would not be perfectly smooth unless i ran it in windowed mode, and same thing happens with 2) darksiders 2, the game was extremely choppy until i ran it in windowed mode, using a borderless window app to make it look just as good as fullscreen mode and forcing vsync on , triple buffering off , with triple buffering on forced in nvidia control panel,
as described here:

http://bitmapstudios.com/?p=1584

lots of people reported doing this trick to fix stuttering in sleeping dogs and dark souls, also.


my question is, what is the real reason so many games have this problem with full screen in win 7? is it a problem with directx and win7 fullscreen mode, and could we inform microsoft of it so they patch it?


btw, this guy wrote a nice borderless window app here:

http://forums.steampowered.com/forum....php?t=2675769

edit: since I posted this , i bought sleeping dogs on steam sale, and this title definitely suffers from the same problem of fullscreen stuttering, even worse than darksiders 2. running it in fullscreen windowed makes a huge difference. you can read about it here:

http://forums.sleepingdogs.net/viewtopic.php?f=5&t=1596

update : FIXED!

adaptive vsync helped but did not completely eliminate the stuttering with my GTX 670 4gb SC card, the final solution was to download an tiny program called d3d antilag from here:

http://www.kegetys.fi/dl.php/d3d_antilag101.zip

the game is smooth as glass now!

Last edited by adrock311; 12-06-2012 at 18:25.
   
Reply With Quote
 
Old
  (#2)
K.S.
Master Guru
 
K.S.'s Avatar
 
Videocard: EVGA GTX Titan SC. SLI
Processor: Core i7 4930K @ 4.2GHz
Mainboard: ASUS P9X79-E WS
Memory: Ripjaws X DDR3-2133 16GB
Soundcard: Realtek ALC1150, NV HDMI
PSU: CM Silent Pro Gold 1200W
Default 11-17-2012, 00:13 | posts: 756 | Location: Honolulu, Hawaii

I've never encountered this issue myself, in fact, windowed mode runs slower for me than fullscreen in games, esp. Sleeping Dogs. I notice it the most if I'm maintaining close to my monitor's native fullscreen res when in windowed mode. I picked up on it when minimizing a game to do work in other apps. Windowed would often cut fps in half until I went Fullscreen again. This usually is the same scenario with all of my other games. Maybe you just think it's fixing stuttering because you aren't noticing the fps fluctuating as much? Have you seen if windowed mode caps fps? If so that could explain it fixing "stuttering" if setup(s) struggle to handle whatever graphical settings the games are playing on.

Last edited by K.S.; 11-17-2012 at 00:47.
   
Reply With Quote
Old
  (#3)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 11-17-2012, 00:25 | posts: 753

Quote:
Originally Posted by K.S. View Post
I've never encountered this issue myself, in fact, windowed mode runs slower for me than fullscreen in games, esp. Sleeping Dogs. I notice it the most if I'm maintaining close to my monitor's native fullscreen res when in windowed mode. I picked up on it when minimizing a game to do work in other apps. Windowed would often cut fps in half until I went Fullscreen again. This usually is the same scenario with all of my other games. Maybe you just think it's fixing stuttering because you aren't noticing the fps fluctuating as much? Have you seen if windowed mode caps fps? If so that could explain it fixing "stuttering" if your setup(s) struggle to handle whatever graphical settings the games are playing on.
hmm, interesting, so what you are saying is that running the game in windowed mode could be having the same effect as using a framerate limiter , and thus increasing smoothness... if running a game in windowed mode effectively caps fps, it could be it, I"m not sure if it does though?
   
Reply With Quote
Old
  (#4)
K.S.
Master Guru
 
K.S.'s Avatar
 
Videocard: EVGA GTX Titan SC. SLI
Processor: Core i7 4930K @ 4.2GHz
Mainboard: ASUS P9X79-E WS
Memory: Ripjaws X DDR3-2133 16GB
Soundcard: Realtek ALC1150, NV HDMI
PSU: CM Silent Pro Gold 1200W
Default 11-17-2012, 00:35 | posts: 756 | Location: Honolulu, Hawaii

Quote:
Originally Posted by adrock311 View Post
hmm, interesting, so what you are saying is that running the game in windowed mode could be having the same effect as using a framerate limiter , and thus increasing smoothness... if running a game in windowed mode effectively caps fps, it could be it, I"m not sure if it does though?
I'm just speculating, but yes, that was my theory.

Update: Found this thread which has some info reg. your issue with windowed mode. http://www.tomshardware.com/forum/35...d-issues-games

Quote taken from it,

Quote:
Originally Posted by Mythiniel
Different Reasons This Can Happen

Affinity - If Fable 3, like most modern PC games, can only use a certain number (IE, 2) of your available CPU threads, and you are running it full screen, your computer will end up running at around 1/4 of it's total available speed. This is a modern gaming engineering fault, and they're only just starting to allow games 8/16 thread support. When you're in windowed mode, I suspect, your computer uses a range of threads to handle all available tasks, allowing Fable to have more of the threads available to it. (Solved by closing a lot of useless crap that you'll have running all the time. Steam, ect)
OnBoard Confusion - Depends on your config. Disable your built in GPU using BIOS, Fable could be using it as a default display adapter. I don't know why, but it's possible...
Windowed Support - Some graphics cards disable FSAA and other features while windowed mode. Even stepping down from AA16 to AA4 will give the speed difference you're talking about. Try running the game on minimum settings and recording FPS both for windowed and full screen.

Last edited by K.S.; 11-17-2012 at 00:45.
   
Reply With Quote
 
Old
  (#5)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 11-17-2012, 00:43 | posts: 402

It is getting annoying to me that almost every new game I play has the same stuttering and jerkiness when panning the camera.

Have you found a solution for Sleeping Dogs that gives a fullscreen borderless window without stretching the image out? I tried a program by someone in the Steam user forums, but it never gave a full unaltered picture. The game is too distracting for me to continue playing in fullscreen.
   
Reply With Quote
Old
  (#6)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 11-17-2012, 00:59 | posts: 753

Quote:
Originally Posted by NeoandGeo View Post
It is getting annoying to me that almost every new game I play has the same stuttering and jerkiness when panning the camera.

Have you found a solution for Sleeping Dogs that gives a fullscreen borderless window without stretching the image out? I tried a program by someone in the Steam user forums, but it never gave a full unaltered picture. The game is too distracting for me to continue playing in fullscreen.
yes, exactly, stuttering and jerkiness when panning the camera, in so many games. sorry, I dont know how to fix sleeping dogs, i just know a lot of people were saying borderless window helped
   
Reply With Quote
Old
  (#7)
Mineria
Ancient Guru
 
Mineria's Avatar
 
Videocard: EVGA GTX 770 SC 4GB ACX
Processor: Intel i7 4770K
Mainboard: Asus Maximus VI Formula
Memory: 32G G.Skill TridentX
Soundcard: Asus Phoebus
PSU: EVGA SuperNova 1000 G2
Default 11-17-2012, 01:20 | posts: 3,059 | Location: Denmark

Have you tried Process Lasso on gaming mode while running full-screen?
   
Reply With Quote
Old
  (#8)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 11-17-2012, 04:56 | posts: 753

Quote:
Originally Posted by Mineria View Post
Have you tried Process Lasso on gaming mode while running full-screen?
I gave it a try, it didn't make any difference, thanks anyway
   
Reply With Quote
Old
  (#9)
The Goose
Maha Guru
 
The Goose's Avatar
 
Videocard: Evga gtx680sc sli-h2o
Processor: I7 4820@4.6ghz-H2O
Mainboard: Asus rampage formula BF3
Memory: 16g Gskill redZ 2133 ddr3
Soundcard: Recon3D pro series
PSU: Ocz ZX-1250
Default 11-17-2012, 06:10 | posts: 1,529 | Location: shropshire,UK

Sli...or the lack of it might be the reason
   
Reply With Quote
Old
  (#10)
drewho
Master Guru
 
drewho's Avatar
 
Videocard: EVGA GTX780
Processor: i7 4770K @ 4.4GHz
Mainboard: Asus Maximus VII Ranger
Memory: 16GB (2x8GB) Vengeance
Soundcard:
PSU: Corsair 850W HX Modular
Default 11-17-2012, 10:07 | posts: 267 | Location: UK

Ive been noticing the same thing for quite a while now, ive posted this before that i'd read an article pointing out a serious bug in the nvidia full screen buffer, but try as i might i cant find the article anymore.

if anybody else can find it or knows the link its an interesting read.

also has anyone played "age of empires online"? Its a total stuttering mess in full screen but smooth in windowed mode.
   
Reply With Quote
 
Old
  (#11)
RecluSe
Master Guru
 
RecluSe's Avatar
 
Videocard: EVGA GTX 780Ti SC/ACX
Processor: Intel i5 2500k 4.5 GHz
Mainboard: Asus P8Z77-V LX
Memory: Corsair 8GB DDR3 1600Mhz
Soundcard: Asus Xonar D2X
PSU: Corsair TX 650W
Default 11-17-2012, 10:24 | posts: 686 | Location: UK

Quote:
Originally Posted by NeoandGeo View Post
It is getting annoying to me that almost every new game I play has the same stuttering and jerkiness when panning the camera.

Have you found a solution for Sleeping Dogs that gives a fullscreen borderless window without stretching the image out? I tried a program by someone in the Steam user forums, but it never gave a full unaltered picture. The game is too distracting for me to continue playing in fullscreen.
Only thing that works for me is to download Afterburner or EVGA precision and use the on screen display tool to cap the game at 60. Same thing happens in Borderlands 2 if I don't use the in game frame limiter. Dead Space 2 and the Darksiders games are the same too. These are the only games I have had problems with so far.
   
Reply With Quote
Old
  (#12)
SLI-756
Ancient Guru
 
SLI-756's Avatar
 
Videocard: 760 SLI ftw bios @1215
Processor: Devil's Canyon i5 @4.9
Mainboard: gigabyte z97 G1 Sniper
Memory: 8gb dominator gt @2400
Soundcard: asus xonar dx
PSU: xfx 850
Default 11-17-2012, 10:36 | posts: 6,426 | Location: Sunny Scotland

If you have 60fps movies you'll know the same bug happens with video playback too ie. drops frames when going fullscreen, i suspect a v sync issue, at least that's how to sort it with movies unless you go full dx11 mode with it (talking about mpc 64 bit).
In games the bug gets sorted by capping frames it seems, of course sometimes it's game engine related.
Basically a general framerate / v sync conflict i guess.

Last edited by SLI-756; 11-17-2012 at 10:38.
   
Reply With Quote
Old
  (#13)
OrigamiZor
Newbie
 
Videocard: Nvidia 680M
Processor: i7 3820QM
Mainboard:
Memory: 16g 1600mhz
Soundcard:
PSU: ?
Default 11-17-2012, 10:51 | posts: 16

I also notice that. More since r306 drivers. It's worth posting this on nvidia forum.

Last edited by OrigamiZor; 11-17-2012 at 10:53.
   
Reply With Quote
Old
  (#14)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 11-17-2012, 14:13 | posts: 753

Quote:
Originally Posted by OrigamiZor View Post
I also notice that. More since r306 drivers. It's worth posting this on nvidia forum.
the only problem is , i was having the same problems with ATI too, which leads me to think its a windows bug
   
Reply With Quote
Old
  (#15)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 11-17-2012, 14:20 | posts: 402

A bit off topic, but went to play some Just Cause 2, and it runs perfect in every respect. So smooth without any judder. Wish that carried over into Sleeping Dogs, they both look like they are on similar engines?

I talked to a community manager for Square Enix of London about the stuttering and performance issues in full screen mode and suggested they implement a proper full screen windowed mode and to review this thread for many people with the same issue and the only way to fix it was running a full screen window.

Quote:
Hey, please can you send me this request to sleepingdogs@square-enix.com, detailing what you'd like us to implement in full so that it's easy for me to pass up the chain?

If you want to canvass any others and get them to do the same too, please be my guest.

Last edited by NeoandGeo; 11-17-2012 at 14:24.
   
Reply With Quote
Old
  (#16)
NorysLintas
Newbie
 
Videocard: Asus Nvidia 8800 Gt
Processor: Intel Core 2 Quad 6600
Mainboard: P5kR
Memory: Team Group PC 6400 8 GB
Soundcard:
PSU: Enermax 720 W
Thumbs up 11-17-2012, 14:40 | posts: 8

From many many years (at least 6 years, but can be over, my memory is lacking) playing game in windowed mode was "the" trick to boost fps and do alt+tab without crash or freeze of the videogame (alt tab is used to back to the desktop in order to reply at any im software or surfing in a webpage during the game) without waiting loooooong time...(because back to the desktop in fullscreen mode in past was very slow).

The problem exist indeed since windows xp... in windowed mode a lot of games (old and not) freeze and crash less than fullscreen mode, like all bethesda games or all valve games...

I don't know why because in these windowed mode, the games goes faster than fullscreen mode, but it's true.
   
Reply With Quote
Old
  (#17)
RecluSe
Master Guru
 
RecluSe's Avatar
 
Videocard: EVGA GTX 780Ti SC/ACX
Processor: Intel i5 2500k 4.5 GHz
Mainboard: Asus P8Z77-V LX
Memory: Corsair 8GB DDR3 1600Mhz
Soundcard: Asus Xonar D2X
PSU: Corsair TX 650W
Default 11-17-2012, 16:43 | posts: 686 | Location: UK

Quote:
Originally Posted by adrock311 View Post
the only problem is , i was having the same problems with ATI too, which leads me to think its a windows bug
I had the same issues with ATI too so yeh something to do with windows I think.
   
Reply With Quote
Old
  (#18)
-Tj-
Ancient Guru
 
-Tj-'s Avatar
 
Videocard: ZOTAC GTX780 AmpF 1215MHz
Processor: Intel i7 4770K OC 4.7GHz
Mainboard: ASUS Z87 Deluxe
Memory: Crucial BLE 16GB 2400MHz
Soundcard: Creative X-Fi Titanium HD
PSU: Chieftec NTRO88+ 650W|52A
Default 11-17-2012, 18:02 | posts: 6,948 | Location: Urban`Jungle

I think its something with fullscreen buffer and the way driver grabs the screen when it switches to fullscreen..

Some games ie Skyrim, AVP2010 make a small screen on the upper left corner, some make a small 640x480 most Dirt series and then it can sometime conflict with it.

btw none of these games produce stutter, although Dirt3 is a big buggy with build in triplebuffer and it can leak cpu usage which makes stutter - they didnt fix it still.

Last edited by -Tj-; 11-17-2012 at 19:42. Reason: typo., upper left corner.
   
Reply With Quote
Old
  (#19)
Penal Stingray
Banned
 
Videocard: GTX 680 Tri-Sli-S27A950
Processor: i7 3930K 4.6 GHZ
Mainboard: Gigabyte UD3 X79
Memory: 16 GB Ripjaws 2200 MHZ
Soundcard: XFi Titanium HD
PSU: Antec HCP 1200 Watts
Default 11-17-2012, 18:22 | posts: 961 | Location: JerZe

Never had this issue but there could be other things that's causing the issue.
   
Reply With Quote
Old
  (#20)
Wagnard
Maha Guru
 
Wagnard's Avatar
 
Videocard: EVGA Signature GTX 690
Processor: I7 3770K
Mainboard: Asus Maximus Gene V
Memory: 16GB corsair DDR 3
Soundcard: Realtek
PSU: Corsair 1k Watt
Default 11-17-2012, 19:10 | posts: 1,414 | Location: Laval (Qc) , Canada

for darksiders 2 , alt-tab out and then in.
Stutter for me went away
   
Reply With Quote
Old
  (#21)
RecluSe
Master Guru
 
RecluSe's Avatar
 
Videocard: EVGA GTX 780Ti SC/ACX
Processor: Intel i5 2500k 4.5 GHz
Mainboard: Asus P8Z77-V LX
Memory: Corsair 8GB DDR3 1600Mhz
Soundcard: Asus Xonar D2X
PSU: Corsair TX 650W
Default 11-17-2012, 19:54 | posts: 686 | Location: UK

Quote:
Originally Posted by Wagnard View Post
for darksiders 2 , alt-tab out and then in.
Stutter for me went away
Just went back to Darksiders 2, no more stuttering anymore for me. On the 310.54 beta drivers.
   
Reply With Quote
Old
  (#22)
Wagnard
Maha Guru
 
Wagnard's Avatar
 
Videocard: EVGA Signature GTX 690
Processor: I7 3770K
Mainboard: Asus Maximus Gene V
Memory: 16GB corsair DDR 3
Soundcard: Realtek
PSU: Corsair 1k Watt
Default 11-17-2012, 21:45 | posts: 1,414 | Location: Laval (Qc) , Canada

Quote:
Originally Posted by RecluSe View Post
Just went back to Darksiders 2, no more stuttering anymore for me. On the 310.54 beta drivers.
Ya its running a lot better. Still some verry verry smal stutter but fixed with alt-tab out / in
   
Reply With Quote
Old
  (#23)
racingx
Member Guru
 
racingx's Avatar
 
Videocard: EVGA GTX560ti fpb
Processor: Intel i5 2500k
Mainboard: MSI p67a-gd65
Memory: 8g Crucial 1333
Soundcard: Realtek 882 onboard
PSU: Corsair ax750
Default 11-18-2012, 13:55 | posts: 141 | Location: Texas

I started to see this issue the most when I went from windows xp to windows vista. It was most noticable to me in world of warcraft. I actually downgraded to xp until windows 7 came out it was so bad. Over the years it has gotten slightly better but WOW never runs as smooth as it did back in the WinXp days for me.
   
Reply With Quote
Old
  (#24)
snorge
Member Guru
 
Videocard: gtx 560 2GB
Processor: Core 2 Duo @3.4
Mainboard:
Memory:
Soundcard:
PSU: Antec
Default 11-20-2012, 09:55 | posts: 84

Quote:
Originally Posted by adrock311 View Post


btw, this guy wrote a nice borderless window app here:

http://forums.steampowered.com/forum....php?t=2675769
Confused. If your game has the windowed full screen option is it the same as borderless window fullscreen tweak?
   
Reply With Quote
Old
  (#25)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 11-20-2012, 16:35 | posts: 753

Quote:
Originally Posted by snorge View Post
Confused. If your game has the windowed full screen option is it the same as borderless window fullscreen tweak?
yes, that is correct. I know diablo 3 and borderlands 2 have a built in option for "fullscreen windowed" mode.

Last edited by adrock311; 11-20-2012 at 16:38.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.