Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD Radeon Catalyst Drivers Section
Videocards - AMD Radeon Catalyst Drivers Section In this section you can discuss everything AMD Catalyst related. Catalyst drivers are for all AMD based graphics cards and APUs.



Closed Thread
 
Thread Tools Display Modes
AMD Catalyst 12.11 BETA (9.010.8 October 12)
Old
  (#1)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: Sapphire Nitro+ RX480 8GB
Processor: i7 3770k @ 4.9GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 16GB G.Skill 2133Mhz CL9
Soundcard: Asus Strix Soar
PSU: CoolerMaster Vanguard 850
Talking AMD Catalyst 12.11 BETA (9.010.8 October 12) - 10-22-2012, 12:41 | posts: 1,196 | Location: iTALY

Enjoy


[b]UPDATE download is active again/b]

> Download <

Driver Review



Build Info:
DriverVer=10/12/2012, 9.010.8.0000
9.01.8-121012a-147510E-ATI
CCC: 2012.1013.139.1062
2D: 8.01.01.1278
D3D: 9.14.10.0942
OGL: 6.14.10.11973
OCL: 10.0.1084.2

Supported Cards:
 Click to show spoiler


Last edited by asder00; 10-22-2012 at 12:55.
   
 
Old
  (#2)
MerolaC
Ancient Guru
 
MerolaC's Avatar
 
Videocard: Sapphire NITRO R9 390 8GB
Processor: i7 6700k@Stock@CorsairH60
Mainboard: ASUS Maximus VIII Ranger
Memory: Vengeance LPX 16G@3200
Soundcard: SB Titanium HD
PSU: OCZ Fatal1ty G.G. - 750w
Default 10-22-2012, 12:42 | posts: 2,797 | Location: Argentina

Thanks a lot!


BTW, any version without NET Framework 4? I don't want to download something that came with something else that I Already have. LOL

Thanks none the less.
   
Old
  (#3)
ankinferno
Master Guru
 
ankinferno's Avatar
 
Videocard: GeForce GT 840M
Processor: Intel Core i5-4210U
Mainboard: Intel Lynx Point-LP
Memory: DDRIII - 8GB / 1600 MHz
Soundcard: Realtek / CreativeSBSA335
PSU: __
Talking 10-22-2012, 12:44 | posts: 315

My Hero.....

Thank U Bro...
   
Old
  (#4)
pakoo
Member Guru
 
Videocard: 295 X2 + 290X Tri-crossfi
Processor: I7 4790K @ 4.7 Ghz HT ON
Mainboard: Gigabyte GA-Z87X-UD3H
Memory: 16 GB Kingston 1866 Mhz
Soundcard: Ozone Strato 5.1 EVO
PSU: TX950
Default 10-22-2012, 12:44 | posts: 104 | Location: SPAIN

Yahhhhhh!!!!!111!!!.

I love you Asder .
   
 
Old
  (#5)
vejn
Maha Guru
 
vejn's Avatar
 
Videocard: MSI 7870 TF3
Processor: Core i5 3350P
Mainboard: MSI B75 G41
Memory: 4 Gb DDR
Soundcard:
PSU: 500W
Default 10-22-2012, 12:46 | posts: 1,002

Asder please, legacy driver for Win XP!!!
   
Old
  (#6)
TestDriver
Member Guru
 
Videocard: 980 Ti
Processor: I5 3570K@ 4.2
Mainboard: P8Z77-V Deluxe
Memory: Corsair Vengeance LP 8GB
Soundcard: OnBoard, Logitech z906
PSU: Corsair HX850
Default 10-22-2012, 12:46 | posts: 88 | Location: Norway

Looking forward to testing these ones!

Thanks alot
   
Old
  (#7)
Terepin
Master Guru
 
Terepin's Avatar
 
Videocard: MSI GTX 1080 GAMING X
Processor: Core i7-6700K
Mainboard: ASUS ROG STRIX H270F
Memory: Corsair DDR4 2x8 GB @2133
Soundcard: ROG SupremeFX S1220A
PSU: Seasonic SS-860XP
Default 10-22-2012, 12:53 | posts: 596 | Location: Košice, Slovakia

Great, DXVA is broken. AGAIN! This is ridiculous!
   
Old
  (#8)
Prasad007
Member Guru
 
Prasad007's Avatar
 
Videocard: AMD Radeon HD 7970M 2GB
Processor: Intel® Core™ i7-3820QM
Mainboard: Dell Alienware M17x R4
Memory: 16GB DDR3 1600MHz
Soundcard: Sound Blaster Recon3Di
PSU: Smart 9-Cell Li-ion 90Wh
Default 10-22-2012, 12:54 | posts: 97 | Location: Bangalore, India

Sticky thread!
   
Old
  (#9)
Progeny
Member Guru
 
Videocard: GTX 670 DC2T @ 1300 MHz
Processor: Intel Core i7 3770K
Mainboard: ASUS Maximus V Gene
Memory: G.Skill Sniper 8GB 1866
Soundcard:
PSU: XFX Pro 450W Core Edition
Default 10-22-2012, 12:54 | posts: 47

First download link won't start and the second link is extremely slow; 8 hours of waiting time.
   
Old
  (#10)
V-FrIeNd
Member Guru
 
Videocard: GTX 750Ti
Processor: i5 4590S
Mainboard: ECS Z97-PK
Memory: XPG V2 2400/8GB
Soundcard: Xonar DX
PSU: FSP 550W
Default 10-22-2012, 13:02 | posts: 142 | Location: Bangkok, Thailand

I love you.
   
Old
  (#11)
Stone Gargoyle
Ancient Guru
 
Stone Gargoyle's Avatar
 
Videocard: AMD R9 270 2GB
Processor: Phenom II X4 Quad 3.4 OC
Mainboard: Asus M5A78L-M
Memory: G-Skill 8GB DDR3
Soundcard:
PSU: OCZ 620W
Default 10-22-2012, 13:04 | posts: 5,286

And lo the heavens slowly opened and a new driver emerged.

Thanks Asder!
   
Old
  (#12)
Prasad007
Member Guru
 
Prasad007's Avatar
 
Videocard: AMD Radeon HD 7970M 2GB
Processor: Intel® Core™ i7-3820QM
Mainboard: Dell Alienware M17x R4
Memory: 16GB DDR3 1600MHz
Soundcard: Sound Blaster Recon3Di
PSU: Smart 9-Cell Li-ion 90Wh
Default 10-22-2012, 13:07 | posts: 97 | Location: Bangalore, India

Quote:
Originally Posted by Progeny View Post
First download link won't start and the second link is extremely slow; 8 hours of waiting time.
Luckily got it off the first link early! Try it now.. still works for me.
   
Old
  (#13)
Prasad007
Member Guru
 
Prasad007's Avatar
 
Videocard: AMD Radeon HD 7970M 2GB
Processor: Intel® Core™ i7-3820QM
Mainboard: Dell Alienware M17x R4
Memory: 16GB DDR3 1600MHz
Soundcard: Sound Blaster Recon3Di
PSU: Smart 9-Cell Li-ion 90Wh
Default 10-22-2012, 13:09 | posts: 97 | Location: Bangalore, India

Would I have to do a clean install of this driver to truly gain the performance increments? Or is it okay to have installed over 12.9 Beta?
   
Old
  (#14)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 5960K
Mainboard: X99
Memory: 16GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 10-22-2012, 13:11 | posts: 28,948 | Location: Guru3D testlab

We might need to take these drivers offline, AMD is creating a new build to fix some bugs that are in this version. Just so that you guys know !


Follow Guru3D on twitter - facebook and Youtube.
   
Old
  (#15)
Espionage724
 
Videocard:
Processor:
Mainboard:
Memory:
Soundcard:
PSU:
Default 10-22-2012, 13:12 | posts: n/a

Quote:
Originally Posted by Prasad007 View Post
Would I have to do a clean install of this driver to truly gain the performance increments? Or is it okay to have installed over 12.9 Beta?
It's recommended to do a clean install for all drivers I believe.
   
Old
  (#16)
jud666
Newbie
 
Videocard: Sapphire hd7850 2gb
Processor: 955 be @ 3.8ghz
Mainboard: M4a77T
Memory: XMS3 8gb
Soundcard:
PSU: 750w OCZ
Default 10-22-2012, 13:12 | posts: 6 | Location: England, Sheffield

Mine is slowly speeding up now, something is being improved !
   
Old
  (#17)
ClockClocker
Master Guru
 
Videocard: 970 gtx
Processor: Core i5 2500k
Mainboard: Asrock z68 Pro3
Memory: 8GB DDR 1333 Kingston
Soundcard:
PSU: Straight Power E9 580W
Default 10-22-2012, 13:13 | posts: 389

Quote:
Originally Posted by Hilbert Hagedoorn View Post
We might need to take these drivers offline, AMD is creating a new build to fix some bugs that are in this version. Just so that you guys know !
I heard about that too. There are Bugs in this one. Sometimes Buildings in BF3 will pop up pretty late. Thats what i read. It has nothing to do with the performance increasing and it'S not cheating it's just a bug which happens now and then.
   
Old
  (#18)
TestDriver
Member Guru
 
Videocard: 980 Ti
Processor: I5 3570K@ 4.2
Mainboard: P8Z77-V Deluxe
Memory: Corsair Vengeance LP 8GB
Soundcard: OnBoard, Logitech z906
PSU: Corsair HX850
Default 10-22-2012, 13:15 | posts: 88 | Location: Norway

hmm, tried to install this on my gigabyte 7950 GF3 now, and didn't get the option to install the driver, just SDK and CCC? Anyone know why, using Vista64


hmm, checking the unpack path I can't find Vista drivers..
Just reinstalled vista, is there something that prevents me from installing since this driver is unsigned?

Last edited by TestDriver; 10-22-2012 at 13:21.
   
Old
  (#19)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 5960K
Mainboard: X99
Memory: 16GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 10-22-2012, 13:23 | posts: 28,948 | Location: Guru3D testlab

UPDATE - At the request of AMD the driver has been taken offline. They discovered some bugs and a new build is due to be released later today. Please keep checking this post, once we have the new build we'll update the file-mirror and thus the download.


Follow Guru3D on twitter - facebook and Youtube.
   
Old
  (#20)
Undying
Ancient Guru
 
Undying's Avatar
 
Videocard: R9 280X Vapor-X
Processor: Intel i5 @ 4.8Ghz-1.38v
Mainboard: Gigabyte Z68XP-UD3P
Memory: HyperX 16GB @ 2133Mhz
Soundcard: Realtek onboard
PSU: Tt ToughpowerXT 775W
Default 10-22-2012, 13:26 | posts: 9,667 | Location: Serbia, NS

Strange i was just going to download, ah i guess we wait little longer...
   
Old
  (#21)
diwik
Newbie
 
Videocard: XFX HD5870 1Gb (stock)
Processor: Intel i5-2500K@4.5
Mainboard: Asus Sabertooth P67
Memory: SEC DDR3/8GB/1866Mhz
Soundcard: Int/ALC 892
PSU: Acbel 750W
Default 10-22-2012, 13:27 | posts: 12 | Location: Russia\Neftekamsk

Ok! Wait new build
   
Old
  (#22)
Xzibit
Banned
 
Videocard: 7970 Windforce
Processor: i5 3570K/H70
Mainboard: ASUS Z77VLX
Memory: 8Gb 2,2GHz, 1.5V
Soundcard: Creative X-Fi
PSU: Thermaltake 850W
Default 10-22-2012, 13:33 | posts: 4,383 | Location: Europe

Thanks
I managed to download it before it was deleted. Playing now with it in 3Dmark \
   
Old
  (#23)
TheOriginalTO
Master Guru
 
Videocard: ATI 5870m
Processor: Intel Core i7 Q720
Mainboard: ASUS G73JH
Memory: 6.00
Soundcard:
PSU: Rbbx05
Default 10-22-2012, 13:35 | posts: 287

I was wondering when another driver would spawn from the depths of amd's hell cellar. haha Hope it's up later today! ATI 5870m would love more good drivers.
   
Old
  (#24)
Didusieq
Member Guru
 
Videocard: Asus Strix GTX 970
Processor: Intel Core i7-4790K
Mainboard: Asus Maximus VII Ranger
Memory: A-Data 16GB DDR3 1600 MHz
Soundcard: Marantz + Pylon Audio ;)
PSU: Modecom Volcano 750W
Default 10-22-2012, 13:46 | posts: 45 | Location: Poland

For me its a big difference. No changes in the system!

12.8
https://picasaweb.google.com/lh/phot...eat=directlink

12.11
https://picasaweb.google.com/lh/phot...eat=directlink

Amazing...
   
Old
  (#25)
jud666
Newbie
 
Videocard: Sapphire hd7850 2gb
Processor: 955 be @ 3.8ghz
Mainboard: M4a77T
Memory: XMS3 8gb
Soundcard:
PSU: 750w OCZ
Default 10-22-2012, 13:47 | posts: 6 | Location: England, Sheffield

Damn you all.
   
Closed Thread

Tags
@asder00

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.