Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA Drivers Section
Videocards - NVIDIA Drivers Section In this section you can discuss everything ForceWare driver related. ForceWare (Detonator) drivers are for NVIDIA TNT, Quadro and all GeForce based videocards.


Reply
 
Thread Tools Display Modes
Borderlands 2 + MSI 670 oc + Physx High
Old
  (#1)
mentalpeace
Member Guru
 
Videocard: MSI GTX 670 Oc edition
Processor: Intel I7 2600K @ 4.2ghz
Mainboard: ASUS P8Z68-V PRO
Memory: 8GB DDR3 K.HyperX 1600mhz
Soundcard:
PSU: XFX 650 XXX
Default Borderlands 2 + MSI 670 oc + Physx High - 09-26-2012, 18:24 | posts: 78 | Location: Argentina

Hey, i bought a MSI 670 OC edition yesterday.

There is an outstanding difference comparing with a 6850 crossfire. Everything seems smoother, and im not talking about FPS, it is a different feeling... 45 fps ingame with the 670 seems like 60 fps in the crossfire. Also everything looks smoother in terms of quality.

I love how it works for Physx. Batman (Max settings Dx11 Physx high) is REALLY enjoyable. Mafia II is lovely.

The thing is in Borderlands 2 (1080, Max setings, Physx high) when a lot of action is going on (especially with 3 team mates) the fps go as low as 38 or so... its kinda annoying. The GPU usage at those moments are 60%~ so i figured that must be a driver problem.

Sorry for the english!
   
Reply With Quote
 
Old
  (#2)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 09-26-2012, 18:48 | posts: 465

I do believe it is a driver problem with the 6xxx series. Lots of reports of 560-580 cards getting better performance. Hopefully it is sorted out soon.
   
Reply With Quote
Old
  (#3)
dnottis
Master Guru
 
Videocard: Zotac GTX 680 1310/7000
Processor: i7 2600k @ 4.7ghz 1.35v
Mainboard: Asus P8P67
Memory: 16GB G.Skill RipJaws 1600
Soundcard: X-FI Titanium PCI-e
PSU: Coolermaster 1100
Default 09-26-2012, 19:05 | posts: 676

Its physx, having it on high with lots of stuff happening kills FPS quick. I've got a single 680 overclocked to 1290 and I get slow downs in huge battles with physx on high (1680x1050).

Physx has always been a taxing technology. try installing the latest 0613 physx from nvidia but thats really all you can do for now. Otherwise, drop it a notch.

http://www.nvidia.com/object/physx-9...13-driver.html


Physx will render cloth and stuff happening in the area you in not just particles from guns / etc. Keep this in mind alot of times thats why you are seeing slowdowns, it's not just whats happening from the battle...

Last edited by dnottis; 09-26-2012 at 19:12.
   
Reply With Quote
Old
  (#4)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 09-26-2012, 19:15 | posts: 465

I get the performance dips with Physx on medium and high. Sometimes even when there are no particles, only complicated scenery in the distance I will drop to 40-50. GPU usage never goes above 70% at any time either. Some on Neogaf have reported Nvidia is aware of the issue and that it mostly affects the 6xx series. Many are getting better performance on 570/580.

Along with the vsync stutter issue that plagued these cards, I wonder if there is a very real defect in the hardware somewhere.




This is from a trustworthy source. Can any of the Nvidia officials here comment on this?

Last edited by NeoandGeo; 09-26-2012 at 19:28.
   
Reply With Quote
 
Old
  (#5)
dnottis
Master Guru
 
Videocard: Zotac GTX 680 1310/7000
Processor: i7 2600k @ 4.7ghz 1.35v
Mainboard: Asus P8P67
Memory: 16GB G.Skill RipJaws 1600
Soundcard: X-FI Titanium PCI-e
PSU: Coolermaster 1100
Default 09-26-2012, 19:35 | posts: 676

Quote:
Originally Posted by NeoandGeo View Post
Many are getting better performance on 570/580.
Its because of the dynamic clocks. They really need to disable that entirely if you choose a high performance setting. I set mine for max performance, but from what I understand if a game isn't pushing it hard and the usage is low the clock can drop causing these "performance" drops. With mine at max performance I've never seen the clock drops.
   
Reply With Quote
Old
  (#6)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 09-26-2012, 19:40 | posts: 465

My clocks stay steady through the performance drops.
   
Reply With Quote
Old
  (#7)
Spets
Maha Guru
 
Spets's Avatar
 
Videocard: GTX780Ti+GTX750Ti+G-Sync
Processor: Intel Core i7 2600k @ 4.5
Mainboard: GA-Z68X-UD7-B3
Memory: G.Skill Ripjaws 16gb 2133
Soundcard:
PSU: EVGA SuperNOVA
Default 09-26-2012, 19:43 | posts: 2,137

Quote:
Originally Posted by NeoandGeo View Post
I get the performance dips with Physx on medium and high. Sometimes even when there are no particles, only complicated scenery in the distance I will drop to 40-50. GPU usage never goes above 70% at any time either. Some on Neogaf have reported Nvidia is aware of the issue and that it mostly affects the 6xx series. Many are getting better performance on 570/580.

Along with the vsync stutter issue that plagued these cards, I wonder if there is a very real defect in the hardware somewhere.

*snip*

This is from a trustworthy source. Can any of the Nvidia officials here comment on this?
Nvidia officials have commented about it over at GeForce.com. There should be a patch for Borderlands 2 that increases performance from Gearbox/2k and I'm assuming there will be one at a driver level too.
   
Reply With Quote
Old
  (#8)
dnottis
Master Guru
 
Videocard: Zotac GTX 680 1310/7000
Processor: i7 2600k @ 4.7ghz 1.35v
Mainboard: Asus P8P67
Memory: 16GB G.Skill RipJaws 1600
Soundcard: X-FI Titanium PCI-e
PSU: Coolermaster 1100
Default 09-26-2012, 19:48 | posts: 676

Quote:
Originally Posted by NeoandGeo View Post
My clocks stay steady through the performance drops.
I meant in general, thats why the 400/500 series are sometimes perceived as faster. I use max performance and mine only drops when it's idle. it doesnt drop in any game, some people dont change that setting though in the driver CP.
   
Reply With Quote
Old
  (#9)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 09-26-2012, 19:50 | posts: 465

Just confirmed, and at least for me, that setting didn't have any effect on Borderlands 2 performance. I am pretty sure that setting is just placebo on the 6xx series cards.
   
Reply With Quote
Old
  (#10)
dnottis
Master Guru
 
Videocard: Zotac GTX 680 1310/7000
Processor: i7 2600k @ 4.7ghz 1.35v
Mainboard: Asus P8P67
Memory: 16GB G.Skill RipJaws 1600
Soundcard: X-FI Titanium PCI-e
PSU: Coolermaster 1100
Default 09-26-2012, 19:53 | posts: 676

Quote:
Originally Posted by NeoandGeo View Post
Just confirmed, and at least for me, that setting didn't have any effect on Borderlands 2 performance. I am pretty sure that setting is just placebo on the 6xx series cards.
I know, the borderlands 2 issue is different. I always run mine set for max performance, it's water cooled and I've got a 1100 watt PSU so I dont care about heat or power used.
   
Reply With Quote
 
Old
  (#11)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 09-26-2012, 19:55 | posts: 465

Is there any evidence that max performance setting actually does anything for the 6 series? If I run into issues it is the first thing I try, and it always has the same end result of making no difference.
   
Reply With Quote
Old
  (#12)
mentalpeace
Member Guru
 
Videocard: MSI GTX 670 Oc edition
Processor: Intel I7 2600K @ 4.2ghz
Mainboard: ASUS P8Z68-V PRO
Memory: 8GB DDR3 K.HyperX 1600mhz
Soundcard:
PSU: XFX 650 XXX
Default 09-26-2012, 20:06 | posts: 78 | Location: Argentina

Ok so all we gave to do is wait for a patch.

Im so impressed right now with the overall performance that i dont care waiting like 3 months for it .

Best videocard i bought in many many years. (8600gt - 8800gt - ati 4850 - amd 5850 - amd 6850 Toxic crossfire - 670 GTX).

Its a freaking monster.
   
Reply With Quote
Old
  (#13)
dnottis
Master Guru
 
Videocard: Zotac GTX 680 1310/7000
Processor: i7 2600k @ 4.7ghz 1.35v
Mainboard: Asus P8P67
Memory: 16GB G.Skill RipJaws 1600
Soundcard: X-FI Titanium PCI-e
PSU: Coolermaster 1100
Default 09-26-2012, 20:12 | posts: 676

Quote:
Originally Posted by NeoandGeo View Post
Is there any evidence that max performance setting actually does anything for the 6 series? If I run into issues it is the first thing I try, and it always has the same end result of making no difference.
yea it down clocks different steps. i think the max performance option is either low clock / idle or max clock / loaded.

using the power option lets the card clock down over multiple clock speed steps.
   
Reply With Quote
Old
  (#14)
NeoandGeo
Master Guru
 
Videocard: Geforce GTX 680
Processor: Intel Core i7 2600k @4.6
Mainboard: GA-P67A-UD4B3
Memory: 16GB DDR3 1600 RipJaws
Soundcard: HT Omega Claro+ 7.1
PSU: Corsair 750w
Default 09-26-2012, 20:15 | posts: 465

Give an example.
   
Reply With Quote
Old
  (#15)
Matt151b
Master Guru
 
Videocard: Gtx 670
Processor: i5-3570k
Mainboard: ASUS P8Z77-V Pro
Memory: 8gb ddr3
Soundcard: onboard
PSU: PC Power and Cooling 750W
Default 09-26-2012, 20:29 | posts: 436 | Location: California, USA

670 owner here. Never have issues with The game. Physx is on high and all maxed at 1920x1200. Stays pegged at 60 fps for me.
   
Reply With Quote
Old
  (#16)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 09-26-2012, 20:49 | posts: 753

If i turn on physx high and play coop with my 670, the framerate drops are terrible.
   
Reply With Quote
Old
  (#17)
adrock311
Master Guru
 
Videocard: EVGA GTX 670 4gb SC
Processor: i5 2500k @ 4ghz
Mainboard: GIGABYTE GA-Z68X-UD3H-B3
Memory: 8 gb DDR3 1600mhz
Soundcard: Creative Soundblaster Z
PSU: 850 watt Thermaltake
Default 09-26-2012, 20:51 | posts: 753

Quote:
Originally Posted by NeoandGeo View Post
I get the performance dips with Physx on medium and high. Sometimes even when there are no particles, only complicated scenery in the distance I will drop to 40-50. GPU usage never goes above 70% at any time either.
yes, i've noticed, while using fraps, that just staring into the distance in certain directions in certain areas drops my fps into the 30's and 40's on a GTX 670. strange
   
Reply With Quote
Old
  (#18)
Matt151b
Master Guru
 
Videocard: Gtx 670
Processor: i5-3570k
Mainboard: ASUS P8Z77-V Pro
Memory: 8gb ddr3
Soundcard: onboard
PSU: PC Power and Cooling 750W
Default 09-26-2012, 20:56 | posts: 436 | Location: California, USA

Could it be hdd related? I moved my game to ssd right after install. I have a system like many of you, but mine has been trouble free. I have been in some big 4 way coop fights and never have trouble.
   
Reply With Quote
Old
  (#19)
The Phoenix
Maha Guru
 
The Phoenix's Avatar
 
Videocard: 4870 temp
Processor: 3770k@4.8ghz/hyper212+
Mainboard: biostar tz68a+ z68
Memory: 8 gig g-skill DDR3
Soundcard: onboard hd audio
PSU: CORSAIR 650w
Default 09-26-2012, 21:04 | posts: 958

same here trouble free and i dont have an ssd ,pegged at 60.1fps i do use vsync
   
Reply With Quote
Old
  (#20)
Matt151b
Master Guru
 
Videocard: Gtx 670
Processor: i5-3570k
Mainboard: ASUS P8Z77-V Pro
Memory: 8gb ddr3
Soundcard: onboard
PSU: PC Power and Cooling 750W
Default 09-26-2012, 21:13 | posts: 436 | Location: California, USA

I use vsync too. Maybe that is the secret ...
   
Reply With Quote
Old
  (#21)
mentalpeace
Member Guru
 
Videocard: MSI GTX 670 Oc edition
Processor: Intel I7 2600K @ 4.2ghz
Mainboard: ASUS P8Z68-V PRO
Memory: 8GB DDR3 K.HyperX 1600mhz
Soundcard:
PSU: XFX 650 XXX
Default 09-26-2012, 21:15 | posts: 78 | Location: Argentina

Quote:
Originally Posted by Matt151b View Post
I use vsync too. Maybe that is the secret ...
mmm i will test when i get home...but there are way too many people reporting these slowdowns...so i dont think that could be the problem. Anyhow, i will try today and report back.
   
Reply With Quote
Old
  (#22)
KingpinZero
Maha Guru
 
KingpinZero's Avatar
 
Videocard: Zotac GTX 780Ti AMP!
Processor: i7-3770k @4.6/Hyper 212+E
Mainboard: Asrock Z77 extreme 3
Memory: G.Skill ARES 1600mhz 8gb
Soundcard: Realtek Crystal HD
PSU: CX750W 80+
Default 09-26-2012, 23:20 | posts: 891 | Location: Rome

Guys try this rapid fix: go into option and lower the FOV. I've lowered it to 82 and all my problems are gone.
Mind you I'm on medium physix, didn't tried high yet.
   
Reply With Quote
Old
  (#23)
Matt151b
Master Guru
 
Videocard: Gtx 670
Processor: i5-3570k
Mainboard: ASUS P8Z77-V Pro
Memory: 8gb ddr3
Soundcard: onboard
PSU: PC Power and Cooling 750W
Default 09-27-2012, 00:35 | posts: 436 | Location: California, USA

Quote:
Originally Posted by KingpinZero View Post
Guys try this rapid fix: go into option and lower the FOV. I've lowered it to 82 and all my problems are gone.
Mind you I'm on medium physix, didn't tried high yet.
I play at fov at 110. No problems for me.
   
Reply With Quote
Old
  (#24)
Pey
Master Guru
 
Pey's Avatar
 
Videocard: EVGA GTX 780Ti @ SLI
Processor: Core i7 2600k @ 5.0ghz
Mainboard: ASUS Maximux V Formula
Memory: 16GB Patriot Extreme D2
Soundcard: Asus Xonar Phoebus
PSU: Seasonic 1000w Plaitnum
Default 09-27-2012, 02:24 | posts: 565 | Location: Argentina

I have a single 680 gtx now, playing 2560x1600 max details, pshyx high and im getting 50-60fps.
   
Reply With Quote
Old
  (#25)
Noisiv
Ancient Guru
 
Videocard: GTX 460 HAWK Talon Attack
Processor: Q6600@3.5GHz
Mainboard: Gigabyte EP-43-DS3L
Memory: 4GB OCZ 5-4-4-4-12
Soundcard: Onboard Realtek ALC888
PSU: Silent Pro M700
Default 09-27-2012, 02:32 | posts: 3,084

Quote:
Originally Posted by dnottis View Post
Its because of the dynamic clocks. They really need to disable that entirely if you choose a high performance setting. I set mine for max performance, but from what I understand if a game isn't pushing it hard and the usage is low the clock can drop causing these "performance" drops. With mine at max performance I've never seen the clock drops.
Keep spreading this dynamic clock bs of yours, but know this:

BL2 fps drops are entirely due to game issues. GPU on 60% usage while having low fps means CPU is trashing due to PhysX calculations done on CPU, leaving GPU starved - hence low GPU usage.

It blows my mind how bad can you be with numbers to think that 20,30, or 60MHz drop on 1000GHz GPU can halve your fps. Not to mention that your usage stays low even after the drop.........

You are barking at the entirely wrong tree
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.