Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA Drivers Section
Videocards - NVIDIA Drivers Section In this section you can discuss everything ForceWare driver related. ForceWare (Detonator) drivers are for NVIDIA TNT, Quadro and all GeForce based videocards.


Reply
 
Thread Tools Display Modes
Another look at HPET High Precision Event Timer
Old
  (#1)
Bukkake
Member Guru
 
Videocard: EVGA SC GTX 780Ti OC
Processor: i7 940 @ 3.7hz
Mainboard: dx58so
Memory: 8GB DDR3-2133
Soundcard: Onboard
PSU: 650 watt
Default Another look at HPET High Precision Event Timer - 09-18-2012, 00:46 | posts: 79 | Location: in the Kingdom

I came across this site

http://www.neowin.net/forum/topic/10...mance-and-fps/

i used to have hpet disabled in bios and it was also disabled in my windows.

now i enabled it in the bios and i enabled it in windows.

i have yet to test any games and i dont really notice any difference

my max latency in dpc latenacy check is 132 us

in the topic there is wildy different results

but with my computer in non gaming related usage i dont see any differnce at all.
   
Reply With Quote
 
Old
  (#2)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 09-18-2012, 10:42 | posts: 3,650 | Location: UK

How do you test if its enabled in windows?
   
Reply With Quote
Old
  (#3)
Prophet
Master Guru
 
Prophet's Avatar
 
Videocard: Msi 680 Gtx Twin Frozr
Processor: Intel Sb@4.7
Mainboard: Asus P8Z68V Progen3
Memory: 12 Gb Kingston
Soundcard: Asus Essence STX|Akg k701
PSU: Corsair 1200w
Default 09-18-2012, 11:03 | posts: 572 | Location: Heaven

Quote:
Originally Posted by HonoredShadow View Post
How do you test if its enabled in windows?
You can only set it in bios. You cannot enable/disable it from windows either. Asus bioses tend to have it, other vendors you have a to have a bit of luck. I think more and more are implementing it in bios updates.

Edit: You can enable/disable hpet from the devmanager but that doesnt enable/disable it.

Edit 2.

Last edited by Prophet; 09-18-2012 at 13:16.
   
Reply With Quote
Old
  (#4)
IcE
Ancient Guru
 
IcE's Avatar
 
Videocard: Zotac GTX 780
Processor: i5 3570K @4.0
Mainboard: ASRock Z77 Extreme6
Memory: 8GB G.Skill Sniper 1866
Soundcard: SBZ + Aune T1 + CAL
PSU: Enermax NAXN 82+ 750W
Default 09-18-2012, 11:24 | posts: 9,188 | Location: Toledo

Quote:
Originally Posted by HonoredShadow View Post
How do you test if its enabled in windows?
You assume it's on unless you've turned it off in the BIOS.
   
Reply With Quote
 
Old
  (#5)
WhiteLightning
Ancient Guru
 
WhiteLightning's Avatar
 
Videocard: EVGA 780GTX ACX
Processor: i7-2600k HT @ 4.5 +H70 PP
Mainboard: MSI Z77A-GD65 GAMING
Memory: Gskill 2133Mhz 8GB
Soundcard: Onboard
PSU: Corsair 1000 watt
Default 09-18-2012, 12:46 | posts: 23,493 | Location: Hoek van Holland, Netherlands

Quote:
Originally Posted by HonoredShadow View Post
How do you test if its enabled in windows?
You need WinTimerTester 1.1 to test it. its off by default (even for windows 8).
(so setting in the bios alone does nothing, has to be enabled in windows aswell).
   
Reply With Quote
Old
  (#6)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 09-18-2012, 13:47 | posts: 3,650 | Location: UK

Really? Oh! It is on by default on my PC but its not doing anything then?

Is it best on or off in bios and windows?
   
Reply With Quote
Old
  (#7)
WhiteLightning
Ancient Guru
 
WhiteLightning's Avatar
 
Videocard: EVGA 780GTX ACX
Processor: i7-2600k HT @ 4.5 +H70 PP
Mainboard: MSI Z77A-GD65 GAMING
Memory: Gskill 2133Mhz 8GB
Soundcard: Onboard
PSU: Corsair 1000 watt
Default 09-18-2012, 13:53 | posts: 23,493 | Location: Hoek van Holland, Netherlands

Quote:
Originally Posted by HonoredShadow View Post
Really? Oh! It is on by default on my PC but its not doing anything then?

Is it best on or off in bios and windows?
i really dont know. there are positive and negative reports. best is to see for yourself.
i wanted to use dpclatency checker , but since im on windows 8 its not supported as of yet. giving the wrong values
   
Reply With Quote
Old
  (#8)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 09-18-2012, 14:17 | posts: 3,650 | Location: UK

Well I did try with it off in the past and what i saw happen with DPC Latency tester was that my overall latency (idle) was done consistently but when I did do something like load a game or open firefox etc. then I noticed the latency spiked higher than before by quiet a bit.

This was all of course without me knowing that I had to enable it in Windows (which I have no clue how too!)

I'm sure I already had a thread on this.

Last edited by HonoredShadow; 09-18-2012 at 14:28.
   
Reply With Quote
Old
  (#9)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 09-18-2012, 14:27 | posts: 3,650 | Location: UK

http://forums.guru3d.com/search.php?searchid=3982593

I must have added to another thread as I can't find one I started.

I think I added to the discussion in this thread. Starting at the end of the thread and back:

http://forums.guru3d.com/showthread....highlight=hpet

Last edited by HonoredShadow; 09-18-2012 at 14:35.
   
Reply With Quote
Old
  (#10)
Noisiv
Ancient Guru
 
Videocard: GTX 460 HAWK Talon Attack
Processor: Q6600@3.5GHz
Mainboard: Gigabyte EP-43-DS3L
Memory: 4GB OCZ 5-4-4-4-12
Soundcard: Onboard Realtek ALC888
PSU: Silent Pro M700
Default 09-18-2012, 15:07 | posts: 3,020

Snake oil
   
Reply With Quote
 
Old
  (#11)
-Tj-
Ancient Guru
 
-Tj-'s Avatar
 
Videocard: ZOTAC GTX780 OC AmpFan
Processor: i7 4770K OC 4.7GHz @1.28v
Mainboard: ASUS Z87 Deluxe
Memory: Crucial BLE 16GB 2400MHz
Soundcard: Creative X-Fi Titanium HD
PSU: Chieftec NTRO88+ 650W
Default 09-18-2012, 15:15 | posts: 8,094 | Location: Urban`Jungle

Quote:
Originally Posted by WhiteLightning View Post
You need WinTimerTester 1.1 to test it. its off by default (even for windows 8).
(so setting in the bios alone does nothing, has to be enabled in windows aswell).
If its running at 14.31818MHz then its enabled.


And to use this 14.3mhz as the only clock open CMD (run as administrator) and type in bcdedit /set useplatformclock true


I use this option since Vista days and it never caused any issues at 90-150us, actually it helped with X-FI drivers, if i used 2MHz (HPET off) i got some 250-350us spikes time to time.
   
Reply With Quote
Old
  (#12)
PhazeDelta1
Ancient Guru
 
PhazeDelta1's Avatar
 
Videocard: EVGA 780Ti Classified SLI
Processor: Intel i7 4770k
Mainboard: Asus Sabertooth Z87
Memory: 16GB Corsair 2133MHz
Soundcard: Creative SB Z
PSU: EVGA SuperNOVA 1200 P2
Default 09-18-2012, 15:34 | posts: 13,602 | Location: USA

Quote:
Originally Posted by Noisiv View Post
Snake oil

More like Placebo.
   
Reply With Quote
Old
  (#13)
kalston
Newbie
 
Videocard: Gigabyte GTX 670
Processor: Intel i5 2500k
Mainboard:
Memory:
Soundcard:
PSU: Seasonic X Series 560w
Default 09-18-2012, 15:42 | posts: 9

Not exactly placebo.

When I enable it in windows and get 14.3 or so mhz in wintimertester my system feels completely different. It is smoother but everything is somewhat slower and delayed. The difference is very noticeable for me (and some other people have reported the same thing on neowin forums).

And regardless of the windows configuration enabling it or not in the bios makes a slight difference in terms of DPC latency (apparently windows uses different timers by default so disabling HPET in the bios means one less conflicting timer to use and lower DPC latency). However apart from the DPC latency readings I certainly can't tell the difference in benchmarks or games between HPET ON/OFF in the bios. It's only by enabling it in both windows and the bios that I notice a BIG (and NEGATIVE) difference. Why don't you just try it for yourself? It's harmless and easy to revert the changes.

Last edited by kalston; 09-18-2012 at 15:51.
   
Reply With Quote
Old
  (#14)
Svarog
Ancient Guru
 
Svarog's Avatar
 
Videocard: Zotac GTX 680 4GB
Processor: Intel Core 4770K
Mainboard: Gigabyte Z87X-UD5H
Memory: 8GB G.Skill ARES 2133 MHz
Soundcard: SoundBlaster ZxR
PSU: Seasonic Platinum 760
Default 09-18-2012, 17:36 | posts: 3,828 | Location: The Netherlands

Running at 14.31818 MHz for me.

I enabled it not long ago. Set it to 64-Bit in BIOS and enabled it in Windows with the Command shown earlier.

Ever since i enabled it everything ingame does feel somewhat smoother.
   
Reply With Quote
Old
  (#15)
Mineria
Ancient Guru
 
Mineria's Avatar
 
Videocard: ASUS STRIX GTX 970
Processor: Intel i7 4770K
Mainboard: Asus Maximus VI Formula
Memory: 32G G.Skill TridentX
Soundcard: Asus Phoebus
PSU: EVGA SuperNova 1000 G2
Default 09-18-2012, 18:04 | posts: 3,071 | Location: Denmark

Quote:
Originally Posted by HonoredShadow View Post
How do you test if its enabled in windows?
From CMD: bcdedit /enum
One line should say: useplatformclock Yes

Althoug it seems to be more related to FSB overclocking.

Quote:
Some motherboards/BIOSes dynamically varies the FSB
frequency depending on the processor's load, and this results in TSC
(Time Stamp Counter, the internal processors' clocks) not being longer
the reliable source of time, even if processor claims it is; and some
of Windows timer-related API becomes broken as the sequence.
Actually, this does not cause any real performance degradation,
however, just looking into outputs one can easily suppose that
there is serious performance degradation.
Ive seen a few mention that it fixes multimedia playback issues, and even IBM advices that it gets via bcdedit enabled for certain software/hardware combinations.

EDIT: Something for Windows 8 users:
bcdedit /set disabledynamictick yes
What it will do is stop Windows from coalescing CPU clock ticks when idle, a feature added in Windows 8 for power savings.

If you have real high DPC spikes your better of investigating which driver or software that causes it thou, since neither of the 2 settings above will help upon that.

Last edited by Mineria; 09-18-2012 at 18:25.
   
Reply With Quote
Old
  (#16)
Mineria
Ancient Guru
 
Mineria's Avatar
 
Videocard: ASUS STRIX GTX 970
Processor: Intel i7 4770K
Mainboard: Asus Maximus VI Formula
Memory: 32G G.Skill TridentX
Soundcard: Asus Phoebus
PSU: EVGA SuperNova 1000 G2
Default 09-18-2012, 18:35 | posts: 3,071 | Location: Denmark

Quote:
Originally Posted by kalston View Post
Not exactly placebo.

When I enable it in windows and get 14.3 or so mhz in wintimertester my system feels completely different. It is smoother but everything is somewhat slower and delayed. The difference is very noticeable for me (and some other people have reported the same thing on neowin forums).

And regardless of the windows configuration enabling it or not in the bios makes a slight difference in terms of DPC latency (apparently windows uses different timers by default so disabling HPET in the bios means one less conflicting timer to use and lower DPC latency). However apart from the DPC latency readings I certainly can't tell the difference in benchmarks or games between HPET ON/OFF in the bios. It's only by enabling it in both windows and the bios that I notice a BIG (and NEGATIVE) difference. Why don't you just try it for yourself? It's harmless and easy to revert the changes.
What kind of motherboard are you using?
You should also check the output with this tool: http://www.resplendence.com/latencymon or with xperf: http://social.technet.microsoft.com/...2-cea920296271
   
Reply With Quote
Old
  (#17)
Prophet
Master Guru
 
Prophet's Avatar
 
Videocard: Msi 680 Gtx Twin Frozr
Processor: Intel Sb@4.7
Mainboard: Asus P8Z68V Progen3
Memory: 12 Gb Kingston
Soundcard: Asus Essence STX|Akg k701
PSU: Corsair 1200w
Default 09-18-2012, 18:36 | posts: 572 | Location: Heaven

Quote:
Originally Posted by Mineria View Post
From CMD: bcdedit /enum
One line should say: useplatformclock Yes

Althoug it seems to be more related to FSB overclocking.

Ive seen a few mention that it fixes multimedia playback issues, and even IBM advices that it gets via bcdedit enabled for certain software/hardware combinations.

EDIT: Something for Windows 8 users:
bcdedit /set disabledynamictick yes
What it will do is stop Windows from coalescing CPU clock ticks when idle, a feature added in Windows 8 for power savings.

If you have real high DPC spikes your better of investigating which driver or software that causes it thou, since neither of the 2 settings above will help upon that.
http://www.sevenforums.com/general-d...e-command.html


bcdedit /set useplatformclock true (then reboot) is said to enable HPET using Win 7.

bcdedit /deletevalue useplatformclock (then reboot) is said to remove it.

So full credit goes to the guy on sevenforums.
   
Reply With Quote
Old
  (#18)
Mineria
Ancient Guru
 
Mineria's Avatar
 
Videocard: ASUS STRIX GTX 970
Processor: Intel i7 4770K
Mainboard: Asus Maximus VI Formula
Memory: 32G G.Skill TridentX
Soundcard: Asus Phoebus
PSU: EVGA SuperNova 1000 G2
Default 09-18-2012, 18:38 | posts: 3,071 | Location: Denmark

Quote:
Originally Posted by Prophet View Post
http://www.sevenforums.com/general-d...e-command.html


bcdedit /set useplatformclock true (then reboot) is said to enable HPET using Win 7.

bcdedit /deletevalue useplatformclock (then reboot) is said to remove it.

So full credit goes to the guy on sevenforums.
It will not enable it if it is disabled in your BIOS.
Quest was: How do you check if it is enabled on Windows, btw.
Where the command is: bcdedit /enum

Last edited by Mineria; 09-18-2012 at 18:43.
   
Reply With Quote
Old
  (#19)
brendanvista
Master Guru
 
Videocard: 2x GTX 480 SLI
Processor: AMD FX-8150 @4.5Ghz w/H2O
Mainboard: GIGABYTE GA-990FXA-UD3
Memory: DDR3 1866 16GB
Soundcard: Xonar D1
PSU: PC Power & Cooling 950W
Default 09-18-2012, 19:20 | posts: 223 | Location: Oregon

If you run this tool and it says 14.xxxx mhz, then you have it enabled.
http://www.mediafire.com/?xzo9n84d8lze9nb
I just did this tweak; I'll do some testing and see how things go.
   
Reply With Quote
Old
  (#20)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 09-18-2012, 19:47 | posts: 9,769 | Location: UK

I tried this last night and it made very little difference for me, but I didnt have any issues with jerkiness or perfomance before this.
Before doing it, wintimertester reported my QueryperformanceFrequency as 3MHz, after it was 14MHz (to clarify that HPET is fully active and is the sole event timer).
I did a few benchmarks prior and afterwards, namely Heaven 2.5, Heaven 3.0 (both GPU limited), Crysis Warhead DX10 (GPU limited) and X3:TC benchmark (CPU limited).

Results:
All results were identical (within 1%) except X3:TC which dropped from 141fps to 131fps (7% drop).

Further observations:
During the loading of Crysis warhead, the grey loading map showed more frames on screen.
There is a lot more EM noise on my microphone socket on my Auzentech Prelude soundcard (used for listening to satellite TV through PC as I'm not using a pre-amp or audio switch), while running the benchmarks.

I dont doubt that some people will find it helps in an extreme circumstance, but not for me.
In fact it caused slightly lower framerate in the CPU limited test, although being CPU limited is not common with todays games.
I'll keep my eye on this.

If I dont see any further issues, I wont change back.
   
Reply With Quote
Old
  (#21)
spajdrik
Maha Guru
 
spajdrik's Avatar
 
Videocard: MSI Geforce 770 TF 2GD5
Processor: Intel i5-4670K
Mainboard: MSI Z87-G45 Gaming
Memory: 8GB Kingston HyperX 2400
Soundcard: onboard
PSU: Enermax NAXN 500W
Default 09-18-2012, 20:21 | posts: 1,114 | Location: Czech Republic

oww crap, i enabled it and since then windows was randomly freezing, i dont have settings in bios for that but i guess its permanently enabled and together with this registry parameter its a mess for system, ohh well.
   
Reply With Quote
Old
  (#22)
kakarot
Maha Guru
 
Videocard: r9-290 cfx
Processor: intel 4790k@4.7
Mainboard: msi z97 max ac
Memory: 2x8 ripjaws x 2133
Soundcard: creative sbz
PSU: evga p2-1000
Default 09-18-2012, 20:21 | posts: 809 | Location: USA

Don't see the option in my bios as well. Running that tool shows 4.09MHz and my dpc latency hovers around 102-138 depending on what I'm doing on the pc.
   
Reply With Quote
Old
  (#23)
HonoredShadow
Ancient Guru
 
HonoredShadow's Avatar
 
Videocard: MSI 970 SLI OC+ASUS Swift
Processor: 2700k@4.8 Noctua NH-U12P
Mainboard: AsRock Z77 Extreme4
Memory: 16GB Corsair 1866mhz
Soundcard: ASUS Xonar DX PCI-E
PSU: 1300W EVGA SuperNOVA
Default 09-18-2012, 20:41 | posts: 3,650 | Location: UK

Quote:
Originally Posted by Mufflore View Post
I tried this last night and it made very little difference for me, but I didnt have any issues with jerkiness or perfomance before this.
Before doing it, wintimertester reported my QueryperformanceFrequency as 3MHz, after it was 14MHz (to clarify that HPET is fully active and is the sole event timer).
I did a few benchmarks prior and afterwards, namely Heaven 2.5, Heaven 3.0 (both GPU limited), Crysis Warhead DX10 (GPU limited) and X3:TC benchmark (CPU limited).

Results:
All results were identical (within 1%) except X3:TC which dropped from 141fps to 131fps (7% drop).

Further observations:
During the loading of Crysis warhead, the grey loading map showed more frames on screen.
There is a lot more EM noise on my microphone socket on my Auzentech Prelude soundcard (used for listening to satellite TV through PC as I'm not using a pre-amp or audio switch), while running the benchmarks.

I dont doubt that some people will find it helps in an extreme circumstance, but not for me.
In fact it caused slightly lower framerate in the CPU limited test, although being CPU limited is not common with todays games.
I'll keep my eye on this.

If I dont see any further issues, I wont change back.
Sorry I'm probably being thick but the later half of this. Is this with HPET on or off?

Thanks.

Last edited by HonoredShadow; 09-18-2012 at 20:51.
   
Reply With Quote
Old
  (#24)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 09-18-2012, 20:45 | posts: 9,769 | Location: UK

All is with HPET active.
I have left it on for now.
   
Reply With Quote
Old
  (#25)
Mufflore
Ancient Guru
 
Mufflore's Avatar
 
Videocard: KFA2 Anarchy 580@930/4650
Processor: 2500K @ 4.5GHz - blew it!
Mainboard: Gigabyte P67 UD4 B3
Memory: 8G Kngston 2.2GHz CL11 1T
Soundcard: Minimax+ & Dexa Opamps !!
PSU: Corsair Pro AX750
Default 09-18-2012, 20:46 | posts: 9,769 | Location: UK

Quote:
Originally Posted by spajdrik View Post
oww crap, i enabled it and since then windows was randomly freezing, i dont have settings in bios for that but i guess its permanently enabled and together with this registry parameter its a mess for system, ohh well.
Its easy to disable again.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.