Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - NVIDIA Drivers Section
Videocards - NVIDIA Drivers Section In this section you can discuss everything ForceWare driver related. ForceWare (Detonator) drivers are for NVIDIA TNT, Quadro and all GeForce based videocards.


Reply
 
Thread Tools Display Modes
Nvidia GeForce 302.80 Windows 8 Drivers-Certified
Old
  (#1)
allup
Master Guru
 
allup's Avatar
 
Videocard: 2 X SLi Asus 7870 V2 ROG
Processor: AMD8150 Black C.M.TPC-812
Mainboard: Asus Sabertooth 990 V2.0
Memory: 16 GB G Skill PC3 1866
Soundcard: Realtek& Creative S-750's
PSU: C.M. Silent Pro2 M2 1000W
Default Nvidia GeForce 302.80 Windows 8 Drivers-Certified - 06-14-2012, 12:28 | posts: 275 | Location: Mountain country!

This drver is in Nvidias US website as of now

GeForce 302.80 Windows 8 WHQL 32-bit
GeForce 302.80 Windows 8 WHQL 64-bit

Release Highlights:
This is a preview GeForce driver to be used only with the Microsoft Windows 8 Release Preview. This driver should not be used with Windows Vista or Windows 7.
This driver offers full support for the new Windows 8 display driver model WDDM 1.2.


Those that would like to add any other may do so as i don't have much time this morning.

Last edited by allup; 06-14-2012 at 12:56. Reason: to fix driver info
   
Reply With Quote
 
Old
  (#2)
Rapyer
Master Guru
 
Videocard: GTX 680
Processor: 2500k @ 4.4ghz
Mainboard: Asus Z68P8 VLX
Memory: 8GB Corsair DD3 1600hz
Soundcard:
PSU:
Default 06-14-2012, 12:41 | posts: 159

sounds like a challenge
   
Reply With Quote
Old
  (#3)
Cyberdyne
Maha Guru
 
Cyberdyne's Avatar
 
Videocard: EVGA GTX760 ACX 1241/3139
Processor: i7 4770K @4.4GHz CLW0222
Mainboard: MSI Z87-G45 Gaming
Memory: Vengeance 2x8GB @1600
Soundcard: Logitech G430 + FiiO E6
PSU: CORSAIR tx750w
Default 06-14-2012, 12:47 | posts: 2,128 | Location: USA, Pennsylvania

Wowowow, OK at first, I was like 308?! I definitely got to get these working on Windows 7.
They are not 308. They are 302.80. lol.

Right off the bat, it comes with an older Physx then what was with .71, PhysX_9.12.0213 vs. PhysX_9.12.0507.

Last edited by Cyberdyne; 06-14-2012 at 12:52.
   
Reply With Quote
Old
  (#4)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 12:47 | posts: 11,710 | Location: England

v308?!?!?

Wow, I was expecting it to be a 302.xx driver.

I'll download these and put them on a USB memory stick as I'm at work currently but I'm waiting to hear from someone that they can be modded and installed on Windows 7. I'm especially interested to know whether these have the v-sync stutter bug fix for the GTX 600 series cards.
   
Reply With Quote
 
Old
  (#5)
allup
Master Guru
 
allup's Avatar
 
Videocard: 2 X SLi Asus 7870 V2 ROG
Processor: AMD8150 Black C.M.TPC-812
Mainboard: Asus Sabertooth 990 V2.0
Memory: 16 GB G Skill PC3 1866
Soundcard: Realtek& Creative S-750's
PSU: C.M. Silent Pro2 M2 1000W
Default 06-14-2012, 12:49 | posts: 275 | Location: Mountain country!

Sorry guys my bad.. It is "302.80" Cannot seem to edit the thread title. Maybe the ops can do it for us??

Also these are international.
Just got them loaded will play with them and see how good, real quick.

Last edited by allup; 06-14-2012 at 13:01.
   
Reply With Quote
Old
  (#6)
deByte
Member Guru
 
Videocard: GTX780WF3 1293/6458@1.212
Processor: i5-3570k @ 4.5Ghz 1.25v
Mainboard: Asus P8Z77-V LX
Memory: DDR3 Hynix 8GB 2133Mhz
Soundcard: Asus Phoebus & Tiamat 7.1
PSU: OCZ ZS 750W
Default 06-14-2012, 12:51 | posts: 88 | Location: Saint Petersburg

LOL? Deleted Win8 10 minutes ago cuz no drivers for it... so mad
   
Reply With Quote
Old
  (#7)
Cyberdyne
Maha Guru
 
Cyberdyne's Avatar
 
Videocard: EVGA GTX760 ACX 1241/3139
Processor: i7 4770K @4.4GHz CLW0222
Mainboard: MSI Z87-G45 Gaming
Memory: Vengeance 2x8GB @1600
Soundcard: Logitech G430 + FiiO E6
PSU: CORSAIR tx750w
Default 06-14-2012, 12:54 | posts: 2,128 | Location: USA, Pennsylvania

The installation starts without modded the INF. I'll see how it goes.
   
Reply With Quote
Old
  (#8)
sapo_joe
Master Guru
 
Videocard: MSi Radeon R9 290 4GB
Processor: AMD PhenomII X6 1090T
Mainboard: Asus M4A78 Pro
Memory: 8GB DDRII 667Mhz Dual
Soundcard: SB X-Fi Titanium
PSU: 620W Antec Gamer
Default 06-14-2012, 12:58 | posts: 393 | Location: Brazil

Well... After someone installs this on a factory overclocked 500 series cards, let us know if there's the 3d clock bug and the stuttering with vsync... For now, I'm keeping 269.88. Thanks!
   
Reply With Quote
Old
  (#9)
Techio
Master Guru
 
Videocard: Sapphire 7950 925MHZ
Processor: Intel i7 960 @ 3.4GHZ
Mainboard: Gigabyte GA-XD58A-UDR3
Memory: 3 Sticks 6GB
Soundcard: Pioneer HTP-522
PSU: Corsair HX650W
Default 06-14-2012, 12:58 | posts: 152

Good news: It fixed all the strange graphical glitches that involves Metro interface. No blurry texts, black boxes. All gone!

Bad news: Restarted after installation, caused my computer to crash on boot but booted normally afterwards.

So far so good on my end. Will test games.
   
Reply With Quote
Old
  (#10)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 12:58 | posts: 11,710 | Location: England

Can anyone confirm whether these will install on Windows 7 without any modification? They're obviously certified for Windows 8 but that doesn't mean they won't install on Windows 7. I'm very keen to know as I'm downloading them now (slowly) on the work internet connection but will cancel them if they won't work.

Last edited by Darren Hodgson; 06-14-2012 at 13:05.
   
Reply With Quote
 
Old
  (#11)
Cyberdyne
Maha Guru
 
Cyberdyne's Avatar
 
Videocard: EVGA GTX760 ACX 1241/3139
Processor: i7 4770K @4.4GHz CLW0222
Mainboard: MSI Z87-G45 Gaming
Memory: Vengeance 2x8GB @1600
Soundcard: Logitech G430 + FiiO E6
PSU: CORSAIR tx750w
Default 06-14-2012, 13:00 | posts: 2,128 | Location: USA, Pennsylvania

Works fine.

Did a quick over-install on the 302.71 drivers, kept the newer Physx from 71.
Went smoothly. And as you can see, all the files were replaced correctly.

Last edited by Cyberdyne; 06-14-2012 at 13:03.
   
Reply With Quote
Old
  (#12)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 13:01 | posts: 11,710 | Location: England

Quote:
Originally Posted by Cyberdyne View Post
The installation starts without modded the INF. I'll see how it goes.
You mean you're installing them on Windows 7 without a custom/modded INF? If so then that's encouraging news... so long as they actually work.

Wonder if the desktop/notebook drivers will also be out today though? ManuelG said today on the GeForce.com forum that they'd be out "soon" so maybe they'll be out as well within the next few hours. At the very least I hope these work on Windows 7 as I want rid of the v-sync stutter bug for good.

*EDIT*
Thanks for the confirmation, Cyberdyne.
   
Reply With Quote
Old
  (#13)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 13:04 | posts: 11,710 | Location: England

P.S. You might want to edit the thread title to show the correct driver version number of 302.80.
   
Reply With Quote
Old
  (#14)
Glottiz
Member Guru
 
Videocard: Asus GTX670 DCII TOP 2GB
Processor: i5 2500K @ 4.5Ghz
Mainboard: Asus P8Z68-V PRO/GEN3
Memory: 16GB Corsair Vengeance
Soundcard: Realtek ALC892
PSU: Corsair TX750 v2
Default 06-14-2012, 13:08 | posts: 49

I think many here will ask same question. Do these have Kepler Vsync stutter fix, and do they install on Windows7?
   
Reply With Quote
Old
  (#15)
allup
Master Guru
 
allup's Avatar
 
Videocard: 2 X SLi Asus 7870 V2 ROG
Processor: AMD8150 Black C.M.TPC-812
Mainboard: Asus Sabertooth 990 V2.0
Memory: 16 GB G Skill PC3 1866
Soundcard: Realtek& Creative S-750's
PSU: C.M. Silent Pro2 M2 1000W
Default 06-14-2012, 13:10 | posts: 275 | Location: Mountain country!

Quote:
Originally Posted by Darren Hodgson View Post
P.S. You might want to edit the thread title to show the correct driver version number of 302.80.
I did. No luck. It shows up in the header but not in the thread title.
Might have something to do with the fact it is on the download page already?
On the download page, it does show as 302.80 though. Oh well.

Last edited by allup; 06-14-2012 at 13:13.
   
Reply With Quote
Old
  (#16)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 13:13 | posts: 11,710 | Location: England

Quote:
Originally Posted by allup View Post
I did. No luck. It shows up in the header but not in the thread title.
Might have something to do with the fact it is on the download page already?
I've had that happen to me as well. I think you have to select Advanced editing to change the thread title as I've been able to do it before.
   
Reply With Quote
Old
  (#17)
deByte
Member Guru
 
Videocard: GTX780WF3 1293/6458@1.212
Processor: i5-3570k @ 4.5Ghz 1.25v
Mainboard: Asus P8Z77-V LX
Memory: DDR3 Hynix 8GB 2133Mhz
Soundcard: Asus Phoebus & Tiamat 7.1
PSU: OCZ ZS 750W
Default 06-14-2012, 13:14 | posts: 88 | Location: Saint Petersburg

Installed at Win7 x64. Works perfect. Will test some games later.

   
Reply With Quote
Old
  (#18)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 13:18 | posts: 11,710 | Location: England

Nooooooooooooooooooooooo, deByte, you have to test your games now, now, NOW! You hear me? I *must* know if the v-sync stutter bug is fixed or not?
   
Reply With Quote
Old
  (#19)
allup
Master Guru
 
allup's Avatar
 
Videocard: 2 X SLi Asus 7870 V2 ROG
Processor: AMD8150 Black C.M.TPC-812
Mainboard: Asus Sabertooth 990 V2.0
Memory: 16 GB G Skill PC3 1866
Soundcard: Realtek& Creative S-750's
PSU: C.M. Silent Pro2 M2 1000W
Default 06-14-2012, 13:19 | posts: 275 | Location: Mountain country!

Quote:
Originally Posted by Darren Hodgson View Post
I've had that happen to me as well. I think you have to select Advanced editing to change the thread title as I've been able to do it before.
No luck on that one.. I'll just have to live with my shame..
   
Reply With Quote
Old
  (#20)
HairyUK
Master Guru
 
Videocard: KFA2 NVIDIA 680 GTX
Processor: Intel i5 750 @ 4.2
Mainboard: ASUS p7p55d EVO
Memory: 8GB DDR3 1366mhz
Soundcard: Soundblaster xtreme xfi
PSU: 750w HighPower
Default 06-14-2012, 13:21 | posts: 271 | Location: Belfast, Northern Ireland

i will test it now Darren , i will try bf3 and Fifa 12 as thats where i got it most
   
Reply With Quote
Old
  (#21)
maur0
Master Guru
 
Videocard: point of view gtx 570 1gb
Processor: core 2 quad Q9550
Mainboard: asus P5G41T-M LX3
Memory: ddr3 8gb gskill 1333 mhz
Soundcard: realtek HD
PSU: 500w
Default 06-14-2012, 13:29 | posts: 242 | Location: curitiba brazil

work at me fine win 7 x64 but WDDM 1.1 in win 7 not 1.2




tekken vs street fight up 195 fps in 296.79 driver to 198 fps in 302.80

and with all filter 75 to 78 fps

Last edited by maur0; 06-14-2012 at 13:56.
   
Reply With Quote
Old
  (#22)
deByte
Member Guru
 
Videocard: GTX780WF3 1293/6458@1.212
Processor: i5-3570k @ 4.5Ghz 1.25v
Mainboard: Asus P8Z77-V LX
Memory: DDR3 Hynix 8GB 2133Mhz
Soundcard: Asus Phoebus & Tiamat 7.1
PSU: OCZ ZS 750W
Default 06-14-2012, 13:34 | posts: 88 | Location: Saint Petersburg

Darren Hodgson, got my GTX 670 today... so Idk anything about vsync-stutter bug.
I can test any game u want (if i got it).
And say which settings I must set in nvidia panel and in-game (vsync)

Btw played in COD:BO 5 mins ago. Perfect performance. Fps up from 100 (with drops) to 150 (without drops).
   
Reply With Quote
Old
  (#23)
HairyUK
Master Guru
 
Videocard: KFA2 NVIDIA 680 GTX
Processor: Intel i5 750 @ 4.2
Mainboard: ASUS p7p55d EVO
Memory: 8GB DDR3 1366mhz
Soundcard: Soundblaster xtreme xfi
PSU: 750w HighPower
Default 06-14-2012, 13:35 | posts: 271 | Location: Belfast, Northern Ireland

Ok Darren , tried bf3 so far. V-Sync bug seems fixed to me or its not noticeable at all. BF3 menu video setting problem with the "Video Settings" menu, that happened with the laptop drivers, has been fixed. Dont know if its just me , but the picture quality on these drivers seem a bit grainy. could just be me tho
   
Reply With Quote
Old
  (#24)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 13:42 | posts: 11,710 | Location: England

Someone on the GeForce.com forum here: http://forums.nvidia.com/index.php?s...post&p=1421182 says that he still experiences stutter with these drivers unless he limits the framerate.

Looks like I'll need to test these for myself. To be honest, the v-sync stutter bug is more of a minor irritation than a major annoyance but now I know it happens I'm constantly looking for it. And it seems to affect Diablo III really badly as well.
   
Reply With Quote
Old
  (#25)
Darren Hodgson
Ancient Guru
 
Darren Hodgson's Avatar
 
Videocard: EVGA NVIDIA GTX 780
Processor: Intel Core i7-4770K
Mainboard: ASUS Z87 Deluxe
Memory: 16GB Corsair Veng 1600MHz
Soundcard: SB X-Fi Titanium HD
PSU: XFX Pro B.E. 850W
Default 06-14-2012, 13:48 | posts: 11,710 | Location: England

Quote:
Originally Posted by deByte View Post
Darren Hodgson, got my GTX 670 today... so Idk anything about vsync-stutter bug.
I can test any game u want (if i got it).
And say which settings I must set in nvidia panel and in-game (vsync)

Btw played in COD:BO 5 mins ago. Perfect performance. Fps up from 100 (with drops) to 150 (without drops).
Thanks deByte. I was only teasing; I think I can wait until I get home to try them for myself.

This v-sync stutter bug only occurs when v-sync is enabled so you won't see it in Call of Duty: Black Ops as you clearly play with v-sync disabled. The issue is caused by a driver polling bug that sees the v-synced framerate dip from 60 fps on a 60 Hz display every few seconds to 59/58 fps and down to 55/56 fps every 30 seconds or so. This causes noticeable stutter in many games though I've only noticed it being really bad in Assassin's Creed II (when turning the camera around Ezio) and Diablo III. In most other games it isn't that obvious even though I still see the framerate wavering in Afterburner's OSD. For some though, the issue renders the games unplayable with v-sync on.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.