Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
AMD Radeon HD 7900 driver 8.921.2 RC11
Old
  (#1)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default AMD Radeon HD 7900 driver 8.921.2 RC11 - 01-20-2012, 17:35 | posts: 21,373 | Location: Guru3D testlab

Download AMD Radeon HD 7900 driver 8.921.2 RC11 for windows Vista and 7 64-bit
Feature highlights of the 8.921.2 RC11 AMD Radeon™ HD 7900 driver

Super Sampling Anti-Aliasing and Adaptive Anti-Aliasing Preview support for DirectX® 10 and DirectX® 11 applications
  • AMD Radeon™ HD 7900 users can now enable Super Sample Anti-Aliasing and Adaptive Anti-Aliasing through the AMD Catalyst™ Control Center for DirectX® 10 and DirectX® 11 applications.
  • Applications must support in game Anti-Aliasing for the feature to work (Forced on Anti-Aliasing through the Catalyst™ Control Center is not supported for DirectX 10 and DirectX 11 applications)
Performance highlights of the 8.921.2 RC11 AMD Radeon™ HD 7900 driver
  • 8% (up to) performance improvement in Aliens vs. Predator
  • 15% (up to) performance improvement in Battleforge with Anti-Aliasing enabled
  • 3% (up to) performance improvement in Battlefield 3
  • 3% (up to) performance improvement in Crysis 2
  • 6% (up to) performance improvement in Crysis Warhead
  • 10% (up to) performance improvement in F1 2010
  • 5% (up to) performance improvement in Unigine with Anti-Aliasing enabled
  • 250% (up to) performance improvement in TessMark (OpenGL) when set to “insane” levels
Resolved issues: highlights of the 8.921.2 RC11 AMD Radeon™ HD 7900 driver
  • Folding@Home: intermittent stability issues have been resolved for the OpenCL version of Folding@Home
  • Call of Duty Modern Warfare 3 no longer experiences minor flickering with Tri CrossFireX™ configurations
  • Dragon Age 2 no longer experiences minor flickering with Tri CrossFireX™ configurations
  • StarCraft 2 no longer encounters issues when quitting campaign with Tri and Quad CrossFireX™ configurations
  • BattleForge stability has been improved with Tri CrossFireX™ configurations
  • Improved stability when enabling / disabling CrossFireX™ and installing the AMD graphics driver on AMD CrossfireX™ configurations
Known Issues:
  • Just Cause 2 - Launching the application will cause a hang for single GPU and CrossfireX™ configurations
Download right here.


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
 
Old
  (#2)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-20-2012, 17:40 | posts: 9,280 | Location: UK

Downloading now, thanks Hilbert
   
Reply With Quote
Old
  (#3)
MfA
Maha Guru
 
MfA's Avatar
 
Videocard: GBT GTX4601GB@950/4600MHz
Processor: Q9650 @4.25GHz (8.5*500)
Mainboard: Gigabyte EP45-DS3P
Memory: 4GB DDR2 1000MHz 5-5-5-15
Soundcard: Logitech X-530 & ALC889A
PSU: Seasonic Platinum 1kW
Default 01-20-2012, 17:49 | posts: 971 | Location: Istanbul

  • 250% (up to) performance improvement in TessMark (OpenGL) when set to “insane” levels

waiting

http://forums.guru3d.com/showthread.php?t=342525
   
Reply With Quote
Old
  (#4)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Default 01-20-2012, 17:53 | posts: 1,021 | Location: iTALY

Still points to the same driver DriverVer=01/04/2012, 8.921.2.0000
not yet uploaded or wrong link i guess.

http://support.amd.com/us/kbarticles...C11Driver.aspx

Last edited by asder00; 01-20-2012 at 18:01.
   
Reply With Quote
 
Old
  (#5)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-20-2012, 18:02 | posts: 9,280 | Location: UK

^ Just installed, and can confirm, it is the same driver

Last edited by Rich_Guy; 01-20-2012 at 18:08.
   
Reply With Quote
Old
  (#6)
Jakshi
Master Guru
 
Videocard: PoV GTX680@1300/3700
Processor: Intel i5-3570k@4.5 Ghz
Mainboard: Asrock Z77 Extreme4
Memory: Corsair Vengeance 1600Mhz
Soundcard: Onboard 7.1 Sound
PSU: Corsair 750 Watt
Default 01-20-2012, 18:28 | posts: 184

Waiting for a mod to allow Super-Sampling on 6970/50 ^^.
   
Reply With Quote
Old
  (#7)
iamgod1985
Member Guru
 
Videocard: p5k deluxe p35
Processor: q9550 2.83ghz @ 3.75
Mainboard:
Memory:
Soundcard:
PSU: 750 watt
Default 01-20-2012, 18:48 | posts: 102

Do you guys just install this over the 1/9? Or uninstall 1/9, boot into safe mode, run driver sweeper, & then install this new driver?



I am basically asking if the later step is necessary. Does anyone really know? Or it just to be on the "safe" side.
   
Reply With Quote
Old
  (#8)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: X-Fi Fatal1ty
PSU: AcBel M8 750
Default 01-20-2012, 19:03 | posts: 24,260 | Location: NZ

Quote:
Originally Posted by iamgod1985 View Post
Do you guys just install this over the 1/9? Or uninstall 1/9, boot into safe mode, run driver sweeper, & then install this new driver?



I am basically asking if the later step is necessary. Does anyone really know? Or it just to be on the "safe" side.
No, it's not necessary but I do sometimes run driver sweeper.
   
Reply With Quote
Old
  (#9)
iamgod1985
Member Guru
 
Videocard: p5k deluxe p35
Processor: q9550 2.83ghz @ 3.75
Mainboard:
Memory:
Soundcard:
PSU: 750 watt
Default 01-20-2012, 19:10 | posts: 102

wth? this driver still says 11.12 and the same packaging number as 1/9 drivers (8.921.2-120104a-131222E-ATI).

I am looking at the catalyst control centre (information and software section).








edit: actually wait, 8.921.2. So I guess the .2 is different than before? Anyone confirm? I am sure it is. Just making sure (paranoid).
   
Reply With Quote
Old
  (#10)
BlackZero
Ancient Guru
 
BlackZero's Avatar
 
Videocard: MSI 7970 OC
Processor: 2600K H2O
Mainboard: Asus P67 Pro
Memory: G.Skill 2133
Soundcard: X-Fi + 2400ES
PSU: Corsair AX850
Default 01-20-2012, 19:12 | posts: 8,110 | Location: United Kingdom

Quote:
Originally Posted by Jakshi View Post
Waiting for a mod to allow Super-Sampling on 6970/50 ^^.
That would be a great update.

+1
   
Reply With Quote
 
Old
  (#11)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Default 01-20-2012, 19:14 | posts: 1,021 | Location: iTALY

Quote:
Originally Posted by iamgod1985 View Post
wth? this driver still says 11.12 and the same packaging number as 1/9 drivers (8.921.2-120104a-131222E-ATI).

I am looking at the catalyst control centre (information and software section).








edit: actually wait, 8.921.2. So I guess the .2 is different than before? Anyone confirm? I am sure it is. Just making sure (paranoid).
some posts above you
http://forums.guru3d.com/showpost.ph...99&postcount=4
http://forums.guru3d.com/showpost.ph...10&postcount=5
   
Reply With Quote
Old
  (#12)
iamgod1985
Member Guru
 
Videocard: p5k deluxe p35
Processor: q9550 2.83ghz @ 3.75
Mainboard:
Memory:
Soundcard:
PSU: 750 watt
Default 01-20-2012, 19:25 | posts: 102

so.....................???????????? I just reinstalled the same ****ing driver (after booting into safe mode and using driver sweeper?)

What a waste of time.
   
Reply With Quote
Old
  (#13)
chispy
Ancient Guru
 
chispy's Avatar
 
Videocard: 2x290X CF on H2O Swiftech
Processor: 4790K on H2O Swiftech
Mainboard: Asus Maximus VII Hero Z97
Memory: 16GB Team eXtreme 2400 c9
Soundcard: X-Fi-Titanium HD / Z5500
PSU: eVGA Supernova G2 1300w
Talking 01-20-2012, 19:27 | posts: 6,622 | Location: Puerto Rico

Quote:
Originally Posted by BlackZero View Post
That would be a great update.

+1
+2 , me too my friend
   
Reply With Quote
Old
  (#14)
ethne
Maha Guru
 
Videocard: 3xEVGA 980 SC/U28D590Dx2
Processor: Intel i7 5960X @ 4.4/H110
Mainboard: EVGA X99 Classified
Memory: 32GB GSKILL DDR4 @ 2666
Soundcard: SB ZxR
PSU: Antec HCP-1300 PSU
Default 01-20-2012, 19:46 | posts: 1,602 | Location: US

So this is the same driver from the 9th with a different date on it because they are EXACTLY the same size.

WTH is wrong with this company?
   
Reply With Quote
Old
  (#15)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-20-2012, 19:46 | posts: 9,280 | Location: UK

Quote:
Originally Posted by iamgod1985 View Post
Do you guys just install this over the 1/9? Or uninstall 1/9, boot into safe mode, run driver sweeper, & then install this new driver?



I am basically asking if the later step is necessary. Does anyone really know? Or it just to be on the "safe" side.
All i do is, Programs & Features, double-click the ATi Install Manager, select to uninstall all, then after the reboot, i install the new ones

They still not updated the link yet

Quote:
Originally Posted by ethne View Post
So this is the same driver from the 9th with a different date on it because they are EXACTLY the same size.

WTH is wrong with this company?
They havn't put this new driver up, the link is still for the 9th driver.

Last edited by Rich_Guy; 01-20-2012 at 20:10.
   
Reply With Quote
Old
  (#16)
ethne
Maha Guru
 
Videocard: 3xEVGA 980 SC/U28D590Dx2
Processor: Intel i7 5960X @ 4.4/H110
Mainboard: EVGA X99 Classified
Memory: 32GB GSKILL DDR4 @ 2666
Soundcard: SB ZxR
PSU: Antec HCP-1300 PSU
Default 01-20-2012, 20:05 | posts: 1,602 | Location: US

I really want to try new drivers in one last ditch attempt to get these working before I send them back.
   
Reply With Quote
Old
  (#17)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-20-2012, 20:16 | posts: 9,280 | Location: UK

Someones tweeted him, so hopefully won't be to long until its sorted
   
Reply With Quote
Old
  (#18)
ethne
Maha Guru
 
Videocard: 3xEVGA 980 SC/U28D590Dx2
Processor: Intel i7 5960X @ 4.4/H110
Mainboard: EVGA X99 Classified
Memory: 32GB GSKILL DDR4 @ 2666
Soundcard: SB ZxR
PSU: Antec HCP-1300 PSU
Default 01-20-2012, 20:17 | posts: 1,602 | Location: US

Nice
   
Reply With Quote
Old
  (#19)
The Mac
Maha Guru
 
Videocard: Sapphire R9-290 Vapor-X
Processor: i7-4970K
Mainboard: Asus Z97-A
Memory: Corsair Vengence Pro 16GB
Soundcard: X-Fi Titianum HD
PSU: Corasir AX750
Default 01-20-2012, 20:18 | posts: 2,448 | Location: USA

deleted...

Last edited by The Mac; 01-20-2012 at 20:20.
   
Reply With Quote
Old
  (#20)
ethne
Maha Guru
 
Videocard: 3xEVGA 980 SC/U28D590Dx2
Processor: Intel i7 5960X @ 4.4/H110
Mainboard: EVGA X99 Classified
Memory: 32GB GSKILL DDR4 @ 2666
Soundcard: SB ZxR
PSU: Antec HCP-1300 PSU
Default 01-20-2012, 20:29 | posts: 1,602 | Location: US

K, file size has changed to 130 from 134 so I guess they uploaded the right one
   
Reply With Quote
Old
  (#21)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Default 01-20-2012, 20:32 | posts: 1,021 | Location: iTALY

Ok now its good:
DriverVer=01/19/2012, 8.921.2.0000
8.921.2-120119a-132101E-ATI

will investigate for the new aa
   
Reply With Quote
Old
  (#22)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-20-2012, 20:41 | posts: 9,280 | Location: UK

At last, new one up, AndrewD confirmed on twitter.
   
Reply With Quote
Old
  (#23)
Rich_Guy
Ancient Guru
 
Rich_Guy's Avatar
 
Videocard: MSi Gaming 290X 1080/1250
Processor: i7 920 D0
Mainboard: Biostar Tpower x58
Memory: 6GB Corsair DDR3
Soundcard: Xonar DX - Logi. X-530s
PSU: Corsair AX860w
Default 01-20-2012, 21:40 | posts: 9,280 | Location: UK

Working fine for me these, then again, so did the earlier set
   
Reply With Quote
Old
  (#24)
Vortex
Newbie
 
Vortex's Avatar
 
Videocard: HD7970@1125/1620 1.218v
Processor: i7-2600k@4.5
Mainboard: Asus P8Z68 Deluxe/Gen3
Memory: G.Skill 1600mhz 16G 1.35v
Soundcard: Corsair Vengeance 1500
PSU: Corsair AX850
Default 01-20-2012, 22:01 | posts: 35 | Location: South Africa

Thanks for the update on the drivers Hilbert. Installing them now + testing for improvements.
   
Reply With Quote
Old
  (#25)
kpo6969
Master Guru
 
kpo6969's Avatar
 
Videocard: Asus 280X DC2T
Processor: i7-4790K
Mainboard: Gigabyte Z97X-UD5H
Memory: 8GB TridentX 2400mhz cas9
Soundcard: SB XFi Extreme Music
PSU: Seasonic SS-660XP2
Default 01-20-2012, 22:45 | posts: 579

Quote:
Originally Posted by ethne View Post
K, file size has changed to 130 from 134 so I guess they uploaded the right one
All the links still show 130 and not 134??
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.