Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
Help: Vsync in Skyrim
Old
  (#1)
Miken420
Member Guru
 
Miken420's Avatar
 
Videocard: XFX HD5770 @950/1250 CFX
Processor: Phenom II X4 960T @4.0Ghz
Mainboard: Asus M4A78T-E 790GX
Memory: 8GB AMD DDR3 @1337 7-8-7
Soundcard: AMD HDMI Audio
PSU: Corsair TX650 V2
Default Help: Vsync in Skyrim - 11-16-2011, 22:48 | posts: 99 | Location: Chesilhurst NJ

Hello all

Like all of you I've been hard at work trying to get the best possible gaming experience out of Skyrim on my system.

It runs great, upwards of 100-120 fps sometimes. However there is one gleaming problem for me.

I can't for the life of me get Vsync to enable in the game. When I try to look up the problem online, all I can manage to find is people who are having trouble Disabling Vsync.

I've tried forcing it in the CCC to on. Using RadeonPRO to force Vsync ON with and without API Detection.

I've tried putting iPresentInterval=1 in the Skyrim.ini and the SkyrimPrefs.ini

I've tried disabling CrossfireX

I even tried D3DOverrider!

My problem is that when vsync is off, I get a splashing effect that's like I'm constantly being submerged in and out of water, even though I'm standing on solid land with no water around. It's totally immersion breaking and it's driving me insane!

When I looked up this issue I found people saying to Enable Vsync. Arghhhh!!

If anyone can help me get Vsync to turn ON in Skyrim, I would much appreciate it.

Thanks in advance!

:Edit: I forgot to add I've tried the 11.9, 11.10 and 11.11 drivers. Also the CAPs I've tried are 11.9 CAP4 and 11.11 CAP1

I use RadeonPRO Oblivion CFX Profile forced with AFR rendering method.

Last edited by Miken420; 11-16-2011 at 22:53.
   
Reply With Quote
 
Old
  (#2)
Miken420
Member Guru
 
Miken420's Avatar
 
Videocard: XFX HD5770 @950/1250 CFX
Processor: Phenom II X4 960T @4.0Ghz
Mainboard: Asus M4A78T-E 790GX
Memory: 8GB AMD DDR3 @1337 7-8-7
Soundcard: AMD HDMI Audio
PSU: Corsair TX650 V2
Default 11-17-2011, 03:06 | posts: 99 | Location: Chesilhurst NJ

I ended up fixing my problem by using a program called Dxtory to limit the FPS to 59.9 FPS

It's a great program with a free trial mode that lets you use the fps limiting feature. If anyone ends up having a problem like mine, I recommend trying Dxtory prior to jumping out of a 3rd story window.
   
Reply With Quote
Old
  (#3)
cmdrdredd
Master Guru
 
Videocard: GTX 670 SLI @ 1240/6772
Processor: 3570k @ 4.6Ghz
Mainboard: Asus Maximus V Gene
Memory: 8GB Samsung 30nm
Soundcard:
PSU: Corsair HX1000
Default 11-17-2011, 03:09 | posts: 235 | Location: Florida

That's odd, I had a hell of a time getting vsync off. Then I went back to vsync on because I was getting a lot of tearing. Not only that but my mouse would be uncontrollable when looking up and down even when side to side was really slow. I don't use mouse accel or any smoothing so maybe that's why.
   
Reply With Quote
Old
  (#4)
Miken420
Member Guru
 
Miken420's Avatar
 
Videocard: XFX HD5770 @950/1250 CFX
Processor: Phenom II X4 960T @4.0Ghz
Mainboard: Asus M4A78T-E 790GX
Memory: 8GB AMD DDR3 @1337 7-8-7
Soundcard: AMD HDMI Audio
PSU: Corsair TX650 V2
Default 11-17-2011, 03:31 | posts: 99 | Location: Chesilhurst NJ

Quote:
Originally Posted by cmdrdredd View Post
That's odd, I had a hell of a time getting vsync off. Then I went back to vsync on because I was getting a lot of tearing. Not only that but my mouse would be uncontrollable when looking up and down even when side to side was really slow. I don't use mouse accel or any smoothing so maybe that's why.
Yeah that's pretty much the sum of every Vsync related post on the entire internet.

I haven't had the issue with the laggy mouse because I've never managed to get Vsync to work.

Limiting the FPS this way I guess is kind of the best of both worlds. You get the FPS limiting feature of Vsync without all of the lag involved.

This program works on Dx9,10, and 11 too. And you only have to register it if you want to use it like FRAPS for video recording n stuff.
   
Reply With Quote
 
Old
  (#5)
Netherwind
Maha Guru
 
Netherwind's Avatar
 
Videocard: EVGA 780Ti ACX @1252/7600
Processor: Intel i5 3570K @ 4,4GHz
Mainboard: MSI Z77A-GD55
Memory: Corsair 16GB Ven. 1600MHz
Soundcard: Asus Xonar DX
PSU: Corsair 850W HX
Default 11-17-2011, 08:37 | posts: 819 | Location: Sweden

I understood that Vsync is enabled in Skyrim by default.
There are two sets of config files, one set in the game folder and one in the My Documents/MyGames folder. And I've read that it's the Skyrim.ini not the SkyrimPrefs.ini that should receive the iPresentInterval=1 under [Display].

Setting 0 in the Skyrim.ini definitly disables Vsync and forcing it On in CCC would not help. I had to use RadeonPro to have Vsync enabled once again.
   
Reply With Quote
Old
  (#6)
asder00
Don Di Driver
 
asder00's Avatar
 
Videocard: R9 290 4GB @ 1100/1400
Processor: i7 3770k @ 4.7GHz
Mainboard: ASUS P8Z77-V PRO
Memory: 8GB G.Skill @ 2133Mhz CL9
Soundcard: X-FI Xtreme Music
PSU: CoolerMaster 850W
Default 11-17-2011, 11:46 | posts: 989 | Location: iTALY

You can also use this mod to limit fps and change some other settings:
http://www.skyrimnexus.com/downloads/file.php?id=34
   
Reply With Quote
My solution
Old
  (#7)
Salvador
Newbie
 
Videocard: AMD HD6950 (Unlocked)
Processor: Intel i5 2500K @ 4.5 ghz
Mainboard: MSI Z68A-GD55-(G3)
Memory: 8GB DDR3-1600 (9-9-9-21)
Soundcard: Asus Xonar DS 7.1
PSU: 750W Zalman
Default My solution - 11-17-2011, 12:22 | posts: 1 | Location: Cambridge UK

This is the first post I see about the splashing issue.
Couldn't find a solution on the net myself.
It started when I started meddling with either the ini files or setting the 3d settings in CCC to high quality.

For me it was solved by setting the 3d settings back to default. Then backup both your skyprefs and skyrim ini files in the my games folder. Then delete them and restart your skyrim launcher. set everything back to ultra. Play the game.

This solved it for me. Shadows looked much better after I did that!!. (There are shadows on trees even though I deleted the changed ini file, therefore they should be off, but their not?...)

I forced vsync in CCC after that, I don't like the tearing, and fps limiters have been shown to cause CTD.

I'd say, give it a try.

Last edited by Salvador; 11-17-2011 at 12:38.
   
Reply With Quote
Old
  (#8)
zhengzhoudave
Master Guru
 
zhengzhoudave's Avatar
 
Videocard: EVGA GTX 680 2GB
Processor: Intel i7 2700k
Mainboard: Asus P8Z68-V
Memory: 16GB DDR3
Soundcard: Onboard
PSU: BeQuiet Pure Power 730w
Default 11-17-2011, 13:00 | posts: 600 | Location: United Kingdom

I also understand that vsync is enabled by default and that you can disable it by putting the command "iPresentInterval=0" into the "C,Users,Name,My Docs,My Games,Skyrim,SkyrimPrefs" folder just at the bottom of the [Display] section. Just an idea but have a go at putting "iPresentInterval=1" there instead? Might work?
   
Reply With Quote
Old
  (#9)
Pill Monster
Ancient Guru
 
Pill Monster's Avatar
 
Videocard: 7950 Vapor-X 1175/1550
Processor: AMD FX-8320 @4.8
Mainboard: ASUS Sabertooth 990FX R2
Memory: 8GB Kingston HyperX 2400
Soundcard: Audigy 2 Platinum Ex 5.1
PSU: AcBel M8 750
Default 11-17-2011, 13:25 | posts: 23,460 | Location: NZ

iPresentInterval=0 is found in .cfg files of many different games, and yes it disables game enabled vsync .

However you'll need to make sure it's off in the CCC as well.
   
Reply With Quote
Old
  (#10)
Gromuhl'Djun
Ancient Guru
 
Gromuhl'Djun's Avatar
 
Videocard: GTX660ti
Processor: i7 3770
Mainboard: Gb GA-Z77D3H
Memory: 8GB DDR1866
Soundcard: VIA VT2021
PSU: CM M520
Default 11-17-2011, 13:57 | posts: 5,249 | Location: Netherlands

Quote:
Originally Posted by asder00 View Post
You can also use this mod to limit fps and change some other settings:
http://www.skyrimnexus.com/downloads/file.php?id=34
That mod disables vsync. It works, but the tearing I get is terrible, even when the framrate is set at 30fps, so I wouldn't advise using it if you hate tearing (or the "splashing-effect" as the OP calls it)
   
Reply With Quote
 
Old
  (#11)
Netherwind
Maha Guru
 
Netherwind's Avatar
 
Videocard: EVGA 780Ti ACX @1252/7600
Processor: Intel i5 3570K @ 4,4GHz
Mainboard: MSI Z77A-GD55
Memory: Corsair 16GB Ven. 1600MHz
Soundcard: Asus Xonar DX
PSU: Corsair 850W HX
Default 11-17-2011, 15:38 | posts: 819 | Location: Sweden

Quote:
Originally Posted by zhengzhoudave View Post
I also understand that vsync is enabled by default and that you can disable it by putting the command "iPresentInterval=0" into the "C,Users,Name,My Docs,My Games,Skyrim,SkyrimPrefs" folder just at the bottom of the [Display] section. Just an idea but have a go at putting "iPresentInterval=1" there instead? Might work?
Apparently Skyrims Vsync option heavily impacts on the FPS which is why it's recommended to force Vsync through D3DOverrider or RadeonPro.

I agree to the statement that extreme tearing occur when disabling Vsync ingame.
   
Reply With Quote
Old
  (#12)
Miken420
Member Guru
 
Miken420's Avatar
 
Videocard: XFX HD5770 @950/1250 CFX
Processor: Phenom II X4 960T @4.0Ghz
Mainboard: Asus M4A78T-E 790GX
Memory: 8GB AMD DDR3 @1337 7-8-7
Soundcard: AMD HDMI Audio
PSU: Corsair TX650 V2
Default 11-17-2011, 21:16 | posts: 99 | Location: Chesilhurst NJ

Yea I have no idea wtf is going on with the vsync and my Skryim. I deleted my .ini files and reset my 3d settings and all that stuff just for the hell of it to see if it works. I'm kinda OCD about troubleshooting lol xD

But I've tried all of the other suggestions prior to making this post, as you can see in my OP.

The only thing that worked for me was this Dxtory program. It's fine by me, I'm not sure about the FPS limiter mod, but this program doesn't induce any kind of crazy screen tearing. Everything is pretty much perfect now, no complaints!
   
Reply With Quote
Reply

Tags
enable vsync skyrim, skyrim, vertical sync, vsync

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.