Guru3D.com Forums

Go Back   Guru3D.com Forums > Hardware > General Hardware
General Hardware Want to talk about anything Hardware related? This is the place, you can discuss it here.


Reply
 
Thread Tools Display Modes
EHCI Hands-off
Old
  (#1)
Fyew-jit-tiv
Master Guru
 
Fyew-jit-tiv's Avatar
 
Videocard: EVGA 580 Hydro 3GB x2
Processor: i7-990x on liquid
Mainboard: Rampage 3 Black Edition
Memory: Corsair Vengence (24gb)
Soundcard: XFI Pro
PSU: Corsiar HX1000
Default EHCI Hands-off - 12-12-2010, 10:49 | posts: 714 | Location: Memories 4 Life

Hey Guru's,

Quick Question... Do you have EHCI Hands-off enabled or disabled within your bios..?

Regards


Fugitive
   
Reply With Quote
 
Old
  (#2)
K.S.
Master Guru
 
K.S.'s Avatar
 
Videocard: EVGA GTX Titan SC. SLI
Processor: Core i7 4930K @ 4.2GHz
Mainboard: ASUS P9X79-E WS
Memory: Ripjaws X DDR3-2133 16GB
Soundcard: Realtek ALC1150, NV HDMI
PSU: CM Silent Pro Gold 1200W
Default 12-12-2010, 11:24 | posts: 760 | Location: Honolulu, Hawaii

It controls USB 2.0 functionality, Enable it
   
Reply With Quote
Old
  (#3)
Fyew-jit-tiv
Master Guru
 
Fyew-jit-tiv's Avatar
 
Videocard: EVGA 580 Hydro 3GB x2
Processor: i7-990x on liquid
Mainboard: Rampage 3 Black Edition
Memory: Corsair Vengence (24gb)
Soundcard: XFI Pro
PSU: Corsiar HX1000
Default 12-12-2010, 11:36 | posts: 714 | Location: Memories 4 Life

Quote:
Originally Posted by K.S. View Post
It controls USB 2.0 functionality, Enable it
Hi K.S, Thanks for your reply, I have just read some bits about EHCI and it bascially says its a work around for OS's that dont have E/Hand-off support.... Surely Win7 does have EHCI Hand-off support? and if so then Disabling would be a better option no?

Regards
   
Reply With Quote
Old
  (#4)
K.S.
Master Guru
 
K.S.'s Avatar
 
Videocard: EVGA GTX Titan SC. SLI
Processor: Core i7 4930K @ 4.2GHz
Mainboard: ASUS P9X79-E WS
Memory: Ripjaws X DDR3-2133 16GB
Soundcard: Realtek ALC1150, NV HDMI
PSU: CM Silent Pro Gold 1200W
Default 12-12-2010, 11:42 | posts: 760 | Location: Honolulu, Hawaii

Yes, that's correct, but personally I'd enable it just in case having it "disabled" overides something (I guess the OS should replace the need for it though, whether enabled or not). Basically since Win Xp Sp1 you technically shouldn't need it as the OS is supposed to compensate for the BIOS option. (I would benchmark your USB perf. with and without it to see whether the BIOS fix or OS fix works best for your config) Also are you running the latest mobo BIOS:http://support.asus.com/download/dow...ge=en-us&os=30

Last edited by K.S.; 12-12-2010 at 11:47.
   
Reply With Quote
 
Old
  (#5)
Fyew-jit-tiv
Master Guru
 
Fyew-jit-tiv's Avatar
 
Videocard: EVGA 580 Hydro 3GB x2
Processor: i7-990x on liquid
Mainboard: Rampage 3 Black Edition
Memory: Corsair Vengence (24gb)
Soundcard: XFI Pro
PSU: Corsiar HX1000
Default 12-12-2010, 11:50 | posts: 714 | Location: Memories 4 Life

Hi K.S, Yeah i am running the latest bios... Its funny you mentioned benching cause i just ran a usb drive bump from one to another with EHCI Disabled and the read & writes speeds are faster. EX... Enabled, copy speeds are about 20ish mbps.. Disabled, copy speeds are around 34ish mbps... So it does seem to be faster with EHCI disabled.
   
Reply With Quote
Old
  (#6)
K.S.
Master Guru
 
K.S.'s Avatar
 
Videocard: EVGA GTX Titan SC. SLI
Processor: Core i7 4930K @ 4.2GHz
Mainboard: ASUS P9X79-E WS
Memory: Ripjaws X DDR3-2133 16GB
Soundcard: Realtek ALC1150, NV HDMI
PSU: CM Silent Pro Gold 1200W
Default 12-12-2010, 11:54 | posts: 760 | Location: Honolulu, Hawaii

Sounds like the OS is better at managing that, I'd leave it disabled then and if you start having stability issues or errors try enabling it. (you shouldn't though with win7 x64)
   
Reply With Quote
Old
  (#7)
Fyew-jit-tiv
Master Guru
 
Fyew-jit-tiv's Avatar
 
Videocard: EVGA 580 Hydro 3GB x2
Processor: i7-990x on liquid
Mainboard: Rampage 3 Black Edition
Memory: Corsair Vengence (24gb)
Soundcard: XFI Pro
PSU: Corsiar HX1000
Default 12-12-2010, 18:31 | posts: 714 | Location: Memories 4 Life

Yh im going to leave it for a while and see what happens..! Thanks for feedback.!
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.