Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI Drivers Section
Videocards - AMD - ATI Drivers Section In this section you can discuss everything Catalyst related. AMD Catalyst drivers are for all AMD ATI based graphics cards. This is also the place to discuss modified Catalyst drivers.


Reply
 
Thread Tools Display Modes
mysterious ATI driver has popped up
Old
  (#1)
d2k
Master Guru
 
d2k's Avatar
 
Videocard: GTX260 BE
Processor: C2Q
Mainboard:
Memory:
Soundcard:
PSU: 800W
Arrow mysterious ATI driver has popped up - 04-04-2010, 13:13 | posts: 204

i just came across this driver....



while the OGL driver is older than the march 29th release (10.3b OGL4.0 preview...*image below*), the 2D-3D driver versions are actually newer...



its simply listed as the..''8.73 driver package''

source

so...fill your boots
   
Reply With Quote
 
Old
  (#2)
sivis
Newbie
 
Videocard: Sapphire 7950 (950 Mhz)
Processor: 3570k @ 4.0
Mainboard: P8Z77-V Deluxe
Memory: Corsair 1600 Mhz
Soundcard: Asus Xonar DX
PSU: Epsilon 700W
Default 04-04-2010, 13:50 | posts: 33

Nice.Will download for sure =)
Thanks =)
   
Reply With Quote
Old
  (#3)
DSK
Banned
 
Videocard: HD5770/BenQ G2220HD
Processor: E6300 @ 4Ghz
Mainboard: Gigabyte - GA-EP43T-UD3L
Memory: Sector Five @ 1333CAS7
Soundcard: Realtek 81xx
PSU: Silverstone 500w
Default 04-04-2010, 14:24 | posts: 17,954 | Location: Coldwells,UK

Hmm it has an older openGL version =/ and older OPGL where terrible dunno if i'll install.
   
Reply With Quote
Old
  (#4)
d2k
Master Guru
 
d2k's Avatar
 
Videocard: GTX260 BE
Processor: C2Q
Mainboard:
Memory:
Soundcard:
PSU: 800W
Default 04-04-2010, 14:25 | posts: 204

Quote:
Originally Posted by d2k View Post
i just came across this driver....



while the OGL driver is older than the march 29th release (10.3b OGL4.0 preview...*image below*), the 2D-3D driver versions are actually newer...



its simply listed as the..''8.73 driver package''

source

so...fill your boots
as i stated in the OP.....
   
Reply With Quote
 
Old
  (#5)
rflair
Don Commisso
 
rflair's Avatar
 
Videocard: R9 290x/670 GTX
Processor: 3770K@4.4/Q9550@3.83
Mainboard: Asus P877V-Pro/Asus P5K-E
Memory: 16G 2GHz/8G 900MHz
Soundcard: Onboard/Fiio E10
PSU: Corsair HX850/PPC 860
Default 04-04-2010, 14:51 | posts: 2,935 | Location: Canada

This is an early internal build of what should be Cat 10.5.

I had an earlier 8.72.0 internal build (what 10.4 should be based on) and these are newer based on driver build.
   
Reply With Quote
Old
  (#6)
d2k
Master Guru
 
d2k's Avatar
 
Videocard: GTX260 BE
Processor: C2Q
Mainboard:
Memory:
Soundcard:
PSU: 800W
Default 04-04-2010, 14:53 | posts: 204

Quote:
Originally Posted by rflair View Post
This is an early internal build of what should be Cat 10.5.

I had an earlier 8.72.0 internal build (what 10.4 should be based on) and these are newer based on driver build.
Awesome!!!

Last edited by d2k; 04-04-2010 at 14:56.
   
Reply With Quote
Old
  (#7)
GhostXL
Ancient Guru
 
GhostXL's Avatar
 
Videocard: ASUS GTX 780 SLI @ 1150
Processor: i7 4790K @ 4.8ghz on H90
Mainboard: ASUS Maximus VII HERO Z97
Memory: G.Skill Trident DDR3 2667
Soundcard: Sound Blaster Z
PSU: CORSAIR AX1200 watt
Default 04-04-2010, 15:23 | posts: 5,632 | Location: PA, USA

Hmmmm...wonder if these are worth installing then.

They seem highly Beta.
   
Reply With Quote
Old
  (#8)
Ghosty
Ancient Guru
 
Ghosty's Avatar
 
Videocard: -
Processor: -
Mainboard: -
Memory: -
Soundcard: -
PSU: -
Default 04-04-2010, 15:26 | posts: 3,359 | Location: UK

Someone test these with BC2 and see if they get a performance boost.
   
Reply With Quote
Old
  (#9)
GhostXL
Ancient Guru
 
GhostXL's Avatar
 
Videocard: ASUS GTX 780 SLI @ 1150
Processor: i7 4790K @ 4.8ghz on H90
Mainboard: ASUS Maximus VII HERO Z97
Memory: G.Skill Trident DDR3 2667
Soundcard: Sound Blaster Z
PSU: CORSAIR AX1200 watt
Default 04-04-2010, 15:26 | posts: 5,632 | Location: PA, USA

Quote:
Originally Posted by Ghosty View Post
Someone test these with BC2 and see if they get a performance boost.
ERGHHH, I may as well, I'm free for half the day...
   
Reply With Quote
Old
  (#10)
perosmct
Banned
 
Videocard: unknown
Processor: unknown
Mainboard: unknown
Memory: unknown
Soundcard: unknown
PSU: unknown
Default 04-04-2010, 15:38 | posts: 1,072 | Location: unknown

wow..far the best driver package i have installed till today, more stable even from the latest ogl4 set..!! it stopped dx11 crossfire flashing in Battlefield BC2 and i gained fps in dx11 only games..respect..
   
Reply With Quote
 
Old
  (#11)
MerolaC
Maha Guru
 
MerolaC's Avatar
 
Videocard: Sapphire HD 7970 OC 3Gb
Processor: i5 3770k@H60
Mainboard: AsRock Z77 Pro3
Memory: G.Skill Sniper 1866 8GB
Soundcard: C-SB-Titanium HD PCI-E
PSU: OCZ Fatal1ty G.G. - 750w
Default 04-04-2010, 15:50 | posts: 2,309 | Location: Argentina

oh my gad 380 of joy (i think)

Thanks!!!!
   
Reply With Quote
Old
  (#12)
Memorian
Maha Guru
 
Memorian's Avatar
 
Videocard: Waiting for GTX980
Processor: i5-3570K@4.5Ghz
Mainboard: Gigabyte Z77x UD3H
Memory: 8GB G.Skill
Soundcard: SB Audigy
PSU: TT 750W
Default 04-04-2010, 15:51 | posts: 1,834 | Location: Beyond the coast

Quote:
Originally Posted by perosmct View Post
wow..far the best driver package i have installed till today, more stable even from the latest ogl4 set..!! It stopped dx11 crossfire flashing in battlefield bc2 and i gained fps in dx11 only games..respect..
lies
   
Reply With Quote
Old
  (#13)
d2k
Master Guru
 
d2k's Avatar
 
Videocard: GTX260 BE
Processor: C2Q
Mainboard:
Memory:
Soundcard:
PSU: 800W
Default 04-04-2010, 16:02 | posts: 204

these are ''WOW'' drivers....... BFBC2 performance is much better than all 10.3 revisions, im averaging 80-100fps fully maxed now, at least 10fps gain (maybe more) IMO....

& these drivers have replaced the 2nd GPU temp on the 5970 which vanished after 9.12....its back!!

great work ATI.....
   
Reply With Quote
Old
  (#14)
perosmct
Banned
 
Videocard: unknown
Processor: unknown
Mainboard: unknown
Memory: unknown
Soundcard: unknown
PSU: unknown
Default 04-04-2010, 16:11 | posts: 1,072 | Location: unknown

Quote:
Originally Posted by Memorian View Post
lies
why.? it depends on each system separately, some people consider 10.3b best, some others ogl4 29march..but..!!

as for me, even in overclocking is more stable these here..i dont get artifacts in grand theft auto IV for example with memory's upper limit..
   
Reply With Quote
Old
  (#15)
evilfury
Master Guru
 
evilfury's Avatar
 
Videocard: Sapphire HD 5850
Processor: Intel Core I5 760
Mainboard: Gigabyte GA-P55
Memory: G.Skill Trident 4GB
Soundcard: SB X-Fi EM
PSU: LC power arkangel
Default 04-04-2010, 16:13 | posts: 533 | Location: Slovenia

Did you guys install these drivers over 10.3 opengl march 29 or clean install?
   
Reply With Quote
Old
  (#16)
perosmct
Banned
 
Videocard: unknown
Processor: unknown
Mainboard: unknown
Memory: unknown
Soundcard: unknown
PSU: unknown
Default 04-04-2010, 16:19 | posts: 1,072 | Location: unknown

Quote:
Originally Posted by evilfury View Post
Did you guys install these drivers over 10.3 opengl march 29 or clean install?
i've installed them over anything they are much newer in everything inside(except date)
   
Reply With Quote
Old
  (#17)
d2k
Master Guru
 
d2k's Avatar
 
Videocard: GTX260 BE
Processor: C2Q
Mainboard:
Memory:
Soundcard:
PSU: 800W
Default 04-04-2010, 16:27 | posts: 204

Quote:
Originally Posted by evilfury View Post
Did you guys install these drivers over 10.3 opengl march 29 or clean install?
installed over the top, but these need a reboot.....

well, here it is folks.... these runs are 24hrs apart.

here's a stock GPU run...not much, but its gonna boost all games by a few fps.

10.3b = 21,561

8.73 package (10.x) = 22,079


   
Reply With Quote
Old
  (#18)
Solace
Member Guru
 
Videocard: Asus GTX 780 DCU II
Processor: Xeon X5670@4.2ghz
Mainboard: Asus P6TD Deluxe
Memory: G.Skill DDR3 1600MHz 12GB
Soundcard: HD Audio
PSU: Enermax Modu82+ 625w
Default 04-04-2010, 16:29 | posts: 129 | Location: Finland

can someone upload it to rapidshare?

Megaupload is slow...
   
Reply With Quote
Old
  (#19)
RAVEN1001
Banned
 
Videocard: Sapphire 5870
Processor: i7920@4Ghz
Mainboard:
Memory:
Soundcard:
PSU: Corsair HX750
Default 04-04-2010, 16:56 | posts: 11

Clocks on 5870 idle at 400 GPU and memory does not drop with this set.
   
Reply With Quote
Old
  (#20)
d2k
Master Guru
 
d2k's Avatar
 
Videocard: GTX260 BE
Processor: C2Q
Mainboard:
Memory:
Soundcard:
PSU: 800W
Default 04-04-2010, 16:57 | posts: 204

Quote:
Originally Posted by RAVEN1001 View Post
Clocks on 5870 idle at 400 GPU and memory does not drop with this set.
hmm..... the 5900 is sitting @ 157/300..??
   
Reply With Quote
Old
  (#21)
Solace
Member Guru
 
Videocard: Asus GTX 780 DCU II
Processor: Xeon X5670@4.2ghz
Mainboard: Asus P6TD Deluxe
Memory: G.Skill DDR3 1600MHz 12GB
Soundcard: HD Audio
PSU: Enermax Modu82+ 625w
Default 04-04-2010, 17:00 | posts: 129 | Location: Finland

DL speed on megaupload: 40kb/s -.-
   
Reply With Quote
Old
  (#22)
RAVEN1001
Banned
 
Videocard: Sapphire 5870
Processor: i7920@4Ghz
Mainboard:
Memory:
Soundcard:
PSU: Corsair HX750
Default 04-04-2010, 17:04 | posts: 11

Quote:
Originally Posted by d2k View Post
hmm..... the 5900 is sitting @ 157/300..??
Yeah, I installed the WM9 acceleration driver, uninstalled it and clocks are back to normal now, all good.

Edit, clocks are still going up in idle, idle temps have gone up 20c because of the clock bug so back to 10.3's

Last edited by RAVEN1001; 04-04-2010 at 17:22.
   
Reply With Quote
Old
  (#23)
evilfury
Master Guru
 
evilfury's Avatar
 
Videocard: Sapphire HD 5850
Processor: Intel Core I5 760
Mainboard: Gigabyte GA-P55
Memory: G.Skill Trident 4GB
Soundcard: SB X-Fi EM
PSU: LC power arkangel
Default 04-04-2010, 17:21 | posts: 533 | Location: Slovenia

Having same problem as you raven.
   
Reply With Quote
Old
  (#24)
signex
Ancient Guru
 
signex's Avatar
 
Videocard: ASUS Striker GTX760 4GB
Processor: Intel Core i5 4440/H80i
Mainboard: MSI Z97 GAMING 3
Memory: Corsair Veng LP 8GB DDR3
Soundcard: Onboard/ADA885
PSU: Cooler Master GX650
Default 04-04-2010, 17:23 | posts: 5,059 | Location: Netherlands

Nice find! Gonna try this fo sho.. thanks
   
Reply With Quote
Old
  (#25)
Sever
Ancient Guru
 
Sever's Avatar
 
Videocard: Galaxy 3GB 660TI
Processor: i7 2600k - XSPC Raystorm
Mainboard: Asrock Z77 Extreme9
Memory: 16gb Corsair Vengeance
Soundcard: Asus Xonar D2X
PSU: Silverstone Gold 1200w
Default 04-04-2010, 17:30 | posts: 4,826 | Location: Land of the Great Downunder

im suspicious of the file size...

normally drivers are around the 100-120 mark for a full package... any reason why this is 380megs?
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.