Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD - ATI
Videocards - AMD - ATI AMD Radeon graphics cards. Do you have one or want to buy one? Use this forum to discuss anything concerning products using Radeon graphics cards, CrossFireX, from Radeon 9800 to HD 6900


Reply
 
Thread Tools Display Modes
Ati 4780 HDMI Output only stereo
Old
  (#1)
CainStar
Newbie
 
Videocard: Ati 4780x2 512
Processor: Intel Core 2 Duo
Mainboard: Asus P5K SE
Memory: Kingston 4GB 800Mhz
Soundcard: Realtek High Definition
PSU: 750 Wattz Corsair
Default Ati 4780 HDMI Output only stereo - 03-16-2009, 21:59 | posts: 8

Using Vista x64 with latest catalyst and audio drivers(Realtek High Definition Audio & Ati High Definition Audio both downloaded from Realteks site. Everything is connected VIA PC HDMI cable --> Home Theater --> TV. My Home Theater is 5.1.

So I have this weird problem stay with me.

When I go to Control Panel --> Sound and click I get this

http://img244.imageshack.us/my.php?image=picture01.jpg
And as you can see HDMI output is selected.

And this is when I hit configure here's the problem I can only select stereo. Then I click "next"
http://img515.imageshack.us/my.php?image=picture02.jpg

This is the next screen and as you can see there is a surround sound 'click box' but it is greyed out.
http://img525.imageshack.us/my.php?image=picture03.jpg

And this Realtek HD Audio Manager which pretty much tells the same thing.

http://img205.imageshack.us/my.php?image=picture04.jpg

Now this is where it get's really interesting, if I click properties at the sound window and click 'supported format' tab and hit test on dolby digital or DTS audio everything works as it should sounds come out excatly where they are supposed to.
http://img17.imageshack.us/my.php?image=picture05.jpg

And also if I watch normal dvd's on my computer and select DTS or Dolby from dvd menu it works just as it should.

But when I try to watch ripped HD movies which have surround sound audio all the rear audio is played in my front speakers because of stereo(I have checked this - turned rear audio to full and disable front speakers from ac97).

Please I know this sound complicated, but I just bought 52" LCD and Home Theater which costed me almost 4000/euros. And I really want this thing to work.

Hopefully some one can help me...haven't had much luck with Ati forums...even thou this propably their problem.

Last edited by CainStar; 03-16-2009 at 22:03.
   
Reply With Quote
 
Old
  (#2)
bokah
Maha Guru
 
Videocard: EVGA 670GTX 2G
Processor: i5 2500k
Mainboard: GA-P67A-UD3-B3
Memory: G-Skill F3-12800CL7D-8GB
Soundcard: Xonar Essence STX
PSU: LC-Power 750W
Default 03-17-2009, 01:41 | posts: 2,314

never used ati hdmi or hd sound, but it should be chip on it own, not controlled by realtek
try disable realtek onboard or get new codec pack

few things to check in vista, disable large speakers, auto detect headphones on/off

Last edited by bokah; 03-17-2009 at 01:47.
   
Reply With Quote
Old
  (#3)
CainStar
Newbie
 
Videocard: Ati 4780x2 512
Processor: Intel Core 2 Duo
Mainboard: Asus P5K SE
Memory: Kingston 4GB 800Mhz
Soundcard: Realtek High Definition
PSU: 750 Wattz Corsair
Default 03-18-2009, 11:13 | posts: 8

Thank you everybody for your contributions and help!

In the end it was a codec error I guess, since I have the same drivers as before, but now I'm able to get full 5.1 support.



And just for the record how I did it.



1. Uninstall all codecs 2. Get MPC-HC select audio options and check DTS/Dolby Digital has S/PDIF enabled(Both). Atleast this worked for me.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.