Guru3D.com Forums

Go Back   Guru3D.com Forums > General Chat > Frontpage news
Frontpage news Perhaps you have some news to report or want to check out the latest Guru3D headlines and comment ? Check it in here.


Reply
 
Thread Tools Display Modes
Galaxy GeForce 9800 GTX 512MB review [Guru3D]
Old
  (#1)
Guru3D News
Ancient Guru
 
Guru3D News's Avatar
 
Videocard:
Processor: HAL 9000
Mainboard:
Memory:
Soundcard:
PSU:
Default Galaxy GeForce 9800 GTX 512MB review [Guru3D] - 02-16-2009, 09:00 | posts: 6,462

The Galaxy GeForce 9800GTX PLUS tested - Galaxy recently released this product custom PCB custom cooling custom bracket HDMI output black DVI and backplate. I sometimes wonder why a small company...

More...
   
Reply With Quote
 
Old
  (#2)
UnrealGaming
Maha Guru
 
UnrealGaming's Avatar
 
Videocard: AMD HD 7870 2GB
Processor: Intel Core 2 Quad Q9550
Mainboard: MSI P45 Platinum
Memory: Kingston HyperX DDR2 4GB
Soundcard: Realtek ALC888/888T
PSU: Chieftec 650W
Default 02-16-2009, 10:07 | posts: 2,453 | Location: Serbia

Far Cry 2 test ...
Quote:
We start off with a title I like very much. Not so much for the gameplay, but the rendered environment and how the game can react to it. We are in high-quality DX10 mode with 4x AA (anti-aliasing) and 16x AF (anisotropic filtering).
But the FPS matches with 8aa used when compared to the 2nd graph showing 8aa vs 4aa .
   
Reply With Quote
Old
  (#3)
Hilbert Hagedoorn
Don Vito Corleone
 
Hilbert Hagedoorn's Avatar
 
Videocard: AMD | NVIDIA
Processor: Core i7 4770K
Mainboard: Z77
Memory: 8GB
Soundcard: X-Fi - GigaWorks 7.1
PSU: 1200 Watt
Default 02-16-2009, 10:10 | posts: 20,943 | Location: Guru3D testlab

Aah, typo .. the upper chart is done (our standard test) at 8xAA. Fixing, thanks for noticing.


Follow Guru3D on twitter.
Follow Guru3D on facebook.
   
Reply With Quote
Old
  (#4)
DSK
Banned
 
Videocard: HD5770/BenQ G2220HD
Processor: E6300 @ 4Ghz
Mainboard: Gigabyte - GA-EP43T-UD3L
Memory: Sector Five @ 1333CAS7
Soundcard: Realtek 81xx
PSU: Silverstone 500w
Default 02-16-2009, 10:18 | posts: 17,954 | Location: Coldwells,UK

Ha i only got 21FPS in farcry 2 everything @ ultra with 8x AA 1280x1024 damn i must of had some bottleneck.

I'm also liking the arrows looks a lot better than a boring normal line if you know what i mean.

Last edited by DSK; 02-16-2009 at 10:24.
   
Reply With Quote
 
Old
  (#5)
Skiddywinks
Ancient Guru
 
Skiddywinks's Avatar
 
Videocard: Asus Matrix 285
Processor: i5 750 @ 4GHz 1.32v H²0
Mainboard: Asus Sabertooth i55
Memory: 4GB OCZ XMP DDR3 1353MHz
Soundcard: Asus Xonar D2X
PSU: Corsair HX1000W
Default 02-16-2009, 13:22 | posts: 4,628 | Location: North Wales

Anyone else think those temerpatures are pretty high for a non reference, two slot cooler?
   
Reply With Quote
Old
  (#6)
raken
Newbie
 
Videocard: galaxy 9800gtx+ 512 mb
Processor: e5200@3.3 ghz
Mainboard: MSI P43 NEO3-F
Memory: Kingston Hyperx 2 x 2GB
Soundcard:
PSU: 610 silencer
Default 02-17-2009, 02:18 | posts: 7

I have owned a Galaxy 9800GTX+ 1 1/2 months and the reveiw is highly accurate. My card does have 2D settings so it can change from 3D settings when leaving games etc. The bios is posted at Mvktech you could try to download it and flash with Nibitor. My 2D settings in bios where 300 600 100 and I used Rivatuner to change to 450 900 150 and can get even higher settings with Xtreme Tuner. The only game in the Review I own is Call of Duty World At War and I get 65-75C ingame [using EVGA Presision to check]. I set Rivatuner's fan settings to 30 percent 30-50C and it idles 48-50C 1550RPM, 70 percent 61-70C 2600 RPM and 80 percent 71C+ 2700 RPM. I agree it could run cooler but it's not much higher than cards in this price range or performance. Noise is way to loud in 3D and have seen this in other Reviews.
   
Reply With Quote
Old
  (#7)
getsuga12
Ancient Guru
 
getsuga12's Avatar
 
Videocard: Geforce GTX870M
Processor: Intel i7 4810MQ, 2.8Ghz
Mainboard: MSI GT60 2PC Dominator
Memory: 2x4GB DDR3-1600
Soundcard: Realtek Audio Card
PSU: MSI GT60 2PC Dominator
Default 02-17-2009, 02:37 | posts: 4,358

i do agree that the dual-slot cooler is a bit... useless. After all, they fitted the very same cooler onto their 9800GT model too, which I just so happen to have.

But then again I just live in a country where the outside temp is always near 40 degrees celsius, and my room only has one ceiling fan. So in my case, high temps are hard to avoid.
   
Reply With Quote
Old
  (#8)
applejack
Master Guru
 
applejack's Avatar
 
Videocard: MSI GTX 780 Gaming OC
Processor: Intel® Core™ i7-4930K
Mainboard: GIGABYTE GA-X79-UP4
Memory: G.Skill 4x4GB 2133mhz cl9
Soundcard: Creative Sound Blaster Z
PSU: Seasonic G-650
Default 02-17-2009, 16:30 | posts: 451 | Location: Israel

summing the results show a ~28% overall advantage to the 9800GTX+ over HD4850,
with the 9800GTX+ beating the 4850 in every single test.

considering the Galaxy 9800GTX+ using reference frequencies,
is there a reason why other reviews draw a completely different picture between the 2 ?

Last edited by applejack; 02-17-2009 at 16:44.
   
Reply With Quote
Old
  (#9)
reeven
Member Guru
 
Videocard: XFX GTX280 750/1450/3000
Processor: Q6600 @4Ghz
Mainboard: MSI P35 Platinum
Memory: 4GB 800 A-data Extreme
Soundcard: XFI Extreme Audio PCIe
PSU: Corsair TX 650W
Default 02-17-2009, 19:00 | posts: 133 | Location: Bucharest, Romania

This card bought it 3 days ago, sometimes, some users report the artefacts problem, when enter 3d... same on evga, bfg, leadtek, zotac 9800GTX+.

Galaxy makes an update Bios, it there:

http://www.szgalaxy.com/rain/serve/UpdBios_923K.rar

Bios in this archives is 2198.rom.

Some users report that when you enter 2d/3d sometimes, artefacts and freeze appear, and you must restart the computer.

This bios put fan to 20%, but raise the cicles, and it's good... No more freeze and artefacts appear.


EDIT: Problem with 2d/3d mode is FIXED on ALL NVIDIA CARDS with Nvidia Driver 182.60.

Last edited by reeven; 02-23-2009 at 16:14.
   
Reply With Quote
Old
  (#10)
Denithor
Newbie
 
Videocard: EVGA 8800GTS 512MB
Processor: Intel E8400
Mainboard: Asus P5Q Pro
Memory: mushkin 2x2GB DDR2-800
Soundcard: Klipsch 4.1
PSU: Corsair 750TX
Default 02-18-2009, 14:33 | posts: 7 | Location: Charlotte, NC

This review would have been a lot more interesting & informative if you had tested CF 4850 & SLI 9800GTX+ in addition to the single cards against the higher end single card setups. I mean, who doesn't know that 4850 & 9800GTX+ run very close together and both lose to 4870 & GTX 285? C'mon...
   
Reply With Quote
 
No Issues Here
Old
  (#11)
wpeltola
Newbie
 
Videocard: Galaxy 9800 GTX+
Processor: AMD Phenom 9850
Mainboard: ASUS M2N SLI
Memory: Mushkin DDR 2 800 4GB
Soundcard:
PSU: Antec 650 NeoBlue
Default No Issues Here - 03-22-2009, 20:58 | posts: 4 | Location: Indiana

Just so you all know, I have had this card now for a few weeks and have loved every second of it. I went from an 8800gt to this one and have had no issues at all. I believe some of the early problems that people were having was more of a driver issues than hardware. This card runs cool and pretty quiet for me.

I just got back from a LAN party and people liked how it looks in my case, along with the blue theme, it stood out

Anyway, thanks for reading!
   
Reply With Quote
big problem
Old
  (#12)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default big problem - 08-14-2009, 15:35 | posts: 8 | Location: Bulgaria

First: I'm new in PCworld and sorry if my english is bad.

I have Galaxy 9800 GTX+ 512mb I have random freezes with sound continue loop after that i have to restart PC...
and Realtemp shows my idle temp GPU is 60-65'C when i start playing World of Warcraft after 5-10min the temp is increasing to 105'C sometimes more, is that problem from Graphic Card or something else? Thanks
   
Reply With Quote
Old
  (#13)
wpeltola
Newbie
 
Videocard: Galaxy 9800 GTX+
Processor: AMD Phenom 9850
Mainboard: ASUS M2N SLI
Memory: Mushkin DDR 2 800 4GB
Soundcard:
PSU: Antec 650 NeoBlue
Default 08-14-2009, 15:50 | posts: 4 | Location: Indiana

Quote:
Originally Posted by Mateiii View Post
First: I'm new in PCworld and sorry if my english is bad.

I have Galaxy 9800 GTX+ 512mb I have random freezes with sound continue loop after that i have to restart PC...
and Realtemp shows my idle temp GPU is 60-65'C when i start playing World of Warcraft after 5-10min the temp is increasing to 105'C sometimes more, is that problem from Graphic Card or something else? Thanks
Welcome! That could be any number of things, to be honest. When you have the chance, post the rest of your hardware specs and also make sure you are using the lastest drivers from Nvidia.com for your GTX+.

Thanks!

   
Reply With Quote
Here!
Old
  (#14)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default Here! - 08-14-2009, 15:58 | posts: 8 | Location: Bulgaria

CPU: C2 DUO E7300 2.66 1066 3M box
Motherboard: P5Q SE P45 LGA 775
RAM: KIT 2 x 2GB DDR2 1066 A-DATA
PSU: Fortron BlueStorm II 500
Video: Galaxy GF 9800 GTX+ 512mb DDR-3 PCIE


Downloaded leatest Drivers from Nvidia.com and motherboard Disc instaled with updates.

Last edited by Mateiii; 08-14-2009 at 16:04.
   
Reply With Quote
Old
  (#15)
wpeltola
Newbie
 
Videocard: Galaxy 9800 GTX+
Processor: AMD Phenom 9850
Mainboard: ASUS M2N SLI
Memory: Mushkin DDR 2 800 4GB
Soundcard:
PSU: Antec 650 NeoBlue
Default 08-14-2009, 16:02 | posts: 4 | Location: Indiana

Do you have adequate cooling in your case? Sometimes heat buildup can cause a crash like that. Is it just on one game, or at random times?

Again, make sure all of your drivers all up to date, including motherboard devices and see if that helps.

   
Reply With Quote
Old
  (#16)
buddyfriendo
Ancient Guru
 
buddyfriendo's Avatar
 
Videocard: EVGA GTX 480 SC
Processor: Intel Core i7 920 3.7GHz
Mainboard: ASUS P6T
Memory: Corsair DDR3 1600 6GB
Soundcard: Onboard -_-
PSU: Corsair TX750
Default 08-14-2009, 16:09 | posts: 3,419 | Location: New England - M@ss

Quote:
Originally Posted by wpeltola View Post
Do you have adequate cooling in your case? Sometimes heat buildup can cause a crash like that. Is it just on one game, or at random times?

Again, make sure all of your drivers all up to date, including motherboard devices and see if that helps.

Manually adjust the fan speed? Should do the trick.

Last edited by buddyfriendo; 08-14-2009 at 16:13.
   
Reply With Quote
hmm
Old
  (#17)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default hmm - 08-14-2009, 16:13 | posts: 8 | Location: Bulgaria

This is fun but...
Today i bought normal room Fan i open the case and i put on the fan to help cooling with my other 3 coolers... but it didnt help . Case and coolers are fresh cleaned and CPU temp is 34-44'C max but the GPU temp is 60-65'C idle and 75-105'C.
   
Reply With Quote
Old
  (#18)
wpeltola
Newbie
 
Videocard: Galaxy 9800 GTX+
Processor: AMD Phenom 9850
Mainboard: ASUS M2N SLI
Memory: Mushkin DDR 2 800 4GB
Soundcard:
PSU: Antec 650 NeoBlue
Default 08-14-2009, 16:15 | posts: 4 | Location: Indiana

Quote:
Originally Posted by Mateiii View Post
This is fun but...
Today i bought normal room Fan i open the case and i put on the fan to help cooling with my other 3 coolers... but it didnt help . Case and coolers are fresh cleaned and CPU temp is 34-44'C max but the GPU temp is 60-65'C idle and 75-105'C.
I would make sure all of your drivers are up to date then.
   
Reply With Quote
Old
  (#19)
.Rain
Master Guru
 
Videocard: ATI 5870
Processor: i5 750
Mainboard: ASUS
Memory: 2gb ddr3
Soundcard:
PSU: OCz 700w
Default 08-14-2009, 16:22 | posts: 233 | Location: Argentina

Mateiii, you should download rivatuner or evga precisioin (not sure if it works with other gfx cards or only evgas'). That way you can monitor the temps of your gpu during gameplay. If the freezes occur when temps hit 90-100c+ then it may be a heat issue. The software i mentioned also lets you raise the fan speed of the GPU which you may wanna do.
   
Reply With Quote
Old
  (#20)
RejZoR
Ancient Guru
 
RejZoR's Avatar
 
Videocard: Sapphire HD4870 Silent
Processor: Core i7 920 @ 4GHz
Mainboard: ASUS Rampage II Gene
Memory: 6GB OCZ Platinum 1600MHz
Soundcard: ASUS Xonar Essence STX
PSU: Corsair HX750
Default 08-14-2009, 16:27 | posts: 4,212 | Location: Europe/Slovenia/Ljubljana

I see no reason to buy overpriced GeForce 9800GTX+/GTS250 cards when you can get Sapphire HD4870 with aftermarket heatpipe cooler for 122 eur. And the Radeon tears 9800GTX+ apart with ease.
   
Reply With Quote
i got
Old
  (#21)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default i got - 08-14-2009, 16:40 | posts: 8 | Location: Bulgaria

I had (190.38_desktop_win764bit_whql) downloaded from (http://www.nvidia.com/object/win7_wi...0.38_whql.html) But beacouse ALT-TABing Desktop to game was very slow i had to w8 around 10-20sec. i got suggestions to install Driver (190.56 downloaded from http://developer.nvidia.com/object/opengl_3_driver.html) that fix the alt-tabing but the freeze problems still exist.
   
Reply With Quote
hmm
Old
  (#22)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default hmm - 08-14-2009, 16:44 | posts: 8 | Location: Bulgaria

I used Xtreme tuner to increase the fan speed but same problem. RivaTunner dosent recognised the drivers :S.
   
Reply With Quote
hmm
Old
  (#23)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default hmm - 08-14-2009, 16:51 | posts: 8 | Location: Bulgaria

I dont know but is there any chance to open that card and clean it? Cooler is cleaned it dosent overheat there. Overheat is backward card under the brand writed on it here look http://www.guru3d.com/imageview.php?image=16293. Maybe its dusty >.<
   
Reply With Quote
guys?
Old
  (#24)
Mateiii
Newbie
 
Videocard: GeForce 9800 GTX+ 512mb
Processor: Intel Core2Duo 2.66 1066
Mainboard: ASUS P5Q-SE P45 LGA775
Memory: A-DATA 4GB DDR2 1066
Soundcard:
PSU: BlueStorm II 500
Default guys? - 08-14-2009, 18:03 | posts: 8 | Location: Bulgaria

no answers .
   
Reply With Quote
Old
  (#25)
Cybermancer
Don Quixote
 
Cybermancer's Avatar
 
Videocard: BFG GTX260OC (192 SP)
Processor: Intel E8400 @ 3.6 GHz
Mainboard: XFX 680i LT
Memory: 6 GB Corsair DDR2 PC6400
Soundcard: X-Fi
PSU: PC Power & Cooling 750W
Default 08-14-2009, 22:05 | posts: 13,828 | Location: Cyberspace

You could try removing the cooler and reapplying some thermal paste on the chip - if feel comfortable doing this and don't have any warranty left on the card.

Otherwise get a RMA and get a replacement.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.