Guru3D.com Forums

Go Back   Guru3D.com Forums > Hardware > General Hardware
General Hardware Want to talk about anything Hardware related? This is the place, you can discuss it here.


Reply
 
Thread Tools Display Modes
Remembering the Old
Old
  (#1)
Netgamer
Maha Guru
 
Netgamer's Avatar
 
Videocard: 6600LE 300/300
Processor: C2D E6550 @ 3.3Ghz
Mainboard: MSI P6N SLI-FI 650i
Memory: 2gigs pc6400 Patriot Extreme 4-4-4
Soundcard: Looking
PSU: COOLMAX V-500 ATX 500W
Default Remembering the Old - 04-22-2008, 17:07 | posts: 2,096

Got board, decided to see if Rosewill still had the card i bought LONG ago.

Post a Pic of your Favorite (older,no 9800GTX and such u know.) Video card you've owned.


Yes

Rules.

1. NO HDMI
2. No Dual DVI
3. NO PCIe

Must be AGP or PCI.... easy simple, and a way to remember the simple times

(im glad Rosewill does not sell graphic cards anymore)

http://www.rosewill.com/Product/prod...?productId=155

The 6800 Was not my First but my Favorite
Geforce 6800 (NV40) 128mb DDR 256bit [ 325core / 700mem ]


eVGA FX5200 128mb DDR [250core/400mem] This was my First( gamed Hl2 on it)

Last edited by Netgamer; 04-23-2008 at 15:16.
   
Reply With Quote
 
Old
  (#2)
Passion Fruit
Ancient Guru
 
Passion Fruit's Avatar
 
Videocard: 6950 Unlocked 900/1250
Processor: i5 750 @ 4209Mhz on H50
Mainboard: MSI P55-GD65
Memory: 4x2GB RipJaws @ 2100 CL9
Soundcard: XFI XtremeMusic / Z-5500
PSU: OCZ ModXStream 700W
Default 04-22-2008, 17:34 | posts: 5,981 | Location: Middlesbrough, England



Voodoo 5 5500. LOL at the heatsinks

   
Reply With Quote
Old
  (#3)
gmavignier
Maha Guru
 
gmavignier's Avatar
 
Videocard: Gigabyte GTX760 OC
Processor: Core i5 4570
Mainboard: Gigabyte GA-H87-HD3
Memory: Kingston HyperX 8Gb 1600
Soundcard:
PSU: 750W Corsair modular 80+
Default 04-22-2008, 18:58 | posts: 1,445 | Location: Brasil Belo Horizonte

This is a promissing thread. I am going to look up some of my old cards and post a picture of them here.
   
Reply With Quote
Old
  (#4)
proFits
Ancient Guru
 
proFits's Avatar
 
Videocard: EVGA GTX 680
Processor: Intel i7 950
Mainboard: ASUS P6X58D PREMIUM
Memory: Corsair 2x8GB 1600MHZ
Soundcard: Turtle Beach Headphones
PSU: Thermaltake 850W modular
Default 04-22-2008, 19:03 | posts: 5,850 | Location: Montreal

Nothing with an HDMI or dual-dvi port accepted XD
   
Reply With Quote
 
Old
  (#5)
Mannerheim
Ancient Guru
 
Mannerheim's Avatar
 
Videocard: VTX3D R9 280x
Processor: AMD FX8150
Mainboard: Asus M5A99X Evo
Memory: Kingston 2x4GB DDR3 1600
Soundcard: X-fi Xtreme Gamer 5.1
PSU: Chieftec 700W
Default 04-22-2008, 19:06 | posts: 4,574 | Location: Finland / Helsinki

Here is 1 I LOVED =)
Creative Geforce 3 ti200 64MB



Cant find Creative RIva tnt2 m64 32MB PCI card picture that i also loved sooo much =)


   
Reply With Quote
Old
  (#6)
Reality|Bites
Ancient Guru
 
Reality|Bites's Avatar
 
Videocard: SLI Asus/eVGA 8800Ultra/B
Processor: C2D E8600 @ 4.4Ghz 1.42v
Mainboard: eVGA Nforce 680i
Memory: 2 X 1GB OCZ DDR2 6400 Fle
Soundcard: Creative Inspire 5300/M-A
PSU: PCP&C Silencer 750W
Default 04-22-2008, 19:28 | posts: 5,038 | Location: Scotland

My old ti 4400 from Leadtek

   
Reply With Quote
Old
  (#7)
Reality|Bites
Ancient Guru
 
Reality|Bites's Avatar
 
Videocard: SLI Asus/eVGA 8800Ultra/B
Processor: C2D E8600 @ 4.4Ghz 1.42v
Mainboard: eVGA Nforce 680i
Memory: 2 X 1GB OCZ DDR2 6400 Fle
Soundcard: Creative Inspire 5300/M-A
PSU: PCP&C Silencer 750W
Default 04-22-2008, 19:33 | posts: 5,038 | Location: Scotland



Your TNT PCI
   
Reply With Quote
Old
  (#8)
Mannerheim
Ancient Guru
 
Mannerheim's Avatar
 
Videocard: VTX3D R9 280x
Processor: AMD FX8150
Mainboard: Asus M5A99X Evo
Memory: Kingston 2x4GB DDR3 1600
Soundcard: X-fi Xtreme Gamer 5.1
PSU: Chieftec 700W
Default 04-22-2008, 19:42 | posts: 4,574 | Location: Finland / Helsinki

Quote:
Originally Posted by Reality|Bites View Post


Your TNT PCI
Not same.. It was with passive heatsink =)


   
Reply With Quote
Old
  (#9)
Netgamer
Maha Guru
 
Netgamer's Avatar
 
Videocard: 6600LE 300/300
Processor: C2D E6550 @ 3.3Ghz
Mainboard: MSI P6N SLI-FI 650i
Memory: 2gigs pc6400 Patriot Extreme 4-4-4
Soundcard: Looking
PSU: COOLMAX V-500 ATX 500W
Default 04-22-2008, 19:44 | posts: 2,096

Quote:
Originally Posted by proFits View Post
Nothing with an HDMI or dual-dvi port accepted XD
Yes

Rules.

1. NO HDMI
2. No Dual DVI
3. NO PCIe

Must be AGP or PCI.... easy simple, and a way to remember the simple times
   
Reply With Quote
Old
  (#10)
Passion Fruit
Ancient Guru
 
Passion Fruit's Avatar
 
Videocard: 6950 Unlocked 900/1250
Processor: i5 750 @ 4209Mhz on H50
Mainboard: MSI P55-GD65
Memory: 4x2GB RipJaws @ 2100 CL9
Soundcard: XFI XtremeMusic / Z-5500
PSU: OCZ ModXStream 700W
Default 04-22-2008, 19:48 | posts: 5,981 | Location: Middlesbrough, England

Actually, i know of a Voodoo4 that had a DVI out althugh it wasnt dual.
   
Reply With Quote
 
Old
  (#11)
FlawleZ
Ancient Guru
 
FlawleZ's Avatar
 
Videocard: Sapphire HD 7950 Boost
Processor: Phenom II 980BE @ 4.4Ghz
Mainboard: MSI GD70 790FX
Memory: 4GB OCZ Reaper DDR3 CL6
Soundcard: Realtek HD Audio
PSU: OCZ 850W Modular
Default 04-22-2008, 20:04 | posts: 4,263 | Location: San Antonio

Quote:
Originally Posted by Netgamer View Post
Yes

Rules.

1. NO HDMI
2. No Dual DVI
3. NO PCIe

Must be AGP or PCI.... easy simple, and a way to remember the simple times
Put these in your first post.


GeForce 3 Ti500

   
Reply With Quote
Old
  (#12)
Reality|Bites
Ancient Guru
 
Reality|Bites's Avatar
 
Videocard: SLI Asus/eVGA 8800Ultra/B
Processor: C2D E8600 @ 4.4Ghz 1.42v
Mainboard: eVGA Nforce 680i
Memory: 2 X 1GB OCZ DDR2 6400 Fle
Soundcard: Creative Inspire 5300/M-A
PSU: PCP&C Silencer 750W
Default 04-22-2008, 20:50 | posts: 5,038 | Location: Scotland

Quote:
Originally Posted by Mannerheim View Post
Not same.. It was with passive heatsink =)

Are you sure you didn't have the TNT2 Vanta then?
   
Reply With Quote
Old
  (#13)
---TK---
Ancient Guru
 
---TK---'s Avatar
 
Videocard: 780Ti SLI/Qnix 2710 100Hz
Processor: 2600k 4.5Ghz HT On
Mainboard: Asus P8P67 Deluxe
Memory: RipJaws X 2x8GB 2133Mhz
Soundcard: Phoebus + DT880 Pro 250
PSU: Corsair AX 1200
Default 04-22-2008, 21:13 | posts: 17,811 | Location: New Jersey, USA

Quote:
Originally Posted by Passion Fruit View Post


Voodoo 5 5500. LOL at the heatsinks

Have that one too
   
Reply With Quote
Old
  (#14)
Zareph
Maha Guru
 
Zareph's Avatar
 
Videocard: EVGA GTX 670 FTW @ 1241
Processor: Core i7-920 C0 @ 4.01GHz
Mainboard: Gigabyte EX58-UD3R FK
Memory: 16GB G.Skill RipjawZ 2400
Soundcard: X-Fi XtremeGamer + T6100
PSU: Corsair TX650W
Default 04-22-2008, 21:30 | posts: 2,634 | Location: Denmark

3dfx Voodoo 3 2000


I simply loved that card. Till I got something better

Also had this, and I remember playing Battlefield 1942 with it (albeit with a terrible 20-30 fps):

ATi Rage 128 Pro (16mb)

Last edited by Zareph; 04-22-2008 at 21:35.
   
Reply With Quote
Old
  (#15)
ST19AG_WGreymon
Ancient Guru
 
ST19AG_WGreymon's Avatar
 
Videocard: PNY GTX770
Processor: Intel Core i7 4770K@4.5
Mainboard: Asus Z87 Pro
Memory: GSkill 16GB DDR3 2400
Soundcard: Realtek HD
PSU: Corsair AX760i
Default 04-22-2008, 21:48 | posts: 4,675 | Location: Maryland, USA

Here's a quick picture I took with my PSP, can anyone guess what it is?

   
Reply With Quote
Old
  (#16)
Xaser04
Ancient Guru
 
Xaser04's Avatar
 
Videocard: GTX780M @ 980/6000
Processor: i7 4700MQ @ 3.4-3.6Ghz
Mainboard: Intel H87m
Memory: 16GB 1600MT/s DDR3
Soundcard: On Board
PSU: 230w Adaptor
Default 04-22-2008, 21:54 | posts: 2,869 | Location: Southwest England

Quote:
Originally Posted by ST19AG_WGreymon View Post
Here's a quick picture I took with my PSP, can anyone guess what it is?

Looks like some sort of FX5800 / FX59XX
   
Reply With Quote
Old
  (#17)
Reality|Bites
Ancient Guru
 
Reality|Bites's Avatar
 
Videocard: SLI Asus/eVGA 8800Ultra/B
Processor: C2D E8600 @ 4.4Ghz 1.42v
Mainboard: eVGA Nforce 680i
Memory: 2 X 1GB OCZ DDR2 6400 Fle
Soundcard: Creative Inspire 5300/M-A
PSU: PCP&C Silencer 750W
Default 04-23-2008, 00:38 | posts: 5,038 | Location: Scotland

Yup it's the leaf blower
   
Reply With Quote
Old
  (#18)
Fahim
Master Guru
 
Videocard: XFX RADEON HD 5850 1GB Bl
Processor: AMD Phenom II X4 955 3.20
Mainboard: MSI 790FX-GD70 Winki
Memory: 4 x 2GB Corsair PC3-12800
Soundcard: Creative X-Fi Extreme
PSU: Coolermaster RP 1000W
Default 04-23-2008, 01:06 | posts: 188 | Location: In Front Of My PC

Quote:
Originally Posted by ST19AG_WGreymon View Post
Here's a quick picture I took with my PSP, can anyone guess what it is?

Thats the ABIT Siluro GeForce FX 5800 Ultra. Can't forget that card, i used to own it once.
   
Reply With Quote
Old
  (#19)
CorNeLL
Maha Guru
 
CorNeLL's Avatar
 
Videocard: ASUS EAH6850 DC V2
Processor: Phenom II X6 1055T 3.5GHz
Mainboard: ASUS M4A88TD-V EVO USB3
Memory: DDR3 G.SKILL Ripjaws 12GB
Soundcard: Onboard HD + AltecLansing
PSU: Coolmax 550W
Default 04-23-2008, 01:20 | posts: 871 | Location: Tijuana

this is still working on my rig as im typing

3DFX Voodoo 3 3000 16MB

also had:

HIS NVIDIA Riva TNT2 M64 PRO 32MB PCI - Passive
Leadtek & PNY NVIDIA GeForce 4 MX 440 64MB AGP
3 BFG & 1 MSI NVIDIA GeForce FX 5500 256MB AGP
Apollo NVIDIA GeForce "FX" 6800GT (NV40) AGP - VGA & DVI
ATi Radeon 7000 AGP - Passive
and 3 or 4 S3 Diamond Stealth 2D/3D 2MB PCI - No heatsink
S3 Trio 2MB AGP

Last edited by CorNeLL; 04-23-2008 at 18:27.
   
Reply With Quote
Old
  (#20)
Estima8tor
Maha Guru
 
Estima8tor's Avatar
 
Videocard: EVGA GTX 570
Processor: Core i7 920
Mainboard: Foxconn X58
Memory: 6GB CORSAIR XMS3 1600MHz
Soundcard: X-Fi Xtreme Gamer
PSU: CORSAIR GS 700w
Default 04-23-2008, 01:48 | posts: 2,580 | Location: Virginia, USA

My all time favorite was my old msi ti 4200 - call of duty was beautiful on that card.




My wife is still using my old leadtek 5700 ultra, it runs google earth nicely, lol.

   
Reply With Quote
Old
  (#21)
JoPiss
Master Guru
 
JoPiss's Avatar
 
Videocard: ATI
Processor: AMDURP
Mainboard:
Memory:
Soundcard:
PSU: THE BEST KIND
Default 04-23-2008, 02:01 | posts: 234

Quote:
Originally Posted by Estima8tor View Post
My all time favorite was my old msi ti 4200 - call of duty was beautiful on that card.




My wife is still using my old leadtek 5700 ultra, it runs google earth nicely, lol.

I think that card is in my old set up!
   
Reply With Quote
Old
  (#22)
TroM
Maha Guru
 
TroM's Avatar
 
Videocard: Gigabyte HD6850 OC
Processor: E6750 @ 3.640 Ghz
Mainboard: Gigabyte P35-DS3L
Memory: A-DATA DDR2 4GB
Soundcard: X-Fi Xtream Gamer
PSU: OCZ GameXstream 700W
Default 04-23-2008, 02:08 | posts: 1,942

Ah yes here we go. From 1996



8 MB PCI Video card/modem/sound card by SMART Modular Technologies^^^



Back side^ all the outputs

Last edited by TroM; 04-23-2008 at 02:12.
   
Reply With Quote
Old
  (#23)
CorNeLL
Maha Guru
 
CorNeLL's Avatar
 
Videocard: ASUS EAH6850 DC V2
Processor: Phenom II X6 1055T 3.5GHz
Mainboard: ASUS M4A88TD-V EVO USB3
Memory: DDR3 G.SKILL Ripjaws 12GB
Soundcard: Onboard HD + AltecLansing
PSU: Coolmax 550W
Default 04-23-2008, 02:13 | posts: 871 | Location: Tijuana

Quote:
Originally Posted by TroM View Post
Ah yes here we go. From 1996



8 MB PCI Video card/modem/sound card by SMART Modular Technologies^^^



Back side^ all the outputs
Duuuuuuude you won't fool us! not me at least! that's a conexant Riptide modem not a video card. the port at the right it's the game port! i just installed this very same modem this morning in my sister's PC so she can use her old gamepad.

Last edited by CorNeLL; 04-23-2008 at 02:16.
   
Reply With Quote
Old
  (#24)
allesclar
Ancient Guru
 
allesclar's Avatar
 
Videocard: Asus 1950XTX
Processor: Intel Quad Q6600
Mainboard: Asus P5N32-E SLI 680i
Memory: Corsair 8GB PC2-6400 XMS2
Soundcard: SB Audigy 2
PSU: Enermax Liberty 620W
Default 04-23-2008, 02:18 | posts: 5,097 | Location: England

thats not a graphics card port dude, its a game port so you could connect up stuff like joysticks.

Damn you CornNELL, beat me to it
   
Reply With Quote
Old
  (#25)
CorNeLL
Maha Guru
 
CorNeLL's Avatar
 
Videocard: ASUS EAH6850 DC V2
Processor: Phenom II X6 1055T 3.5GHz
Mainboard: ASUS M4A88TD-V EVO USB3
Memory: DDR3 G.SKILL Ripjaws 12GB
Soundcard: Onboard HD + AltecLansing
PSU: Coolmax 550W
Default 04-23-2008, 02:23 | posts: 871 | Location: Tijuana

Quote:
Originally Posted by allesclar View Post
thats not a graphics card port dude, its a game port so you could connect up stuff like joysticks.

Damn you CornNELL, beat me to it
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 1995-2014, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.